Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-08-2019 13:15:10

kerlap
Membre
Distrib. : Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Mate
Inscription : 21-08-2019

Ecran noir à l'installation de Debian 10

Bonjour à tous.

Je débute tout à fait dans l'univers Linux .

J'essaie d'installer mon premier os Debian depuis six jours (trois installations avec le même problème à chaque fois).
Je bute sur un problème d'écran noir au lancement de l'environnement de bureau avec un curseur visible et actif (il se transforme même en main à certains endroits de l'écran).
Après moults lectures de pages web et forums et moults vains essais (voir mon post précédent :https://debian-facile.org/viewtopic.php … 25#p309325) pour trouver une solution je me décide enfin à me tourner vers les ceuss qui y comprennent quequ'chose.

C'est le seul OS sur mon ordi (donc pas de dual boot)
Pas de carte graphique dédiée (voir ci-dessous ma config)
J'avais auparavant utilisé 3 semaines Debian 9 en machine virtuelle hébergé sous Windows 7 (supprimé depuis) et ça fonctionnait

J'ai installé 3 fois Debian 10 à partir d'une clé USB configurée avec le logiciel RUFUS : (et chaque fois après installation le même écran noir au boot)
- 2 fois [Debian GNU/Linux 10.0.0 -Buster -Official amd 64 Netinst 20190706-10:23] buster main non free
    depuis : https://lecrabeinfo.net/installer-linux … ourceslist
- puis 1 fois  [Debian GNU/Linux 10.0.0 -Buster -Official amd 64 Netinst 20190706-10:23] buster main
    depuis https://www.debian.org/distrib/ (image ISO netinst  pour PC 64 bits)

uname -a


renvoie

Linux debian 4.19.0-5-amd64 #1 SMP Debian 4.19.37-5+deb10u2 (2019-08-08) x86-64 GNU/Linux



Erreurs vues dans le journal :

journalctl -r -p err


systemd-udevd[359] : event 3: Failed to call EVIOCSKEYCODE with scan code 0xc022e, and key code 108: Invalid argument
systemd-udevd[359] : event 3: Failed to call EVIOCSKEYCODE with scan code 0xc022d, and key code 103: Invalid argument
kernel : [Firmware Bug] TSC_DEADLINE disabled due to Errata; please update microcode to version: 0x22 (or later)




Merci. smile


Matériel :
- Processeur I5 intel 4460 avec
- carte graphique intégréée :Intel Corporation Xeon E3-1200 v3/4 th Gen core processor integrated
- carte mère : Asus Z 87-A Series
- BIOS :date : 08/15/2014 - Version : 2103
- Ram : 8 Go
- Disque SSD 124 Go

Dernière modification par kerlap (27-08-2019 23:03:29)

Hors ligne

#2 23-08-2019 13:41:49

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran noir à l'installation de Debian 10

il faut la référence exacte de la carte mère pour mettre a jour le bios (si il existe une mise a jour )
sinon si tu a la main en console fait cette commande
ps: si tu a le net , sinon juste le retour de lspci


apt update
 




apt-get --reinstall install firmware-misc-nonfree intel-microcode
 



et un reboot de la machine


reboot
 



je ne voit rien a propos des firmwares sur les erreurs ( gpu , carte réseau etc )

si tu peu faire ceci (si tu a le net ce qui n'est pas certain roll )


update-pciids
 



puis


lspci
 

Dernière modification par robert2a (23-08-2019 13:43:16)

Hors ligne

#3 23-08-2019 14:30:34

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran noir à l'installation de Debian 10

voila une machine en Z81 (ma Z87 a mouru roll) et un cpu intel 4770K
pas d'erreur (ne tien pas compte des erreurs nvidia , j'ai retiré la carte pour test du gpu intel et le driver nvidia est toujours installé )


journalctl -r -p err
 



-- Logs begin at Fri 2019-08-23 15:15:35 CEST, end at Fri 2019-08-23 15:17:02 CEST. --
août 23 15:15:36 debian11 systemd[1]: Failed to start NVIDIA Persistence Daemon.
août 23 15:15:36 debian11 nvidia-persistenced[546]: Failed to query NVIDIA devices. Please ensure that the NVIDIA device files
août 23 15:15:36 debian11 systemd[1]: Failed to start Load Kernel Modules.
août 23 15:15:36 debian11 systemd-modules-load[291]: Failed to insert module 'nvidia_drm': Operation not permitted
août 23 15:15:36 debian11 systemd-modules-load[291]: Error running install command for nvidia_drm
 



la prise en charge du gpu sous buster


glxinfo -B
 



name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Intel Open Source Technology Center (0x8086)
    Device: Mesa DRI Intel(R) Haswell Desktop  (0x412)
    Version: 18.3.4
    Accelerated: yes
    Video memory: 1536MB
    Unified memory: yes
    Preferred profile: core (0x1)
    Max core profile version: 4.5
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.1
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Haswell Desktop
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.3.4
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.0 Mesa 18.3.4
OpenGL shading language version string: 1.30
OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.1 Mesa 18.3.4
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
 



le retour de lspci


lspci
 



00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
00:19.0 Ethernet controller: Intel Corporation Ethernet Connection (2) I218-V (rev 05)
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d5)
00:1c.5 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #6 (rev d5)
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation C220 Series Chipset Family H81 Express LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 05)
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 05)
03:00.0 USB controller: ASMedia Technology Inc. ASM1042A USB 3.0 Host Controller
 



donc ce matériel ne devrait pas poser de problème sous buster

ps: la machine a besoin d une mise a jour ( a l'arrêt depuis pas mal de temps )  smile


apt update
 



Atteint :1 https://cdn-aws.deb.debian.org/debian-security buster/updates InRelease
Atteint :2 https://cdn-aws.deb.debian.org/debian buster InRelease
Atteint :3 https://cdn-aws.deb.debian.org/debian buster-updates InRelease
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
461 paquets peuvent être mis à jour. Exécutez « apt list --upgradable » pour les voir.
 



le serveur X utilise "modesetting" du noyau , driver i915 (mon bureau Mate)


dmesg | grep intel
 



[    0.675669] intel_idle: MWAIT substates: 0x42120
[    0.675670] intel_idle: v0.4.1 model 0x3C
[    0.675874] intel_idle: lapic_timer_reliable_states 0xffffffff
[    0.697574] intel_pstate: Intel P-state driver initializing
[    2.542049] intel_rapl: Found RAPL domain package
[    2.542050] intel_rapl: Found RAPL domain core
[    2.542050] intel_rapl: Found RAPL domain uncore
[    2.542051] intel_rapl: Found RAPL domain dram
[    2.542152] snd_hda_intel 0000:00:03.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    2.567243] fbcon: inteldrmfb (fb0) is primary device
[    2.606779] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
 



dmesg | grep drm
 



[    2.533856] [drm] PipeC fused off
[    2.533873] [drm] Replacing VGA console driver
[    2.535871] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    2.535871] [drm] Driver supports precise vblank timestamp query.
[    2.540234] [drm] Initialized i915 1.6.0 20180719 for 0000:00:02.0 on minor 0
[    2.567243] fbcon: inteldrmfb (fb0) is primary device
[    2.606779] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
 

Dernière modification par robert2a (23-08-2019 14:42:27)

Hors ligne

#4 23-08-2019 14:53:52

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran noir à l'installation de Debian 10

toutes les commandes "root" sont faites avec "su -" (et pas "su")


su -
Mot de passe :
 

Hors ligne

#5 23-08-2019 15:36:23

kerlap
Membre
Distrib. : Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Mate
Inscription : 21-08-2019

Re : Ecran noir à l'installation de Debian 10

Une urgence médicale pour le fiston plus tard me voici de retour ...
Merci robert2a pour tes messages.

J'ai bien internet puisque j'ai pu charger les paquets d'installation (iso de taille réduite d'ailleurs donc beaucoup de paquets)

apt update


Bla Bla
Tous les paquets sont à jour.
W : impossible de récupérer http://ftp.fr.debian.org/debian/dists/buster/InRelease Erreur temporaire de résolution de " ftp.fr.debian.org"
W : impossible de récupérer http://security.debian.org/debian-security/dists/buster/updates/InRelease Erreur temporaire de résolution de "security.debian.org"
W : impossible de récupérer http://ftp.fr.debian.org/debian/dists/buster-updates/InRelease Erreur temporaire de résolution de " ftp.fr.debian.org"
W : impossible de récupérer http://deb.debian.org/debian/dists/buster-backports/InRelease Erreur temporaire de résolution de " deb.debian.org"
W : Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place


apt-get --reinstall install firmware-misc-nonfree intel-microcode


bla bla : Lecture + construction + lecture  fait
Le paquet suivant a été installé automatiquement et n'est plus nécessaire :
libxvmc1
bla bla
Les paquets suivants seront installés :
[b]iucode-tool[/b]
les nouveaux paquets suivants seront installés :
[b]intel-microcode iucode-tool[/b]
Souhaitez-vous continuer ?


o


Des erreurs
Impossible de récupérer iucode-tool
Impossible de récupérer intel-microcode
impossible de récupérer certaines archives, peut-être devrez-vous lancer apt-get update ou essayer avec --fix-missing ?
 


apt-get update


messages d'erreur identiques : impossible récupérer etc


--fix-missing


commande introuvable


lspci


beaucoup de lignes !!


Quelle ligne en particulier dois-je recopier ? (Pitié ne me dis pas: toutes !)

Dernière modification par kerlap (23-08-2019 15:40:33)

Hors ligne

#6 23-08-2019 15:57:11

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran noir à l'installation de Debian 10

moi j'ai finit la mise a jour et remit la carte nvidia


journalctl -r -p err
-- Logs begin at Fri 2019-08-23 16:38:35 CEST, end at Fri 2019-08-23 16:42:44 CEST. --
-- No entries --
 


pas d'erreur
pour le clavier et la souris tu utilise quoi ?
pour cette erreur


systemd-udevd[359] : event 3: Failed to call EVIOCSKEYCODE with scan code 0xc022e, and key code 108: Invalid argument
 



on va commencer par l'essentiel , le sources.list et le réseau
rempli ton profil sur le forum , pour debian c'est buster ok , ton bureau c'est quoi ?
avec nano tu peu modifier ton sources.list


nano /etc/apt/sources.list
 


un exemple


#buster 10
deb http://security.debian.org/debian-security buster/updates main contrib non-free
deb http://deb.debian.org/debian/ buster main contrib non-free
deb http://deb.debian.org/debian/ buster-updates main contrib non-free
 


.

tu peu remplacer son contenu par un copier/coller ci dessus (sinon les rentrer a la main sans te tromper )
explique moi comment tu a la console pure ?
après l'écran noir , la combinaison de touche Ctrl+Alt+F2 fonctionne ?

pour lspci le réseau , par exemple pour moi intel , je n'ai pas besoin du retour de lspci , tu le donnera lorsque tu aura le bureau
il doit ressembler beaucoup a ma machine


00:19.0 Ethernet controller: Intel Corporation Ethernet Connection (2) I218-V (rev 05)
 



en général c'est "realtek" ou "intel" le plus commun comme carte réseau

Dernière modification par robert2a (23-08-2019 16:01:27)

Hors ligne

#7 23-08-2019 16:11:39

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran noir à l'installation de Debian 10

pour le réseau fait un ping de google.fr pour vérifier le net
tu peu avoir le réseau pendant l'installation et plus après au redémarrage a la fin de l'installation
tant que "apt update" ne fonctionne pas bien , il faut vérifier le net et le sources.list


ping -c4 google.fr
 



PING google.fr (216.58.213.131) 56(84) bytes of data.
64 bytes from par21s03-in-f131.1e100.net (216.58.213.131): icmp_seq=1 ttl=53 time=24.7 ms
64 bytes from par21s03-in-f131.1e100.net (216.58.213.131): icmp_seq=2 ttl=53 time=24.1 ms
64 bytes from par21s03-in-f131.1e100.net (216.58.213.131): icmp_seq=3 ttl=53 time=24.0 ms
64 bytes from par21s03-in-f131.1e100.net (216.58.213.131): icmp_seq=4 ttl=53 time=24.0 ms

--- google.fr ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 7ms
rtt min/avg/max/mdev = 24.008/24.218/24.715/0.310 ms
 

Dernière modification par robert2a (23-08-2019 16:14:51)

Hors ligne

#8 23-08-2019 16:14:52

kerlap
Membre
Distrib. : Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Mate
Inscription : 21-08-2019

Re : Ecran noir à l'installation de Debian 10

Comme j'ai quasiment les mêmes caractéristiques que toi (bien vu de me les avoir mises) j'ai pu recopier et changer les quelques lignes différentes

lspci



00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d5)
00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d5)
00:1c.6 PCI Bridge : Intel Corp 82801 PCI bridge (rev d5)
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation Z87 Express LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 05)
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 05)
03:00:0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 11)
04:00:0 PCI Bridge: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge (rev 03)
 

Hors ligne

#9 23-08-2019 16:25:03

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran noir à l'installation de Debian 10

donc ce serait la carte realtek qui nous fait des misères pour le réseau   roll
il y a un firmware pour realtek , mais souvent elle fonctionne sans .
regarde ce que te renvoie cette commande


ip address
 



1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 2c:4d:54:58:30:6f brd ff:ff:ff:ff:ff:ff
    inet 192.168.10.31/24 brd 192.168.10.255 scope global dynamic eno1   => "cette ligne doit exister avec une ip"
       valid_lft 26202sec preferred_lft 26202sec
    inet6 fe80::2e4d:54ff:fe58:306f/64 scope link
       valid_lft forever preferred_lft forever
 



pendant l'installation tu a choisi configurer "dhcp" et tout était correct.
il me manque ton bureau , si c'est gnome sûrement aussi "network-manager"

pour nano tu connaît ? , il est simple a utiliser
ctrl+o  pour enregistrer
ctrl+x pour fermer

Dernière modification par robert2a (23-08-2019 16:35:13)

Hors ligne

#10 23-08-2019 16:58:13

kerlap
Membre
Distrib. : Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Mate
Inscription : 21-08-2019

Re : Ecran noir à l'installation de Debian 10

- clavier microsoft natural ergonomic keyboard 4000 vI.O
souris : logitech
- dans nano : la première ligne que tu me donnes était ok
les deux suivantes n'y étaient pas
par contre j'ai beaucoup plus de lignes :
elles commencent avec deb http://ftp.fr.debian.org/debian

A l'installation j'avais ajouté dans nano à la fin les mentions contib non-free qui n'y étaient pas ainsi qu'une ligne pour le backport

Est-ce que je dois supprimer toutes les lignes et ne garder que les trois que tu m'as indiquées ?

- Je ne peux pas faire de copier coller, je communique depuis un portable et sur mon pc bureau je n'ai pas d'autre os que le buster. (si astuce je suis preneur bien sûr!)
- Euh console pure qu'est-ce que c'est ? J'arrive au terminal en root en passant par le rescue mode au lancement de grub.
- je n'ai pas refait d'essai mais arrivé à l'écran noir je ne pouvais rien faire , je rebootais à la main.
- j'ai corrigé le profil, pour l'instant c'est un peu le minimum ce que j'ai mis ...

Hors ligne

#11 23-08-2019 17:03:08

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran noir à l'installation de Debian 10

pour te simplifier la vie , je l'ai testé , celui la


#test
deb http://ftp.fr.debian.org/debian/ buster main contrib non-free
deb http://security.debian.org/debian-security/ buster/updates main contrib non-free
deb http://ftp.fr.debian.org/debian/ buster-updates main contrib non-free
deb http://ftp.fr.debian.org/debian/ buster-backports main contrib non-free
 



tout le reste tu le supprime , normalement il doit ressembler a ce qui existe actuellement (petite modif sur les backports ) et avec "main contrib non-free" sur chaque ligne

Dernière modification par robert2a (23-08-2019 17:03:41)

Hors ligne

#12 23-08-2019 17:17:12

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran noir à l'installation de Debian 10

bon en mode "rescue" tu n'a pas de réseau c'est normal.
teste ceci


service networking start
 


mais ça ne fonctionnera pas , vérifie avec un "apt update" , il va sûrement échouer
modifie ce fichier


nano /etc/network/interfaces
 


comme ceci avec le bon nom de ton interface réseau


# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eno1
iface eno1 inet dhcp
 



tu a juste les deux dernière lignes a ajouter avec le bon nom de l'interface , eno1 a remplacer par le tien que tu aura avec la commande  ip address
redémarre la machine et refais  un "service networking start" tu aura le réseau
fais un :


apt update
 


et installe le paquet "firmware-realtek"


apt-get install firmware-realtek intel-microcode firmware-misc-nonfree
 


et un reboot de la machine voir si tu arrive au bureau

pour le nom de l'interface avec la commande "ip address"


2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
 



le nom commence toujours par "en" , la ligne 2 .

Dernière modification par robert2a (23-08-2019 18:17:27)

Hors ligne

#13 23-08-2019 17:18:14

kerlap
Membre
Distrib. : Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Mate
Inscription : 21-08-2019

Re : Ecran noir à l'installation de Debian 10

ok c'est fait j'ai bien relu plusieurs fois parceque j'ai remarqué que je n'avais pas certains "/" avant "buster" avant de faire les modifs ...
je reboot ?

Hors ligne

#14 23-08-2019 17:24:33

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran noir à l'installation de Debian 10

aucune importance les / avant buster mais tu a bien fait , je l'ai testé il est fonctionnel  smile

Hors ligne

#15 23-08-2019 17:31:28

kerlap
Membre
Distrib. : Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Mate
Inscription : 21-08-2019

Re : Ecran noir à l'installation de Debian 10

je n'ai pas rebooté,
je suis allé voir ip adress qui me renvoie quelquechose d'approchant à ce que tu mets à #9 sauf que ça s'arrête à link/ether e0:3f etc
je n'ai donc pas la ligne avec l'ip.
modif faites avec les deux lignes ajoutées.
comment je fais service networking start ?

Dernière modification par kerlap (23-08-2019 17:40:49)

Hors ligne

#16 23-08-2019 17:45:51

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran noir à l'installation de Debian 10

c'est quoi le nom alors ?  en....... ?
la commande


service networking start
 



après la modification du fichier "interfaces" fait un reboot de la machine , en mode rescue tu fais la commande ci dessus et ensuite comme sur le #12 (update et install)

Hors ligne

#17 23-08-2019 18:08:25

kerlap
Membre
Distrib. : Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Mate
Inscription : 21-08-2019

Re : Ecran noir à l'installation de Debian 10

service networking start ok j'avais oublié le #12 . Trop d'infos pour ma petite tête !
puis j'ai fait

apt update
 


Tous les paquets sont à jour


C'est bon ça non ?

installation du firmware realtek ok
j'ai rebooté mais toujours écran noir ...

à la fin de l'install du realtek on me recommendais de retirer lixvmc1 avec apt autoremove
j'ai pas fait. il faut ?

Je dois aller bosser, c'est concert ce soir à a crêperie de ma femme et elle a besoin d'aide.
Suite demain en ce qui me concerne.

Merci de tout le temps passé aujourd'hui. Ca progresse !

Hors ligne

#18 23-08-2019 18:12:20

kerlap
Membre
Distrib. : Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Mate
Inscription : 21-08-2019

Re : Ecran noir à l'installation de Debian 10

Ah oui le nom : enp3s0
Pour le firmware realtek dans ta ligne de commande tu as mis "nofree" au lieu de "nonfree". Au cas où ça servirait à quelqu'un ...;)

Hors ligne

#19 23-08-2019 18:19:30

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran noir à l'installation de Debian 10

ok j'ai corrigé le nofree
donc tu a installé le fimware realtek , le misc-nonfree et le intel-microcode et toujours l'écran noir ?

on reprendra plus tard , ce serait KDE qui nous fais des miséres
tu n'a même pas le gestionnaire de session ou l'on entre le mot de passe , direct écran noir et a priori gros freeze si tu est obligé d'éteindre au bouton

pour l'autoremove oui tu peu le faire

bonne soirée   wink

re,
il faudra vérifier quand ça bug si tu a  la main avec ctrl+alt+f2 sur l'écran noir avec les firmwares installés (les trois)
sinon voir sur le syslog a quel moment ça bug en mode dépannage (remonté au moment du bug )
refaire la commande des erreurs en mode rescue (mais on n'aurra qu un apperçu tout n'est pas lancé )
plus radical casser le bureau KDE et tester un autre bureau  roll
normalement ce matériel avec debian fonctionne bien (avec mon ancienne carte mèreZ87  et la nouvelle Z81)
ps: on trouve plus de matériel neuf en Z87 , et moi le processeur est encore d' actualité ( intel 4770K)

Dernière modification par robert2a (24-08-2019 00:32:01)

Hors ligne

#20 24-08-2019 10:22:04

kerlap
Membre
Distrib. : Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Mate
Inscription : 21-08-2019

Re : Ecran noir à l'installation de Debian 10

Bonjour robert2a.

Au bout du boot : écran noir toujours.
Ctrl + Alt + F2 me permet d'arriver sur tty2. Et ça c'est bon je ne vais plus être obligé d'arrêter l'ordi à la sauvage.
J'ai voulu lancer un journal entre hier soir, ma dernière manip pour récupérer Realtek et consorts ,et être sûr que j'avais bien fait :


apt-get install firmware-realtek intel-microcode firmware-misc-nonfree

comme tu me l'as dis en #12
et pas :

apt-get --reinstall install firmware-misc-nonfree intel-microcode

comme tu me l'as dis en # 5
J'avoue que je commençais à buguer un peu hier soir et du coup je ne sais plus ce que j'ai fait !

Le journal ne m'as renvoyé que les infos depuis le boot d'aujourd'hui, est-ce que je dois comprendre qu'il ne me revoie que ce qui se passe en tty2 et pas en mode rescue ?
Pour info deux lignes en rouge dans le journal identiques à celles vues précédemment :

journalctl --since="2019-08-23 18:45:00" --until="2019-08-24 11:00:OO"


systemd-udevd[359] : event 3: Failed to call EVIOCSKEYCODE with scan code 0xc022e, and key code 108: Invalid argument
systemd-udevd[359] : event 3: Failed to call EVIOCSKEYCODE with scan code 0xc022d, and key code 103: Invalid argument



Je teste l'historique en mode rescue pour voir (et avec une plage horaire plus resserrée parceque là 1231 lignes pour 4 minutes d'activité !

Bon ben je ne sais pas comment sortir du journal c'est malin !
Ctrl + Alt + sup m'a permis de rebooter
Journal en mode rescue ne donne rien : il démarre au moment du boot.

Tjs en mode rescue :

apt-get install firmware-realtek intel-microcode firmware-misc-nonfree


les trois : misc, realtek et intel microcode sont la version la plus récente


Donc j'avais bien installé les trois.

Dernière modification par kerlap (24-08-2019 10:55:37)

Hors ligne

#21 24-08-2019 10:49:57

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran noir à l'installation de Debian 10

Bonjour

donc tu a la console pure (avec la combinaison ctrl+alt+f2) et on a plus le bug du bios
donc a mon avis ça bug au démarrage du gestionnaire de connexion.

pour visualiser le syslog , soit avec nano soit avec cat
ps: pour nano c'est "ctrl+x" pour sortir


cat /var/log/syslog
 



il faut que je trouve le nom de l'utilitaire de connexion (pour gnome c'est gdm3 , mate c'est lightdm , KDE je connais pas ou oublié hmm )

pour ceci , démarre sans souris voir si il disparaît


systemd-udevd[359] : event 3: Failed to call EVIOCSKEYCODE with scan code 0xc022e, and key code 108: Invalid argument
 

Dernière modification par robert2a (24-08-2019 11:02:17)

Hors ligne

#22 24-08-2019 11:06:19

kerlap
Membre
Distrib. : Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Mate
Inscription : 21-08-2019

Re : Ecran noir à l'installation de Debian 10

cat /var/log/syslog


je repère :

failed to load module mdraid: libbd_mdraid.so.2
failed to load the 'mdraid' libblockdev plugin
 

Hors ligne

#23 24-08-2019 11:10:43

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran noir à l'installation de Debian 10

regarde si tu trouve ceci


apt-cache policy sddm
 



et que retourne ceci


service sddm status
 

Dernière modification par robert2a (24-08-2019 11:13:16)

Hors ligne

#24 24-08-2019 11:17:04

kerlap
Membre
Distrib. : Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Mate
Inscription : 21-08-2019

Re : Ecran noir à l'installation de Debian 10

Reboot sans souris :

journalctl -r -p err


juste le chiffre entre crochets qui change :[345] au lieu de [359]

systemd-udevd[345] : event 3: Failed to call EVIOCSKEYCODE with scan code 0xc022e, and key code 108: Invalid argument
systemd-udevd[345] : event 3: Failed to call EVIOCSKEYCODE with scan code 0xc022d, and key code 103: Invalid argument

Hors ligne

#25 24-08-2019 11:22:37

kerlap
Membre
Distrib. : Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Mate
Inscription : 21-08-2019

Re : Ecran noir à l'installation de Debian 10

apt-cache policy sddm


bloc à supprimer si la commande n’affiche rien


sddm:
  Installé : 0.18.0-1
  Candidat : 0.18.0-1
 Table de version :
 *** 0.18.0-1-500
            500 http://ftp.fr.debian.org/debian buster/main amd64 Packages
            100 /var/lib/dpkg/status

Dernière modification par kerlap (24-08-2019 11:53:14)

Hors ligne

Pied de page des forums