Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#76 25-08-2019 12:23:36

kerlap
Membre
Distrib. : Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Mate
Inscription : 21-08-2019

Re : Ecran noir à l'installation de Debian 10

Quand j'ai voulu installer Mate et que je n'avais pas de réseau, j'ai fait bêtement la manip que tu m'as donnée en #12 et j'ai supprimé la dernière ligne pour être conforme à #12 :

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eno1
iface eno1 inet dhcp
 


Puis j'ai compris que j'avais oublié de modifier "/etc/apt/sources.list" et qu'il ne servait à rien à rien de modifier "/etc/network/interfaces" qui n'est utile qu'en mode rescue si j'ai bien compris.

Hors ligne

#77 25-08-2019 12:27:16

kerlap
Membre
Distrib. : Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Mate
Inscription : 21-08-2019

Re : Ecran noir à l'installation de Debian 10

Ligne que j'ai supprimée :
#This is an autoconfigured ipv6 interface
iface enp3s0inet6auto

Hors ligne

#78 25-08-2019 12:28:27

lagrenouille
Adhérent(e)
Lieu : Toulouse, con !
Distrib. : debian buster - openbsd
Noyau : d'olive
(G)UI : env i3w - openbox_bépo
Inscription : 28-03-2012
Site Web

Re : Ecran noir à l'installation de Debian 10

effectivement dans etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

ça suffit, le reste doit giclé

« La conscience de soi est en soi et pour soi quand et parce qu'elle est en soi et pour soi pour une autre conscience de soi ; c'est-à-dire qu'elle n'est qu'en tant qu'être reconnu.»
Hegel (Phénoménologie de l'Esprit).

En ligne

#79 25-08-2019 12:32:16

kerlap
Membre
Distrib. : Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Mate
Inscription : 21-08-2019

Re : Ecran noir à l'installation de Debian 10

apt-cache policy intel-microcode


Installé


J'ai un autre clavier. Je redémarre sans et je le branche après.

A lagrenouille : effectivement je recopie à la main. J'ai vérifié pls fois donc je ne pense pas avoir oublié qqchose, il faudrait que je demande à qqn d'autre de vérifier parceque des fois on ne voit plus les erreurs ...

Hors ligne

#80 25-08-2019 12:34:20

lagrenouille
Adhérent(e)
Lieu : Toulouse, con !
Distrib. : debian buster - openbsd
Noyau : d'olive
(G)UI : env i3w - openbox_bépo
Inscription : 28-03-2012
Site Web

Re : Ecran noir à l'installation de Debian 10

J'ai un autre clavier. Je redémarre sans et je le branche après.
là je pige pas, c'est quoi le problème, il y a des commandes pour changer la conf du clavier

« La conscience de soi est en soi et pour soi quand et parce qu'elle est en soi et pour soi pour une autre conscience de soi ; c'est-à-dire qu'elle n'est qu'en tant qu'être reconnu.»
Hegel (Phénoménologie de l'Esprit).

En ligne

#81 25-08-2019 12:45:41

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran noir à l'installation de Debian 10

pour le réseau avant tu devais être avec KDE avec network-manager (en auto sans fichier interfaces )
maintenant tu est en manuel avec le fichier interfaces qui a du être créer a l'installation
le mode "rescue" désactive pas mal de choses (démarrage minimal ) et en autre le réseau.
dans ta configuration actuelle un simple "service networking start" le démarre
ça ne fonctionne que avec la configuration que je t'ai donné et ça ne fonctionne pas avec network-manager

pour le log de X vérifie la date (au début du log )


[    12.533] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Aug 24 13:50:22 2019
 



dis moi si tu a des lignes avec "modeset" ou "intel"
pour moi par exemple en amd


[    12.569] (==) Matched amdgpu as autoconfigured driver 0
[    12.569] (==) Matched ati as autoconfigured driver 1
[    12.569] (==) Matched modesetting as autoconfigured driver 2
[    12.569] (==) Matched fbdev as autoconfigured driver 3
[    12.569] (==) Matched vesa as autoconfigured driver 4
 



après la moitié du log tu va trouvé la fin de l'init du gpu
du genre (pour toi "intel" mon exemple est en amd )


[    12.875] (II) AMDGPU(0): [DRI2] Setup complete
[    12.875] (II) AMDGPU(0): [DRI2]   DRI driver: radeonsi
[    12.875] (II) AMDGPU(0): [DRI2]   VDPAU driver: radeonsi

et

[    13.002] (II) AMDGPU(0): Setting screen physical size to 508 x 285
 



ps: toi tu aura soit "modeset" ou "intel" en début de ligne a la place de "AMDGPU"

au sujet de EFI il est activé avec le secure-key actif
je n'ai jamais eu de soucis avec cette carte en mode boot "mbr" , en fait je me souvient plus trop (je regarde sur ma Z81 )
mais bon le souci est sur le lancement du bureau , en mode "serveur" sans bureau pas de problème .

Dernière modification par robert2a (25-08-2019 12:51:12)

Hors ligne

#82 25-08-2019 12:53:12

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran noir à l'installation de Debian 10

@lagrenouille

au début avec KDE il a eu de vilain message pour le bios et pour le clavier
le bios on a résolu avec le "intel-microcode"
pour le clavier ça donne ceci


systemd-udevd[359] : event 3: Failed to call EVIOCSKEYCODE with scan code 0xc022e, and key code 108: Invalid argument   => le clavier usb
systemd-udevd[359] : event 3: Failed to call EVIOCSKEYCODE with scan code 0xc022d, and key code 103: Invalid argument
kernel : [Firmware Bug] TSC_DEADLINE disabled due to Errata; please update microcode to version: 0x22 (or later)    =>  le bios
 

Dernière modification par robert2a (25-08-2019 12:54:27)

Hors ligne

#83 25-08-2019 12:54:26

lagrenouille
Adhérent(e)
Lieu : Toulouse, con !
Distrib. : debian buster - openbsd
Noyau : d'olive
(G)UI : env i3w - openbox_bépo
Inscription : 28-03-2012
Site Web

Re : Ecran noir à l'installation de Debian 10

je m'y perd un peu dans ton histoire
c'est un portable ou une tour ?

tu as toujours pas de session graphique ?
tu as une carte radeon si je suis bien ?
tu as donc installé
xserver-xorg-video-radeon
et ce qui va avec ??

là je sais pas très bien où tu en es ?

que te dis la commande
dpkg -l | grep -v ^ii

Dernière modification par lagrenouille (25-08-2019 12:54:49)


« La conscience de soi est en soi et pour soi quand et parce qu'elle est en soi et pour soi pour une autre conscience de soi ; c'est-à-dire qu'elle n'est qu'en tant qu'être reconnu.»
Hegel (Phénoménologie de l'Esprit).

En ligne

#84 25-08-2019 12:55:00

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran noir à l'installation de Debian 10

non une tour avec un gpu intel  (un vieux I5 )

Dernière modification par robert2a (25-08-2019 12:55:26)

Hors ligne

#85 25-08-2019 12:55:37

kerlap
Membre
Distrib. : Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Mate
Inscription : 21-08-2019

Re : Ecran noir à l'installation de Debian 10

reboot - sans clavier - écran noir - ctrl + alt + f2 - branchement nouveau clavier - login - en "su -"
je n'arrive pas à valider mon mot de passe, si je le tape en commande pour le voir il est ok (verr num. est bien enclenché je le met à chaque fois parcequ'il se déconnecte à chaque fois)
???

Hors ligne

#86 25-08-2019 12:58:20

lagrenouille
Adhérent(e)
Lieu : Toulouse, con !
Distrib. : debian buster - openbsd
Noyau : d'olive
(G)UI : env i3w - openbox_bépo
Inscription : 28-03-2012
Site Web

Re : Ecran noir à l'installation de Debian 10

pourquoi ?

reboot - sans clavier





tu sais si tu es en qwerty ou azerty
auquel cas la commande
setxkbmap fr  poulr passer en azerty
et setxkbmap us pour passer en qwerty


« La conscience de soi est en soi et pour soi quand et parce qu'elle est en soi et pour soi pour une autre conscience de soi ; c'est-à-dire qu'elle n'est qu'en tant qu'être reconnu.»
Hegel (Phénoménologie de l'Esprit).

En ligne

#87 25-08-2019 13:00:18

kerlap
Membre
Distrib. : Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Mate
Inscription : 21-08-2019

Re : Ecran noir à l'installation de Debian 10

sauf que je quand je tape mon mot de passe en commande pour le voir (en mot de passe on ne voit rien) il est ok

Hors ligne

#88 25-08-2019 13:00:51

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran noir à l'installation de Debian 10

kerlap a écrit :

reboot - sans clavier - écran noir - ctrl + alt + f2 - branchement nouveau clavier - login - en "su -"
je n'arrive pas à valider mon mot de passe, si je le tape en commande pour le voir il est ok (verr num. est bien enclenché je le met à chaque fois parcequ'il se déconnecte à chaque fois)
???



donc tu a l'invite de connexion graphique ?  avec le nouveau clavier ?
non ça bloque aussi  roll  , tu est en console pure

remet l'ancien et regarde les erreurs


journalctl -r -p err
 



je passe sur ma Z81 voir ce que me propose le bios

Dernière modification par robert2a (25-08-2019 13:05:04)

Hors ligne

#89 25-08-2019 13:15:32

lagrenouille
Adhérent(e)
Lieu : Toulouse, con !
Distrib. : debian buster - openbsd
Noyau : d'olive
(G)UI : env i3w - openbox_bépo
Inscription : 28-03-2012
Site Web

Re : Ecran noir à l'installation de Debian 10

sauf que je quand je tape mon mot de passe en commande pour le voir (en mot de passe on ne voit rien)


essaie avec les deux commandes,  setxkbmap  fr et us

tu m'as pas répondu pour

dpkg -l | grep -v ^ii

tu as essayé
apt update
apt install -f
et
apt full-upgrade

pour vouaarrrr

Dernière modification par lagrenouille (25-08-2019 13:17:18)


« La conscience de soi est en soi et pour soi quand et parce qu'elle est en soi et pour soi pour une autre conscience de soi ; c'est-à-dire qu'elle n'est qu'en tant qu'être reconnu.»
Hegel (Phénoménologie de l'Esprit).

En ligne

#90 25-08-2019 13:22:03

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran noir à l'installation de Debian 10

le bios c'est du standard Asus


démarrage rapide et logo désactivé

CSM activé

démarrage sécurisé  =>  autre SE
 


le disque sda en mbr (en EFI ça fonctionne aussi si choisi a l'installation )


fdisk -l
 



Disque /dev/sda : 489,1 GiB, 525112713216 octets, 1025610768 secteurs
Modèle de disque : Crucial_CT525MX3
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : dos
Identifiant de disque : 0x13d89cbc

Périphérique Amorçage     Début       Fin  Secteurs Taille Id Type
/dev/sda1    *             2048 943470591 943468544 449,9G 83 Linux
/dev/sda2             943472638 976771071  33298434  15,9G  5 Étendue
/dev/sda5             943472640 976771071  33298432  15,9G 82 partition d'échange Linux / Solaris


Disque /dev/sdb : 931,5 GiB, 1000204886016 octets, 1953525168 secteurs
Modèle de disque : ST1000DM003-1CH1
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 4096 octets
taille d'E/S (minimale / optimale) : 4096 octets / 4096 octets
Type d'étiquette de disque : dos
Identifiant de disque : 0xd9516017

Périphérique Amorçage Début        Fin   Secteurs Taille Id Type
/dev/sdb1              2048 1953523711 1953521664 931,5G 83 Linux
 



je comprend pas pourquoi tu a tous ces soucis


journalctl -r -p err
-- Logs begin at Sun 2019-08-25 14:10:13 CEST, end at Sun 2019-08-25 14:17:01 CEST. --
-- No entries --
 



j'ai retiré ma carte nvidia et je t'ai montré que debian buster tourne sans problème sur ce matériel (page 1 ou 2 ) avec le gpu intel

le jour ou ma Z87-A a claqué => https://debian-facile.org/viewtopic.php?id=22568
j'ai trouvé cette Z81 et j'ai remonté la machine , le ssd crucial avec stretch , j'ai dist-upgrade en buster
ps: le /home est sur sdb1

Dernière modification par robert2a (25-08-2019 13:35:00)

Hors ligne

#91 25-08-2019 13:39:37

kerlap
Membre
Distrib. : Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Mate
Inscription : 21-08-2019

Re : Ecran noir à l'installation de Debian 10

Quand je tape :

cat /var/log/Xorg.0.log

je ne sais pas me déplacer dans le fichier, du coup j'ai fait

vi /var/log/Xorg.0.log


ça marche sauf que j'ai un bip à chaque appui sur la touche ^. Bon je bidouille hein...
Pour le coup j'ai en date :

[    65.285] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Aug 25 13:35:16 2019


Modesetting :


[    65.336] (==) Matched modesetting as autoconfigured driver 0
[    65.336] (==) Matched fbdev as autoconfigured driver 1
[    65.336] (==) Matched vesa as autoconfigured driver 2
[    65.336] (==) Assigned the driver to the Xf²86ConfigLayout
 


init du gpu (j'ai mis un bon moment à le trouver celui-là !)


[    65.671] (II) modeset(0): [DRI2] Setup complete
[    65.671] (II) modeset(0): [DRI2]   DRI driver: 1965
[    65.671] (II) modeset(0): [DRI2]   VDPAU driver: 1965


écran :


[    65.698] (II) modeset(0): Damage tracking initialized
[    65.698] (II) modeset(0): Setting screen physical size to 952 x 285

Hors ligne

#92 25-08-2019 13:47:33

kerlap
Membre
Distrib. : Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Mate
Inscription : 21-08-2019

Re : Ecran noir à l'installation de Debian 10


journalctl -r -p err



Toujours :

systemd-udevd[316] : event 0: Failed to call EVIOCSKEYCODE with scan code 0xc022e, and key code 108: Invalid argument
systemd-udevd[316] : event 0: Failed to call EVIOCSKEYCODE with scan code 0xc022d, and key

Hors ligne

#93 25-08-2019 13:52:15

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran noir à l'installation de Debian 10

bien que nos cpu soit différent , on a le même gpu  =>  Cœur graphique Intel® HD 4600 (toi un I5 4460 et moi un I7 4770K )

ton retour ci dessus confirme que tout va bien , tu est en modesetting (noyau) et l'init du gpu est correct
faut voir a la fin du log de X si des erreurs.

quand la machine démarre , et que lightdm ce lance , le serveur X est actif , il peu afficher l' invite de connexion graphique .
il y a quelque chose qui fait planter lightdm et (ou) le serveur X
mais comme j'ai pas la machine sous la main , difficile de savoir quoi  roll

Dernière modification par robert2a (25-08-2019 13:56:56)

Hors ligne

#94 25-08-2019 13:59:10

kerlap
Membre
Distrib. : Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Mate
Inscription : 21-08-2019

Re : Ecran noir à l'installation de Debian 10

@ lagrenouille

dpkg -l | grep -v ^ii


me renvoie souhait = inconnU etc..
etat=non/installé etc...
err?= etc...
nom     version      architecture description
+++- =======================================
c'est tout !


"tu as essayé
apt update
apt install -f
et
apt full-upgrade "
oui pls fois sauf apt install -f

je vais faire manger les enfants et je reviens ...

Hors ligne

#95 25-08-2019 14:17:40

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran noir à l'installation de Debian 10

quand tu revient teste de créer un xorg.conf (c'est vraiment parce que je suis déprimé tongue )
te trompe pas sinon écran noir tongue  lol


nano /etc/X11/xorg.conf
 



tu colle celui la


Section "Device"
Identifier      "Device0"
Driver          "intel"
EndSection
 


ou celui la


Section "Device"
Identifier      "Device0"
Driver          "modesetting"
EndSection
 


et un reboot
ps: respecte bien minuscule et majuscule
c'est petit a rentrer au clavier pas trop compliqué

bon j'y crois pas trop , mais on aura essayé roll (teste au moins le premier avec le driver "intel" )

Hors ligne

#96 25-08-2019 14:44:08

kerlap
Membre
Distrib. : Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Mate
Inscription : 21-08-2019

Re : Ecran noir à l'installation de Debian 10

nano /etc/X11/xorg.conf


Section "Device"
Identifier      "Device0"
Driver          "intel"
EndSection



Reboot

Et là .........
Tadammm !!!

                         Le bureau Mate !!!

Bravo robert2a t'es un chef !yes.gif

Y a-t-il un test à faire ou est-ce que l'on peut considérer que c'est ok ?

Hors ligne

#97 25-08-2019 15:03:17

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran noir à l'installation de Debian 10

c'est buster qui est pourri , il y a un bug sur intel encore
ce que je comprend pas c'est que j'ai pas pu le reproduire

donc maintenant tu profite du bureau et tu installe tes logiciels
moi j'installe firefox et synaptic
gdebi ne fonctionne plus
gedit mais mate a son éditeur "pluma"
la tu a vraiment le minimum comme bureau (si tu a utilisé le paquet "mate-core" )
tu pourra poster le log de X maintenant , avec de la chance (et si tu redémarre pas ) on aura aussi celui du bug

tu a Xorg.0.log ou Xorg.1.log ou Xorg.0.log.old (le dernier est toujours Xorg.0.log (le plus récent) )

Dernière modification par robert2a (25-08-2019 15:25:21)

Hors ligne

#98 25-08-2019 15:14:48

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran noir à l'installation de Debian 10

lit mon #97
non c'est pas ok , les erreurs par exemple , la commande glxinfo -B , xrandr (relit depuis le début )  etc....
passe en résolu si tu veut mais a mon avis le sujet devrait resté ouvert un petit moment.
tu a une recherche a faire pour le bios de cette carte mère (ta version actuelle et les versions disponible sur le site Asus )
ce souci de périphérique usb

installe le paquet "hardinfo" , tu peu l'utiliser en root ou en user selon ce que tu veut comme retour
il est dans le menu de mate aussi
en console root par exemple


apt-get install hardinfo
 



hardinfo
 


ps: dans "dmi" il te donnera la version du bios installé
pour les logiciels je te laisse faire  wink  (pense a mettre le paquet de langue "fr" , par exemple pour firefox )

nota: pour KDE je te garanti pas que ce soit bon aussi (surtout si il utilise Wayland comme gnome )

pour le système je met smartmontools (disque dur) , le démon acpid (pour les événement acpi ) , le paquet lm-sensors pour la température
pour Mate avec synaptic dans recherche tu tape "mate" il va te donner une liste de paquet , tu choisi ce qui te convient
sinon sur le forum il y a un wiki pour Mate

Dernière modification par robert2a (25-08-2019 15:34:18)

Hors ligne

#99 25-08-2019 15:30:47

lagrenouille
Adhérent(e)
Lieu : Toulouse, con !
Distrib. : debian buster - openbsd
Noyau : d'olive
(G)UI : env i3w - openbox_bépo
Inscription : 28-03-2012
Site Web

Re : Ecran noir à l'installation de Debian 10

@robert2a

bien vu, ça fait souvent la même chose avec nvidia, faut faire sois même un petit fichier xorg

buster à encore de sérieux problèmes, je pense que ça va se régler petit à petit, c'est un peu le cas à chaque nouveau noyau

Dernière modification par lagrenouille (25-08-2019 15:31:21)


« La conscience de soi est en soi et pour soi quand et parce qu'elle est en soi et pour soi pour une autre conscience de soi ; c'est-à-dire qu'elle n'est qu'en tant qu'être reconnu.»
Hegel (Phénoménologie de l'Esprit).

En ligne

#100 25-08-2019 15:46:16

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran noir à l'installation de Debian 10

ce qu'il a enduré pour installer debian sur du matériel de 2013  roll
tien faudra nous donner le retour de fdisk -l aussi
voir comment tu a installé debian


fdisk -l
 


ps: moi personnellement je n'ai plus fait d'installation neuve depuis stretch
peut être testé en rc1 ou rc2 le DVD1 sur une clé usb qui doit traîner quelque part  roll  sur une vielle machine pour faire des tests .

Hors ligne

Pied de page des forums