Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-08-2019 06:44:51

eveil
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Xfce
Inscription : 25-08-2019

[RESOLU] Debian ne boot pas une fois installéé.

Bonjour,

J'ai installé Debian sur mon Dell Latitude et le Pc ne boot pas lors du redémarrage, j'ai cherché et trouvé qu'il faut "move EFI/debian/grub64.efi with that name: EFI/boot/bootx64.efi" (https://wiki.debian.org/InstallingDebia … titude5490).

Comment je fais cela,en sachant que je peux redemarrer sur le live cd une fois debian Buster installée. ma partition Efi est /dev/nvme01p1/.

Merci
eveil.

Dernière modification par eveil (25-08-2019 09:49:29)

Hors ligne

#2 25-08-2019 08:11:47

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU] Debian ne boot pas une fois installéé.

<persiflage>Tiens, encore un firmware UEFI buggé jusqu'à l'os et pourtant sur une machine apparemment récente puisqu'elle a un SSD NMVe ? Comme c'est étonnant...</persiflage>

Il faut lancer un shell root dans un terminal, monter la partition EFI, par exemple sur /mnt, créer le répertoire EFI/boot (la casse peut varier, c'est du FAT) s'il n'existe pas et copier le fichier.

mount /dev/nvme01p1 /mnt
mkdir /mnt/EFI/boot
cp /mnt/EFI/debian/grubx64.efi /mnt/EFI/boot/bootx64.efi
umount /mnt


Note que si le secure boot est activé (ça ne sert à rien), ce n'est pas grubx64.efi qu'il faut copier et renommer mais shimx64.efi, et copier les autres fichiers.

Dernière modification par raleur (25-08-2019 08:13:24)


Il vaut mieux montrer que raconter.

En ligne

#3 25-08-2019 08:15:35

eveil
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Xfce
Inscription : 25-08-2019

Re : [RESOLU] Debian ne boot pas une fois installéé.

Merci beaucoup pour vôtre réponse, je vous tiens informé du résultat.

eveil.

Hors ligne

#4 25-08-2019 09:42:40

eveil
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Xfce
Inscription : 25-08-2019

Re : [RESOLU] Debian ne boot pas une fois installéé.

raleur a écrit :

<persiflage>Tiens, encore un firmware UEFI buggé jusqu'à l'os et pourtant sur une machine apparemment récente puisqu'elle a un SSD NMVe ? Comme c'est étonnant...</persiflage>

Il faut lancer un shell root dans un terminal, monter la partition EFI, par exemple sur /mnt, créer le répertoire EFI/boot (la casse peut varier, c'est du FAT) s'il n'existe pas et copier le fichier.

mount /dev/nvme01p1 /mnt
mkdir /mnt/EFI/boot
cp /mnt/EFI/debian/grubx64.efi /mnt/EFI/boot/bootx64.efi
umount /mnt


Note que si le secure boot est activé (ça ne sert à rien), ce n'est pas grubx64.efi qu'il faut copier et renommer mais shimx64.efi, et copier les autres fichiers.





Wow, la grande classe @raleur, mon dell boot sur Debian Buster, j'avais déjà tenté les même commandes sans succès, cette fois çi j'ai executé avec "sudo" -i et pas "su"

Merci Beaucoup.

eveil.

Hors ligne

#5 25-08-2019 09:52:44

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : [RESOLU] Debian ne boot pas une fois installéé.

eveil a écrit :

cette fois çi j'ai executé avec "sudo" -i et pas "su"


Y'a le tuto sudo, là :
https://debian-facile.org/doc:systeme:sudo wink


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#6 25-08-2019 10:05:39

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU] Debian ne boot pas une fois installéé.

Puisque Debian démarre, on peut voir la sortie de la commande suivante qui affiche les variables d'amorçage EFI pour voir si Debian a été correctement enregistré (et éventuellement s'il y a des variables obsolètes créées par d'autres installations à supprimer) ?

efibootmgr -v

Dernière modification par raleur (25-08-2019 10:08:59)


Il vaut mieux montrer que raconter.

En ligne

Pied de page des forums