Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-09-2019 18:23:54

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

donner les droits à un disque en lecture seule [résolu]

Salut à tout le monde,

Toujours aussi nul en recherche sur le forum...

J'ai deux disques internes en plus de mon disque D9.

Quand je regarde les permissions des "auxiliaires" avec Caja il y a juste accès au dossier mais pas accès aux fichiers.
Sur mon Fedora (désolé de donner cette référence) je monte mon disque avec le code et après je peux faire ce que je veux.
Sur D9 pareil je monte le disque avec le code et après pas pareil, les droits de modifications ne sont pas présents.

Je suppose qu'il doit y avoir une ligne de commande pour "autoriser"...

Dernière modification par statis (04-09-2019 21:41:57)


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#2 03-09-2019 19:56:55

raleur
Membre
Inscription : 03-10-2014

Re : donner les droits à un disque en lecture seule [résolu]

Plutôt vague, tout ça. Et si tu nous montrais au lieu de raconter ? La sortie d'une commande "ls -l" dans l'un de ces disques par exemple.

Il vaut mieux montrer que raconter.

Hors ligne

#3 03-09-2019 20:44:06

nuka
Membre
Distrib. : debian 10
(G)UI : xfce
Inscription : 03-09-2019

Re : donner les droits à un disque en lecture seule [résolu]

oups tromper de forum

Dernière modification par nuka (03-09-2019 20:53:17)

Hors ligne

#4 03-09-2019 21:01:19

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : donner les droits à un disque en lecture seule [résolu]

Merci raleur,

C'est certain que c'est vague pour les officionados de la ligne de commande.
Je vais chercher comment on peut se positionner sur le disque concerné avec le terminal car c'est vague pour moi aussi wink

J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#5 03-09-2019 21:22:10

raleur
Membre
Inscription : 03-10-2014

Re : donner les droits à un disque en lecture seule [résolu]

Sinon tu peux commencer par montrer une capture d'écran avec les permissions.

Il vaut mieux montrer que raconter.

Hors ligne

#6 03-09-2019 21:38:00

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : donner les droits à un disque en lecture seule [résolu]

je ne sais pas si c'est ce qui est demandé

ls -l dev/sda1


brw-rw---- 1 root disk 8, 1 sept.  3 22:04 dev/sda1


Les fichiers sur sda1 sont en lecture seule, plus possible d'en copier dessus...


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#7 03-09-2019 21:38:44

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : donner les droits à un disque en lecture seule [résolu]

statis a écrit :

je ne sais pas si c'est ce qui est demandé

ls -l dev/sda1


brw-rw---- 1 root disk 8, 1 sept.  3 22:04 dev/sda1


Les fichiers sur sda1 sont en lecture seule, plus possible d'en copier dessus...



note sda1 est en NTFS


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#8 03-09-2019 22:17:08

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : donner les droits à un disque en lecture seule [résolu]

Bon c'est un problème avec le disque...
J'ai démarré le PC D9 avec mon disque Fedora et même chose les fichiers sont en lecture seule malgré que les droits soient totaux.
Je suspecte une connerie de W10 car mon PC "D9" à tiroir extractible a été utilisé avec un disque W10 donc les "auxiliaires" ont du être "touchés"...

J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#9 03-09-2019 22:26:42

raleur
Membre
Inscription : 03-10-2014

Re : donner les droits à un disque en lecture seule [résolu]

Non, ce n'est pas le périphérique mais le point de montage qui importe.
Recherche la ligne correspondante dans la sortie de la commande "mount".
Tu n'as peut-être pas démonté correctement le volume dans Windows, et maintenant ntfs-3g refuse de le monter en lecture-écriture.

Il vaut mieux montrer que raconter.

Hors ligne

#10 03-09-2019 23:11:21

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : donner les droits à un disque en lecture seule [résolu]

merci raleur,
J'ai éteint le PC D9...
Je chercherais les détails de la commande "mount" que je ne connais pas du tout demain

J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#11 04-09-2019 01:53:27

MicP
Membre
Inscription : 29-02-2016

Re : donner les droits à un disque en lecture seule [résolu]

Bonjour

Dans son message #10, statis a écrit :

…Je chercherais les détails de la commande "mount" …


Pourquoi ne pas utiliser la commande udisksctl
qui créera (et détruira au démontage) automatiquement
le répertoire qui sera utilisé comme point de montage

Dernière modification par MicP (04-09-2019 10:40:04)

Hors ligne

#12 04-09-2019 08:31:04

raleur
Membre
Inscription : 03-10-2014

Re : donner les droits à un disque en lecture seule [résolu]

MicP a écrit :

Pourquoi ne pas utiliser la commande udisksctl
qui créera (et détruira au démontage) automatiquement
le répertoire qui sera utilisé comme point de montage


Parce que mon but n'est pas de monter le volume mais d'afficher son point de montage et ses options de montage, ce que fait la commande mount sans argument en tant qu'utilisateur simple.


Il vaut mieux montrer que raconter.

Hors ligne

#13 04-09-2019 09:57:05

MicP
Membre
Inscription : 29-02-2016

Re : donner les droits à un disque en lecture seule [résolu]

Ok, Merci pour l'explication, je comprends mieux la démarche.

Désolé d'avoir "pollué" le fil de discussion.ops.gif

Hors ligne

#14 04-09-2019 20:46:08

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : donner les droits à un disque en lecture seule [résolu]

Merci MicP ton intervention a fait quand même avancer le fil.
Merci Raleur d'avoir précisé mount sans argument car c'était pas évident pour moi

mount


sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,nosuid,relatime,size=4076648k,nr_inodes=1019162,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=817904k,mode=755)
/dev/sdb1 on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=28,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=10502)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
mqueue on /dev/mqueue type mqueue (rw,relatime)

/dev/sda1 on /media/deb64/LINUX type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096)

binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=817900k,mode=700,uid=1000,gid=1000)



J'ai introduit deux sauts de ligne pour isoler mon sda1


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#15 04-09-2019 20:54:00

raleur
Membre
Inscription : 03-10-2014

Re : donner les droits à un disque en lecture seule [résolu]

Tu pouvais aussi bien ne poster que cette ligne, on n'a pas besoin du reste.

/dev/sda1 on /media/deb64/LINUX type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096)


ro = read-only = lecture seule. Ce n'est pas à cause des permissions que tu ne peux pas écrire, même root ne pourrait pas écrire dans un système de fichiers monté en lecture seule.

Démonte-le. Avec udiskctl en tant qu'utilisateur comme le suggère MicP, ou simplement en tant que root comme je le ferais

umount /dev/sda1


puis remonte-le manuellement, ce qui devrait afficher la cause du montage en lecture seule.

mount /dev/sda1 /mnt
umount /dev/sda1


Je parie pour un système de fichiers "dirty" mal démonté par Windows.


Il vaut mieux montrer que raconter.

Hors ligne

#16 04-09-2019 21:00:33

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : donner les droits à un disque en lecture seule [résolu]

Merci raleur, t'es trop fort wink

mount /dev/sda1 /mnt


The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Falling back to read-only mount because the NTFS partition is in an
unsafe state. Please resume and shutdown Windows fully (no hibernation
or fast restarting.)



C'est pas cool car je ne n'ai pas utilisé ce disque avec W10...


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#17 04-09-2019 21:25:39

raleur
Membre
Inscription : 03-10-2014

Re : donner les droits à un disque en lecture seule [résolu]

statis a écrit :

t'es trop fort


Non, juste l'expérience.

statis a écrit :

je ne n'ai pas utilisé ce disque avec W10


Pourtant tu as écrit plus haut :

statis a écrit :

Je suspecte une connerie de W10 car mon PC "D9" à tiroir extractible a été utilisé avec un disque W10 donc les "auxiliaires" ont du être "touchés"...


Si tu n'as pas de Windows sous la main pour réparer (et démonter proprement, donc pas d'arrêt avec le démarrage rapide activé), tu peux essayer avec ntfsfix.

ntfsfix -d /dev/sda1


Il vaut mieux montrer que raconter.

Hors ligne

#18 04-09-2019 21:40:49

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : donner les droits à un disque en lecture seule [résolu]

Merci raleur,

Oui j'ai utilisé le PC avec un disque W10 dans le tiroir mais je n'ai fait aucun accès au disque auxilliaire.

ntfsfix -d /dev/sda1


Mounting volume... The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
FAILED
Attempting to correct errors...
Processing $MFT and $MFTMirr...
Reading $MFT... OK
Reading $MFTMirr... OK
Comparing $MFTMirr to $MFT... OK
Processing of $MFT and $MFTMirr completed successfully.
Setting required flags on partition... OK
Going to empty the journal ($LogFile)... OK
Checking the alternate boot sector... OK
NTFS volume version is 3.1.
NTFS partition /dev/sda1 was processed successfully.
 



Et mes fichiers ne sont plus en lecture seule wink
Merci 100 fois smile

Je vais mettre le sujet en résolu mais j'ai des questions...

ntfsfix est une commande que pour Debian ?

Est-ce aussi applicable pour des clefs USB car çà m'est arrivé de devoir en reformater plusieurs suite à des échanges de données entre PCLinux et PCWindows et de me retrouver en lecture seule ?

Mis à part en utilisant un format que ne touche pas W10 (lequel ?) comment protéger les disques auxiliaires de Windows ?


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#19 04-09-2019 21:48:38

raleur
Membre
Inscription : 03-10-2014

Re : donner les droits à un disque en lecture seule [résolu]

Pas besoin d'accéder à un volume pour que Windows le monte, il suffit qu'il lui ait affecté une lettre de lecteur.

ntfsfix fait partie du paquet ntfs-3g qui contient le pilote NTFS en lecture-écriture et divers utilitaires pour manipuler NTFS.
Je pense que ntfs-3g est disponible dans la plupart des distributions GNU/Linux et peut-être au delà (*BSD ?).

ntfsfix est utilisable avec n'importe quel type de support du moment qu'il est formaté en NTFS.

Pourquoi utiliser NTFS si ce n'est pas pour partager des données avec Windows ?
Pour éviter ce problème, il faut arrêter Windows "proprement". Par défaut, l'arrêt de Windows 8 et plus est en fait une hibernation hybride qui ne démonte pas les systèmes de fichiers. Pour qu'il s'arrête "normalement", il faut désactiver le démarrage rapide (fast startup). Autrement, il faut redémarrer au lieu d'arrêter, car cela provoque un vrai arrêt de Windows.

Dernière modification par raleur (04-09-2019 21:51:40)


Il vaut mieux montrer que raconter.

Hors ligne

#20 04-09-2019 22:42:18

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : donner les droits à un disque en lecture seule [résolu]

raleur a écrit :


Pourquoi utiliser NTFS si ce n'est pas pour partager des données avec Windows ?

Pour qu'il s'arrête "normalement", il faut désactiver le démarrage rapide (fast startup). Autrement, il faut redémarrer au lieu d'arrêter, car cela provoque un vrai arrêt de Windows.



J'ai formaté les auxiliaires pour qu'ils soit lisibles par un windows au besoin en cas de crash de Linux, pas pour faire du partage qui lui est fait par des disques externes.
Comme j'ai un disque Fedora "tiroir" je n'ai plus besoin d'être en NTFS pour les auxiliaires.

Sur w10 je ne sais pas ou trouver les options de démarrage, il va falloir que je cherche car de temps en temps je peux démarrer avec cette horreur...
J'adore le redémarrer pour arrêter, j'appuie sur le bouton power quand j'ai le message de démarrage du Bios, merci Windows...

Merci raleur car ta commande pourra me sauver si je suis obligé d'utiliser W10 avant d'avoir reformaté mes auxiliaires...


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

Pied de page des forums