Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-09-2019 16:18:41

unit
Membre
Lieu : Montreuil sur mer
Distrib. : Buster
Noyau : Linux 4.19.0-6 amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Message d'erreur pendant la migration de Stretch vers Buster

Bonjour à tous,
je viens de mettre à niveau Stretch vers Buster mais à la fin j'ai eu ce message d'erreur :

E: Sub-process /usr/bin/dpkg returned an error code (1)


hmm
Quelqu'un aurait-il une idée
Merci pour l'aide.


Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#2 05-09-2019 16:37:43

raleur
Membre
Inscription : 03-10-2014

Re : Message d'erreur pendant la migration de Stretch vers Buster

Et avant il y a des messages qui sont indispensables pour comprendre où se situe l'erreur.

Il vaut mieux montrer que raconter.

Hors ligne

#3 05-09-2019 16:44:08

unit
Membre
Lieu : Montreuil sur mer
Distrib. : Buster
Noyau : Linux 4.19.0-6 amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Re : Message d'erreur pendant la migration de Stretch vers Buster

E: Sub-process /usr/bin/dpkg returned an error code (1)
dpkg: avertissement: « ldconfig » introuvable dans la variable PATH ou non exécutable
dpkg: avertissement: « start-stop-daemon » introuvable dans la variable PATH ou non exécutable
dpkg: erreur: 2 programmes attendus non trouvés dans la variable PATH ou non exécutables
Note : la variable PATH du superutilisateur doit normalement contenir /usr/local/sbin, /usr/sbin et /sbin
 

Dernière modification par unit (05-09-2019 16:44:30)


Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#4 05-09-2019 16:45:53

raleur
Membre
Inscription : 03-10-2014

Re : Message d'erreur pendant la migration de Stretch vers Buster

Tu n'aurais pas lancé des commandes de mise à jour avec "su" tout seul au lieu de "su -"  ?

Il vaut mieux montrer que raconter.

Hors ligne

#5 05-09-2019 18:10:37

unit
Membre
Lieu : Montreuil sur mer
Distrib. : Buster
Noyau : Linux 4.19.0-6 amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Re : Message d'erreur pendant la migration de Stretch vers Buster

Ben si j'ai utilisé su

Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#6 05-09-2019 18:13:46

raleur
Membre
Inscription : 03-10-2014

Re : Message d'erreur pendant la migration de Stretch vers Buster

Voilà ton erreur. Marche plus comme avant depuis buster, il faut utiliser "su -".

Il vaut mieux montrer que raconter.

Hors ligne

#7 05-09-2019 18:19:06

unit
Membre
Lieu : Montreuil sur mer
Distrib. : Buster
Noyau : Linux 4.19.0-6 amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Re : Message d'erreur pendant la migration de Stretch vers Buster

J'ai celui là aussi comme message :

ens5 wls1 Job for minissdpd.service failed because the control process exited with error code.
See "systemctl status minissdpd.service" and "journalctl -xe" for details.
invoke-rc.d: initscript minissdpd, action "restart" failed.
● minissdpd.service - keep memory of all UPnP devices that announced themselves
   Loaded: loaded (/lib/systemd/system/minissdpd.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Thu 2019-09-05 19:15:31 CEST; 12ms ago
     Docs: man:minissdpd(1)
  Process: 3607 ExecStart=/usr/lib/minissdpd/minissdpd-systemd-wrapper ${MiniSSDPd_INTERFACE_ADDRESS} $MiniSSDPd_OTHER_OPTIONS (code=exited, status=1/FAILURE)

sept. 05 19:15:31 debian systemd[1]: Starting keep memory of all UPnP devices that announced themselves...
sept. 05 19:15:31 debian minissdpd-systemd-wrapper[3607]: Usage: /usr/sbin/minissdpd [-d] [-6] [-s socket] [-p pidfile] [-t TTL] [-f device] -i <interface> [-i <interface2>] ...
sept. 05 19:15:31 debian minissdpd-systemd-wrapper[3607]:   <interface> is either an IPv4 address with mask such as
sept. 05 19:15:31 debian minissdpd-systemd-wrapper[3607]:   192.168.1.42/255.255.255.0, or an interface name such as eth0.
sept. 05 19:15:31 debian minissdpd-systemd-wrapper[3607]:   By default, socket will be open as /var/run/minissdpd.sock
sept. 05 19:15:31 debian minissdpd-systemd-wrapper[3607]:   and pid written to file /var/run/minissdpd.pid
sept. 05 19:15:31 debian systemd[1]: minissdpd.service: Control process exited, code=exited, status=1/FAILURE
sept. 05 19:15:31 debian systemd[1]: minissdpd.service: Failed with result 'exit-code'.
sept. 05 19:15:31 debian systemd[1]: Failed to start keep memory of all UPnP devices that announced themselves.
dpkg: erreur de traitement du paquet minissdpd (--configure) :
 installed minissdpd package post-installation script subprocess returned error exit status 1
Paramétrage de firmware-linux (20190114-1) ...
Traitement des actions différées (« triggers ») pour initramfs-tools (0.133) ...
update-initramfs: Generating /boot/initrd.img-4.19.0-5-amd64
Des erreurs ont été rencontrées pendant l'exécution :
 minissdpd
E: Sub-process /usr/bin/dpkg returned an error code (1)


Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#8 05-09-2019 18:25:43

unit
Membre
Lieu : Montreuil sur mer
Distrib. : Buster
Noyau : Linux 4.19.0-6 amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Re : Message d'erreur pendant la migration de Stretch vers Buster

Voici ce que me retourne un :  journalctl -r -p err

-- Logs begin at Thu 2019-09-05 19:05:58 CEST, end at Thu 2019-09-05 19:22:43 CEST. --
sept. 05 19:15:31 debian systemd[1]: Failed to start keep memory of all UPnP devices that announced themselves.
sept. 05 19:12:02 debian systemd[1]: Failed to start keep memory of all UPnP devices that announced themselves.
sept. 05 19:07:11 debian systemd[1]: Failed to start keep memory of all UPnP devices that announced themselves.
sept. 05 19:06:08 debian systemd[2530]: Failed to start Music Player Daemon.
sept. 05 19:06:01 debian systemd[2423]: Failed to start Music Player Daemon.
sept. 05 19:06:01 debian systemd[1]: Failed to start keep memory of all UPnP devices that announced themselves.
sept. 05 19:05:59 debian avahi-daemon[543]: chroot.c: open() failed: No such file or directory
sept. 05 19:05:59 debian kernel: mei mei::55213584-9a29-4916-badf-0fb7ed682aeb:01: FW version command failed -5
sept. 05 19:05:59 debian kernel: mei mei::55213584-9a29-4916-badf-0fb7ed682aeb:01: Could not read FW version
 




Merci


Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#9 05-09-2019 18:30:15

unit
Membre
Lieu : Montreuil sur mer
Distrib. : Buster
Noyau : Linux 4.19.0-6 amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Re : Message d'erreur pendant la migration de Stretch vers Buster

J'ai essayé un dpkg-reconfigure  minissdpd et ça me retourne :

/usr/sbin/dpkg-reconfigure: minissdpd est cassé ou partiellement installé
 


Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#10 05-09-2019 18:30:21

raleur
Membre
Inscription : 03-10-2014

Re : Message d'erreur pendant la migration de Stretch vers Buster

unit a écrit :

J'ai celui là aussi comme message :


En faisant quoi exactement ?

Dernière modification par raleur (05-09-2019 18:31:25)


Il vaut mieux montrer que raconter.

Hors ligne

#11 05-09-2019 18:39:00

unit
Membre
Lieu : Montreuil sur mer
Distrib. : Buster
Noyau : Linux 4.19.0-6 amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Re : Message d'erreur pendant la migration de Stretch vers Buster

Rien de spéciale c'est depuis ma migration de Stretch vers Buster

Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#12 05-09-2019 18:40:23

raleur
Membre
Inscription : 03-10-2014

Re : Message d'erreur pendant la migration de Stretch vers Buster

Les messages d'erreur de dpkg ne se produisent pas tout seuls.

Il vaut mieux montrer que raconter.

Hors ligne

#13 05-09-2019 18:53:10

unit
Membre
Lieu : Montreuil sur mer
Distrib. : Buster
Noyau : Linux 4.19.0-6 amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Re : Message d'erreur pendant la migration de Stretch vers Buster

A chaque installation d'un logiciel j'ai ce message d'erreur :

apt install plank
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Les paquets supplémentaires suivants seront installés :
  bamfdaemon libbamf3-2 libgtop-2.0-11 libgtop2-common libplank-common libplank1
Paquets suggérés :
  libplank-doc
Les NOUVEAUX paquets suivants seront installés :
  bamfdaemon libbamf3-2 libgtop-2.0-11 libgtop2-common libplank-common libplank1 plank
0 mis à jour, 7 nouvellement installés, 0 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 962 ko dans les archives.
Après cette opération, 3244 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de :1 http://deb.debian.org/debian buster/main amd64 libbamf3-2 amd64 0.5.4-1 [117 kB]
Réception de :2 http://deb.debian.org/debian buster/main amd64 libgtop2-common all 2.38.0-4 [94,8 kB]
Réception de :3 http://deb.debian.org/debian buster/main amd64 libgtop-2.0-11 amd64 2.38.0-4 [71,6 kB]
Réception de :4 http://deb.debian.org/debian buster/main amd64 bamfdaemon amd64 0.5.4-1 [153 kB]
Réception de :5 http://deb.debian.org/debian buster/main amd64 libplank-common all 0.11.4-4 [98,8 kB]
Réception de :6 http://deb.debian.org/debian buster/main amd64 libplank1 amd64 0.11.4-4 [292 kB]
Réception de :7 http://deb.debian.org/debian buster/main amd64 plank amd64 0.11.4-4 [134 kB]
962 ko réceptionnés en 0s (2174 ko/s)
Sélection du paquet libbamf3-2:amd64 précédemment désélectionné.
(Lecture de la base de données... 255517 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../0-libbamf3-2_0.5.4-1_amd64.deb ...
Dépaquetage de libbamf3-2:amd64 (0.5.4-1) ...
Sélection du paquet libgtop2-common précédemment désélectionné.
Préparation du dépaquetage de .../1-libgtop2-common_2.38.0-4_all.deb ...
Dépaquetage de libgtop2-common (2.38.0-4) ...
Sélection du paquet libgtop-2.0-11:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../2-libgtop-2.0-11_2.38.0-4_amd64.deb ...
Dépaquetage de libgtop-2.0-11:amd64 (2.38.0-4) ...
Sélection du paquet bamfdaemon précédemment désélectionné.
Préparation du dépaquetage de .../3-bamfdaemon_0.5.4-1_amd64.deb ...
Dépaquetage de bamfdaemon (0.5.4-1) ...
Sélection du paquet libplank-common précédemment désélectionné.
Préparation du dépaquetage de .../4-libplank-common_0.11.4-4_all.deb ...
Dépaquetage de libplank-common (0.11.4-4) ...
Sélection du paquet libplank1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../5-libplank1_0.11.4-4_amd64.deb ...
Dépaquetage de libplank1:amd64 (0.11.4-4) ...
Sélection du paquet plank précédemment désélectionné.
Préparation du dépaquetage de .../6-plank_0.11.4-4_amd64.deb ...
Dépaquetage de plank (0.11.4-4) ...
Paramétrage de libbamf3-2:amd64 (0.5.4-1) ...
Paramétrage de libgtop2-common (2.38.0-4) ...
Paramétrage de minissdpd (1.5.20190210-1) ...
ens5 wls1 Job for minissdpd.service failed because the control process exited with error code.
See "systemctl status minissdpd.service" and "journalctl -xe" for details.
invoke-rc.d: initscript minissdpd, action "restart" failed.
● minissdpd.service - keep memory of all UPnP devices that announced themselves
   Loaded: loaded (/lib/systemd/system/minissdpd.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Thu 2019-09-05 19:51:00 CEST; 11ms ago
     Docs: man:minissdpd(1)
  Process: 32719 ExecStart=/usr/lib/minissdpd/minissdpd-systemd-wrapper ${MiniSSDPd_INTERFACE_ADDRESS} $MiniSSDPd_OTHER_OPTIONS (code=exited, status=1/FAILURE)

sept. 05 19:51:00 debian systemd[1]: Starting keep memory of all UPnP devices that announced themselves...
sept. 05 19:51:00 debian minissdpd-systemd-wrapper[32719]: Usage: /usr/sbin/minissdpd [-d] [-6] [-s socket] [-p pidfile] [-t TTL] [-f device] -i <interface> [-i <interface2>] ...
sept. 05 19:51:00 debian minissdpd-systemd-wrapper[32719]:   <interface> is either an IPv4 address with mask such as
sept. 05 19:51:00 debian minissdpd-systemd-wrapper[32719]:   192.168.1.42/255.255.255.0, or an interface name such as eth0.
sept. 05 19:51:00 debian minissdpd-systemd-wrapper[32719]:   By default, socket will be open as /var/run/minissdpd.sock
sept. 05 19:51:00 debian minissdpd-systemd-wrapper[32719]:   and pid written to file /var/run/minissdpd.pid
sept. 05 19:51:00 debian systemd[1]: minissdpd.service: Control process exited, code=exited, status=1/FAILURE
sept. 05 19:51:00 debian systemd[1]: minissdpd.service: Failed with result '
exit-code'.
sept. 05 19:51:00 debian systemd[1]: Failed to start keep memory of all UPnP devices that announced themselves.
dpkg: erreur de traitement du paquet minissdpd (--configure) :
 installed minissdpd package post-installation script subprocess returned error exit status 1
Paramétrage de libplank-common (0.11.4-4) ...
Paramétrage de libgtop-2.0-11:amd64 (2.38.0-4) ...
Paramétrage de bamfdaemon (0.5.4-1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.17-2) ...
Traitement des actions différées (« triggers ») pour libglib2.0-0:amd64 (2.58.3-2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.28-10) ...
Paramétrage de libplank1:amd64 (0.11.4-4) ...
Traitement des actions différées (« triggers ») pour man-db (2.8.5-2) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-4) ...
Traitement des actions différées (« triggers ») pour mime-support (3.62) ...
Paramétrage de plank (0.11.4-4) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.28-10) ...
Des erreurs ont été rencontrées pendant l'
exécution :
 minissdpd
E: Sub-process /usr/bin/dpkg returned an error code (1)


Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#14 05-09-2019 19:05:05

raleur
Membre
Inscription : 03-10-2014

Re : Message d'erreur pendant la migration de Stretch vers Buster

Installer des logiciels, ce n'est pas "rien de spécial". Avec "su -" cette fois ?
A vue de nez, minissdpd (démon UPnP) semble ne pas reconnaître un argument passé par systemd. Comme l'UPnP fait partie des trucs superflus que je n'utilise pas, je n'y connais rien.

Dernière modification par raleur (05-09-2019 19:07:29)


Il vaut mieux montrer que raconter.

Hors ligne

#15 27-09-2020 03:23:10

Francewhoa
Membre
Lieu : Powell River, Canada
Distrib. : Debian
Noyau : Buster 10
(G)UI : GNOME
Inscription : 27-09-2020
Site Web

Re : Message d'erreur pendant la migration de Stretch vers Buster

ens5 wls1 Job for minissdpd.service failed because the control process exited with error code.


Sens toi vraiment libre d'utiliser minissdpd. Pour la prévention de sécurité et pour une sécurité plus forte, je suggère de ne JAMAIS installer, JAMAIS activé, et JAMAIS utiliser MiniSSDPd. Parce que MiniSSDPd a une très longue histoire de risques et sécurité très faible.

Source & détails à https://debian-facile.org/viewtopic.php … 49#p343849

Hors ligne

Pied de page des forums