Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 20-09-2019 21:50:58

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

Si tu mets ton ordinateur portable sur batterie, est-ce que ton constates encore un grésillement ?

Si tu désactives les entrées microphone et ligne, as tu encore du grésillement ?

Pour gérer la mise en veille des ports audio, on peut passer le temps de mise en veille dans /sys/module/snd_hda_intel/parameters/power_save (pour de l'HDA intel).
Par exemple, si on ne veut pas de mise en veille :

echo 0 > /sys/module/snd_hda_intel/parameters/power_save


Ou créer un fichier dans /etc/modprobe.d et ajouter (pour du HDA intel):

options snd-hda-intel power_save=0 power_save_controller=N


A noter, le paquet TLP (advanced power management tool) gère cette option.

Dernière modification par Beta-Pictoris (20-09-2019 21:53:41)

Hors ligne

#27 21-09-2019 06:22:19

hybridemoineau
Membre
Inscription : 21-02-2016

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

Sur batterie, le grésillement est simplement un peu moins faible, et je ne peux désactiver aucune entrée dans alsamixer.

Créer un fichier dans modprode.d n'a pas fonctionné, mais l'instruction echo 0, si ! Le grésillement ondule un peu au démarrage de l'ordi, puis cesse au même moment que le permettait le démarrage de mocp.

Un grand merci, la solution est claire et propre !

j'ai installé tlp, je ne vois pas très bien où se situerait l'option, d'après le man, sur secteur il suffirait d'entrer

tlp start ac



au démarrage ?

Il y a aussi un autosuspend pour les ports usb. Quel est son effet précis ? Je fonctionne avec un /home sur disque usb externe, et la led est toujours activée quand le pc est éteint sur secteur. Ca, ça devrait se régler dans le bios mais je ne crois pas qu'il y ait l'option, si mes souvenirs sont bons. Mais une fois Debian lancé, que pourrait faire tlp pour économiser éventuellement le disque ou de l'energie ?

Dernière modification par hybridemoineau (21-09-2019 06:32:10)

Hors ligne

#28 21-09-2019 07:01:39

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 5.9.4-arch1-1
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

@hybridemoineau

bonjour,

au risque de passer pour un c.n, as-tu essayé une live pour voir, si au niveau du son, ces parasites persistent ?

Dernière modification par golgot200 (21-09-2019 07:03:31)

Hors ligne

#29 21-09-2019 07:19:17

hybridemoineau
Membre
Inscription : 21-02-2016

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

Houlà, non... Pour vérifier quoi ou agir sur quoi ?

Hors ligne

#30 21-09-2019 07:25:24

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 5.9.4-arch1-1
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

Ben, tu lis soit un fichier audio ou encore ne rien faire "repos" et tu vois si tu as les mêmes parasites qui réapparaissent ou disparaissent selon les cas cités plus haut.

Dernière modification par golgot200 (21-09-2019 07:31:14)

Hors ligne

#31 21-09-2019 07:36:15

hybridemoineau
Membre
Inscription : 21-02-2016

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

Oui, mais je ne vois pas la différence entre le faire sur un live ou sur un système installé sur dd. Le live passerait par un port usb avec le même noyau, mais le problème du grésillement vient de l'activation d'un line out audio standard; et comme la solution de Beta-Pictoris fonctionne, il semble bien que ça vienne d'une veille de ces ports.

Et oui, le problème vient du noyau, puisqu'avant sous Stretch, le grésillement cessait, je crois, une fois grub passé. Mais je n'ai plus les noyaux antérieurs et j'ai la flemme de faire des tests à ce niveau...!

Hors ligne

#32 21-09-2019 08:34:31

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

En ce qui concerne TLP, les paramètres se trouvent dans /etc/default/tlp.

Hors ligne

#33 21-09-2019 10:45:19

hybridemoineau
Membre
Inscription : 21-02-2016

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

Vu, c'est très complet, merci.

Hors ligne

#34 23-09-2019 14:00:25

muadeeb
Membre
Lieu : Manche
Distrib. : Jessie
Noyau : Linux 4.8.0-0.bpo.2-amd64
(G)UI : gnome 3.14.1
Inscription : 16-05-2011

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

Bonjour,

je n'ai pas pu me pencher plus sur mon problème ces deniers jours.
Pour répondre à hybridemoineau

anthony@fixe:~$ amixer controls
numid=4,iface=MIXER,name='Master Playback Switch'
numid=3,iface=MIXER,name='Master Playback Volume'
numid=2,iface=MIXER,name='Capture Switch'
numid=1,iface=MIXER,name='Capture Volume'
anthony@fixe:~$ amixer -c 1 controls
numid=1,iface=CARD,name='HDMI/DP,pcm=3 Jack'
numid=7,iface=CARD,name='HDMI/DP,pcm=7 Jack'
numid=13,iface=CARD,name='HDMI/DP,pcm=8 Jack'
numid=19,iface=CARD,name='HDMI/DP,pcm=9 Jack'
numid=2,iface=MIXER,name='IEC958 Playback Con Mask'
numid=8,iface=MIXER,name='IEC958 Playback Con Mask',index=1
numid=14,iface=MIXER,name='IEC958 Playback Con Mask',index=2
numid=20,iface=MIXER,name='IEC958 Playback Con Mask',index=3
numid=3,iface=MIXER,name='IEC958 Playback Pro Mask'
numid=9,iface=MIXER,name='IEC958 Playback Pro Mask',index=1
numid=15,iface=MIXER,name='IEC958 Playback Pro Mask',index=2
numid=21,iface=MIXER,name='IEC958 Playback Pro Mask',index=3
numid=4,iface=MIXER,name='IEC958 Playback Default'
numid=10,iface=MIXER,name='IEC958 Playback Default',index=1
numid=16,iface=MIXER,name='IEC958 Playback Default',index=2
numid=22,iface=MIXER,name='IEC958 Playback Default',index=3
numid=5,iface=MIXER,name='IEC958 Playback Switch'
numid=11,iface=MIXER,name='IEC958 Playback Switch',index=1
numid=17,iface=MIXER,name='IEC958 Playback Switch',index=2
numid=23,iface=MIXER,name='IEC958 Playback Switch',index=3
numid=6,iface=PCM,name='ELD',device=3
numid=25,iface=PCM,name='Playback Channel Map',device=3
numid=12,iface=PCM,name='ELD',device=7
numid=26,iface=PCM,name='Playback Channel Map',device=7
numid=18,iface=PCM,name='ELD',device=8
numid=27,iface=PCM,name='Playback Channel Map',device=8
numid=24,iface=PCM,name='ELD',device=9
numid=28,iface=PCM,name='Playback Channel Map',device=9
 

Hors ligne

#35 24-09-2019 10:08:32

hybridemoineau
Membre
Inscription : 21-02-2016

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

La solution la plus logique est celle qui est indiquée au post #26, si tu as une carte son hda intel

Pour le savoir :

aplay -l



Sinon, la solution avec mocp fonctionne, encore mieux avec l'option -S

Ce que j'avais essayé au départ (mute/unmute) est instable/ne marche plus... Vu ton retour de commande, ça donnerait ceci :

amixer -c 1 'HDMI/DP,pcm=3 Jack' mute
amixer -c 1 'HDMI/DP,pcm=3 Jack' unmute



En rajoutant les mêmes lignes avec pcm=7, 8 et 9 suivant ce qui est utilisé

Dernière modification par hybridemoineau (24-09-2019 10:09:11)

Hors ligne

#36 24-09-2019 13:10:14

muadeeb
Membre
Lieu : Manche
Distrib. : Jessie
Noyau : Linux 4.8.0-0.bpo.2-amd64
(G)UI : gnome 3.14.1
Inscription : 16-05-2011

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

anthony@fixe:~$ aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: PCH [HDA Intel PCH], périphérique 0: ALC892 Analog [ALC892 Analog]
  Sous-périphériques: 0/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 1: ALC892 Digital [ALC892 Digital]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: NVidia [HDA NVidia], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: NVidia [HDA NVidia], périphérique 7: HDMI 1 [HDMI 1]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: NVidia [HDA NVidia], périphérique 8: HDMI 2 [HDMI 2]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: NVidia [HDA NVidia], périphérique 9: HDMI 3 [HDMI 3]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0



par contre je ne comprend pas :

anthony@fixe:~$ amixer -c 1 'HDMI/DP,pcm=3 Jack' mute
amixer: Unknown command 'HDMI/DP,pcm=3 Jack'...



mais la solution du post #26  visiblement fonctionne pour moi aussi. Si je comprend bien cette commande empêche la mise en veille de la carte son ?

Hors ligne

#37 24-09-2019 16:01:10

hybridemoineau
Membre
Inscription : 21-02-2016

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

Désolé, je me suis planté deux fois.

1) La liste des noms de contrôle, qui vont apparaître entre ' '

amixer -c 1 scontrols



2) La commande de mutage

amixer -c -1 set 'un des noms de controle obtenus avec la commande précédente' mute



La commande du #26 empêche la mise en veille : il n'y a pas de jus, donc pas de grésillement.

Dernière modification par hybridemoineau (24-09-2019 16:02:24)

Hors ligne

#38 25-09-2019 18:56:20

muadeeb
Membre
Lieu : Manche
Distrib. : Jessie
Noyau : Linux 4.8.0-0.bpo.2-amd64
(G)UI : gnome 3.14.1
Inscription : 16-05-2011

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

Merci beaucoup hybridemoineau, je viens de passer le sujet en [résolu] merci.gif

Hors ligne

Pied de page des forums