Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 18-09-2019 15:53:32

muadeeb
Membre
Lieu : Manche
Distrib. : Jessie
Noyau : Linux 4.8.0-0.bpo.2-amd64
(G)UI : gnome 3.14.1
Inscription : 16-05-2011

[RESOLU] sons parasites quand il n'y a pas de lecture

Bonjour,

quand je ne regarde pas de vidéo ou que je n'écoute plus de musique (quand il n'y a plus de sons diffusé par mon PC) il y a un fort bruit parasite dans mes enceintes.
J'ai vérifié dans alsamixer que le volume ne depasser pas les 80% et tester tout les curseurs, sans que ça ne change rien.
Comme j'utilise un petit ampli classe D, je pense que c'est la carte qui se "désactive". Ça fait a peu près le même bruit quand je débranche le jack en laissant l'ampli allumé.
Une âme charitable aurait une solution a me proposer ?

configue : Debian 10.1 Gnome
               jack carte mère -> ampli classe D -> enceintes

Merci d'avance,


Grace à hybridemoineau la solution est donnée au post #26
Pour gérer la mise en veille des ports audio, on peut passer le temps de mise en veille dans /sys/module/snd_hda_intel/parameters/power_save (pour de l'HDA intel).
Par exemple, si on ne veut pas de mise en veille :

 


echo 0 > /sys/module/snd_hda_intel/parameters/power_save




Ou créer un fichier dans /etc/modprobe.d et ajouter (pour du HDA intel):

options snd-hda-intel power_save=0 power_save_controller=N




A noter, le paquet TLP (advanced power management tool) gère cette option.

Merci beaucoup

Dernière modification par muadeeb (25-09-2019 19:22:25)

Hors ligne

#2 18-09-2019 16:15:46

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.10.0-8-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

bonjour muadeeb , big_smile

problème de masse ?

ampli fatigué ou de mauvaise qualité ?

quelle marque d'ampli ?

quel age ?

si tu as des E / S  optiques (tos - link) , essaie les ...

Dernière modification par Debian Alain (18-09-2019 16:16:45)

Hors ligne

#3 18-09-2019 16:37:52

hybridemoineau
Membre
Inscription : 21-02-2016

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

Souci similaire depuis le passage à Buster sur un portable acer : le souci disparaît si je lance de la lecture de son, ou si je débranche puis rebranche le jack qui relie l'ordi à l'ampli.

Curiosité 1. Le grésillement apparaît quasiment à l'ouverture de l'ordi, disparaît un temps au boot jusqu'à ce que je monte mes dd (crypttab), puis reprends jusqu'à ce que je mette en oeuvre une des solutions plus haut.

Curiosité 2. Si je lance mocp, pas besoin de lire un morceau de son, le grésillement disparaît.

Ca ne le faisait pas sur Stretch.

Vu l'effet du branchement/débranchement du jack, il faudrait sans doute muter puis démuter la sortie son au démarrage dans alsa, mais je n'ai pas tenté.

Pulseaudio est installé, sous xfce.

Hors ligne

#4 18-09-2019 16:50:15

hybridemoineau
Membre
Inscription : 21-02-2016

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

Je re-réponds et me réponds, vu que je devais redémarrer l'ordi, je l'ai fait dans la foulée : en exécutant les commandes suivantes au démarrage dans un script en /etc/init.d, le grésillement disparaît après le montage des disques durs

amixer set Master mute
amixer set Master unmute
amixer set PCM mute
amixer set PCM unmute
amixer set Headphone mute
amixer set Headphone unmute

 



C'est à paufiner sans doute (il y a un message d'erreur, sans doute avec pcm), et à adapter suivant ce que renvoie alsamixer, mais ça marche (chez moi).

Merci de la question !

Dernière modification par hybridemoineau (18-09-2019 16:51:22)

Hors ligne

#5 18-09-2019 17:01:15

muadeeb
Membre
Lieu : Manche
Distrib. : Jessie
Noyau : Linux 4.8.0-0.bpo.2-amd64
(G)UI : gnome 3.14.1
Inscription : 16-05-2011

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

Comme hybridemoineau je n'avait pas le problème avec "Stretch" ni les rares fois où je boot sous Window$ 10.
C'est un petit ampli de ce type  https://www.amazon.fr/Pro-Amplificateur … 483&sr=8-8 (pour le prix : une tuerie)
qui n'est pas très vieux (1 ans ou 2) et qui n'a pas d'entrés digital.
Je pense bien que ne sais pas comment faire qu'il suffirait d'un bruit inaudible pour maintenir la carte son active et ne plus avoir ce désagrément

Hors ligne

#6 18-09-2019 17:16:04

hybridemoineau
Membre
Inscription : 21-02-2016

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

L'idée, c'est de désactiver puis de désactiver la sortie son. Le souci, c'est de parvenir à le faire avec un ampli externe.

Lorsque tu rentres la commande suivante

alsamixer



tu accèdes à un ensemble de contrôle son. Si ton ampli y apparaît sous le nom, par exemple, de ampl, tu entres

amixer set ampl mute
amixer set ampl unmute



Si ton ampli n'y apparaît pas, après avoir entré

alsamixer



Tu appuies sur la touche 's'. Tu devrais voir ton ampli, tu vas dessus, touche entrée, tu vois le nom du contrôle, et tu rentres la commande qui commence par amixer avec le bon nom.

Au plus simple : essaie de mettre la commande

amixer set master mute
amixer set master unmute



au démarrage. Là, je ne peux pas t'aider plus, car j'utilise encore sysvinit, et pas systemd que je ne maîtrise donc pas.

Hors ligne

#7 18-09-2019 17:19:12

muadeeb
Membre
Lieu : Manche
Distrib. : Jessie
Noyau : Linux 4.8.0-0.bpo.2-amd64
(G)UI : gnome 3.14.1
Inscription : 16-05-2011

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

nous n'avons pas le même problème, pour moi mute ne change rien. Il n'y a que la lecture d'un morceau ou d'une vidéo qui coupe les parasites. Le bruit parasite arrive 5 secondes après la coupure ou pause du lecteur.
Je ne sais pas ce qu'est mocp : apt me répond :

E: Impossible de trouver le paquet mocp

Dernière modification par muadeeb (18-09-2019 17:21:11)

Hors ligne

#8 18-09-2019 17:25:13

muadeeb
Membre
Lieu : Manche
Distrib. : Jessie
Noyau : Linux 4.8.0-0.bpo.2-amd64
(G)UI : gnome 3.14.1
Inscription : 16-05-2011

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

tes commandes hybridemoineau non aucun effets. il n'y qu'un lecteur actif qui remplace les parasites. Et le sont est bon

Hors ligne

#9 18-09-2019 17:26:44

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.10.0-8-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

je suis pas beaucoup plus calé que hybridemoineau , et , dans ce cas ,

je recommande souvent d'aller sur le site de -- linux M.A.O. --

ils sont spécialisés dans tout ce qui touche  au son , en particulier pour les mélomanes .

mais qui peut le plus , peut le moins , non ???

Hors ligne

#10 18-09-2019 17:30:53

muadeeb
Membre
Lieu : Manche
Distrib. : Jessie
Noyau : Linux 4.8.0-0.bpo.2-amd64
(G)UI : gnome 3.14.1
Inscription : 16-05-2011

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

c'est peut-être le câble (jack -> 2RCA) :
  - j'arrête le playeur (vidéo ou Spotify) + 5 secondes = parasites
  - je débranche je jack du PC = parasites
  - je débranche les RCA de l'ampli = pas de problèmes

Hors ligne

#11 18-09-2019 17:33:47

muadeeb
Membre
Lieu : Manche
Distrib. : Jessie
Noyau : Linux 4.8.0-0.bpo.2-amd64
(G)UI : gnome 3.14.1
Inscription : 16-05-2011

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

Hors ligne

#12 18-09-2019 17:34:29

muadeeb
Membre
Lieu : Manche
Distrib. : Jessie
Noyau : Linux 4.8.0-0.bpo.2-amd64
(G)UI : gnome 3.14.1
Inscription : 16-05-2011

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

quelqu'un a un conseil d'achat ?

Hors ligne

#13 18-09-2019 17:42:22

hybridemoineau
Membre
Inscription : 21-02-2016

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

Dernière précision : je mute et je démute.

Surtout, je viens de faire des tests par éliminations, ces commandes sont nécessaires (PCM+Headphone) et ne fonctionnent pas chez moi séparément

amixer set PCM mute
amixer set PCM unmute
amixer set Headphone mute
amixer set Headphone unmute
 



Mocp, c'est music on console, un lecteur hyperléger qui fonctionne, il faut l'installer (paquet moc). Mais ça ne réglera pas ton problème.

Je serais étonné que le grésillement cesse avec un passage de son si c'était le câble, surtout si le grésillement est fort.

Bon courage !

Hors ligne

#14 18-09-2019 17:54:59

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.10.0-8-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

généralement , j'ai pas de bol quand je conseille qqun , donc ,

je te montre les 3 articles que j'ai retenu sur le site de ldlc .

n'hésite pas à regarder les caractéristiques techniques .

n'achète surtout pas les yeux fermés .

pourquoi LDLC ?

avec Materiel.net  ce sont  deux sites spécialisés en matériel informatique .

https://www.ldlc.com/recherche/s0671207/

https://www.ldlc.com/recherche/s0300756/

https://www.materiel.net/produit/201703100268.html  compatible linux

ce sont des interfaces , des cartes son .

appelées donc à remplacer ta carte son interne .

c'est pour çà qu'on les appelle "carte son externe".

Dernière modification par Debian Alain (19-09-2019 11:49:12)

Hors ligne

#15 18-09-2019 17:58:03

muadeeb
Membre
Lieu : Manche
Distrib. : Jessie
Noyau : Linux 4.8.0-0.bpo.2-amd64
(G)UI : gnome 3.14.1
Inscription : 16-05-2011

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

merci pour Mocp, juste le fait de le lancer et il n'y a plus de bruits de m***e

Hors ligne

#16 18-09-2019 18:08:31

hybridemoineau
Membre
Inscription : 21-02-2016

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

Ah oui, je n'avais pas fait attention au fait qu'il y avait grésillement chez toi dès qu'il n'y avait pas de musique... Dans ce cas, oui, mocp fait l'affaire.

Dans ce cas, ça vient bien de la sortie son, il faut identifier la sortie de ton ampli dans alsamixer (post 6 de ce fil) et automatiser le lancement de ces 4 commandes au démarrage de l'ordi

amixer set PCM mute
amixer set PCM unmute
amixer set XXXXX mute
amixer set XXXXX unmute



ou lancer mocp automatiquement au démarrage de gnome, du bricolage, mais simple.

Dernière modification par hybridemoineau (18-09-2019 18:09:26)

Hors ligne

#17 18-09-2019 18:16:53

hybridemoineau
Membre
Inscription : 21-02-2016

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

J'oubliais : si ton ampli se règle dans alsamixer en sélectionnant une autre carte  son que celle proposée à l'origine par alsamixer, alors il faut indiquer le numéro de cette carte dans la commande, du type :

amixer -c 1 set XXXX mute

Hors ligne

#18 18-09-2019 18:28:43

muadeeb
Membre
Lieu : Manche
Distrib. : Jessie
Noyau : Linux 4.8.0-0.bpo.2-amd64
(G)UI : gnome 3.14.1
Inscription : 16-05-2011

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

Il n'y a que Master.
j'ai essayer ces commandes dans un terminal, sans effets. Tu crois que si elles sont lancées au démarrage  il va y avoir une différence ?

Hors ligne

#19 18-09-2019 18:38:27

hybridemoineau
Membre
Inscription : 21-02-2016

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

Si ça ne fonctionne pas en console, ça ne fonctionnera pas même au démarrage...

C'est vraiment curieux que tu n'aies que "Master". Pas d'autres cartes en appuyant sur "s" ?

Que liste

 cat /proc/asound/cards

Hors ligne

#20 18-09-2019 18:54:45

muadeeb
Membre
Lieu : Manche
Distrib. : Jessie
Noyau : Linux 4.8.0-0.bpo.2-amd64
(G)UI : gnome 3.14.1
Inscription : 16-05-2011

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

 


anthony@fixe:~$ cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7a00000 irq 34
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xf7080000 irq 17
 

Hors ligne

#21 18-09-2019 19:00:34

muadeeb
Membre
Lieu : Manche
Distrib. : Jessie
Noyau : Linux 4.8.0-0.bpo.2-amd64
(G)UI : gnome 3.14.1
Inscription : 16-05-2011

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

tu as raison dans alsaMixer il y a bien :Master, Headphone, PCM, Front etc
Mais :

 


anthony@fixe:~$ amixer set Headphone mute
amixer: Unable to find simple control 'Headphone',0


  Il n'y a que Master qui réagit

Hors ligne

#22 18-09-2019 19:03:58

hybridemoineau
Membre
Inscription : 21-02-2016

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

OK ! Donc il faut accéder aux contrôles de la nvidia pour avoir leurs noms et le mettre dans la commande.

Rentre cette première commande

amixer controls



Elle devrait te renvoyer une liste de quelques lignes max, avec Master dedans...

C'est celle-ci qui compte. Essaie

amixer -c 1 controls



Quest-ce qu'elle raconte ?

Ajout : Je viens de voir ton nouveau post, a priori, il faut agir sur les contrôles de la nvdia, pch ne marchera pas et le mssage d'erreur que tu as viens de là

Dernière modification par hybridemoineau (18-09-2019 19:05:49)

Hors ligne

#23 18-09-2019 20:36:22

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 5.11.12-arch1-1
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

Bonsoir,

juste une question, mocp fonctionne juste avec alsa, c'est ça ?

Hors ligne

#24 19-09-2019 10:25:20

hybridemoineau
Membre
Inscription : 21-02-2016

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

A s'en tenir à ce que renvoie 'aptitude show' et 'apt-cache depends', moc ne dépend pas du tout de pluseaudio.

Cette piste sur le grésillement apparu avec Buster est sans doute la bonne.

En effet, Clementine fonctionne avec les paquets gstreamer, et en particulier gstreamer-pulseaudio et gstreamer-alsa. Les deux sont installés chez moi. Et il y a un autre bug son qui est apparu avec Buster : si je bascule sur un tty avec Cémentine lancé, celui-ci passe le morceau en cours, mais ne peut passer au morceau suivant tant que je ne rebascule pas en graphique. Ca n'était pas le cas avant.

Le souci n'existe pas avec vlc, qui n'a pas de lien avec pulseaudio ou gstreamer, pas non plus avec moc, si je le lance dans une console virtuelle en graphique.

Je vais tester quelques trucs ce soir.

Hors ligne

#25 20-09-2019 12:47:14

hybridemoineau
Membre
Inscription : 21-02-2016

Re : [RESOLU] sons parasites quand il n'y a pas de lecture

Ca n'est pas lié à Pulseaudio, que j'ai intégralement viré, ce qui n'a rien changé, ni en bien, ni en mal (même pour ce qui est de lancer plusieurs sons en même temps, ce qui reste possible sans lui).

Les commandes mute/unmute que j'ai proposées sont instables, elles ne fonctionnent plus pour une raison qui m'échappe complètement, et qui n'est pas liée à la suppression de pulseaudio.

La solution est de lancer mocp dans un script placé dans /etc/init.d, avec l'option -S. Le soft lance le serveur de son et s'éteint de lui-même, ça marche nickel.

mocp -S



mocp ne se contente pas de lancer alsa-utils, car la commande /etc/init.d/alsa-utils start ne change rien, je ne l'ai pas lancé en mode bavard pour savoir tout ce que le logiciel fait.

Enfin, au bout de quelques minutes chez moi, le grésillement s'éteint de lui-même. C'est donc lié à une veille de l'alimentation des ports, y compris des sorties audio.

Dernière modification par hybridemoineau (20-09-2019 12:48:44)

Hors ligne

Pied de page des forums