Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 28-09-2019 18:23:35

Choupex22
CA Debian-Facile
Lieu : Côtes d'Armor
Distrib. : debian 10.1 (x86-64)
Noyau : 4.19.0-6-amd64
(G)UI : Cinnamon 3.8.8
Inscription : 10-02-2018

RÉSOLU mei & wdt !!!

Salut à tous,
Deux ordinateurs sur les trois installés dernièrement en buster-cinnamon en modifiant le sources.list. Ils fonctionnent parfaitement. Pour cela j'ai dû désinstaller Plymouth (VAIO) et installer : firmware-linux-nonfree (ThinkCentre).

Il en reste un, buster-Xfce (Optiplex 755), qui indique, juste avant de s'ouvrir, que mei_wdt ne se connecte pas et que la version FW a échoué. Bon ensuite tout fonctionne.
Lui aussi à une installation de firmware-linux-nonfree et une désinstallation de Plymouth...

Si l'un d'entre vous peut m'expliquer, ce sera avec plaisir.

Fraternellement,

Dernière modification par Choupex22 (13-02-2020 18:35:39)


Amatrice inconditionnelle du libre et surtout de Debian !
Un autre ordinateur fixe, un optiplex 755 installé avec XFce 10 depuis août 2019.

Hors ligne

#2 28-09-2019 18:59:37

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : RÉSOLU mei & wdt !!!

Bon ensuite tout fonctionne.


Y a un dicton en informatique qui dit "if it's not broken, don't fix it".


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#3 28-09-2019 19:43:43

raleur
Membre
Inscription : 03-10-2014

Re : RÉSOLU mei & wdt !!!

Justement j'ai mis à jour un Optiplex 755 de stretch vers buster aujourd'hui. J'ai aussi vu passer un message concernant mei lors du redémarrage avec le noyau 4.19, mais je n'y ai pas particulièrement fait attention. Je n'aurai pas la machine sous la main avant deux semaines. Tu peux retrouver le message dans la sortie de dmesg.

Choupex22 a écrit :

Lui aussi à une installation de firmware-linux-nonfree et une désinstallation de Plymouth


Pourquoi ? Je n'ai pas eu besoin de le faire.


Il vaut mieux montrer que raconter.

Hors ligne

#4 28-09-2019 21:11:22

Choupex22
CA Debian-Facile
Lieu : Côtes d'Armor
Distrib. : debian 10.1 (x86-64)
Noyau : 4.19.0-6-amd64
(G)UI : Cinnamon 3.8.8
Inscription : 10-02-2018

Re : RÉSOLU mei & wdt !!!

Salut Raleur,

Désinstaller Plymouth a permis de supprimer le dérouler d'actions au démarrage, voir le précédent sujet : https://debian-facile.org/viewtopic.php … 09#p311909.
Même topo pour le VAIO.

Tu peux retrouver le message dans la sortie de dmesg.


Une autre énigme ?

J'aime bien que cela fonctionne au mieux, ... sans casse ! parfois l'expérimentation est sur le fil du rasoir ... C'est le lot des amateurs!
Bonne soirée à la communauté


Amatrice inconditionnelle du libre et surtout de Debian !
Un autre ordinateur fixe, un optiplex 755 installé avec XFce 10 depuis août 2019.

Hors ligne

#5 28-09-2019 21:58:26

raleur
Membre
Inscription : 03-10-2014

Re : RÉSOLU mei & wdt !!!

Choupex22 a écrit :

Une autre énigme ?


Non, simplement un moyen de retrouver les messages d'erreur exacts et complets.


Il vaut mieux montrer que raconter.

Hors ligne

#6 29-09-2019 14:33:33

Choupex22
CA Debian-Facile
Lieu : Côtes d'Armor
Distrib. : debian 10.1 (x86-64)
Noyau : 4.19.0-6-amd64
(G)UI : Cinnamon 3.8.8
Inscription : 10-02-2018

Re : RÉSOLU mei & wdt !!!

Salut à tous,
Dimanche tempétueux, petit tour sur la planète linux.

dmesg



Et là, Optiplex est prolixe. Je ne transmets que les lignes m'apparaissant relatives aux messages désignés sous le titre "Mei & wdt". Je choisi la fin à partir de la ligne 11, où Intel powerclamp intervient dans le récit, ...

[   11.033414] intel_powerclamp: No package C-state available
[   11.090511] mei_wdt mei::05b79a6f-4628-4d7f-899d-a91514cb32ab:01: cannot connect
[   11.090577] mei_wdt mei::05b79a6f-4628-4d7f-899d-a91514cb32ab:01: Could not enable cl device
[   11.090640] mei_wdt: probe of mei::05b79a6f-4628-4d7f-899d-a91514cb32ab:01 failed with error -5
[   11.216957] mei mei::55213584-9a29-4916-badf-0fb7ed682aeb:01: Could not read FW version
[   11.217027] mei mei::55213584-9a29-4916-badf-0fb7ed682aeb:01: FW version command failed -5
[   11.416161] pci 0000:00:00.0: Intel Q35 Chipset
[   11.416185] pci 0000:00:00.0: detected gtt size: 524288K total, 262144K mappable
[   11.416403] pci 0000:00:00.0: detected 8192K stolen memory
[   11.416437] [drm] Replacing VGA console driver
[   11.417230] Console: switching to colour dummy device 80x25
[   11.426782] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[   11.426785] [drm] Driver supports precise vblank timestamp query.
[   11.433314] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
[   11.436311] [drm] RC6 disabled, disabling runtime PM support
[   11.436366] [drm] Initialized overlay support.
[   11.438564] [drm] Initialized i915 1.6.0 20180719 for 0000:00:02.0 on minor 0
[   11.478901] fbcon: inteldrmfb (fb0) is primary device
[   11.526490] Console: switching to colour frame buffer device 160x64
[   11.546523] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[   11.957919] snd_hda_codec_analog hdaudioC0D0: autoconfig for AD1984: line_outs=1 (0x12/0x0/0x0/0x0/0x0) type:line
[   11.957923] snd_hda_codec_analog hdaudioC0D0:    speaker_outs=1 (0x13/0x0/0x0/0x0/0x0)
[   11.957925] snd_hda_codec_analog hdaudioC0D0:    hp_outs=1 (0x11/0x0/0x0/0x0/0x0)
[   11.957927] snd_hda_codec_analog hdaudioC0D0:    mono: mono_out=0x0
[   11.957928] snd_hda_codec_analog hdaudioC0D0:    inputs:
[   11.957930] snd_hda_codec_analog hdaudioC0D0:      Mic=0x14
[   11.957932] snd_hda_codec_analog hdaudioC0D0:      Line=0x15
[   11.969579] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:1b.0/sound/card0/input10
[   11.970393] input: HDA Intel Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input11
[   11.970483] input: HDA Intel Line as /devices/pci0000:00/0000:00:1b.0/sound/card0/input12
[   11.970560] input: HDA Intel Line Out as /devices/pci0000:00/0000:00:1b.0/sound/card0/input13
[   11.970637] input: HDA Intel Front Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input14
[   12.443490] Adding 2051068k swap on /dev/sda5.  Priority:-2 extents:1 across:2051068k FS
[   14.603700] EXT4-fs (sda6): mounted filesystem with ordered data mode. Opts: (null)
[   15.834035] audit: type=1400 audit(1569759572.554:2): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/bin/man" pid=339 comm="apparmor_parser"
[   15.834040] audit: type=1400 audit(1569759572.554:3): apparmor="STATUS" operation="profile_load" profile="unconfined" name="man_filter" pid=339 comm="apparmor_parser"
[   15.834044] audit: type=1400 audit(1569759572.554:4): apparmor="STATUS" operation="profile_load" profile="unconfined" name="man_groff" pid=339 comm="apparmor_parser"
[   15.932963] audit: type=1400 audit(1569759572.650:5): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cups-browsed" pid=340 comm="apparmor_parser"
[   16.018396] audit: type=1400 audit(1569759572.738:6): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/telepathy/mission-control-5" pid=343 comm="apparmor_parser"
[   16.018404] audit: type=1400 audit(1569759572.738:7): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/telepathy/telepathy-*" pid=343 comm="apparmor_parser"
[   16.018407] audit: type=1400 audit(1569759572.738:8): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/telepathy/telepathy-*//pxgsettings" pid=343 comm="apparmor_parser"
[   16.018410] audit: type=1400 audit(1569759572.738:9): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/telepathy/telepathy-*//sanitized_helper" pid=343 comm="apparmor_parser"
[   16.018413] audit: type=1400 audit(1569759572.738:10): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/telepathy/telepathy-ofono" pid=343 comm="apparmor_parser"
[   16.056606] audit: type=1400 audit(1569759572.774:11): apparmor="STATUS" operation="profile_load" profile="unconfined" name="libreoffice-soffice" pid=341 comm="apparmor_parser"
[   26.823758] IPv6: ADDRCONF(NETDEV_UP): enp0s25: link is not ready
[   27.289180] IPv6: ADDRCONF(NETDEV_UP): enp0s25: link is not ready
[   28.633803] e1000e: enp0s25 NIC Link is Up 100 Mbps Full Duplex, Flow Control: Rx/Tx
[   28.633912] e1000e 0000:00:19.0 enp0s25: 10/100 speed: disabling TSO
[   28.633949] IPv6: ADDRCONF(NETDEV_CHANGE): enp0s25: link becomes ready
root@claude:~#



Si quelques linusiens arrivent à traduire, j'aurai plaisir à lire leurs avis.

fraternité


Amatrice inconditionnelle du libre et surtout de Debian !
Un autre ordinateur fixe, un optiplex 755 installé avec XFce 10 depuis août 2019.

Hors ligne

#7 15-10-2019 19:36:31

Choupex22
CA Debian-Facile
Lieu : Côtes d'Armor
Distrib. : debian 10.1 (x86-64)
Noyau : 4.19.0-6-amd64
(G)UI : Cinnamon 3.8.8
Inscription : 10-02-2018

Re : RÉSOLU mei & wdt !!!

Je regarde à nouveau l'Optiplex qui démarre toujours avec une information sur wei, etc ...
J'ai vu sur le site de DELL :

Pilote Intel(R) MEI (Management Engine Interface)    Chipset_Driver_316K0_WN32_11.0.0.1167_A02_01.EXE




Je tente l'installation de intel-microcode :

apt-get update && apt-get install intel-microcode


Atteint :1 http://ftp.fr.debian.org/debian buster InRelease
Atteint :2 http://security.debian.org/debian-security buster/updates InRelease
Atteint :3 http://ftp.fr.debian.org/debian buster-updates InRelease
Lecture des listes de paquets... Fait            
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 intel-microcode : Dépend: iucode-tool (>= 1.0) mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
root@claude:~#




Cette phrase m'interroge :

Les paquets suivants contiennent des dépendances non satisfaites :
intel-microcode : Dépend: iucode-tool (>= 1.0) mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».



C'est sans résultat. Que faut-il en penser ?
À vous lire.
Fraternité


Amatrice inconditionnelle du libre et surtout de Debian !
Un autre ordinateur fixe, un optiplex 755 installé avec XFce 10 depuis août 2019.

Hors ligne

#8 15-10-2019 20:46:32

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : RÉSOLU mei & wdt !!!

Est-ce que apt install -f passe sans erreur ? Est-ce que tu as non-free dans ton sources.list ? Si oui et oui, que te sort apt-cache policy  iucode-tool et apt-mark showhold ?

Ça devrait te mettre sur la voie.

datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#9 16-10-2019 10:02:54

Choupex22
CA Debian-Facile
Lieu : Côtes d'Armor
Distrib. : debian 10.1 (x86-64)
Noyau : 4.19.0-6-amd64
(G)UI : Cinnamon 3.8.8
Inscription : 10-02-2018

Re : RÉSOLU mei & wdt !!!

Merci otyugh,

réponses à tes questions : Optiplex est en non-free la commande apt install -f semble passer sans erreur.

apt install -f


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.




Voici pour les deux propositions suivantes :

apt-cache policy iucode-tool


iucode-tool:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :



Reprenant les recherches dans le wiki de DF :


Je tente l'installation de amd64-microcode.

apt-get install amd64-microcode


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
amd64-microcode est déjà la version la plus récente (3.20181128.1).
amd64-microcode passé en « installé manuellement ».
0 mis à jour, 0 nouvellement installés, 0 à enlever et 6 non mis à jour


nada !

je reprends le début de la discussion et en fait il s'agit de dépendances :


Les paquets suivants contiennent des dépendances non satisfaites :
intel-microcode : Dépend: iucode-tool (>= 1.0) mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».



Dois-je essayer d'installer ces firmwares ?

dep: firmware-amd-graphics (= 20190114-2)
        Binary firmware for AMD/ATI graphics chips

    dep: firmware-misc-nonfree (= 20190114-2)
        Binary firmware for various drivers in the Linux kernel



Est-ce sans danger de grosses perturbations ?
À te lire,
fraternité


Amatrice inconditionnelle du libre et surtout de Debian !
Un autre ordinateur fixe, un optiplex 755 installé avec XFce 10 depuis août 2019.

Hors ligne

#10 16-10-2019 10:50:20

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : RÉSOLU mei & wdt !!!

Bonjour

avec "su -" pour passer root (et pas "su")


apt-get remove --purge firmware-linux-nonfree intel-microcode amd64-microcode firmware-misc-nonfree firmware-amd64-graphics iucode-tool
 




apt-get autoremove --purge
 




apt-get autoclean
 



vérifier ton sources.list


cat /etc/apt/sources.list
 



un update


apt update
 



tout doit être a jour
tu a une machine en intel avec un gpu intel
donc tu n' installe que ce qui est utile
firmware-misc-nonfree pour le gpu
intel-microcode pour le cpu

en cas de souci utilise aptitude


apt-get --reinstall install aptitude
 



en simulation ça donne


aptitude -s install firmware-misc-nonfree intel-microcode
 


en vrai


aptitude install firmware-misc-nonfree intel-microcode
 



pour savoir si quelque chose cloche le retour de


journalctl -r -p err
 

Hors ligne

#11 16-10-2019 10:54:38

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : RÉSOLU mei & wdt !!!

si je me trompe pas, ce pc est équipé d'un processeur Intel Pentium E2160.
ça sert à rien d'installer les firmwares AMD, ça apportera aucun changement sur ton problème.

donnes le retour de

apt policy intel-microcode




je sais pas à quoi sert le paquet
iucode-tool

mais personnellement sur tous les pc, le simple intel-microcode fait l'affaire.

et donne le retour de

cat /etc/apt/sources.list


Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#12 16-10-2019 11:32:58

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : RÉSOLU mei & wdt !!!

@melissa6969
=> https://packages.debian.org/fr/buster/intel-microcode

c'est une dépendance que tu a forcément  wink
vérifie


apt policy iucode-tool
 



je pense que aptitude va nous donner la raison de ce blocage
bien nettoyer le système
vérifier le sources.list
mettre a jour le cache
et installer avec aptitude les paquets (si problème il va proposer des solutions )
dans le doute a la fin tu répond "non" pour annuler et tu poste les solutions qu il donne
si tout est correct tu fais l'installation normalement

Hors ligne

#13 16-10-2019 11:49:18

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.8.0-2-amd64
(G)UI : mutter 3.38.0-2
Inscription : 15-02-2016

Re : RÉSOLU mei & wdt !!!

à Choupex22 déjà ces lignes, tu peux laisser tomber :
[   11.216957] mei mei::55213584-9a29-4916-badf-0fb7ed682aeb:01: Could not read FW version
[   11.217027] mei mei::55213584-9a29-4916-badf-0fb7ed682aeb:01: FW version command failed -5

Le projet pharaonique de mise à jour automatique des FirmWares : paquet fwupd ( un aptitude show fwupd pour voir ce que c'est, et la commande en ligne fwupdmgr, c'est honorable comme projet, mais certains firmwares n'ont pas d'installation libre et il faut Windows pour mettre à jour beaucoup de firmwares. C'est notamment le cas pour mon contrôleur de disque Seagate, fwupdmgr m'indique bien qu'il y a une nouvelle version du firmware de mon contrôleur de disque et que je dois aller sur le site du fabricant, mais arrivé sur le site, il n'y a que des pilotes Windows ou Mac. Il y aurait une solution ce serait d'installer FreeDOS en plus de Debian, mais comme j'ai l'impression que cela serait trop la galère, j'ai préféré m'abstenir ! Ce message comme quoi fwupd ne peux pas lire la version du firmware du Management Engine Intel, certaines personnes prennent le risque de mettre à jour le firmware du Management Engine Intel sans passer par fwupd puisqu'il en est incapable, mais avec iucode-tool :
https://gitlab.com/iucode-tool/iucode-tool

https://www.intel.fr/content/www/fr/fr/ … tware.html

C'est tellement rare comme procédure et vu le peu de personnes qui se lancent que je ne retrouve même plus le site où un virtuose d'Arch montrait comment mettre à jour le firmware du Management Engine Intel avec iucode-tool, mais c'était long comme procédure et assez coriace pour que j'y réfléchisse à deux fois avant de m'y lancer vu les risques et depuis j'ai laissé tomber !

La liberté est liée à la qualité du langage, et les bureaucrates qui veulent détruire la liberté ont tous tendance à mal écrire et à mal parler, à se servir d’expressions pompeuses ou confuses, à user de clichés qui occultent ou oblitèrent le sens. Georges Orwell

Hors ligne

#14 16-10-2019 12:19:21

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.2
Noyau : Linux 5.3.18
(G)UI : KDE 5.18.5
Inscription : 11-03-2016

Re : RÉSOLU mei & wdt !!!

Bonjour,
Dans la mesure où il y a eu ce retour dans le message #9 :

apt-cache policy iucode-tool



iucode-tool:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :


La proposition de robert2a de vérifier le sources.list est sans doute la première chose à faire pour installer le paquet intel-microcode.

Hors ligne

#15 16-10-2019 12:30:51

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.8 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : RÉSOLU mei & wdt !!!

iucode-tool est dans la section "contrib", pas "non-free".

Jouer sous Debian ? Facile !

En ligne

#16 16-10-2019 13:03:12

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : RÉSOLU mei & wdt !!!

@chalu
tu est plus sous debian mate ?

en AMD pour moi


apt-cache policy iucode-tool
 



iucode-tool:
  Installé : (aucun)
  Candidat : 2.3.1-1
 Table de version :
     2.3.1-1 500
        500 https://deb.debian.org/debian bullseye/contrib amd64 Packages
 



si "contrib" n'est pas activé ça risque de poser problème (il doit y avoir un wiki pour le sources.list )

Hors ligne

#17 16-10-2019 14:13:18

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : RÉSOLU mei & wdt !!!

@robert2a

Jamais vu passer ce paquet en installant le microcode Intel.
Je regarderais ce soir sur mon pc.
Mais en théorie oui il y est vu que c'est une dépendance.
A chaque fois ça veut dire que j'étais pas concentrée sur la liste des dépendances qui allaient être installées (probablement mon chat qui devait me déconcentrer lol)

Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#18 16-10-2019 14:51:53

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.8.0-2-amd64
(G)UI : mutter 3.38.0-2
Inscription : 15-02-2016

Re : RÉSOLU mei & wdt !!!

Est-ce quelqu'un a un argument pour faire installer intel-microcode et iucode-tool à Choupex22 ? Pour l'instant je n'en ai pas vu.

Est-ce que quelqu'un est capable de supprimer une partie de l'erreur mei par la mise à jour du Management Engine Intel avec iucode-tool ?

La méthode est décrite ici : https://gitlab.com/iucode-tool/iucode-t … ter/README
Une seule erreur dans la démarche et l'ordinateur est mort.

Les erreurs décrites dans le sixième message n'empêchent nullement un fonctionnement correct du PC.

Dernière modification par --gilles-- (16-10-2019 14:53:01)


La liberté est liée à la qualité du langage, et les bureaucrates qui veulent détruire la liberté ont tous tendance à mal écrire et à mal parler, à se servir d’expressions pompeuses ou confuses, à user de clichés qui occultent ou oblitèrent le sens. Georges Orwell

Hors ligne

#19 16-10-2019 15:40:00

naguam
Membre
Lieu : Quelque part
Distrib. : Plusieurs
Noyau : Ça dépend
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : RÉSOLU mei & wdt !!!

Euh souvent les mises a jour de l'IME (Intel Management Engine avec i (mei) pour Interface pour le kernel) se fait avec les update de bios (vu sur mon dell xps) avec fwupd mais si ta machine n'a pas le support d'installation lvfs (machine un peu ancienne par rapport a lvfs, ou constructeur qui ne s'est pas encore impliqué), c'est fichu depuis linux.
Le microcode ne met pas à jour l'IME il me semble et iucode-tool manipule que le microcode.
De plus si la machine est ancienne, peut-être que meme si les derniers microcodes sont installés, le processeur utilisera sa dernière version supportée à lui.

Dans spectre-and-meltdown-checker, il y utilisation de MCExtractor
Vous verrez que meme avec le dernier microcode installé, si intel a décidé d'arrêter de mettre à jour votre microcode (tous intel avant les core i de seconde ou troisième gen globalement), l'outil vous renvera la version du dernier microcode qui supporte votre processeur. Il peut dater de 2008 (date non exhaustive), sans les corrections de spectres et meltdown et autres failles (intégrées dans le microcode, pas des fix dans le kernel).

Dernière modification par naguam (16-10-2019 15:56:49)

Hors ligne

#20 16-10-2019 15:55:55

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.2
Noyau : Linux 5.3.18
(G)UI : KDE 5.18.5
Inscription : 11-03-2016

Re : RÉSOLU mei & wdt !!!

@robert2a : non je suis passée à openSUSE Leap avec KDE, je suis encore en apprentissage tongue

Sinon pour le sources.list, il faudra mettre à la fois contrib et non-free pour réussir à installer le paquet intel-microcode.

@gilles : l’installation du paquet intel-microcode est une demande de Choupex22 au message #7. Tant qu'à savoir ce que ça apportera ....
Enfin ça lui permettra toujours d’ajouter contrib au sources.list et de ne plus avoir de retour sur les dépendances non satisfaites.

Hors ligne

#21 16-10-2019 16:07:57

naguam
Membre
Lieu : Quelque part
Distrib. : Plusieurs
Noyau : Ça dépend
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : RÉSOLU mei & wdt !!!

Donc si melissa ne se trompe pas, le processeur est un Intel Pentium E2160, sorti en 2006. Je peux quasiment vous garantir que mettre les microcodes à jour ne changera pas tellement grand chose étant donné que la dernière version supportée doit commencer à dater.

Ce genre d'erreur

mei_wdt mei::05b79a6f-4628-4d7f-899d-a91514cb32ab:01: cannot connect
[   11.090577] mei_wdt mei::05b79a6f-4628-4d7f-899d-a91514cb32ab:01: Could not enable cl device
[   11.090640] mei_wdt: probe of mei::05b79a6f-4628-4d7f-899d-a91514cb32ab:01 failed with error -5
[   11.216957] mei mei::55213584-9a29-4916-badf-0fb7ed682aeb:01: Could not read FW version
[   11.217027] mei mei::55213584-9a29-4916-badf-0fb7ed682aeb:01: FW version command failed -5

doit probablement venir du fait que le mei de 2006 (même mis à jour jusqu'en je ne sais pas quelle année, mais avant 2016 grand maximum je pense) n'aie pas les fonctionnalitées les derniers mei ont.
Cependant cela ne devrait pas créer de warning ou erreurs kernel, le kernel est tout de même censé fonctionner sur ton processeur qui est une architecture supportée.

Je suppose que malgré ça ton ordinateur doit bien fonctionner, donc il n'y a rien a faire si ce n'est remonter l'erreur aux mainteneurs du kernel debian (pas aux devs du kernel sur kernel.org, car ils le disent sur leur page, qu'ils ne supportent pas les kernel de distro, et que si c'est inhérent au kernel, eux-même en théorie feront remonter le bug)

Aussi il dis au début qu'il a déjà installé firmware-linux-nonfree.
Ce qui signifie qu'il a déjà installé le microcode intel avec (version de debian, je sais pas si très a jour sur stable, mais buster reste accez recent, et probablement plus récent que la dernière version supportée par son processeur si tant est que son processeur utilise un microcode logiciel chargé par le kernel, vu son âge 2006.)

Dernière modification par naguam (16-10-2019 16:18:35)

Hors ligne

#22 16-10-2019 17:41:47

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.2
Noyau : Linux 5.3.18
(G)UI : KDE 5.18.5
Inscription : 11-03-2016

Re : RÉSOLU mei & wdt !!!

naguam a écrit :

Ce qui signifie qu'il a déjà installé le microcode intel avec


euh non puisqu'une dépendance de ce paquet intel-microcode n'est pas présente sur le système.
Peut-être que comme intel-microcode est seulement un paquet recommandé du paquet firmware-linux-nonfree et non une dépendance, ce dernier s'est installé quand même sans le paquet intel-microcode. Je n'ai pas réinstallé de système sous VM pour tester et vérifier mais ça me semble le plus probable.

Hors ligne

#23 16-10-2019 20:24:27

naguam
Membre
Lieu : Quelque part
Distrib. : Plusieurs
Noyau : Ça dépend
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : RÉSOLU mei & wdt !!!

Debian par default sauf configuration spécifique, installe les paquets recommandés (pas les suggérés) et firmware-linux-nonfree (et pas juste free) qui s'installe a partir des dépots non-free a le paquet intel-microcode en recommandé, a moins qu'il ne l'ai pas installé par les dépots, mais le .deb a la main, mais c'est un peu étrange vu que c'est un méta paquet.

En effet le message du post #7 est intrigant de ce côté là par rapport a ce qui est dis dans le premier post.

Exemple sur mon serveur de test.

root@serveur-de-test:~# apt install firmware-linux-nonfree
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
  amd64-microcode firmware-amd-graphics firmware-misc-nonfree intel-microcode iucode-tool
Les NOUVEAUX paquets suivants seront installés :
  amd64-microcode firmware-amd-graphics firmware-linux-nonfree firmware-misc-nonfree intel-microcode iucode-tool
0 mis à jour, 6 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 8819 ko dans les archives.
Après cette opération, 45,7 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] n
Annulation.
root@serveur-de-test:~#



Après de toute manière, ça ne change rien à ce que j'ai dis par rapport aux microcodes.

Dernière modification par naguam (16-10-2019 20:35:44)

Hors ligne

#24 16-10-2019 20:37:06

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : RÉSOLU mei & wdt !!!

dans son sourcelist il y a que non-free et main, tout simplement.

hors quand on met non-free, on met aussi contrib, certains paquets non-free ont besoin de dépendances contrib d'où le blocage, je viens de faire le test en V.M à l'instant wink
tout est reproductible, j'ai exactement le même message d'erreur et le même blocage.

contrib dépend de non-free bien souvent, il est obligatoire, c'est les 2 ensembles ou aucun, mais pas la moitié

Dernière modification par melissa6969 (16-10-2019 20:38:06)


Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#25 16-10-2019 20:41:30

naguam
Membre
Lieu : Quelque part
Distrib. : Plusieurs
Noyau : Ça dépend
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : RÉSOLU mei & wdt !!!

Ok merci de l'info smile et je plussoie, vaut mieux mettre les deux ou rien. Après, d'après l'âge du processeur, il y a des chances que le microcode, ne change pas grand chose, mais ça vaut le coup d'essayer car il ne trouve carrément aucun firmware. smile
Pourtant https://packages.debian.org/fr/buster/intel-microcode, c'est en rouge marqué non-free. Donc comportement spécial si il faut les contrib.
iucode-tool lui est contrib en effet.

Ps: sur le net des personnes ayant le soucis avec le mei, l'ont résolu avec une mise à jour du bios pour le mei, ce qu'il ne risque pas d'arriver sur une machine avec un pro datant de il y a plus de 10 ans.
Je ne veux pas être tout pessimiste quand meme, et au moin l'intérêt de ce genre de proc ancien c'est que je crois qu'il y a moyen de désactiver l'IME completement (processeurs avant nehalem (core i premiere gen), https://github.com/corna/me_cleaner. mais je n'irais pas plus loin, ce n'est pas le sujet

Dernière modification par naguam (16-10-2019 21:18:50)

Hors ligne

Pied de page des forums