Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-10-2019 14:28:39

paul-riluma
Membre
Distrib. : debian...
Noyau : euh...
(G)UI : ah tiens !
Inscription : 22-09-2019

scanne des mails dans claws mail par clamav-daemon

bonjour tout le monde

n'ayant pas trouvé de discussion quant aux configurations de versions récentes du plugin de claws mail permettant de faire scanner les mails par clamav-daemon

n'ayant pas trouvé d'indications fonctionnant avec les versions récentes installées sur Debian9
sur les machines installées avec Debien8 je ne rencontre pas de problème

je propose cette annonce

le problème rencontré depuis Debian9 se présente comme ça dans une fenêtre d'alerte :
Erreur lors de la vérification :
~/.claws-mail/mimetmp/00000000.mimetmp: lstat() failed: Permission denied. ERROR

bon, alors en courant dans les log, on n'est pas mieux renseigné, il y a effectivement un problème de droit d'accès...
donc, j'ai d'abord bidouillé diverses solutions de permissions sur les dossiers concernés, puis d'ajout de groupe et d'utilisateur en fouillant dans le /etc/group et les man de scripts...

ben ça résiste

y'a aussi une recommandation qui traînait sur bon nombre d'échanges autour de cette question :
j'en site une ici, ayant le même principe et la même résolution
Making tests over the new server I have seen that ClamAV is not
operating fine due to permission problems:
[...]
MailScanner[15458]: Virus and Content Scanning: Starting
MailScanner[15458]: Clamd::ERROR:: UNKNOWN CLAMD RETURN ./lstat()
failed: Permission denied. ERROR :: /var/spool/MailScanner/incoming/15458
MailScanner[15458]: Virus Scanning: Clamd found 1 infections
MailScanner[15458]: Virus Scanning: Found 1 viruses
[...]

I have solved the problem modifying the configuration parameter
AllowSupplementaryGroups from false to true in the file:
/etc/clamav/clamd.conf
...
ben, les nouvelles versions de clamav ne prennent pas en compte cet directive AllowSupplementaryGroups
qui n'apparaît pas dans le man...

donc voilà. j'ai pas installé de machine avec Debian 10, donc je ne sais pas si ce truc, qui n'empèche pas de recevoir le mail hein, a été ou pas résolu quelque part.

vais peut-être voir si je peux pas bricoler quelque chose avec p3scan comme ça se faisait il y a longtemps...
mais bon

si quelqu'un a trouvé une astuce, ça servira à d'autres...

Hors ligne

#2 28-11-2019 21:09:33

paul-riluma
Membre
Distrib. : debian...
Noyau : euh...
(G)UI : ah tiens !
Inscription : 22-09-2019

Re : scanne des mails dans claws mail par clamav-daemon

ello le monde
bon, ben si ça intéresse quelqu'un
je pense avoir trouvé une solution à la question de comment configurer clamav pour que les plugins de claws ou de thunderbird de fassent pas des alertes qui font peur...

donc je vous copie ici mes notes à la suite de mes bricolages

sous debian9
la configuration de clamav pose problème
notamment dès lors qu'on veut faire scanner les mails avec les plugins pour claws-mail ou pour thunderbird

même sans rapport avec un client mail, en faisant :
$ systemctl status clamav-daemon.service clamav-daemon.socket clamav-freshclam.service
on a des alertes racontant que le clamav-daemon.socket n'est pas trouvé...
donc il faut "faire quelque chose merde quoi !"

je me suis servi de deux sources principales pour résoudre ma configuration.
j'ai du les adapter du fait que les indications ne correspondaient pas exactement à mon environnement système
https://addons.thunderbird.net/en-US/th … n/reviews/
avec cette remarque en particulier

"Now using a text editor add these two lines to /etc/clamav/clamd.conf
sudo vim /etc/clamav/clamd.conf
TCPSocket 3310
TCPAddr 127.0.0.1
Save changes to clamd.conf

Make sure there are only the following two lines in /etc/systemd/system/clamav-daemon.socket.d/extend.conf
sudo vim /etc/systemd/system/clamav-daemon.socket.d/extend.conf
SocketUser=clamav
ListenStream=127.0.0.1:3310
Save changes to extend.conf

Enter the following since the clamav-daemon.socket changed on disk.
sudo systemctl daemon-reload

Enter the following:
sudo systemctl restart clamav-daemon.service clamav-daemon.socket clamav-freshclam.service

sudo systemctl status clamav-daemon.service clamav-daemon.socket clamav-freshclam.service

The status of the clamav-daemon.socket should be:
Listen: /run/clamav/clamd.ctl (Stream)
127.0.0.1:3310 (Stream)"


https://bbs.archlinux.org/viewtopic.php?id=233951
et avec cette remarque en particulier :

"I managed to get it working, although the configuration file still appears to be getting ignored regarding the socket definition.

I edited the socket definition like this:

$ systemctl edit clamav-daemon.socket

Redefined the listen options:

[Socket]
ListenStream=
ListenStream=/run/clamav/clamd.ctl
ListenStream=127.0.0.1:3310

Then reloaded the defintion and restarted the service, result:

$ systemctl stop clamav-daemon.service
Warning: Stopping clamav-daemon.service, but it can still be activated by:
  clamav-daemon.socket
$ systemctl stop clamav-daemon.socket
$ systemctl daemon-reload
$ systemctl start clamav-daemon.service

Now init (systemd) is listening on port 3310"


je retrace ici mon adaptation dernière

configuration clamav
en root

reprise de /etc/clamav/clamd.conf
avec ceci :
#LocalSocket /var/run/clamav/clamd.ctl (autrement, ça bloque quelque chose avec la définition mise dans extend.conf, genre doublon...)
TCPSocket 3310
TCPAddr 127.0.0.1

reprise de /etc/systemd/system/clamav-daemon.service.d/extend.conf
avec uniquement ceci :
[Socket]
SocketUser=clamav
ListenStream=/var/run/clamav/clamd.ctl
ListenStream=127.0.0.1:3310

puis

$ systemctl edit --force clamav-daemon.socket
ça ouvre un fichier dans un éditeur du genre nano
où je mets strictement
[Socket]
ListenStream=
ListenStream=/var/run/clamav/clamd.ctl
ListenStream=127.0.0.1:3310

ensuite
$ systemctl daemon-reload
puis
$ systemctl restart clamav-daemon.service clamav-daemon.socket clamav-freshclam.service
puis je vérifie :
$ systemctl status clamav-daemon.service clamav-daemon.socket clamav-freshclam.service
ce qui me donne
● clamav-daemon.service - Clam AntiVirus userspace daemon
   Loaded: loaded (/lib/systemd/system/clamav-daemon.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/clamav-daemon.service.d
           └─extend.conf
   Active: active (running) since Thu 2019-11-28 20:16:44 CET; 14s ago
     Docs: man:clamd(8)
           man:clamd.conf(5)
           https://www.clamav.net/documents/
Main PID: 2428 (clamd)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/clamav-daemon.service
           └─2428 /usr/sbin/clamd --foreground=true

nov. 28 20:16:44 carnet systemd[1]: Started Clam AntiVirus userspace daemon.

● clamav-daemon.socket
   Loaded: loaded (/etc/systemd/system/clamav-daemon.socket; static; vendor preset: enabled)
  Drop-In: /etc/systemd/system/clamav-daemon.socket.d
           └─override.conf
   Active: active (running) since Thu 2019-11-28 20:16:44 CET; 14s ago
   Listen: /var/run/clamav/clamd.ctl (Stream)
           127.0.0.1:3310 (Stream)

nov. 28 20:16:44 carnet systemd[1]: Listening on clamav-daemon.socket.

● clamav-freshclam.service - ClamAV virus database updater
   Loaded: loaded (/lib/systemd/system/clamav-freshclam.service; enabled; vendor preset: enabled)
   Active: active (running) since Thu 2019-11-28 20:16:43 CET; 16s ago
     Docs: man:freshclam(1)
           man:freshclam.conf(5)
           https://www.clamav.net/documents
Main PID: 2426 (freshclam)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/clamav-freshclam.service
           └─2426 /usr/bin/freshclam -d --foreground=true

où donc on a bien ceci pour clamav-daemon.socket :
Listen: /var/run/clamav/clamd.ctl (Stream)
           127.0.0.1:3310 (Stream)

et à partir de quoi on peut installer puis configurer claws mail et le plugin clam antivirus de chez claws et compagnie...
on configure un premier compte mail pour lancer le client
puis on charge les plugins à partir de l'onglet /configuration/modules
où il est indiqué je cite :
"vous devez configurer le démon clamav afin qu'il communique via une socket TCP et opter pour la configuration manuelle de clamd." parce que les changements de permissions sur les dossiers ne fonctionnent pas... donc
on va dans /configuration/préférences/modules/clam anti virus
et
où il faut décocher la configuration automatique
et indiquer
pour hôte distant : 127.0.0.1
et pour Port : 3310

à partir de là
ça fonctionne, on n'a plus les alertes qui font peur...
voilà

merci ...de rien...

Dernière modification par paul-riluma (01-12-2019 23:10:45)

Hors ligne

Pied de page des forums