Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-11-2019 17:08:47

ahote
Membre
Lieu : 42
Distrib. : bullseye / win10
Noyau : Linux 5.7.0-3
(G)UI : parfois
Inscription : 09-12-2018
Site Web

serveur wordpress

bonjour a tous

je suis en train d'essayé d'installer wordpress sur mon serveur sous debian 10 nginx php 7.0 et mariaDB

lorsque j'essaye d'ouvrir la page d'installation de WP il essaye de me téléchargé l'index sans l’interprété :-(

lordsque je fait un :test nginx ca ne passe pas

sudo nginx-t
nginx: [emerg] no port in upstream "php-wp" in /etc/nginx/sites-enabled/wp:63
nginx: configuration file /etc/nginx/nginx.conf test failed




emplacement wordpress : /var/www/html/wp/

voicie mon Vhost
(/etc/nginx/sites-aviable)

server {
    listen            80;
    listen            [::]:80;
    server_name        g-linfo.fr www.g-linfo.fr;
    return            301 https://$host$request_uri;

    root                    /var/www/html;

    index                     index.php;


}



server {
    listen            443 ssl http2;
    listen            [::]:443 ssl http2;
    server_name        g-linfo.fr www.g-linfo.fr;

    root            /var/www/html;
   
    index              index.php;
   
    ssl_certificate           /etc/letsencrypt/live/www.g-linfo.fr/fullchain.pem;
    ssl_certificate_key       /etc/letsencrypt/live/www.g-linfo.fr/privkey.pem;
    ssl_trusted_certificate   /etc/letsencrypt/live/www.g-linfo.fr/chain.pem;

    ssl_dhparam               /etc/ssl/certs/dhparam.pem;

    ssl_protocols             TLSv1 TLSv1.1 TLSv1.2;
    ssl_prefer_server_ciphers on;
    ssl_ciphers               'kEECDH+ECDSA+AES128 kEECDH+ECDSA+AES256 kEECDH+AES128 kEECDH+AES256 kEDH+AES128 kEDH+AES256 DES-CBC3-SHA +SHA !aNULL !eNULL !LOW !kECDH !DSS !MD5 !EXP !PSK !SRP !CAMELLIA !SEED';
    ssl_ecdh_curve            secp384r1;
   
    ssl_session_cache         shared:SSL:1m;
    ssl_session_timeout       1440m;
    ssl_stapling              on;
    ssl_stapling_verify       on;
    resolver                  1.1.1.1 1.0.0.1;

    add_header                Strict-Transport-Security max-age=31536000;


    location / {
        try_files     $uri $uri/ /index.php?$args;
    }

    location = /favicon.ico {
        log_not_found off;
        access_log    off;
    }

    location = /robots.txt {
        allow                    all;
        log_not_found off;
        access_log    off;
    }

    location ~ .php$ {
        include       fastcgi.conf;
        fastcgi_pass  php-wp;
    }

    location ~* .(js|css|png|jpg|jpeg|gif|ico)$ {
        expires       max;
        log_not_found off;
    }
}



je sait pas quoi faire ^^

Hors ligne

#2 09-11-2019 17:54:32

phlinux
Membre
Distrib. : Jessie
Noyau : 4.9
(G)UI : Openbox (+Rox+Feh)
Inscription : 09-05-2009

Re : serveur wordpress

Bjr,

Je ne vais pas t'aider beaucoup, mais le fichier que tu as posté ce n'est pas celui où il y a l'erreur ou je me trompe ?

Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#3 09-11-2019 19:06:06

ahote
Membre
Lieu : 42
Distrib. : bullseye / win10
Noyau : Linux 5.7.0-3
(G)UI : parfois
Inscription : 09-12-2018
Site Web

Re : serveur wordpress

salut merci de ta réponse :-)

a priori si j'en crois le message d'erreur, si c'est bien sur celui-ci

mais il y a peut être d'autres erreur ailleur roll

Hors ligne

#4 09-11-2019 21:35:34

bendia
Chadministrateur
Distrib. : openSUSE Tumbleweed, Stretch
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console et un peu Openbox
Inscription : 20-03-2012
Site Web

Re : serveur wordpress

Salut smile

Comme souvent, le message te donne la ligne où se trouve l'erreur, la ligne 63, elle correspond à ça

fastcgi_pass  php-wp;


Donc, il doit y avoir une boulette ligne 63.

Je ne connais pas plus que ça nginx, mais la doc de la directive incriminée est là https://nginx.org/en/docs/http/ngx_http … stcgi_pass

Il semble qu'il faille donner une adresse + port ou un socket, ou un groupe de serveur pour cette directive, et il semble manquer le port hmm


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

Hors ligne

#5 10-11-2019 09:12:18

ahote
Membre
Lieu : 42
Distrib. : bullseye / win10
Noyau : Linux 5.7.0-3
(G)UI : parfois
Inscription : 09-12-2018
Site Web

Re : serveur wordpress

Bonjour,

j'ai finalement trouvé la solution il manquait un paraggraphe ^^

j'ai ajouté ceci comme en-tète

upstream php-wp {
    server            unix:/var/run/wp.sock;
}



ca foctionne nickel ;-)



il ne me reste plus qu'a modifié mon root pour que WP passe en page principale :-)

Hors ligne

Pied de page des forums