Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 18-11-2019 23:09:00

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

[RESOLU]Impossible d'installer le système d'exploitation

Hello, sujet étrange n'est ce pas ?

Je tente désespéremment d'installer debian sur un pc suisse en qwertz mais quelque soit le système d'exploitation, je parviens toujours sur un messqge d'erreur qui me dit que l'installation ne peut se finir.

Je jette un oeil à geparted pour vérifier que mes partitions sont "propres" et  là je tourne en rond :

https://debian-facile.org/images/file-R … c2a7956ea6

Sur certains os linux un smartcontrol est lancé et l'on me dit que le disque dur est clean.

L'ordi est un dell laptop , core 5, 4 go de ram et un dd de 300 go


System:    Host: mx1 Kernel: 4.19.0-6-amd64 x86_64 bits: 64 compiler: gcc v: 8.3.0
           parameters: lang=fr_FR quiet splasht
           Desktop: Xfce 4.14.1 tk: Gtk 3.24.5 info: xfce4-panel wm: xfwm4 dm: LightDM 1.26.0
           Distro: MX-19_x64 patito feo October 21  2019 base: Debian GNU/Linux 10 (buster)
Machine:   Type: Laptop System: Dell product: Latitude E5420 v: 01 serial: <filter> Chassis:
           type: 9 serial: <filter>
           Mobo: Dell model: 0H5TG2 v: A01 serial: <filter> BIOS: Dell v: A05 date: 11/30/2011
Battery:   ID-1: BAT0 charge: 41.6 Wh condition: 41.6/62.2 Wh (67%) volts: 12.6/11.1
           model: Sanyo DELL 2VYF51A type: Li-ion serial: <filter> status: Full
CPU:       Topology: Dual Core model: Intel Core i5-2430M bits: 64 type: MT MCP
           arch: Sandy Bridge family: 6 model-id: 2A (42) stepping: 7 microcode: 2F
           L2 cache: 3072 KiB
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19157
           Speed: 798 MHz min/max: 800/3000 MHz Core speeds (MHz): 1: 798 2: 798 3: 798 4: 798
           Vulnerabilities: Type: l1tf
           mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
           Type: mds
           status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT vulnerable
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass status: Vulnerable
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full generic retpoline, STIBP: disabled, RSB filling
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics vendor: Dell
           driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0116
           Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa
           resolution: 1366x768~60Hz
           OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile v: 3.3 Mesa 18.3.6 compat-v: 3.0
           direct render: Yes
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Dell
           driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1c20
           Sound Server: ALSA v: k4.19.0-6-amd64
Network:   Device-1: Broadcom Limited BCM4313 802.11bgn Wireless Network Adapter
           vendor: Dell Inspiron M5010 / XPS 8300 driver: wl v: kernel port: 7040
           bus ID: 02:00.0 chip ID: 14e4:4727
           IF: wlan0 state: up mac: <filter>
           Device-2: Broadcom Limited NetXtreme BCM5761 Gigabit Ethernet PCIe vendor: Dell
           driver: tg3 v: 3.137 port: 7040 bus ID: 0a:00.0 chip ID: 14e4:1681
           IF: eth0 state: down mac: <filter>
Drives:    Local Storage: total: 327.40 GiB used: 505.0 MiB (0.2%)
           ID-1: /dev/sda vendor: Toshiba model: MK3261GSYN size: 298.09 GiB block size:
           physical: 512 B logical: 512 B speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter>
           rev: 0C scheme: MBR
           ID-2: /dev/sdb type: USB vendor: Kingston model: DataTraveler 3.0 size: 29.31 GiB
           block size: physical: 512 B logical: 512 B serial: <filter> rev: PMAP scheme: MBR
Partition: ID-1: / raw size: N/A size: 2.95 GiB used: 505.0 MiB (16.7%) fs: overlay
           source: ERR-102
Sensors:   System Temperatures: cpu: 59.0 C mobo: 44.0 C sodimm: 49.0 C
           Fan Speeds (RPM): cpu: 0
Repos:     No active apt repos in: /etc/apt/sources.list
           Active apt repos in: /etc/apt/sources.list.d/antix.list
           1: deb http://iso.mxrepo.com/antix/buster buster main
           Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list
           1: deb http://deb.debian.org/debian buster-updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/debian.list
           1: deb http://deb.debian.org/debian buster main contrib non-free
           2: deb http://deb.debian.org/debian-security buster/updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/mx.list
           1: deb http://mxrepo.com/mx/repo/ buster main non-free
           No active apt repos in: /etc/apt/sources.list.d/various.list
Info:      Processes: 232 Uptime: 1h 54m Memory: 3.75 GiB used: 1.22 GiB (32.6%) Init: SysVinit
           v: 2.93 runlevel: 5 default: 5 Compilers: gcc: 8.3.0 alt: 8 Shell: bash v: 5.0.3
           running in: quick-system-in inxi: 3.0.36
 



Merci de vos éclairages.

Dernière modification par calixtus06 (23-11-2019 09:56:07)


Il n'y a pas de mauvaises questions...

Hors ligne

#2 18-11-2019 23:13:59

framend
Modo-Moule zébrée
Lieu : /home/framend
Distrib. : Sid
Noyau : 5.7.0-2-amd64
(G)UI : i3-wm/tty
Inscription : 17-11-2018

Re : [RESOLU]Impossible d'installer le système d'exploitation

Le message d'erreur que tu mentionnes au début de ton message serait probablement d'une grande aide…

“It is not daily increase but daily decrease, hack away the unessential. The closer to the source, the less wastage there is.” - Bruce Lee (philosophe)

Hors ligne

#3 18-11-2019 23:23:50

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : [RESOLU]Impossible d'installer le système d'exploitation

Salut, je tente une réinstall, du coup j'aurai bientôt ce message d'erreur.
Pour le moment j'ai celui là qui semble dire que mom disque dur n'est peutêtre pas si en forme
https://debian-facile.org/images/file-R … fd12a91c0d

Il n'y a pas de mauvaises questions...

Hors ligne

#4 19-11-2019 00:16:04

framend
Modo-Moule zébrée
Lieu : /home/framend
Distrib. : Sid
Noyau : 5.7.0-2-amd64
(G)UI : i3-wm/tty
Inscription : 17-11-2018

Re : [RESOLU]Impossible d'installer le système d'exploitation

C'est décidement de saison c'est le 3eme de la journée hmm

Il est possible que le message indiquant un refus de finir l'install' vienne d'un ou plusieurs secteurs defectueux, j'ai eu le cas… (je ne me souvient plus trop des details, par contre).

“It is not daily increase but daily decrease, hack away the unessential. The closer to the source, the less wastage there is.” - Bruce Lee (philosophe)

Hors ligne

#5 19-11-2019 09:54:24

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU]Impossible d'installer le système d'exploitation

calixtus06 a écrit :

Pour le moment j'ai celui là qui semble dire que mom disque dur n'est peutêtre pas si en forme


Ce n'est pas une erreur, au pire un avertissement. 5 secteurs réalloués sur des centaines de millions, c'est anodin et ça n'a aucun impact opérationnel.

framend a écrit :

Il est possible que le message indiquant un refus de finir l'install' vienne d'un ou plusieurs secteurs defectueux


Dans ce cas l'installateur de cette distribution (MX ?) ferait mieux de se focaliser sur les secteurs illisibles réellement défectueux (pending, uncorrectable) plutôt que sur les secteurs réalloués qui sont en principe corrects.


Il vaut mieux montrer que raconter.

Hors ligne

#6 19-11-2019 21:03:18

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : [RESOLU]Impossible d'installer le système d'exploitation

Salut du coup, si j'ai bien compris... il faudrait que j'installe l'os sur la partie saine ? et si c'est le cas comment la repérer ?

Il n'y a pas de mauvaises questions...

Hors ligne

#7 19-11-2019 21:29:05

framend
Modo-Moule zébrée
Lieu : /home/framend
Distrib. : Sid
Noyau : 5.7.0-2-amd64
(G)UI : i3-wm/tty
Inscription : 17-11-2018

Re : [RESOLU]Impossible d'installer le système d'exploitation

Non, j'ai déjà eu un système refusant de s'installer sur un disque mourrant, c'est tout.
Personnellement un disque avec des secteurs defectueux (ou semblant en avoir) je le teste et le « jette » le cas écheant.

“It is not daily increase but daily decrease, hack away the unessential. The closer to the source, the less wastage there is.” - Bruce Lee (philosophe)

Hors ligne

#8 19-11-2019 22:59:01

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU]Impossible d'installer le système d'exploitation

On peut utiliser badblocks pour rechercher des secteurs défectueux qui n'auraient pas encore été détectés (parce que pas accédés).

Il vaut mieux montrer que raconter.

Hors ligne

#9 20-11-2019 10:34:29

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : [RESOLU]Impossible d'installer le système d'exploitation

Une fois badblock utilisé, que faire ?

Il n'y a pas de mauvaises questions...

Hors ligne

#10 20-11-2019 14:41:19

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU]Impossible d'installer le système d'exploitation

Ça dépend du résultat. Si badblocks n'a détecté aucun secteur défectueux, rien. Sinon, on peut écrire dans les secteurs défectueux détectés pour tenter de les réparer/réallouer. Ou bien créer le(s) système(s) de fichiers avec l'option qui va bien pour vérifier et marquer les blocs défectueux (-c pour mke2fs). S'il existe déjà, le vérifier avec l'option de vérification des blocs défectueux (-c pour e2fsck). Les fichiers contenus dans ces blocs seront endommagés ou supprimés.

Il vaut mieux montrer que raconter.

Hors ligne

#11 21-11-2019 18:12:14

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : [RESOLU]Impossible d'installer le système d'exploitation

raleur a écrit :

Ça dépend du résultat. Si badblocks n'a détecté aucun secteur défectueux, rien. Sinon, on peut écrire dans les secteurs défectueux détectés pour tenter de les réparer/réallouer. Ou bien créer le(s) système(s) de fichiers avec l'option qui va bien pour vérifier et marquer les blocs défectueux (-c pour mke2fs). S'il existe déjà, le vérifier avec l'option de vérification des blocs défectueux (-c pour e2fsck). Les fichiers contenus dans ces blocs seront endommagés ou supprimés.



mke2fs -c /dev/sdb1



 
mke2fs 1.44.5 (15-Dec-2018)
Creating filesystem with 77610240 4k blocks and 19406848 inodes
Filesystem UUID: c5503fa1-d0b3-4b19-b189-d71ee8fab109
Superblock backups stored on blocks:
  32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
  4096000, 7962624, 11239424, 20480000, 23887872, 71663616

Checking for bad blocks (read-only test):   0.00% done, 0:00 elapsed. (0/0/0 errdone                                                
Allocating group tables: done                            
Writing inode tables: done                            
Writing superblocks and filesystem accounting information: mke2fs: Erreur d'entrée/sortie while writing out and closing file system
root@LibraZiK2-studio-audio:/home/nicolas#
 



je ne comprends pas très bien le résultat qui a été très long à arriver 12 h environ, 2600 blocks environ à traiter. On lit 0 % traité mais ce pourcentage est monté à 100 juste avant le traitement .


Il n'y a pas de mauvaises questions...

Hors ligne

#12 21-11-2019 20:50:36

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU]Impossible d'installer le système d'exploitation

2600 blocs défectueux ? Si c'est le cas c'est trop, ce disque est inutilisable. Pour en avoir le coeur net il faudrait exécuter smartctl -a depuis un système live.
Quel a été le résultat de badblocks avant cela ?

Il vaut mieux montrer que raconter.

Hors ligne

#13 21-11-2019 22:08:11

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : [RESOLU]Impossible d'installer le système d'exploitation

raleur a écrit :

Pour en avoir le coeur net il faudrait exécuter smartctl -a depuis un système live.


https://debian-facile.org/doc:systeme:smartmontools

Force et courage


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums