Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-12-2019 10:27:47

RodolpheA
Membre
Inscription : 07-12-2019

Squid : Erreur de ssl-bump

Bonjour,

Je viens de réinstaller Squid sur Debian10 cependant quand je redémarre le service une erreur survient :

------------------
déc. 07 10:18:16 RFAI-FW squid[1296]: 2019/12/07 10:18:16| FATAL: Unknown https_port option 'ssl-bump'.
déc. 07 10:18:16 RFAI-FW squid[1296]: 2019/12/07 10:18:16| FATAL: Bungled /etc/squid/squid.conf line 3: https_port 0.0.0.0:3127 intercept ssl-bump generate-host-certificates=on dynamic_cert_mem_cache_size=4MB cert=/usr/local/squid/etc/ss
déc. 07 10:18:16 RFAI-FW squid[1296]: FATAL: Bungled /etc/squid/squid.conf line 3: https_port 0.0.0.0:3127 intercept ssl-bump generate-host-certificates=on dynamic_cert_mem_cache_size=4MB cert=/usr/local/squid/etc/ssl_cert/myCA.pem key=/
déc. 07 10:18:16 RFAI-FW squid[1296]: 2019/12/07 10:18:16| Squid Cache (Version 4.6): Terminated abnormally.
déc. 07 10:18:16 RFAI-FW squid[1296]: CPU Usage: 0.019 seconds = 0.015 user + 0.004 sys
déc. 07 10:18:16 RFAI-FW squid[1296]: Maximum Resident Size: 50192 KB
déc. 07 10:18:16 RFAI-FW squid[1296]: Page faults with physical i/o: 0
déc. 07 10:18:16 RFAI-FW systemd[1]: squid.service: Control process exited, code=exited, status=1/FAILURE
-----------------

Une personne aurait déjà rencontrer cette erreur ?
Merci par avance.

Hors ligne

#2 07-12-2019 15:18:00

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : Squid : Erreur de ssl-bump

Si tu veux faire du ssl bump, tu dois recompiler squid avec les options ssl qui vont bien.

En ligne

#3 07-12-2019 15:53:34

RodolpheA
Membre
Inscription : 07-12-2019

Re : Squid : Erreur de ssl-bump

Les options ont déjà été affecter lors de la compilation.

Hors ligne

#4 07-12-2019 16:14:34

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : Squid : Erreur de ssl-bump

Tu l'as recompilé toi même ?

Que donne ?

squid -v

En ligne

#5 07-12-2019 18:44:00

RodolpheA
Membre
Inscription : 07-12-2019

Re : Squid : Erreur de ssl-bump

Voici :

root@RFAI-FW:~# squid -v
Squid Cache: Version 4.6
Service Name: squid
Debian linux
configure options:  '--build=i686-linux-gnu' '--prefix=/usr' '--includedir=${prefix}/include' '--mandir=${prefix}/share/man' '--infodir=${prefix}/share/info' '--sysconfdir=/etc' '--localstatedir=/var' '--libexecdir=${prefix}/lib/squid' '--srcdir=.' '--disable-maintainer-mode' '--disable-dependency-tracking' '--disable-silent-rules' 'BUILDCXXFLAGS=-g -O2 -fdebug-prefix-map=/build/squid-SCWQnH/squid-4.6=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -Wl,-z,relro -Wl,-z,now -Wl,--as-needed -latomic' 'BUILDCXX=i686-linux-gnu-g++' '--with-build-environment=default' '--enable-build-info=Debian linux' '--datadir=/usr/share/squid' '--sysconfdir=/etc/squid' '--libexecdir=/usr/lib/squid' '--mandir=/usr/share/man' '--enable-inline' '--disable-arch-native' '--enable-async-io=8' '--enable-storeio=ufs,aufs,diskd,rock' '--enable-removal-policies=lru,heap' '--enable-delay-pools' '--enable-cache-digests' '--enable-icap-client' '--enable-follow-x-forwarded-for' '--enable-auth-basic=DB,fake,getpwnam,LDAP,NCSA,NIS,PAM,POP3,RADIUS,SASL,SMB' '--enable-auth-digest=file,LDAP' '--enable-auth-negotiate=kerberos,wrapper' '--enable-auth-ntlm=fake,SMB_LM' '--enable-external-acl-helpers=file_userip,kerberos_ldap_group,LDAP_group,session,SQL_session,time_quota,unix_group,wbinfo_group' '--enable-security-cert-validators=fake' '--enable-storeid-rewrite-helpers=file' '--enable-url-rewrite-helpers=fake' '--enable-eui' '--enable-esi' '--enable-icmp' '--enable-zph-qos' '--enable-ecap' '--disable-translation' '--with-swapdir=/var/spool/squid' '--with-logdir=/var/log/squid' '--with-pidfile=/var/run/squid.pid' '--with-filedescriptors=65536' '--with-large-files' '--with-default-user=proxy' '--with-gnutls' '--enable-linux-netfilter' 'build_alias=i686-linux-gnu' 'CC=i686-linux-gnu-gcc' 'CFLAGS=-g -O2 -fdebug-prefix-map=/build/squid-SCWQnH/squid-4.6=. -fstack-protector-strong -Wformat -Werror=format-security -Wall' 'LDFLAGS=-Wl,-z,relro -Wl,-z,now -Wl,--as-needed -latomic' 'CPPFLAGS=-Wdate-time -D_FORTIFY_SOURCE=2' 'CXX=i686-linux-gnu-g++' 'CXXFLAGS=-g -O2 -fdebug-prefix-map=/build/squid-SCWQnH/squid-4.6=. -fstack-protector-strong -Wformat -Werror=format-security'

Hors ligne

#6 07-12-2019 19:08:55

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : Squid : Erreur de ssl-bump

Je ne vois pas les options --with-openssl --enable-ssl et --enable-ssl-crtd activées.

Cette version de squid ne gère donc pas le bump ssl.

En ligne

#7 07-12-2019 19:17:55

RodolpheA
Membre
Inscription : 07-12-2019

Re : Squid : Erreur de ssl-bump

Je pensais l'avoir activé mince... Pourriez-vous me dire la procédure à effectuer ?
Merci.

Hors ligne

#8 07-12-2019 20:19:06

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : Squid : Erreur de ssl-bump

Regarde déjà dans les backports si tu n'as pas une version de squid déjà compilée avec ssl.

Sinon, tu peux télécharger les sources de squid et les compiler dans /usr/local.

Mais le mieux, c'est de recompiler le paquet debian source de squid. Pour cela, regarde ceci: https://raphaelhertzog.fr/2011/07/12/co … et-debian/

Tu dois juste modifier le fichier debian/rules du source pour ajouter les options manquantes avant de lancer la compilation.

Dernière modification par Beta-Pictoris (07-12-2019 20:19:23)

En ligne

#9 07-12-2019 20:30:12

RodolpheA
Membre
Inscription : 07-12-2019

Re : Squid : Erreur de ssl-bump

Il a déjà été compiler avec ssl.

Hors ligne

#10 07-12-2019 22:15:09

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : Squid : Erreur de ssl-bump

Tu parles de la version de squid qui est dans les backports ?

Dernière modification par Beta-Pictoris (07-12-2019 22:15:34)

En ligne

#11 08-12-2019 11:00:13

RodolpheA
Membre
Inscription : 07-12-2019

Re : Squid : Erreur de ssl-bump

Comment je vois exactement cela ?

Hors ligne

#12 08-12-2019 14:44:59

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : Squid : Erreur de ssl-bump

Tu peux rechercher des paquets debian en allant ici : https://packages.debian.org/index

En ligne

#13 08-12-2019 14:55:24

RodolpheA
Membre
Inscription : 07-12-2019

Re : Squid : Erreur de ssl-bump

Mais Squid est déjà installé et configuré.

Hors ligne

#14 08-12-2019 15:51:55

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : Squid : Erreur de ssl-bump

Je viens de regarder. Je ne vois pas de version de squid dans les backports.

Tu vas devoir recompiler les sources de squid pour faire du ssl bump.

Apparemment, c'est aussi le cas d'ubuntu.

Par contre, ssl bump est activé par défaut sur la famille redhat (fedora, centos,..).

Dernière modification par Beta-Pictoris (08-12-2019 15:58:48)

En ligne

#15 08-12-2019 16:21:19

RodolpheA
Membre
Inscription : 07-12-2019

Re : Squid : Erreur de ssl-bump

Merci pour l'info je vous retiens au courant les prochains jours wink

Hors ligne

Pied de page des forums