Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 28-12-2019 11:09:07

Lupa
Membre
Distrib. : Debian Stretch 4.9.110-3+deb9u6 / Buster
Noyau : 4.9.0-8-amd64 (Stretch) Buster : 5.4.0-0.bpo.2-amd
(G)UI : xfce
Inscription : 28-06-2017

Buster refuse la mise à jomur de WebMin.

Bonjour à tous, et joyeuse fêtes.

Sous Stretch, pas de problème : WebMin se met à jour. Mais pas sous Buster, ce matin.
Voici ce que me dit APT sous Buster :


E: Le dépôt http://download.webmin.com/download/repository sarge Release n'est pas signé.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
 



J'ai pourtant fait comme d'habitude :


service webmin stop

# Ajout de la clef PGP :
wget -O- http://www.webmin.com/jcameron-key.asc | apt-key add -

service webmin restart

 



Mais APT me refuse encore la mise à jour.

J'ai regardé la man d'apt-secure.



DÉPÔTS NON SIGNÉS
       Si une archive possède un fichier Release non signé ou pas de fichier Release du tout, les versions actuelles d'APT refuseront par défaut d'en télécharger des données dans les
       opérations update. Même si un frontal tel que apt-get(8) est forcé de télécharger, il demandera une confirmation explicite si une installation inclut un paquet d'une archive non
       authentifiée.

       Vous pouvez contraindre les clients APT à n'émettre que des avertissements en configurant l'option Acquire::AllowInsecureRepositories à true. L'option allow-insecure=yes de
       sources.list(5) peut aussi permettre à des dépôts individuels d'être non sécurisés. Veuillez noter que les dépôts non sécurisés sont fortement déconseillés et toutes les options
       pour contraindre APT à continuer à les prendre en charge devront être éventuellement supprimées. Les utilisateurs disposent aussi de l'option Trusted pour désactiver même les
       avertissements, mais il faut être sûr de comprendre ses implications détaillées dans sources.list(5).

       Un dépôt qui auparavant était authentifié, mais qui perdrait cet état lors d'une opération update envoie un message d'erreur à tous les clients d'APT quelle que soit l'option
       d'autoriser ou d'interdire l'utilisation de dépôts non sécurisés. L'erreur peut être contournée par le réglage supplémentaire de Acquire::AllowDowngradeToInsecureRepositories à
       true, ou, pour des dépôts individuels avec l'option allow-downgrade-to-insecure=yes de sources.list(5).
 



Comment dois-je saisir cette syntaxe dans le sources.list : 'allow-downgrade-to-insecure=yes' ?

Merci wink

En ligne

Pied de page des forums