Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-01-2020 17:15:25

laguespa
Membre
Distrib. : Stretch
Noyau : 4.9.0-4-amd64
(G)UI : Mate
Inscription : 25-09-2009

[Résolu] Problème avec grub au démarrage de la machine.

Bonjour.

Je viens de finir l'installation de Debian 10 Mate sur un portable hp. Je suis obligé de garder un dual  boot. Sur cet ordi il y avait windows et ubuntu.
Le problème c'est qu'au démarrage de l'ordi j'arrive sur un grub dont je dois sortir avec exit. Ensuite je peux choisir l'os sur lequel je vais démarrer. À noter qu'Ubuntu est toujours présent comme os possible alors que j'ai installé Debian sur la partition sur laquelle il se trouvait.

Sur le disque j'ai ça :


fdisk -l
 





Disque /dev/sda : 931,5 GiB, 1000204886016 octets, 1953525168 secteurs
Modèle de disque : WDC WD10JPVX-60J
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 4096 octets
taille d'E/S (minimale / optimale) : 4096 octets / 4096 octets
Type d'étiquette de disque : gpt
Identifiant de disque : DA53535D-A5A8-4AFA-9834-FF44C65AF88B

Périphérique      Début        Fin  Secteurs Taille Type
/dev/sda1          2048     534527    532480   260M Système EFI
/dev/sda2        534528     567295     32768    16M Réservé Microsoft
/dev/sda3        567296  932049986 931482691 444,2G Données de base Microsoft
/dev/sda4    1917272064 1919279103   2007040   980M Environnement de récupération Windows
/dev/sda5    1919279104 1953513471  34234368  16,3G Données de base Microsoft
/dev/sda6     932050944  940050431   7999488   3,8G Partition d'échange Linux
/dev/sda7     940050432  996728831  56678400    27G Système EFI
/dev/sda8     996728832 1917272063 920543232   439G Système de fichiers Linux

Les entrées de la table de partitions ne sont pas dans l'ordre du disque.
 



La partition /dev/sda1   2048     534527    532480   260M Système EFI était  présente avant l'installation de Debian et je me demande si le grub qui m'ennuie n'est pas là-dessus. À noter que cette partition dev/sda1 est une partition amorçable.

Vous avez une idée de comment faire pour démarrer tout de suite sur le grub de Debian ?

A+

Dernière modification par laguespa (04-01-2020 14:11:38)


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#2 03-01-2020 17:36:06

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Problème avec grub au démarrage de la machine.

L'installation de Debian n'a pas effacé le GRUB d'Ubuntu qui est sur la partition système EFI ni son entrée de boot EFI qui est dans les variables EFI. Tu peux voir les entrées de boot EFI avec efibootmgr. Tu peux aussi l'utiliser pour modifier l'ordre de boot mais d'expérience les firmwares UEFI de HP peuvent être capricieux et ne pas en tenir compte donc réfléchis à deux fois avant de supprimer le GRUB d'Ubuntu, ça pourrait aboutir à un boot par défaut sur Windows.

Aussi, tu peux remplacer le contenu de /boot/efi/EFI/ubuntu par celui de /boot/efi/EFI/debian, mais c'est sale.

Dernière modification par raleur (03-01-2020 17:39:03)


Il vaut mieux montrer que raconter.

Hors ligne

#3 03-01-2020 20:34:12

laguespa
Membre
Distrib. : Stretch
Noyau : 4.9.0-4-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Résolu] Problème avec grub au démarrage de la machine.

Et si je formate /dev/sda1 Système EFI et que je réinstalle Debian ?

"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#4 03-01-2020 20:50:10

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Problème avec grub au démarrage de la machine.

Tu devras aussi réinstaller Windows puisque le formatage aura effacé son chargeur d'amorçage.
Qu'est-ce que c'est que cette manie de vouloir toujours reformater et réinstaller au moindre petit problème ? On n'apprend jamais rien en faisant ça.

Je suis curieux de voir ce que efibootmgr affiche.

Dernière modification par raleur (03-01-2020 20:51:50)


Il vaut mieux montrer que raconter.

Hors ligne

#5 04-01-2020 07:29:50

laguespa
Membre
Distrib. : Stretch
Noyau : 4.9.0-4-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Résolu] Problème avec grub au démarrage de la machine.


efibootmgr
 




BootCurrent: 0003
Timeout: 10 seconds
BootOrder: 0002,3002,0001,0003,2001,2002,2003
Boot0001* Windows Boot Manager
Boot0002* ubuntu
Boot0003* debian
Boot2001* USB Drive (UEFI)
Boot2002* Internal CD/DVD ROM Drive (UEFI)
Boot3000* Internal Hard Disk or Solid State Disk
Boot3001* Internal Hard Disk or Solid State Disk
Boot3002* Internal Hard Disk or Solid State Disk
Boot3003* Internal Hard Disk or Solid State Disk
Boot3004* Internal Hard Disk or Solid State Disk

 



De ce que je peux constater au démarrage de l'ordi la machine boot sur l'ancien grub d'ubuntu, je tape exit pour en sortir, il passe au boot loader de windows où je choisis Debian et j'arrive sur le grub de Debian. Bref, pas génial comme truc...

Dernière modification par laguespa (04-01-2020 09:12:54)


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#6 04-01-2020 11:42:38

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Problème avec grub au démarrage de la machine.

Normal que ce soit le GRUB d'Ubuntu (0002) qui est lancé, il est en premier dans le BootOrder. Ce qui n'est pas normal, c'est que le GRUB de Debian aurait dû être mis en premier lors de son enregistrement alors qu'il est bon dernier derrière Ubuntu et Windows. Par contre ça m'étonnerait que ce soit le chargeur de Windows qui est lancé ensuite car par défaut il ne sait rien des autres OS installés et lance Windows immédiatement. D'autre part, la valeur de BootCurrent serait celle de Windows (0001) et non de Debian (0003). A mon avis c'est plutôt le menu de démarrage du firmware UEFI. Si tu effaçais le GRUB d'Ubuntu ou son entrée d'amorçage EFI, c'est Windows qui démarrerait par défaut sans possibilité de choisir Debian.

Pour mettre Debian en premier dans le BootOrder EFI, il y a plusieurs moyens possibles, pas forcément efficaces.
- modifier l'ordre dans les options d'amorçage du firmware UEFI, si ce dernier le permet
- réinstaller GRUB avec grub-install (en root, sans argument)
- modifier le BootOrder avec efibootmgr -o (cf. page de manuel)

S'il y a un fichier grub.cfg dans /boot/efi/EFI/ubuntu, il y a aussi moyen de le modifier pour chaîner le GRUB de Debian.

Il vaut mieux montrer que raconter.

Hors ligne

#7 04-01-2020 14:02:23

laguespa
Membre
Distrib. : Stretch
Noyau : 4.9.0-4-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Résolu] Problème avec grub au démarrage de la machine.

Merci raleur,

Un efibootmgr -n 0003 (debian) fonctionne bien, avec un boot direct sur le grub de debian.

Par contre, la commande efibootmgr -o semble être réinitialisée par autre chose dans l'efi :
je demande "efibootmgr -o 0003,3002,0001,0002,2001,2002,3000", ce qui m'affiche le boot order correspondant et est censé me permettre de booter sur debian en premier.
Mais cela n'est pas pris au redémarrage: je tombe sur le grub d'ubuntu, d'où je peux accéder au grub efi avec un "exit" et alors lancer debian.
Une fois sous debian, "efibootmgr" me redonne alors l'ancien ordre, avec ubuntu en premier. et donc sans avoir pris en compte ma demande.
J'ai fait la manip deux fois, sais tu d'où cela peut venir ?

Le problème persiste donc.
Je ne sais pas où chercher pour savoir si le firmware UEFI permet de modifier l'ordre d'amorcage.

Je n'ai pas encore fait le pas d'une réinstallation de grub avec grub-install, cela me permet dangereux.

"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#8 04-01-2020 14:11:06

laguespa
Membre
Distrib. : Stretch
Noyau : 4.9.0-4-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Résolu] Problème avec grub au démarrage de la machine.

C'est bon j'ai trouvé.
En fait, le bios me permettait de modifier l'ordre de d'amorçage assez facilement : dans system config, boot option, et dans la ligne "OS".
J'ai mis debian en 1er, et c'est tout bon.
Merci pour le coup de main.

"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#9 04-01-2020 15:01:08

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Problème avec grub au démarrage de la machine.

laguespa a écrit :

Par contre, la commande efibootmgr -o semble être réinitialisée par autre chose dans l'efi


Voilà typiquement le genre de mauvaise surprise auxquelles il faut s'attendre avec l'UEFI.
Au moins l'ordre de boot était gérable dans les options du firmware.
Maintenant tu peux supprimer l'entrée de boot d'Ubuntu avec efibootmgr -b -B et supprimer le répertoire correspondant dans /boot/efi/EFI.


Il vaut mieux montrer que raconter.

Hors ligne

Pied de page des forums