Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-01-2020 16:04:27

fiche
Membre
Lieu : Paris
Distrib. : Debian stable Buster
Noyau : Linux 4.19.0-6-686
(G)UI : Xfce
Inscription : 11-07-2016

[En attente] ISO Live qui ne charge pas - Toshiba Satellite L30-11E

Bonjour,

Hier j'ai voulu démarrer un PC portable Toshiba Satellite L30-11E sur un support USB live DF10 (et d'autres systèmes) : impossible.
A l'origine, c'était pour vérifier si le processeur pouvait supporter un système 64 bits.
Ce qui aurait dû être une formalité réglée en quelques minutes m'a en réalité posé problème. Et comme je manquais de temps pour réfléchir, j'ai laissé tomber.
Mais il doit bien y avoir une solution !

1) Caractéristiques du PC sur internet :

Satellite L30-11E
Référence: PSL33E-042030FR
    Windows Vista® Home Basic
    Processeur Intel® Pentium Core™ Duo T2080
    15.4 ", écran WXGA TFT
    Disque dur 120 Go
    1,024 (512 + 512) Mo, DDR2 RAM (533 MHz)

La carte graphique serait : ATI Radeon Xpress 200M

Dans les faits, celui d'hier est sous Windows 7 (assez lent et en fin de support Windows), avec 3 Go de RAM.

Après recherches, il ne semble compatible qu'en 32 bits.

2) Systèmes testés :

Accès au BIOS via F2 et paramétrage de la clé USB en 1ère position puis validation par F10 : OK

- DF 10 Buster 32 bits: j'accède au démarrage au menu "Tester Debian...", le système semble charger au tout début mais on reste sur l'écran avec "Legacy", bloqué.
- Ubuntu Budgie 18.04 32 bits : de mémoire : écran noir avec tiret qui clignote en haut à gauche
- Avec une clé Multisystem : Xubuntu 18.04 32 bits : Multisystem permet de choisir l'ISO mais après validation aucun écran pour tester en live

Comme le propriétaire du PC m'a dit que Ubuntu Mate 16.04 démarrait en live, je me suis résolu à l'installer. Et aux 2/3 de la barre d'avancement de l'installation : bloqué, pas de souris, pas de pavé tactile.
J'ai coupé l'alimentation et je devais plier bagages.

En conclusion, je soupçonne un problème de carte graphique (à cause du tiret qui clignote sur écran noir mais qui n'est pas apparu sur tous les tests).
Je n'avais pas le temps de chercher sur internet.

D'après vous, quelles manipulations sont à essayer ?
Quelles modifications des options de démarrage grub (avec la touche e) faut-il tenter pour faire charger le système puis faire l'installation de Debian Buster Xfce ?
nomodeset ?
acpi=off ?
noapic ?

Il n'y a aucune urgence puisque je ne reverrai ce PC que le mois prochain.

Dernière modification par fiche (05-01-2020 23:45:31)

Hors ligne

#2 05-01-2020 16:58:16

raleur
Membre
Inscription : 03-10-2014

Re : [En attente] ISO Live qui ne charge pas - Toshiba Satellite L30-11E

fiche a écrit :

Processeur Intel® Pentium Core™ Duo T2080


64 bits, comme tous les Intel Core.

Dernière modification par raleur (05-01-2020 16:58:45)


Il vaut mieux montrer que raconter.

Hors ligne

#3 05-01-2020 17:38:27

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [En attente] ISO Live qui ne charge pas - Toshiba Satellite L30-11E

On  a pas laissé une entrée grub "sans echec" avec nomodeset & co pour les carte graphiques à problème ? Il me semble.

Sinon les ISO qu'on distribue sont bien 64bits, on l'a "compilé" en 32 aussi. C'est écrit dans le nom de l'ISO normalement.

(et oui je dis "normalement" et "il me semble" parce que j'ai pas de quoi vérifier sous la main là-de suite é_è)

datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#4 05-01-2020 21:47:43

bonyred
Membre
Distrib. : Debian buster
Noyau : 4.14.0-3-686
(G)UI : mate
Inscription : 15-05-2015

Re : [En attente] ISO Live qui ne charge pas - Toshiba Satellite L30-11E

bonsoir et bonne année à tous,

j'ai un toshiba satellite L30-10T avec à peu près la même configuration que toi.

j'ai pas essayé DF linux dessus mais j'ai réussi à intaller une debian XFCE dessus. j'ai utilsé cette iso : firmware-10.2.0-i386-netinst.iso car le 64bit ne passe pas.

https://cdimage.debian.org/cdimage/unof … 86/iso-cd/

Avant l'installation j'ai indiqué

acpi=off
pnpbios=off
noapic



après au redémarrage tu dois installé les firmwares suivant si ils ne le sont pas .

firmware-misc-nonfree



firmware-amd-graphics



Voilà comment j'ai procédé en espérant que cela te soit utile.

A plus.

Hors ligne

#5 05-01-2020 21:51:28

fiche
Membre
Lieu : Paris
Distrib. : Debian stable Buster
Noyau : Linux 4.19.0-6-686
(G)UI : Xfce
Inscription : 11-07-2016

Re : [En attente] ISO Live qui ne charge pas - Toshiba Satellite L30-11E

Pour le processeur, je me suis fié à ce site qui d'après ce que je comprends ne serait que 32 bits : https://ark.intel.com/content/www/fr/fr … z-fsb.html
S'il supporte 64 bits, tant mieux.

J'ai pris la dernière DF 10 32 bits à partir d'un lien du forum wiki sur la prochaine ISO. Ce n'est pas l'ISO qui est en cause car les autres ne font pas mieux.
J'aurai peut-être du essayer la Debian 10 Xfce "pure" mais je ne l'ai que sur ma clé Multisystem et parfois Multisystem ne facilite pas les choses car les menus de démarrage sont modifiés.

Donc, ce serait l'option nomodeset qu'il faudrait privilégier ?

Hors ligne

#6 05-01-2020 23:15:48

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : [En attente] ISO Live qui ne charge pas - Toshiba Satellite L30-11E

@fiche
Méfies toi de multisystem, pour une installation de Debian, essaie de privilégier une clé usb normale (faite par etcher, ou dd, ou gnome-disks)
parce que bien souvent multisystem pose des soucis soit durant l'installation, soit c'est en post-installation que les problèmes surviennent.

et essaie également avec l'iso non free officiel de debian, ça peut parfois aider (ou pas)

et ton CPU est bien un 32 bits, donc inutile de tester le 64 bits (c'est écrit sur la page de Intel)

Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#7 05-01-2020 23:42:39

fiche
Membre
Lieu : Paris
Distrib. : Debian stable Buster
Noyau : Linux 4.19.0-6-686
(G)UI : Xfce
Inscription : 11-07-2016

Re : [En attente] ISO Live qui ne charge pas - Toshiba Satellite L30-11E

Merci Bonyred (et les autres intervenants !)
Cela va me faire gagner du temps en tests.

Et oui, je n'avais même pas fait attention à la ligne Mode sans echec (qui effectivement indique nomodeset etc... dans ses paramètres).

J'utilise toujours les versions non-free de Debian pour faciliter la reconnaissance mais DF10 est déjà une Debian non-free.

Multisystem est bien pratique pour transporter sur une seule clé plusieurs ISO (sur celle testée hier, par exemple, j'ai les différents environnements de Debian 32 bits : Lxde, Xfce, Gnome et Antix.
Jusqu'ici je n'ai pas eu de souci pour démarrer en live avec cette clé. Et comme je n'ai pas N clés USB si je n'ai pas le choix, je l'utilise pour l'installation.
Donc, dans le doute, mieux vaut ne l'utiliser que pour tester les ISO.

Je mets ce sujet en attente.
J'espère revoir ce PC le mois prochain au prochain RDV du libre.

Dernière modification par fiche (06-01-2020 00:20:50)

Hors ligne

#8 06-01-2020 01:14:44

raleur
Membre
Inscription : 03-10-2014

Re : [En attente] ISO Live qui ne charge pas - Toshiba Satellite L30-11E

fiche a écrit :

Pour le processeur, je me suis fié à ce site qui d'après ce que je comprends ne serait que 32 bits


Autant pour moi, j'ai confondu la gamme "Core" avec la micro-architecture de même nom. La seconde, utilisée à partir de la gamme Core 2, est 64 bits mais la première n'utilise pas la seconde mais l'architecture P6 héritée du Pentium Pro. Je trouve que c'est très con de la part d'Intel d'avoir utilisé le même nom pour des choses aussi différentes.


Il vaut mieux montrer que raconter.

Hors ligne

Pied de page des forums