Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-01-2020 22:20:36

jce76350
Membre
Lieu : Rouen
Distrib. : Debian_Buster 10.4
Noyau : 4.19.0-9-amd64
(G)UI : XFCE
Inscription : 24-08-2016
Site Web

Installer wine 5 (wine-devel et wine stable)

Depuis Debian 10 pour installer la version Wine
- pour la version  stable Wine 4.0.3 (winehq-stable) tout est OK depuis le Wiki,
- mais pour la version de développement Wine 5.0-rcX (winehq-devel), ce n'est plus possible de passer directement par le dépôt "https://dl.winehq.org/wine-builds/debian/ buster main".
Comme indiquer sur le Wiki "The wine-devel and wine-staging packages for Debian 10 and later require libfaudio0 as a dependency".
Il est donc fait référence à un post du forum : FAudio for Debian and Ubuntu.
il est conseillé de se servir d'un dépôt Debian 10 download.opensuse.org/ wink
les explications sont assez sommaires et ce n'est pas trop évident car le hic c'est qu'il ne faut surtout pas mélanger les dépôts dl.winehq.org/wine-builds/debian/   et download.opensuse.org/repositories/Emulators:/Wine:/Debian, sinon c'est la galère en message d'alerte.

- Il faut donc commencer comme normalement par

sudo dpkg --add-architecture i386

- puis

sudo apt update

- Télécharger la Release.key avec le navigateur - ou

wget -nc https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/Debian_10/Release.key

- puis

sudo apt-key add Release.key

- Créer le fichier par exemple wine.list dans /etc/apt/sources.list.d avec

## Uniquement ce dépot
deb https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/Debian_10 ./

- puis

sudo apt update

- enfin installer avec

sudo apt install --install-recommends winehq-devel

après l'installation tester la version

wine --version

qui doit donner wine-5.0-rcX
- puis lancer la configuration

winecfg

cela va télécharger Mono et l'installer, puis télécharger Gecko et l'installer et ...  peut être aussi refaire un téléchargement de Gecko et l'installer finalement
et ensuite afficher la configuration de Wine, et voila, il n'y a plus qu'à installer les programmes wink

Dernière modification par jce76350 (25-01-2020 11:08:08)


--
Jc E

Hors ligne

#2 25-01-2020 10:41:59

jce76350
Membre
Lieu : Rouen
Distrib. : Debian_Buster 10.4
Noyau : 4.19.0-9-amd64
(G)UI : XFCE
Inscription : 24-08-2016
Site Web

Re : Installer wine 5 (wine-devel et wine stable)

La version stable de Wine 5.0 est disponible depuis le 21/01/2020
mais attention pour Debian 10 comme indiqué plus haut il faut libfaudio0 comme dépendance.
Le Wiki est ainsi modifié

The WineHQ packages for Debian 10 and later require libfaudio0 as a dependency. Since the distro does not provide it for Debian 10, users of that version can download libfaudio0 packages from the OBS. See https://forum.winehq.org/viewtopic.php?f=8&t=32192 for details.

La version stable Wine 4.0.3 (winehq-stable) ne sera pas mise à jour automatiquement car il y une incompatibilité à cause des dépendances libfaudio0 et libstb0  amd64 et i386.
Pour mettre à jour il est donc conseillé de passer par le dépôt deb https://download.opensuse.org/repositor … /Debian_10 ./ comme indique plus haut

Donc pour passer de la version 4.03 à la 5.0, il faut supprimer le dépôt original
deb https://dl.winehq.org/wine-builds/debian/ buster main
et ajouter
deb https://download.opensuse.org/repositor … /Debian_10 ./
- puis
- Télécharger la Release.key avec le navigateur - ou

wget -nc https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/Debian_10/Release.key

- puis

sudo apt-key add Release.key

- puis

sudo apt update
...4 paquets peuvent être mis à jour 4 paquets peuvent être mis à jour. Exécutez « apt list --upgradable » pour les voir.

- puis

sudo apt upgrade

  - ensuite la mise à jour se déroule, après l'installation tester la version

wine --version

qui doit donner wine-5.0
Et tester votre programme, cela va télécharger Mono et l'installer, puis télécharger Gecko et l'installer et ...  peut être aussi refaire un téléchargement de Gecko et l'installer finalement.

Dernière modification par jce76350 (26-02-2020 09:59:54)


--
Jc E

Hors ligne

Pied de page des forums