Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 28-01-2020 14:58:56

JPTh
Membre
Lieu : Montréal
Distrib. : Buster
Noyau : Linux 4.19.0-6-amd64
Inscription : 28-01-2020

Erreur Synaptic La valeur « stable-updates » n'est pas valable RÉSOLU

Bonjour communauté Debian Facile.
Facile, vraiment ?

Voilà l'accueil que m'offre Synaptic après un épique passage de Stretch à Buster.

E: La valeur « stable-updates » n'est pas valable pour APT::Default-Release car cette version ne fait pas partie des sources disponibles.
E: _cache->open() failed, please report.
Puis m'offre une seule possibilité : fermer Synaptic.
----
Par ailleurs apt update prétend que les paquets sont à jour, ce dont je doute, et termine par un message unanime de
http://debian.mirror.rafal.ca/debian/di … /InReleasehttp://security.debian.org/debian-secur … /InRelease et
http://debian.mirror.rafal.ca/debian/di … /InRelease:
Voici le message.
The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.

Ma question à trois volets je sais ... je pousse un peu avec 3 volets mais mon intuition me dit qu'il est question de la même chose. Je présente quand même des excuses à l'avance
1- Comment rassurer Synaptic et reprendre les mises à jour avec cette interface graphique ?
2- Comment lui faire rapport, comme elle me demande poliment de le faire ?
3- Ou diable puis-je trouver des clés que mon nouvel ami apt pourra lire et exécuter ?

Je vous remercie à l'avance

Dernière modification par JPTh (29-01-2020 13:47:50)

Hors ligne

#2 28-01-2020 16:47:35

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : Erreur Synaptic La valeur « stable-updates » n'est pas valable RÉSOLU

On va regarder tes sources maintenant, il peut y avoir une écriture mauvaise.
Que retourne la commande :

cat /etc/apt/sources.list


Et pour assurer que tu n'as pas d'autres sources :

ls /etc/apt/sources.list.d/



Afin de faciliter la lecture des écritures des codes sur le forum, regarde le tuto :
Oh, quel beau BB …code où comment mettre en forme vos messages dans le fofo wink


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 28-01-2020 20:48:26

JPTh
Membre
Lieu : Montréal
Distrib. : Buster
Noyau : Linux 4.19.0-6-amd64
Inscription : 28-01-2020

Re : Erreur Synaptic La valeur « stable-updates » n'est pas valable RÉSOLU

Merci quasi...modo

La commande

cat /etc/apt/sources.list

  retourne :

# deb cdrom:[Debian GNU/Linux 9.3.0 _Stretch_ - Official amd64 NETINST 20171209-12:10]/ buster main
# deb cdrom:[Debian GNU/Linux 9.3.0 _Stretch_ - Official amd64 NETINST 20171209-12:10]/ buster main
deb http://debian.mirror.rafal.ca/debian/ buster contrib
deb http://security.debian.org/debian-security buster/updates contrib
# buster-updates, previously known as 'volatile'
deb http://debian.mirror.rafal.ca/debian/ buster-updates contrib



et

ls /etc/apt/sources.list.d/


ne retourne rien.

Hors ligne

#4 28-01-2020 22:28:18

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : Erreur Synaptic La valeur « stable-updates » n'est pas valable RÉSOLU

Assez étrange ta source canadienne, je te propose d'essayer cette commande en root qui la remplacera par des sources plus ortdoxes appliquables partout.
Tu copies donc la totalité de la commande ci-après dans un terminal :

cat > /etc/apt/sources.list <<EOF
# stable
deb http://deb.debian.org/debian/ buster main contrib non-free
# stable updates
deb http://deb.debian.org/debian/ buster-updates main contrib non-free
# stable-backports
deb http://deb.debian.org/debian/ buster-backports main contrib non-free
# stable security
deb http://security.debian.org/ buster/updates main contrib non-free
# stable proposed updates
#deb http://deb.debian.org/debian/ buster-proposed-updates main contrib non-free
EOF


Tu la colles tel quel dans un terminal root et tu valides.

Ensuite, le résultat de la commande :

cat /etc/apt/sources.list


devrait indiquer les nouvelles sources.

Fait un :

apt-get update


En utilisant bien l'outil apt-get et non juste apt.
Un :

apt-get dist-upgrade


et tes nouvelles sources seront complètes et plus tranquilles.

Force et courage


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#5 28-01-2020 23:32:20

JPTh
Membre
Lieu : Montréal
Distrib. : Buster
Noyau : Linux 4.19.0-6-amd64
Inscription : 28-01-2020

Re : Erreur Synaptic La valeur « stable-updates » n'est pas valable RÉSOLU

Done !

@smolski Ta longue commande à utiliser en root semble avoir très bien fonctionné puisque le résultat de

cat /etc/apt/sources.list


correspond à ta liste de sources orthodoxes.

Qui plus est

Apt-get update


a mené à la réception de 32 fichiers puis les mentions que je recopie ici. Ça parle de clés ignorées (les pôvres)

33,0 Mo réceptionnés en 30s (1089 ko/s)                                                                 
Lecture des listes de paquets... Fait
W: http://deb.debian.org/debian/dists/buster/InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.
W: http://security.debian.org/dists/buster … /InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.
W: http://deb.debian.org/debian/dists/bust … /InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.
W: http://deb.debian.org/debian/dists/bust … /InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.

apt-get dist-upgrade


annonce 0 mise à jour et 0 tout le reste.

Et, bonne nouvelle liée, Synaptic a cessé de me faire la gueule. 

En substance je dirais ... oui, avec toi, grâce à toi Debian semble facile.
Merci beaucoup

Bon. Voilà pour l'étrange source canadienne. Ça doit aller avec le réchauffement climatique qui tend à pourrir les hivers de Montréal.
 
Je devrais me faire un peu de mouron pour les clés ignorées ou bien je me met à chercher le bouton Résolu ?

Hors ligne

#6 29-01-2020 08:10:20

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : Erreur Synaptic La valeur « stable-updates » n'est pas valable RÉSOLU

Cela doit provenir des reliquats de ton installation précédente, je ne suis pas assez calé pour régler ce problème à distance de ton PC, je laisse à plus velu de t'aider pour la suite.

Nota :
Maintenant, tu peux utiliser la commande apt plutôt que apt-get pour la suite des mises à jour de ton système.
https://debian-facile.org/doc:systeme:apt:apt

Pour mettre le post en Résolu, tu édites ton premier post et tu l'ajoutes en modifiant le titre.
Je te conseille d'ouvrir un autre post dans la même section du forum pour des explications à propos des clés qui semblent mal foutues, et mettre un lien de redirection vers ce post pour demander que comment ce fait-ce ?

Tu peux compléter ton profil pour indiquer plus avant les infos concernant ton système et ta situation géographique :
Voir le tuto : Trop cool d'indiquer son installation dans son profil !

« C'est pas pire ainsi... » wink

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums