Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-01-2020 11:44:58

simon884
Membre
Inscription : 11-04-2019

Difficultées mise en place bonding mode 0 debian 10

J'essaie depuis quelques heures de mettre en place un bonding mode 0 sur une machine Debian 10 sans succès.
Niveau matériel j'ai une carte ethernet 4 ports en PCI express bien detecté par ma machine.

En gros j'ai suivit ce tuto: https://help.ubuntu.com/community/UbuntuBonding

J'ai donc installé ifenslave, j'ai configuré mon fichier interface

#ma connexion de base qui est surla carte mère du pc
auto enp4s0
iface enp4s0 inet static
    address 192.168.10.200
    gateway 192.168.10.1
    netmask 255.255.255.0


#test bonding

auto enp2s0f0
iface enp2s0f0 inet manual
    bond-master bond0

auto enp2s0f1
iface enp2s0f1 inet manual
    bond-master bond0


auto bond0
iface bond0 inet static
    address 192.168.211.124
    gateway 192.168.211.1
    netmask 255.255.255.0
    bond-mode 0
    bond-miimon 100
    bond-slaves none



Sauf que lorsque je lance mon service network j'obitens une erreur :

bond0: option mode: unable to set because the bond device has slaves



J'ai essayé pas mal de chose avant d'écrire ici
  1: ajouter dans

/etc/modules

bonding loop lp rtc
  2: ajouter dans mon fichier interfaces le bond avant le sinterfaces physique, visiblement bug qui était présent avant...
  3; j'ai aussi tenté de crée le fichier

/etc/modprobe.d/bonding.conf

et d'y ajouter

alias bond0 bonding
options bond0 mode=0 miimon=100



Je ne sais plus torp quoi faire, si quelq'un a une idée

Dernière modification par simon884 (29-01-2020 11:46:48)

Hors ligne

#2 29-01-2020 15:48:11

raleur
Membre
Inscription : 03-10-2014

Re : Difficultées mise en place bonding mode 0 debian 10

Tu as essayé de mettre la définition de bond0 avant celles de ses membres ?
Ou de spécifier les membres dans la définition de bond0 et non dans celles de ses membres ?

Il vaut mieux montrer que raconter.

Hors ligne

#3 30-01-2020 11:30:17

simon884
Membre
Inscription : 11-04-2019

Re : Difficultées mise en place bonding mode 0 debian 10

Effectivement j'ai changé l'ordre de déclaration dans mon fichier interfaces et ça fonctionne.

Maintenant j'ai une autre question, je souhaite utiliser ce bonding sur 2 box.
J'ai donc déclaré mon bond dans mon fichier interface ça c'est bon, maintenant j'aimerais savoir comment ça ofnctionne en faite, je souhaite brancher 2 box donc sur ma carte réseau, mais ma question est la suivante mes boxs doivent avoir une adresse ip dans le range de mon bond ou pas?

Actuellement mes boxs ont comme ip 192.168.213.11 et 192.168.214.11 mon bond lui dans mon fichier interfaces est en 192.168.211.124, je pense que si je branche comme tel ça ne peut pas fonctionner si?
Est-ce que mes box doivent avoir une ip en 192.168.211.X aussi?

Hors ligne

#4 30-01-2020 11:54:16

raleur
Membre
Inscription : 03-10-2014

Re : Difficultées mise en place bonding mode 0 debian 10

simon884 a écrit :

je souhaite utiliser ce bonding sur 2 box.


Des box internet ? Pour quoi faire ?


Il vaut mieux montrer que raconter.

Hors ligne

#5 30-01-2020 11:59:30

simon884
Membre
Inscription : 11-04-2019

Re : Difficultées mise en place bonding mode 0 debian 10

raleur a écrit :

Des box internet ? Pour quoi faire ?



Oui pour faire un équilibrage de charge entre mes 2 boxs internet et ainsi avoir un meilleur débit, un genre d'aggrégation wan en gros, j'ai vu pas mal d'exemple sur le net ou des mecs le faisait une box internet + une ligne wifi par exemple

Dernière modification par simon884 (30-01-2020 12:00:05)

Hors ligne

#6 30-01-2020 13:33:46

raleur
Membre
Inscription : 03-10-2014

Re : Difficultées mise en place bonding mode 0 debian 10

Le bonding Ethernet n'est pas la bonne solution pour l'agrégation de liens internet. Il faut une solution au niveau IP (routage avancé/ip rule/ip route).

Il vaut mieux montrer que raconter.

Hors ligne

#7 30-01-2020 13:46:51

simon884
Membre
Inscription : 11-04-2019

Re : Difficultées mise en place bonding mode 0 debian 10

raleur a écrit :

Le bonding Ethernet n'est pas la bonne solution pour l'agrégation de liens internet. Il faut une solution au niveau IP (routage avancé/ip rule/ip route).



Ok quleque chose comme ça https://wiki.debian-fr.xyz/Routage_s%C3 … s_internet ?

Hors ligne

#8 30-01-2020 13:59:12

raleur
Membre
Inscription : 03-10-2014

Re : Difficultées mise en place bonding mode 0 debian 10

Oui.

Il vaut mieux montrer que raconter.

Hors ligne

Pied de page des forums