Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-02-2020 17:21:38

garancerx
Membre
Inscription : 01-02-2020

problème installation Ocaml

Bonjour,
J'essaye en vain d’installer ocaml sur mon ordinateur.. J'ai lancé la commande :

sudo apt install ocaml


et j'ai une réponse

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 ocaml : Dépend: ocaml-base-nox mais ne sera pas installé
         Dépend: ocaml-base-4.05.0
         Dépend: ocaml-nox-4.05.0
 ocaml-ulex : Dépend: ocaml-findlib mais ne sera pas installé
              Dépend: libcamlp4-ocaml-dev-p9wj7 mais il n'est pas installable
              Dépend: ocaml-nox-4.02.3 mais il n'est pas installable
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
 



j'ai donc exécuté la commande demandée et j'ai eu comme réponse :

E: Impossible d'ouvrir le fichier verrou /var/lib/dpkg/lock-frontend - open (13: Permission non accordée)
E: Impossible d'obtenir le verrou de dpkg (/var/lib/dpkg/lock-frontend). Avez-vous les droits du superutilisateur ?
 



Est ce que quelqu'un pourrait me dire comment faire svp ?
J'ai bien évidemment fait :

sudo apt-get update
sudo apt-get upgrade



Merci d'avance

Hors ligne

#2 01-02-2020 20:35:06

ubub
Membre
Distrib. : debian 10 buster/stable
(G)UI : xfce
Inscription : 14-05-2019

Re : problème installation Ocaml

salut,
tu peux installer le paquet aptitude

sudo apt install aptitude


et avec, essayer d'installer ton paquet ou voir les dependances qui vont pas
aptitude est plus "bavard" et lorsque tu feras

sudo aptitude install ocaml


il te diras ce qui pose probleme et te proposera des solutions.
lis la doc avant:
https://debian-facile.org/doc:systeme:apt:aptitude
https://wiki.debian.org/fr/Aptitude

Hors ligne

#3 03-02-2020 12:13:20

garancerx
Membre
Inscription : 01-02-2020

Re : problème installation Ocaml

Pour installer aptitude j'ai exactement le même problème qu'avec Ocaml

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 aptitude : Dépend: aptitude-common (= 0.8.10-6ubuntu1) mais ne sera pas installé
            Dépend: libcwidget3v5 mais ne sera pas installé
            Dépend: libsigc++-2.0-0v5 (>= 2.8.0) mais ne sera pas installé
 ocaml-ulex : Dépend: ocaml-findlib mais ne sera pas installé
              Dépend: libcamlp4-ocaml-dev-p9wj7 mais il n'est pas installable
              Dépend: ocaml-nox-4.02.3 mais il n'est pas installable
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
 

Hors ligne

#4 03-02-2020 13:58:24

ubub
Membre
Distrib. : debian 10 buster/stable
(G)UI : xfce
Inscription : 14-05-2019

Re : problème installation Ocaml

C'est quoi ton source list?

cat /etc/apt/sources.list
cat /etc/apt/sources.list.d



aptitude : Dépend: aptitude-common (= 0.8.10-6ubuntu1)


chez moi

apt show aptitude
Depends: aptitude-common (= 0.8.11-7)

Hors ligne

#5 03-02-2020 14:12:03

garancerx
Membre
Inscription : 01-02-2020

Re : problème installation Ocaml

oulala je me retrouve avec plein de trucs :

Depends: aptitude-common (= 0.8.10-6ubuntu1), libapt-pkg5.0 (>= 1.1), libboost-filesystem1.65.1, libboost-iostreams1.65.1, libboost-system1.65.1, libc6 (>= 2.14), libcwidget3v5, libgcc1 (>= 1:3.0), libncursesw5 (>= 6), libsigc++-2.0-0v5 (>= 2.8.0), libsqlite3-0 (>= 3.6.5), libstdc++6 (>= 5.2), libtinfo5 (>= 6), libxapian30
 

Hors ligne

#6 03-02-2020 14:29:13

ubub
Membre
Distrib. : debian 10 buster/stable
(G)UI : xfce
Inscription : 14-05-2019

Re : problème installation Ocaml

oulala je me retrouve avec plein de trucs


C'est normal, c'est les paquets qui seront installés
Quand tu donnes un retour de commande, c'est bien de mettre la commande qui t'as donné ce résultat aussi..
Au fait, vu que t'as rien renseigné sur ton profil, et que ca aide pas, c'est quoi ton os? debian stretch, buster, ubuntu, mint ????

Hors ligne

#7 03-02-2020 15:28:38

garancerx
Membre
Inscription : 01-02-2020

Re : problème installation Ocaml

oups j'ai oublié de renseigner, je marche avec ubuntu, j'ai réussi à installer ocaml avec la commande aptitude que vous m'aviez donnée !
Merci bcp !!

Hors ligne

Pied de page des forums