Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-02-2020 09:26:28

ahote
Membre
Lieu : 42
Distrib. : bullseye / win10
Noyau : Linux 5.7.0-3
(G)UI : parfois
Inscription : 09-12-2018
Site Web

[RESOLU] buster sur pc asus X540YA (ecran noir suite a installation )

Bonjour à tous  :-)

Ca fait plusieurs  fois que j'essaye  d'installer  debian sur un laptop asus

L'installation  se déroule  correctement (mis a part le firmware ethernet  manquant )
mais lors du boot (après  installation)
L'accès a grub est ok puis Debian  commence  a se lancé ...ET PAF (non pas le chien...) j'ai un écran  noir avec un tiret clignotant...:-( ca rappelle  Windows mad

J'ai essayé  le recovery mode il commence  a se lancé  puis me demande  ctrl D et reste  figé dès que je tape ctrl D

J'ai refait  plusieurs  fois l'installation  c'est la même chose

Le pc a un uefi
J'ai désactivé  le secure boot le fast boot et le csm

J'utilise une  netinstall avec gnome comme choix d'environnement  ( j'ai besoin du gtk pour mac4lin )

C'est  assez urgent  car ma compagne  en a  besoin  pour ses études son macbook n'en peu plus et elle a du mal a lâché  la pomme mdrr aidé  moi a la convertir  au pingouin big_smile

Merci d'avance  :-D

Edit: j'ai oublié de  préciser ppur les partitions  j'ai fais :
Une partition  de démarrage  EFI
une partition  racine
Et une swap

J''ai fais simple big_smile

Dernière modification par ahote (04-02-2020 19:46:05)

Hors ligne

#2 04-02-2020 09:39:05

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : [RESOLU] buster sur pc asus X540YA (ecran noir suite a installation )

Essaye avec un autre environnement de bureau, je te conseille xfce, (car je sais qu'avec gnome il y a des problèmes avec wayland)

Dernière modification par Jean-Pierre Pinson (04-02-2020 09:39:23)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#3 04-02-2020 09:51:16

LaFouine
Membre
Distrib. : Debian testing
Noyau : 4.19.0-4-amd64
(G)UI : Xfce
Inscription : 10-04-2017

Re : [RESOLU] buster sur pc asus X540YA (ecran noir suite a installation )

essaye la methode que te propose Jean-Pierre Pinson.

Si cela ne marche pas tu te logue aux moment il te propose de faire ctrl D  sauf que le tappe le mots de passe root ,
il ne te montera pas le systeme mai sa te permmetra de voire les log

exemple:

cat /var/log/syslog


comme sa t'affiche le fichier en entier tu peux utiliser

cat /var/log/syslog |more

(touche espace pour defiler)
nano a la place de cat smile


Debian testing, nvidia 980 gtx sli, cm asurock 16 gb ram cpu i7 4,2 ghz

Hors ligne

#4 04-02-2020 09:55:20

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : [RESOLU] buster sur pc asus X540YA (ecran noir suite a installation )

ahote a écrit :

(mis a part le firmware ethernet  manquant )



Peux-tu nous en dire plus sur ta carte réseau, quelle marque, quelle modèle ?

Que renvoie la commande :

ifconfig -a

Dernière modification par Jean-Pierre Pinson (04-02-2020 10:00:44)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#5 04-02-2020 09:57:26

ahote
Membre
Lieu : 42
Distrib. : bullseye / win10
Noyau : Linux 5.7.0-3
(G)UI : parfois
Inscription : 09-12-2018
Site Web

Re : [RESOLU] buster sur pc asus X540YA (ecran noir suite a installation )

merci pour vos réponses  rapide big_smile je vais faire ca des que je rentre

Pour Xfce il gère le gtk ?
Comme je l'ai  dit j'en ais absolument  besoin pour mac4lin ( ou un équivalent )

Hors ligne

#6 04-02-2020 10:00:13

ahote
Membre
Lieu : 42
Distrib. : bullseye / win10
Noyau : Linux 5.7.0-3
(G)UI : parfois
Inscription : 09-12-2018
Site Web

Re : [RESOLU] buster sur pc asus X540YA (ecran noir suite a installation )

Le firmware j'e l'installerai après c'est pas un soucis  :-)
De memoire c'est un realtek 18qqch... ou 81qqch... je pense qu'il est dans les dépôts

Hors ligne

#7 04-02-2020 10:05:27

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : [RESOLU] buster sur pc asus X540YA (ecran noir suite a installation )

Si tu utilises une netinstall, tu as besoin d'internet pour l'install, donc il vaut mieux disposer, du firmware, tu peux le mettre sur une clé USB  wink

Dernière modification par Jean-Pierre Pinson (04-02-2020 10:11:43)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#8 04-02-2020 10:18:14

ahote
Membre
Lieu : 42
Distrib. : bullseye / win10
Noyau : Linux 5.7.0-3
(G)UI : parfois
Inscription : 09-12-2018
Site Web

Re : [RESOLU] buster sur pc asus X540YA (ecran noir suite a installation )

Oui c'est  pas faux :-) mais la ou je suis je n'ai pas de box  malheureusement... donc je fais ca en partage 4G via usb
Mais c'est vrais que je devrais me faire une clé  usb qui regroupe  le plus de firmware réseau  possible ( les realtek les broadcom les Intel  etc... )

  pour mes installation  ca peut être  utile  ^^ tu sais ou je pourrais  trouvé  ca ? big_smile
Je ne pe se pas que ce soit possible  de les télécharger depuis les dépôts  pour les mettre  sur une clé ?

Hors ligne

#9 04-02-2020 10:28:18

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : [RESOLU] buster sur pc asus X540YA (ecran noir suite a installation )

pour le firmware realtek, tu peux le télécharger ici -> https://packages.debian.org/buster/firmware-realtek Tout en bas de la page, Tu cliques sur all

Dernière modification par Jean-Pierre Pinson (04-02-2020 10:30:41)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#10 04-02-2020 11:07:50

ahote
Membre
Lieu : 42
Distrib. : bullseye / win10
Noyau : Linux 5.7.0-3
(G)UI : parfois
Inscription : 09-12-2018
Site Web

Re : [RESOLU] buster sur pc asus X540YA (ecran noir suite a installation )

Cool merci :-) je vaise faire une bibliothèque de  firmware  XD
Je sais que j'insiste ( je pense que mon post est passé  a la trappe  mdr
mais est ce que tu sais si Xfce est ok avec le Gtk car j'en ai vraiment  besoin pour mac4lin

Hors ligne

#11 04-02-2020 11:28:15

hybridemoineau
Membre
Inscription : 21-02-2016

Re : [RESOLU] buster sur pc asus X540YA (ecran noir suite a installation )

Xfce gère le gtk2 dans sa version 4.12 (celle de Debian stable buster) et le gtk3 dans sa version 4.14 (celle de Debian testing bullseye).

Un logiciel tiers peut installer les dépendances qui lui manquent, dont gtk, si nécessaire.

Hors ligne

#12 04-02-2020 11:52:27

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : [RESOLU] buster sur pc asus X540YA (ecran noir suite a installation )

oui, merci hybridemoineau wink

-> https://fr.wikipedia.org/wiki/Xfce


Mais xfce S'inspire pas mal déjà du look d'un mac.....-> https://i.imgur.com/KRbmVXQ.png

Dernière modification par Jean-Pierre Pinson (04-02-2020 12:08:21)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#13 04-02-2020 17:00:53

ahote
Membre
Lieu : 42
Distrib. : bullseye / win10
Noyau : Linux 5.7.0-3
(G)UI : parfois
Inscription : 09-12-2018
Site Web

Re : [RESOLU] buster sur pc asus X540YA (ecran noir suite a installation )

merci :-)

je n'avais pas le souvenir que Xfce ressemble a ca ^^
mais plutot a ca :https://memo-linux.com/wp-content/uploa … 3/xfce.png

mais bon pour le coup il faut vraiment qu'elle se croie sur un mac ^^ sinon elle n'en voudras pas ...kernal_panic.gif

je vient de réinstallé Buster avec Xfce c'est le meme probleme :-(
j'essaye de me log en root sur le recovery mode et je vous met les logs si ca fonctionne :-)

pour les firmware je vient de téléchargé tout les firmware contrib et non-free présent sur "package.debian.org" ^^
et je les ait ajouté dans mon iso et je referais une clé ^^ j’espère que ça vas fonctionné et que l'installateur les trouveras XD si c'est le cas c'est que du bonheur !! big_smile:D

Hors ligne

#14 04-02-2020 17:29:42

ahote
Membre
Lieu : 42
Distrib. : bullseye / win10
Noyau : Linux 5.7.0-3
(G)UI : parfois
Inscription : 09-12-2018
Site Web

Re : [RESOLU] buster sur pc asus X540YA (ecran noir suite a installation )

comme promis les logs :-)

pas de possibilité de faire un copier coller du coup j'ai pris une photo de la fin des logs :-)
https://zupimages.net/up/20/06/zqv8.jpg

Dernière modification par ahote (04-02-2020 17:30:00)

Hors ligne

#15 04-02-2020 18:13:10

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : [RESOLU] buster sur pc asus X540YA (ecran noir suite a installation )

Donc tu as Le prompte et Je vois que tu es en root sur la photo, car tu as Le petit symbole #

Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#16 04-02-2020 18:23:56

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : [RESOLU] buster sur pc asus X540YA (ecran noir suite a installation )

Donc il faut que tu identifies ta carte graphique

lspci | grep VGA




et que tu installe le pilote qui correspond- > https://debian-facile.org/doc:materiel: … -graphique

Dernière modification par Jean-Pierre Pinson (04-02-2020 18:33:21)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#17 04-02-2020 18:24:05

ahote
Membre
Lieu : 42
Distrib. : bullseye / win10
Noyau : Linux 5.7.0-3
(G)UI : parfois
Inscription : 09-12-2018
Site Web

Re : [RESOLU] buster sur pc asus X540YA (ecran noir suite a installation )

oui j'ai accès au prompt :-) mais seulement en recovery

j'ai essayé un "startx" et startxfce4" mais sans succès ca me met des erreurs ( erreur serveur et connexion refusée entre autre )

Hors ligne

#18 04-02-2020 18:35:59

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : [RESOLU] buster sur pc asus X540YA (ecran noir suite a installation )

Donc il faut que tu identifies ta carte graphique

lspci | grep VGA



et que tu installe le pilote qui correspond- > https://debian-facile.org/doc:materiel: … -graphique


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#19 04-02-2020 18:59:35

ahote
Membre
Lieu : 42
Distrib. : bullseye / win10
Noyau : Linux 5.7.0-3
(G)UI : parfois
Inscription : 09-12-2018
Site Web

Re : [RESOLU] buster sur pc asus X540YA (ecran noir suite a installation )

pour le GPU c'est facile  une AMD radeon R5 donc le pilote est "fimware-amd-graphics"
le souci c'est que je n'ai pas d'acces réseau sur le pc  donc je l'ai mis sur une clé usb mais je ne trouve pas le point de montage de la clé :-( j'ai cherché dans /média et dans /mnt mais elle n'est pas ici :-(

Hors ligne

#20 04-02-2020 19:16:21

ahote
Membre
Lieu : 42
Distrib. : bullseye / win10
Noyau : Linux 5.7.0-3
(G)UI : parfois
Inscription : 09-12-2018
Site Web

Re : [RESOLU] buster sur pc asus X540YA (ecran noir suite a installation )

YAAAAAAAATTTTAAAAAAAAAAA !!!!!!
J'AI RÉUSSI
alors ce que j'ai fait
j'ai démarré normalement puis au moment de l'ecran noir avec le tiret j'ai tout simplement fait "alt+F2" puis log in en root ce qui m'a donné acces au réseau


j'ai commencé par ajouté les dépot contrib et non-free
puis j'ai fais :

apt install firmware-amd-graphics


puis

reboot now



et la miracle j'ai l'environement qui a chargé :-D



merci beaucoup je n'y serait jamais arrivé sans toi :-)

Dernière modification par ahote (04-02-2020 20:45:48)

Hors ligne

#21 04-02-2020 19:18:07

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : [RESOLU] buster sur pc asus X540YA (ecran noir suite a installation )

Envoie le retour de cette commande

fdisk -l


Cela va nous aider a voir quel est le point de montage de ta clé USB ! Normalement ça ressemble à ça /dev/sdx Ou X est à remplacer par La lettre correspondant à ta Clé USB

Dernière modification par Jean-Pierre Pinson (04-02-2020 19:21:28)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#22 04-02-2020 19:23:21

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : [RESOLU] buster sur pc asus X540YA (ecran noir suite a installation )

ah, nos postes se sont croisés, donc voilà une chose de résolu, wink

Dernière modification par Jean-Pierre Pinson (04-02-2020 19:23:43)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#23 04-02-2020 19:35:17

ahote
Membre
Lieu : 42
Distrib. : bullseye / win10
Noyau : Linux 5.7.0-3
(G)UI : parfois
Inscription : 09-12-2018
Site Web

Re : [RESOLU] buster sur pc asus X540YA (ecran noir suite a installation )

oui le problème est résolue :-) merci encore

au final c’était très simple mais il fallait avoir la solution mdrr !!! je vais ajouté [RESOLU]

par contre pour ce qui est de mac4lin ca ne semble pas fonctionné :-(

Hors ligne

#24 04-02-2020 19:50:05

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : [RESOLU] buster sur pc asus X540YA (ecran noir suite a installation )

Et n'oublie pas Pour passer en root:

su -

Ne pas oublier L'espace entre su et le tiré

Et pour revenir en user

exit

Dernière modification par Jean-Pierre Pinson (04-02-2020 19:51:55)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#25 04-02-2020 20:01:35

ahote
Membre
Lieu : 42
Distrib. : bullseye / win10
Noyau : Linux 5.7.0-3
(G)UI : parfois
Inscription : 09-12-2018
Site Web

Re : [RESOLU] buster sur pc asus X540YA (ecran noir suite a installation )

oui tkt je sais comment passé en root ^^ ce n'est pas ma première installation linux :-)

mais j'avoue que le coup du firmware graphique manquant qui empêche complètement l'interface de démarré je n'avais encore jamais eu big_smile
ca m'a permis d'apprendre big_smile

pour mac4lin je pense que je vais essayé autre chose car je n'avais pas vue mais le projet a été abandonné en 2009 a première vue ....
je vais continué mes recherche la dessus :-D c'est ma seul solution pour convertir ma femme au pingouin plutôt qu'a la pomme XD

Hors ligne

Pied de page des forums