Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-02-2020 21:37:49

JulienOo
Membre
Inscription : 26-02-2020

configuration | module ssl | d'apache2

Bonjour a toute et a tous !
Je suis nouveau sur le forum. big_smile

Je me permet de venir vers vous ce soir a propos d'un soucis que j'ai pour la première fois que je l'ai et je n'arrive vraiment pas à le résoudre malgré que ce n'est pas la première fois que je fais cette manipulation..

Le système dans lequel est ce que je veux faire est le système Raspbian.
Voici les informations du système :

lsb_release -a


No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 10 (buster)
Release: 10
Codename: buster



Voici mon problème.
J'étais en train de configurer un serveur web sur le système, j'ai donc installé apache2, php, mysql et phpmyadmin sans problème mais c'est au moment de la configuration d'un certificat ssl que j'ai le problème..

Pour faire cela j'ai suivit comme j'ai toujours fais ce tutoriel  https://kgaut.net/blog/2016/creer-un-ce … local.html
qui a jusqu'à maintenant toujours fonctionné.

Cependant a la dernière étape j'ai apache qui refuse de démarrer..
Il accepte de démarrer quand je met en commentaire les lignes suivante :

SSLEngine On
SSLCertificateFile "/var/www/server.crt"
SSLCertificateKeyFile "/var/www/server.key"


je ne comprend pas pourquoi apache refuse de démarrer quand les trois lignes ne sont pas en commentaires sachant que le liens que j'ai mis sont bon.

Note : même si je retire de commentaire "SSLEngine On" apache refuse toujours de démarrer..


Si vous pouvais m'aider sa serais super !
Merci d'avance pour votre aide big_smile !

Hors ligne

#2 26-02-2020 21:45:44

leonlemouton
Adhérent(e)
Distrib. : Buster
(G)UI : Mate ∨ LXQt
Inscription : 14-08-2012

Re : configuration | module ssl | d'apache2

Salut,

Tu as lancé l'avant dernière ligne de commande du tuto ?

sudo a2enmod ssl



Peux-tu présenter ton virtualhost que l'on puisse y voir plus clair ?


Leonlemouton
°(")°

Hors ligne

#3 26-02-2020 22:39:32

JulienOo
Membre
Inscription : 26-02-2020

Re : configuration | module ssl | d'apache2

Bonsoir,
merci pour ta réponse aussi rapide big_smile

Oui j'ai bien effectué la commande "sudo a2enmod ssl" qui me retourne a présent

sudo a2enmod ssl


Considering dependency setenvif for ssl:
Module setenvif already enabled
Considering dependency mime for ssl:
Module mime already enabled
Considering dependency socache_shmcb for ssl:
Module socache_shmcb already enabled
Module ssl already enabled





Voici le contenu du virtualhost :

<VirtualHost *:80>
  # The ServerName directive sets the request scheme, hostname and port that
  # the server uses to identify itself. This is used when creating
  # redirection URLs. In the context of virtual hosts, the ServerName
  # specifies what hostname must appear in the request's Host: header to
  # match this virtual host. For the default virtual host (this file) this
  # value is not decisive as it is used as a last resort host regardless.
  # However, you must set it for any further virtual host explicitly.
 
        ServerName example.com

  ServerAdmin webmaster@localhost
  DocumentRoot /var/www/html

  # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
  # error, crit, alert, emerg.
  # It is also possible to configure the loglevel for particular
  # modules, e.g.
  #LogLevel info ssl:warn

  ErrorLog ${APACHE_LOG_DIR}/error.log
  CustomLog ${APACHE_LOG_DIR}/access.log combined

  # For most configuration files from conf-available/, which are
  # enabled or disabled at a global level, it is possible to
  # include a line for only one particular virtual host. For example the
  # following line enables the CGI configuration for this host only
  # after it has been globally disabled with "a2disconf".
  #Include conf-available/serve-cgi-bin.conf
</VirtualHost>


<virtualhost *:443>
  ServerName example.com
  ServerAlias www.example.com

  DocumentRoot "/var/www/html/"

  ErrorLog ${APACHE_LOG_DIR}/error.log
  CustomLog ${APACHE_LOG_DIR}/access.log combined
 
  # Activation du mode SSL
  SSLEngine On
  SSLOptions +FakeBasicAuth +ExportCertData +StrictRequire

  SSLCertificateFile "/var/www/server.crt"
  SSLCertificateKeyFile "/var/www/server.key"

  <directory /var/www/html/>
    Options -Indexes +FollowSymLinks +MultiViews
    AllowOverride All
    Require all granted
  </Directory>
</virtualhost>
# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
 

Hors ligne

#4 27-02-2020 07:52:21

leonlemouton
Adhérent(e)
Distrib. : Buster
(G)UI : Mate ∨ LXQt
Inscription : 14-08-2012

Re : configuration | module ssl | d'apache2

Bonjour,
Le VirtualHost semble correct même si il y a un petit écart entre les deux DocumentRoot.
Apache2 renvoit des erreurs lors de reload ou restart ?
Il y a des choses dans les logs ?
Je me demande si ce n'est pas un problème de droits d'accès au dossier contenant le certificat. Apache peut accéder au contenu ?
Bon courage !

Leonlemouton
°(")°

Hors ligne

#5 27-02-2020 10:32:18

jce76350
Membre
Lieu : Rouen
Distrib. : Debian_Buster 10.6
Noyau : 4.19.0-9-amd64
(G)UI : XFCE
Inscription : 24-08-2016
Site Web

Re : configuration | module ssl | d'apache2

Pourquoi vouloir faire un certificat auto-signé SSL alors qu'il suffit d'utiliser le certificat SSL par défaut , Apache 2 contient deux fichiers pré-configurés , qui fonctionnent bien en local

--
Jc E

Hors ligne

Pied de page des forums