Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 28-02-2020 12:40:00

ouatou
Membre
Distrib. : testing
Noyau : Linux debian 5.4.0-4-amd64
(G)UI : gnome
Inscription : 07-11-2014

debian testing(amd64 fraichement installer) probleme steam "Resolu"

Bonjour,

je rencontre un problème avec steam suite à une nouvelle installation d'une debian en testing en 64bit.

Il m'as pourtant semblé avoir fait comme toujours pourtant

steam


Running Steam on debian  64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Error: You are missing the following 32-bit libraries, and Steam may not run:
libGL.so.1
/home/ouatou/.steam/debian-installation/ubuntu12_32/steam -nominidumps -nobreakpad
WARNING: setlocale('en_US.UTF-8') failed, using locale: 'C'. International characters may not work.
[2020-02-28 11:54:45] Startup - updater built Feb 11 2020 19:26:28
Looks like steam didn't shutdown cleanly, scheduling immediate update check
[2020-02-28 11:54:46] Checking for update on startup
[2020-02-28 11:54:46] Checking for available updates...
[2020-02-28 11:54:46] Downloading manifest: client-download.steampowered.com/client/steam_client_ubuntu12
[2020-02-28 11:54:46] Download skipped: /client/steam_client_ubuntu12 version 1581460722, installed version 1581460722
[2020-02-28 11:54:46] Nothing to do
[2020-02-28 11:54:46] Verifying installation...
[2020-02-28 11:54:46] Performing checksum verification of executable files
[2020-02-28 11:54:47] Verification complete
[2020-02-28 11:54:51] Shutdown



les lib 32 bit sont normalement installer il me semble

dpkg --print-architecture


amd64



dpkg --print-foreign-architectures


i386



aptitude update && aptitude upgrade


Atteint http://deb.debian.org/debian testing InRelease
Atteint http://security.debian.org/debian-security testing-security InRelease
                                                       
Les paquets suivants seront mis à jour :                
  fonts-liberation gzip libbabl-0.1-0 libpython3.8 libpython3.8-minimal
  libpython3.8-stdlib
6 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o/5267 ko d'archives. Après dépaquetage, 6144 o seront libérés.
Voulez-vous continuer ? [Y/n/?] y
Lecture des fichiers de modifications (« changelog »)... Terminé
(Lecture de la base de données... 173863 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../archives/gzip_1.10-1_amd64.deb ...
Dépaquetage de gzip (1.10-1) sur (1.9-3+b1) ...
Paramétrage de gzip (1.10-1) ...
(Lecture de la base de données... 173862 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../fonts-liberation_1%3a1.07.4-11_all.deb ...
Dépaquetage de fonts-liberation (1:1.07.4-11) sur (1:1.07.4-10) ...
Préparation du dépaquetage de .../libbabl-0.1-0_0.1.74-1_amd64.deb ...
Dépaquetage de libbabl-0.1-0:amd64 (0.1.74-1) sur (0.1.72-4) ...
Préparation du dépaquetage de .../libpython3.8_3.8.2-1_amd64.deb ...
Dépaquetage de libpython3.8:amd64 (3.8.2-1) sur (3.8.2~rc2-2) ...
Préparation du dépaquetage de .../libpython3.8-stdlib_3.8.2-1_amd64.deb ...
Dépaquetage de libpython3.8-stdlib:amd64 (3.8.2-1) sur (3.8.2~rc2-2) ...
Préparation du dépaquetage de .../libpython3.8-minimal_3.8.2-1_amd64.deb ...
Dépaquetage de libpython3.8-minimal:amd64 (3.8.2-1) sur (3.8.2~rc2-2) ...
Paramétrage de libpython3.8-minimal:amd64 (3.8.2-1) ...
Paramétrage de libbabl-0.1-0:amd64 (0.1.74-1) ...
Paramétrage de fonts-liberation (1:1.07.4-11) ...
Paramétrage de libpython3.8-stdlib:amd64 (3.8.2-1) ...
Paramétrage de libpython3.8:amd64 (3.8.2-1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.29-10) ...
Traitement des actions différées (« triggers ») pour man-db (2.9.0-2) ...
Traitement des actions différées (« triggers ») pour fontconfig (2.13.1-2+b1) ...
 



apt install --reinstall steam


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 1 réinstallés, 0 à enlever et 6 non mis à jour.
Il est nécessaire de prendre 0 o/1457 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Préconfiguration des paquets...
(Lecture de la base de données... 173863 fichiers et répertoires déjà installés.
)
Préparation du dépaquetage de .../steam_1.0.0.61-2_i386.deb ...
Dépaquetage de steam:i386 (1.0.0.61-2) sur (1.0.0.61-2) ...
Paramétrage de steam:i386 (1.0.0.61-2) ...
Traitement des actions différées (« triggers ») pour mime-support (3.64) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.17-2)
 ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.32.0-1) ...
Traitement des actions différées (« triggers ») pour man-db (2.9.0-2) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.24-1)
 ...
 



uname -a


Linux debian 5.4.0-4-amd64 #1 SMP Debian 5.4.19-1 (2020-02-13) x86_64 GNU/Linux
 




si vous avez une piste ou une info je suis preneur merci.
Je continuerais d'investiguer se soir.

a bientot

Dernière modification par ouatou (29-02-2020 10:14:40)

Hors ligne

#2 28-02-2020 14:20:16

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.8 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : debian testing(amd64 fraichement installer) probleme steam "Resolu"

ouatou a écrit :

Error: You are missing the following 32-bit libraries, and Steam may not run:
libGL.so.1


Il te manque probablement le paquet suivant : libgl1:i386
cf. Debian -- Résultat de la recherche des contenus des paquets -- libGL.so.1


Jouer sous Debian ? Facile !

Hors ligne

#3 29-02-2020 00:46:58

ouatou
Membre
Distrib. : testing
Noyau : Linux debian 5.4.0-4-amd64
(G)UI : gnome
Inscription : 07-11-2014

Re : debian testing(amd64 fraichement installer) probleme steam "Resolu"

Et pourtant il est installer se paquet

aptitude install libgl1:i386


libgl1:i386 est déjà installé avec la version demandée (1.3.1-1)
libgl1:i386 est déjà installé avec la version demandée (1.3.1-1)
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 8 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.
 



du coup je vais quand meme faire les 8 mise a jour

aptitude update && aptitude upgrade


Atteint http://security.debian.org/debian-security testing-security InRelease
Atteint http://deb.debian.org/debian testing InRelease
                                                       
Les paquets suivants seront mis à jour :                
  cpp-9 g++-9 gcc-9 gcc-9-base libasan5 libgcc-9-dev libstdc++-9-dev
  libxslt1.1
8 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 35,3 Mo d'archives. Après dépaquetage, 2048 o seront utilisés.
Voulez-vous continuer ? [Y/n/?] y
Prendre :  1 http://deb.debian.org/debian testing/main amd64 libasan5 amd64 9.2.1-30 [389 kB]
Prendre :  2 http://deb.debian.org/debian testing/main amd64 g++-9 amd64 9.2.1-30 [10,7 MB]
Prendre :  3 http://deb.debian.org/debian testing/main amd64 gcc-9 amd64 9.2.1-30 [10,0 MB]
Prendre :  4 http://deb.debian.org/debian testing/main amd64 libstdc++-9-dev amd64 9.2.1-30 [1697 kB]
Prendre :  5 http://deb.debian.org/debian testing/main amd64 libgcc-9-dev amd64 9.2.1-30 [2349 kB]
Prendre :  6 http://deb.debian.org/debian testing/main amd64 cpp-9 amd64 9.2.1-30 [9711 kB]
Prendre :  7 http://deb.debian.org/debian testing/main amd64 gcc-9-base amd64 9.2.1-30 [196 kB]
Prendre :  8 http://deb.debian.org/debian testing/main amd64 libxslt1.1 amd64 1.1.34-3 [239 kB]
 35,3 Mo téléchargés en 9s (4104 ko/s)                                        
Lecture des fichiers de modifications (« changelog »)... Terminé
(Lecture de la base de données... 173862 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../0-libasan5_9.2.1-30_amd64.deb ...
Dépaquetage de libasan5:amd64 (9.2.1-30) sur (9.2.1-29) ...
Préparation du dépaquetage de .../1-g++-9_9.2.1-30_amd64.deb ...
Dépaquetage de g++-9 (9.2.1-30) sur (9.2.1-29) ...
Préparation du dépaquetage de .../2-gcc-9_9.2.1-30_amd64.deb ...
Dépaquetage de gcc-9 (9.2.1-30) sur (9.2.1-29) ...
Préparation du dépaquetage de .../3-libstdc++-9-dev_9.2.1-30_amd64.deb ...
Dépaquetage de libstdc++-9-dev:amd64 (9.2.1-30) sur (9.2.1-29) ...
Préparation du dépaquetage de .../4-libgcc-9-dev_9.2.1-30_amd64.deb ...
Dépaquetage de libgcc-9-dev:amd64 (9.2.1-30) sur (9.2.1-29) ...
Préparation du dépaquetage de .../5-cpp-9_9.2.1-30_amd64.deb ...
Dépaquetage de cpp-9 (9.2.1-30) sur (9.2.1-29) ...
Préparation du dépaquetage de .../6-gcc-9-base_9.2.1-30_amd64.deb ...
Dépaquetage de gcc-9-base:amd64 (9.2.1-30) sur (9.2.1-29) ...
Préparation du dépaquetage de .../7-libxslt1.1_1.1.34-3_amd64.deb ...
Dépaquetage de libxslt1.1:amd64 (1.1.34-3) sur (1.1.32-2.2) ...
Paramétrage de libxslt1.1:amd64 (1.1.34-3) ...
Paramétrage de gcc-9-base:amd64 (9.2.1-30) ...
Paramétrage de libasan5:amd64 (9.2.1-30) ...
Paramétrage de cpp-9 (9.2.1-30) ...
Paramétrage de libgcc-9-dev:amd64 (9.2.1-30) ...
Paramétrage de gcc-9 (9.2.1-30) ...
Paramétrage de libstdc++-9-dev:amd64 (9.2.1-30) ...
Paramétrage de g++-9 (9.2.1-30) ...
Traitement des actions différées (« triggers ») pour man-db (2.9.0-2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.29-10) ...
                                                       
État actuel : 0 (-8) upgradable.
 



steam


Running Steam on debian  64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Error: You are missing the following 32-bit libraries, and Steam may not run:
libGL.so.1
/home/ouatou/.steam/debian-installation/ubuntu12_32/steam -nominidumps -nobreakpad
WARNING: setlocale('en_US.UTF-8') failed, using locale: 'C'. International characters may not work.
[2020-02-29 00:44:22] Startup - updater built Feb 11 2020 19:26:28
Looks like steam didn't shutdown cleanly, scheduling immediate update check
[2020-02-29 00:44:22] Checking for update on startup
[2020-02-29 00:44:22] Checking for available updates...
[2020-02-29 00:44:22] Downloading manifest: client-download.steampowered.com/client/steam_client_ubuntu12
[2020-02-29 00:44:23] Download skipped: /client/steam_client_ubuntu12 version 1581460722, installed version 1581460722
[2020-02-29 00:44:23] Nothing to do
[2020-02-29 00:44:23] Verifying installation...
[2020-02-29 00:44:23] Performing checksum verification of executable files
[2020-02-29 00:44:24] Verification complete
[2020-02-29 00:44:26] Shutdown
 



je ne sais plus quoi faire en général je sèche sur d'autre chose la je sais pas

Edité :
dailleur j'ai tester ca

find / -name libGL.so.1


/usr/lib/mesa-diverted/i386-linux-gnu/libGL.so.1
/usr/lib/mesa-diverted/x86_64-linux-gnu/libGL.so.1
/usr/lib/x86_64-linux-gnu/libGL.so.1
find: ‘/proc/1702/task/3168’: Aucun fichier ou dossier de ce type
find: ‘/run/user/1000/gvfs’: Permission non accordée
 



c'est sans doutte autre chose merci pour les pistes.

a bientot

c'est installer, dapres le wiki il faut ce paquet mais peut etre que blueye a evoluer

aptitude install libgl1-nvidia-glx:i386
 


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Aucune version du paquet libgl1-nvidia-glx:i386 n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
Cependant les paquets suivants le remplacent :
  libnvidia-glcore:i386 libnvidia-glcore libnvidia-cfg1

E: Le paquet « libgl1-nvidia-glx:i386 » n'a pas de version susceptible d'être installée

 



donc

apt-get install  libnvidia-glcore:i386 libnvidia-glcore libnvidia-cfg1



et/ou peut etre que cette derniere suffit je sais pas vraiment je l'ai fais dans cet ordre la.

apt-get install nvidia-driver-libs-i386



@ bientot

edité
un autre probleme j'ai plus qu'a retrouver le connecteur bluetoos de la manette arf ... mais j'avance smile

Dernière modification par ouatou (29-02-2020 10:34:32)

Hors ligne

Pied de page des forums