Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-02-2020 03:05:27

al louarn
Membre
Distrib. : Buster
Noyau : Linux 4.19.0-8-amd64
(G)UI : lightdm-xsession/xfce
Inscription : 21-02-2012

i915 *ERROR* CPU pipe B FIFO underrun

Bonsoir une nouvelle colle :   

à l'install  en anvier un message me dit  ;


W: Possible missing firmware /lib/firmware/i915/bxt_dmc_ver1_07.bin for module i915
W: Possible missing firmware /lib/firmware/i915/skl_dmc_ver1_27.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_dmc_ver1_04.bin for module i915
W: Possible missing firmware /lib/firmware/i915/cnl_dmc_ver1_07.bin for module i915
W: Possible missing firmware /lib/firmware/i915/glk_dmc_ver1_04.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_guc_ver9_39.bin for module i915
W: Possible missing firmware /lib/firmware/i915/bxt_guc_ver9_29.bin for module i915
W: Possible missing firmware /lib/firmware/i915/skl_guc_ver9_33.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_huc_ver02_00_1810.bin for module i915
W: Possible missing firmware /lib/firmware/i915/bxt_huc_ver01_07_1398.bin for module i915
W: Possible missing firmware /lib/firmware/i915/skl_huc_ver01_07_1398.bin for module i915


Je trouve une solution par

apt install firmware-misc-nonfree

Depuis mes modules sont bien présents dans le noyau,

 lsmod | grep i915


i915                 1736704  3
i2c_algo_bit           16384  1 i915
drm_kms_helper        208896  1 i915
drm                   495616  5 drm_kms_helper,i915
video                  45056  2 i915,asus_laptop


Seulement voilà aujourd'hui mais pas avant une ligne rouge apparait au boot :

[drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe B FIFO underrun



Donc là je ne sais pas où est le conflit, d'autant que mon affichage n'a pas de trouble apparent.
Dois-je logiquement purger  le firmware-misc-nonfree ou y aurait une précaution à prendre avant ? une autre piste à vérifier
Bien-sur sur le web je trouve des réponses contradictoires que je ne sais pas évaluer.


Debianophile = DebiaNoGeek

Hors ligne

#2 24-11-2020 19:21:26

Ernie95
Membre
Inscription : 24-11-2020

Re : i915 *ERROR* CPU pipe B FIFO underrun

Bonjour,

Même enjeu sur le message d'erreur. dmesg signale en rouge (et alerte au démarrage) :
[    5.899730] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[    5.899827] [drm:intel_set_cpu_fifo_underrun_reporting [i915]] *ERROR* pipe B underrun
[    5.899914] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe B FIFO underrun

Mon système:
Processeur    Intel(R) Pentium(R) M processor 1.40GHz
Mémoire    1146MB (440MB utilisé)
Machine Type    Portable
Systeme d'exploitation    Debian GNU/Linux 10 (buster)

Kernel    Linux 4.19.0-11-686 (i686)
Version    #1 SMP Debian 4.19.146-1 (2020-09-17)
C Library    GNU C Library / (Debian GLIBC 2.28-10) 2.28
Distribution    Debian GNU/Linux 10 (buster)

firmware-misc-nonfree est installé.

Debian se lance bien. Je n'ai pas de souci pour le moment.

Est ce que cette alerte est critique ? Que signifie t elle ?

Sur le net, je trouve plein de post mais pas forcément la solution aux messages.

Merci par avance de vos éclairages

Hors ligne

#3 25-11-2020 16:02:18

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : i915 *ERROR* CPU pipe B FIFO underrun

Bonjour
@al louarn
oui le firmware est nécessaire , le oyau te le demande
sinon si tout fonctionne ignore cet erreur
une commande pour les erreurs


journalctl -r -p err
 



sinon avec le paquet mesa-utils installé


glxinfo -B
 



@Ernie95

ton processeur est plus ancien tu dois avoir un gpu dans le chipset ou une carte graphique
idem ignore sauf si cela te rempli le log mais je pense pas
un lspci


lspci
 



vous pouvez installer le paquet "intel-microcode"

Hors ligne

#4 28-11-2020 14:00:02

Ernie95
Membre
Inscription : 24-11-2020

Re : i915 *ERROR* CPU pipe B FIFO underrun

Merci. Intel-microcode est déjà installé.
Pas d'erreur dans le journal.
Donc pas si critique et je pourrais faire avec.

Hors ligne

Pied de page des forums