Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-03-2020 22:48:19

thierryR
Membre
Distrib. : debian
Noyau : Linux 4.19.75+
Inscription : 24-04-2017

msmtp

Bonjour. J'ai le même problème et la même config que ce message https://debian-facile.org/viewtopic.php … 13#p325613

gpg --encrypt -o .msmtp-gmail.gpg -r moi@gmail.com -
gpg: erreur de récupération de « moi@gmail.com » avec WKD : No data
gpg: moi@gmail.com : ignoré : No data
gpg: [stdin]: encryption failed: No data

 



Alors j'ai appliqué la proposition précédente

gpg --list-keys
gpg: /home/thierry/.gnupg/trustdb.gpg : base de confiance créée
 




J'ai créé une clé gpg avec cette commande

gpg --full-gen-key



Puis je suis revenu à ce que je voulais faire et l'ai fait 4 fois:

gpg --encrypt -o .msmtp-gmail.gpg -r moi@gmail.com -
Le fichier « .msmtp-gmail.gpg » existe. Faut-il réécrire par-dessus ? (o/N) o
mon password




J'ai avancé, mais:

echo 'message' | msmtp moi@gmail.com
msmtp: échec de l'authentification (méthode PLAIN)
msmtp: message du serveur : 534-5.7.9 Username and Password not accepted. Learn more at
msmtp: message du serveur : 534 5.7.9  https://support.google.com/mail/?p=BadCredentials o5sm252598wmb.8 - gsmtp
msmtp: le courriel n'
a pas pu être envoyé (compte default dans /home/thierry/.msmtprc)






De ce que je comprends il y a un problème de password. Ma clé ne semble pas vraiment la bonne. Je l'ai refaite 4 fois, mais sans amélioration. Y aurait-il une autre raison ?
Merci de votre aide.

Dernière modification par thierryR (01-03-2020 23:08:30)


Chercheur en amélioration

Hors ligne

#2 02-03-2020 22:47:24

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian bullseye (testing)
Noyau : Linux 5.9.0-5-amd64
(G)UI : LightDM et Xfce4.16
Inscription : 29-04-2015

Re : msmtp

Peux-tu afficher le contenu de ton fichier .msmtprc ?

Dernière modification par Philou92 (02-03-2020 22:48:57)


Chaque siècle fera son œuvre, aujourd’hui civique, demain humaine. Aujourd’hui la question du droit, demain la question du salaire. Salaire et droit, au fond c’est le même mot. L’homme ne vit pas pour n’être point payé ; Dieu en donnant la vie contracte une dette ; le droit, c’est le salaire inné ; le salaire, c’est le droit acquis.
             Quatrevingt-treize
             Victor Hugo.

Hors ligne

#3 03-03-2020 10:51:12

thierryR
Membre
Distrib. : debian
Noyau : Linux 4.19.75+
Inscription : 24-04-2017

Re : msmtp

Oui avec plaisir:  Merci pour ton aide.

# Valeurs par défaut pour tous les comptes.
defaults
port            587
tls            on
tls_trust_file /etc/ssl/certs/ca-certificates.crt

# Exemple pour un compte Gmail
account gmail
host smtp.gmail.com
from moi@gmail.com
auth on
user thierry
passwordeval gpg --no-tty -q -d ~/.msmtp-gmail.gpg

#definir le compte par défaut
account default :gmail



Je vois sur thunderbird, qu'il passe par le port 465 avec un cryptage

Dernière modification par thierryR (03-03-2020 10:52:33)


Chercheur en amélioration

Hors ligne

#4 03-03-2020 21:52:33

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian bullseye (testing)
Noyau : Linux 5.9.0-5-amd64
(G)UI : LightDM et Xfce4.16
Inscription : 29-04-2015

Re : msmtp

Et en essayant avec ça ?

#  Gmail
account gmail
port 465
tls on
tls_starttls off
tls_certcheck on
protocol smtp
tls_trust_file /etc/ssl/certs/ca-certificates.crt
host smtp.gmail.com
from moi@gmail.com
auth login
maildomain gmail.com
user thierry
passwordeval gpg --no-tty -q -d ~/.msmtp-gmail.gpg

#definir le compte par défaut
account default :gmail


Chaque siècle fera son œuvre, aujourd’hui civique, demain humaine. Aujourd’hui la question du droit, demain la question du salaire. Salaire et droit, au fond c’est le même mot. L’homme ne vit pas pour n’être point payé ; Dieu en donnant la vie contracte une dette ; le droit, c’est le salaire inné ; le salaire, c’est le droit acquis.
             Quatrevingt-treize
             Victor Hugo.

Hors ligne

#5 06-03-2020 22:10:51

thierryR
Membre
Distrib. : debian
Noyau : Linux 4.19.75+
Inscription : 24-04-2017

Re : msmtp

Merci pour ton aide. En faisant un copier coller ça me donne ça:

msmtp: échec de l'authentification (méthode LOGIN)
msmtp: message du serveur : 534-5.7.9 Please log in with your web browser and then try again. Learn more at
msmtp: message du serveur : 534 5.7.9  https://support.google.com/mail/?p=WebLoginRequired a7sm14555468wmb.0 - gsmtp
msmtp: le courriel n'
a pas pu être envoyé (compte default dans /home/thierry/.msmtprc)
 


De la methode PLAIN on est passé à la méthode LOGIN ?  (Ça ne me parle pas plus.)


Chercheur en amélioration

Hors ligne

#6 06-03-2020 23:06:08

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian bullseye (testing)
Noyau : Linux 5.9.0-5-amd64
(G)UI : LightDM et Xfce4.16
Inscription : 29-04-2015

Re : msmtp

Maintenant msmtp essaye de se connecter via la méthode login à ton compte google. C’est normal. La où ça coince c’est que ton compte exige a priori la double authentification (voir les infos cité par l’url dans le message d’erreur). Cela demande de supprimer  l’option de valider la connexion avec des applications moins sécurisées dans ton compte google .

Mais j’ai peut-être trouvé mieux. Voir ce tuto sur wiki ubuntu https://doc.ubuntu-fr.org/msmtp . La configuration décrite devrait mieux fonctionner.

Chaque siècle fera son œuvre, aujourd’hui civique, demain humaine. Aujourd’hui la question du droit, demain la question du salaire. Salaire et droit, au fond c’est le même mot. L’homme ne vit pas pour n’être point payé ; Dieu en donnant la vie contracte une dette ; le droit, c’est le salaire inné ; le salaire, c’est le droit acquis.
             Quatrevingt-treize
             Victor Hugo.

Hors ligne

#7 07-03-2020 14:33:10

thierryR
Membre
Distrib. : debian
Noyau : Linux 4.19.75+
Inscription : 24-04-2017

Re : msmtp

Arf. La page ubuntu m'avait servi de base au départ.  J'ai remarque qu'avec  "auth on" je tombe sur la méthode PLAIN et avec "auth login" je tombe sur la méthode LOGIN.
Sinon j'ai bien vérifié ce que tu m'as dit pour les applications moins sécurisées.  https://myaccount.google.com/lesssecureapps
Mais ça ne passe toujours pas. Je me demande bien ce qui coince...scratchhead.gif

Chercheur en amélioration

Hors ligne

#8 07-03-2020 16:55:36

thierryR
Membre
Distrib. : debian
Noyau : Linux 4.19.75+
Inscription : 24-04-2017

Re : msmtp

J'essaie de me connecter en direct avec midori. Je pense ainsi passer les sécurités google, car il ne reconnait pas ce nouveau matériel.
Ben non, ça fonctionne avec midori mais pas avec msmtp

Chercheur en amélioration

Hors ligne

#9 08-03-2020 19:17:16

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian bullseye (testing)
Noyau : Linux 5.9.0-5-amd64
(G)UI : LightDM et Xfce4.16
Inscription : 29-04-2015

Re : msmtp

De mon côté, j'ai essayé avec evolution. La connexion au vieux compte gmail que je possède ne fonctionne pas. Il me demande une double authentification bien que je l'ai invalidé sur le compte.
Du coup je n’ai plus d’idée pour faire fonctionner msmtp avec cet @+-/¡¡^!!! de gmail.
sad

Chaque siècle fera son œuvre, aujourd’hui civique, demain humaine. Aujourd’hui la question du droit, demain la question du salaire. Salaire et droit, au fond c’est le même mot. L’homme ne vit pas pour n’être point payé ; Dieu en donnant la vie contracte une dette ; le droit, c’est le salaire inné ; le salaire, c’est le droit acquis.
             Quatrevingt-treize
             Victor Hugo.

Hors ligne

#10 09-03-2020 21:14:29

thierryR
Membre
Distrib. : debian
Noyau : Linux 4.19.75+
Inscription : 24-04-2017

Re : msmtp

Je sentais bien qu'on épuisait toutes les solutions. Si on a plus, on redonne les infos ici.   Je continue de voir ce qui serait possible. L'autre solution et d'ouvrir une boite ailleurs seulement pour le trafic alerte mail. J'essaierai, histoire de voir si c'est bien gmail qui bloque.

Chercheur en amélioration

Hors ligne

Pied de page des forums