Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-03-2020 07:59:55

loickk
Membre
Inscription : 27-02-2020

Vim et Python YouCompleteMe "unable to load python"

Je bloque.

J'ai vim compilé avec python (+python +python3 dans vim --version)
J'ai python2.7 et python3.8.2 sur la machine
dans le dossier YouCompleteMe j'ai lancé les scripts

./install.py --all

./install.sh


pour faire bonne mesure j'ai lancé

./install.sh --clang-completer

et

./install.py --ts completer

comme recommandé dans le github de YCM https://github.com/ycm-core/YouCompleteMe/issues/3323
Je n'arrive toujours pas à avoir YouCompleteMe
Est-ce que qu'elqu'un a une idée pour moi? Merci

Hors ligne

#2 11-03-2020 16:14:59

David5647
Membre
Distrib. : Debian Bullseye/Sid
Noyau : 5.7.0-2-amd64
(G)UI : KDE/i3wm
Inscription : 27-08-2017

Re : Vim et Python YouCompleteMe "unable to load python"

ça fait longtemps que je l'ai installé et configuré en tout cas je l'ai installé via les dépôts :

apt install vim-youcompleteme

Hors ligne

#3 11-03-2020 20:36:58

Cauryl
Invité

Re : Vim et Python YouCompleteMe "unable to load python"

Salut !

Plusieurs choses :

- Pour avoir le support de JavaScript et TypeScript, as-tu installé  Node.js et npm comme précisé dans la doc ?
- Typo, c'est --ts-completer et non --ts completer
- Autre typo, c'est --clangd-completer et non --clang-completer
- Pourquoi avoir lancé tout ça ?
Il faut juste lancer le fichier install.py, soit :

./install.py --clangd-completer --ts-completer


ou

python3 install.py --clangd-completer --ts-completer



Si je peux me permettre, YCM réinvente la roue et n'apporte rien à Vim. Il y a de nombreux clients LSP plus intéressants. wink

Pied de page des forums