Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-03-2020 17:31:20

glaubule
Membre
Inscription : 20-03-2020

[Résolu] Pas de bluetooth sur mon protable Toshiba

Bonjour,
Je vais tâcher d'être le plus complet possible ...
Toshiba Satellite Pro C70-A-130 (part PSCE3E)

Système Debian Buster 10.3 juste installé, environnement KDE

Le module KDE bluetooth ne voit rien (le wifi est OK)

service bluetooth status
● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2020-03-20 13:55:19 CET; 2h 25min ago
     Docs: man:bluetoothd(8)
 Main PID: 1417 (bluetoothd)
   Status: "Running"
    Tasks: 1 (limit: 4456)
   Memory: 968.0K
   CGroup: /system.slice/bluetooth.service
           └─1417 /usr/lib/bluetooth/bluetoothd

mars 20 13:55:19 lolo-tosh systemd[1]: Starting Bluetooth service...
mars 20 13:55:19 lolo-tosh bluetoothd[1417]: Bluetooth daemon 5.50
mars 20 13:55:19 lolo-tosh systemd[1]: Started Bluetooth service.
mars 20 13:55:19 lolo-tosh bluetoothd[1417]: Starting SDP server
mars 20 13:55:19 lolo-tosh bluetoothd[1417]: Bluetooth management interface 1.14 initialized
 



lsusb (normalement c'est celui en gras) :

Bus 003 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[b]Bus 001 Device 005: ID [b]0930:0220 Toshiba Corp[/b].[/b]
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 002: ID 046d:c52e Logitech, Inc. MK260 Wireless Combo Receiver
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 



dmesg | egrep -i 'blue|firm' (il tente de charger un firmware Atheros?)

[    0.221981] Spectre V2 : Enabling Restricted Speculation for firmware calls
[    3.943731] toshiba_bluetooth: Toshiba ACPI Bluetooth device driver
[    4.520664] Bluetooth: Core ver 2.22
[    4.520679] Bluetooth: HCI device and connection manager initialized
[    4.520683] Bluetooth: HCI socket layer initialized
[    4.520685] Bluetooth: L2CAP socket layer initialized
[    4.520689] Bluetooth: SCO socket layer initialized
[    4.548244] usb 1-1.3: firmware: failed to load ar3k/AthrBT_0x31010000.dfu (-2)
[    4.548285] firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
[    4.548327] usb 1-1.3: Direct firmware load for ar3k/AthrBT_0x31010000.dfu failed with error -2
[    4.548329] Bluetooth: Loading patch file failed
[   13.101990] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   13.101992] Bluetooth: BNEP filters: protocol multicast
[   13.101996] Bluetooth: BNEP socket layer initialized
[ 1007.702063] battery: [Firmware Bug]: battery: (dis)charge rate invalid.
[ 2050.774383] usb 1-1.3: firmware: failed to load ar3k/AthrBT_0x31010000.dfu (-2)
[ 2050.774391] usb 1-1.3: Direct firmware load for ar3k/AthrBT_0x31010000.dfu failed with error -2
[ 2050.774395] Bluetooth: Loading patch file failed
[ 5245.009914] usb 1-1.3: firmware: failed to load ar3k/AthrBT_0x31010000.dfu (-2)
[ 5245.009922] usb 1-1.3: Direct firmware load for ar3k/AthrBT_0x31010000.dfu failed with error -2
[ 5245.009926] Bluetooth: Loading patch file failed
 



bluetoothctl show

No default controller available


Bien ententdu, blueman ne voit rien non plus.

Au préalable j'ai cherché un peu, ajouté le repo non-free et installé le package de firmwares non free sans spécifier une marque particulière donc Atheros est arrivé tout seul :

dmesg | grep -i firmware

[    0.221981] Spectre V2 : Enabling Restricted Speculation for firmware calls
[    4.548244] usb 1-1.3: firmware: failed to load ar3k/AthrBT_0x31010000.dfu (-2)
[    4.548285] firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
[    4.548327] usb 1-1.3: Direct firmware load for ar3k/AthrBT_0x31010000.dfu failed with error -2
[ 1007.702063] battery: [Firmware Bug]: battery: (dis)charge rate invalid.
[ 2050.774383] usb 1-1.3: firmware: failed to load ar3k/AthrBT_0x31010000.dfu (-2)
[ 2050.774391] usb 1-1.3: Direct firmware load for ar3k/AthrBT_0x31010000.dfu failed with error -2
[ 5245.009914] usb 1-1.3: firmware: failed to load ar3k/AthrBT_0x31010000.dfu (-2)
[ 5245.009922] usb 1-1.3: Direct firmware load for ar3k/AthrBT_0x31010000.dfu failed with error -2



Maintenant ça dépasse un peu mes compétences !

Dernière modification par glaubule (20-03-2020 22:40:21)

Hors ligne

#2 20-03-2020 17:54:42

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] Pas de bluetooth sur mon protable Toshiba

Bonjour, et bienvenue donc,

glaubule a écrit :

dmesg | grep firmware

[    4.548244] usb 1-1.3: firmware: failed to load ar3k/AthrBT_0x31010000.dfu (-2)
[    4.548285] ...
[    4.548327] usb 1-1.3: Direct firmware load for ar3k/AthrBT_0x31010000.dfu failed with error -2
[ 2050.774383] usb 1-1.3: firmware: failed to load ar3k/AthrBT_0x31010000.dfu (-2)
[ 2050.774391] usb 1-1.3: Direct firmware load for ar3k/AthrBT_0x31010000.dfu failed with error -2
[ 5245.009914] usb 1-1.3: firmware: failed to load ar3k/AthrBT_0x31010000.dfu (-2)
[ 5245.009922] usb 1-1.3: Direct firmware load for ar3k/AthrBT_0x31010000.dfu failed with error -2


Le métapaquet firmware-linux-nonfree n'installe pas le paquet firmware-atheros... à toi de l'installer.

Hors ligne

#3 20-03-2020 22:32:08

glaubule
Membre
Inscription : 20-03-2020

Re : [Résolu] Pas de bluetooth sur mon protable Toshiba

C'est fait, merci !

Personne n'a pensé à faire un petit programme qui check ces installations ?

Je sais que ça ferait la promotion des non-free mais ça ferait du bien à l'image de Debian ...

Hors ligne

Pied de page des forums