Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 22-03-2020 11:09:46

hussaile
Membre
Inscription : 16-12-2018

Installer le paquet fahcontrol du site foldingathome.org sur Buster

Bonjour,

Des scientifiques du monde entiers demandent que tous les ordinateurs disponibles mettent de la mémoire en ligne pour aider à la recherche.

C'est sur :

https://foldingathome.org/

que l'on peur trouver un programme fahcontrol_7.5.1-1_all.deb à installer.

Malheureusement, l'instruction dpkg comme root donne le message suivant (debian buster backported, 32bits):


dpkg -i '/home/xyz/Téléchargements/fahcontrol_7.5.1-1_all.deb'
dpkg: avertissement: « ldconfig » introuvable dans la variable PATH ou non exécutable
dpkg: avertissement: « start-stop-daemon » introuvable dans la variable PATH ou non exécutable
dpkg: erreur: 2 programmes attendus non trouvés dans la variable PATH ou non exécutables
Note : la variable PATH du superutilisateur doit normalement contenir /usr/local/sbin, /usr/sbin et /sbin
 


et impossible d'installer.

Synaptic donne ldconfig comme installé et start-stop-daemon absent au bataillon.

Quelqu'un pourrait-il arranger ce programme  fahcontrol pour qu'il puisse être installé depuis Synaptic ?

De cette manière, toute la communauté Debian pourra aider la recherche contre ce satané virus !

Edit modération : modification du titre pour que la demande d’aide et l’objet du fil soient plus clairs wink

Hors ligne

#2 22-03-2020 11:27:36

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : Installer le paquet fahcontrol du site foldingathome.org sur Buster

[Modéré Réponse hors de propos dans un fil d'entraide technique]

Dernière modification par smolski (22-03-2020 11:29:54)


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 22-03-2020 11:56:47

bendia
Chadministrateur
Distrib. : openSUSE Tumbleweed, Stretch
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console et un peu Openbox
Inscription : 20-03-2012
Site Web

Re : Installer le paquet fahcontrol du site foldingathome.org sur Buster

@husaille : tu es passé root comment ?

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

Hors ligne

#4 22-03-2020 12:07:33

hussaile
Membre
Inscription : 16-12-2018

Re : Installer le paquet fahcontrol du site foldingathome.org sur Buster

je me mets en console, puis fais "su" et donne le mot de passe root, ce qui me met en mode superutilisateur, administrateur du système.

Hors ligne

#5 22-03-2020 12:14:54

bendia
Chadministrateur
Distrib. : openSUSE Tumbleweed, Stretch
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console et un peu Openbox
Inscription : 20-03-2012
Site Web

Re : Installer le paquet fahcontrol du site foldingathome.org sur Buster

Sous Buster, il faut faire

su -

Avec le tiret. plus d'explications là https://debian-facile.org/viewtopic.php?id=24901


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

Hors ligne

#6 22-03-2020 12:34:04

hussaile
Membre
Inscription : 16-12-2018

Re : Installer le paquet fahcontrol du site foldingathome.org sur Buster

Ok, cela change effectivement.

Nonobstant, maintenant je me retrouve avec l'output suivant :

root@PC:~# dpkg -i '/home/xyz/Téléchargements/fahcontrol_7.5.1-1_all.deb'
Sélection du paquet fahcontrol précédemment désélectionné.
(Lecture de la base de données... 336036 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../fahcontrol_7.5.1-1_all.deb ...
Dépaquetage de fahcontrol (7.5.1-1) ...
dpkg: des problèmes de dépendances empêchent la configuration de fahcontrol :
fahcontrol dépend de python-gnome2 ; cependant :
  Le paquet python-gnome2 n'est pas installé.

dpkg: erreur de traitement du paquet fahcontrol (--install) :
problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour mime-support (3.62) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-4) ...
Des erreurs ont été rencontrées pendant l'exécution :
fahcontrol


Avec synaptics, je cherche python-gnome2 mais ne le trouve pas.

Avec apt-get, j'obtiens le message suivant :

root@PC:~# apt-get install python-gnome2
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet python-gnome2 n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « python-gnome2 » n'a pas de version susceptible d'être installée

Voilà : où est-ce que je peux trouver python-gnome2 ?

Hors ligne

#7 22-03-2020 13:08:58

hussaile
Membre
Inscription : 16-12-2018

Re : Installer le paquet fahcontrol du site foldingathome.org sur Buster

D'après ce que je vois python-gnome2 est considéré deprecated, unmaintained et unsecure et, donc, n'a pas été inclus pour debian buster.

J'ai avisé le webmaster de https://foldingathome.org/ et il ne reste qu'à attendre une modification de leur software, je suppose, à moins qu'il ne soit disponible en source et modifiable par l'un des membres de ce forum.

Personnellement, j'en suis incapable : cela fait 45 ans que je n'ai plus programmé et c'était en Fortran IV-G

Hors ligne

#8 22-03-2020 13:18:27

raleur
Membre
Inscription : 03-10-2014

Re : Installer le paquet fahcontrol du site foldingathome.org sur Buster

La dernière version disponible est dans Stretch (Debian 9). Il a été retiré des versions ultérieures. Raison : obsolète et non maintenu.

Il vaut mieux montrer que raconter.

Hors ligne

#9 22-03-2020 13:39:25

rodrigue7973
Membre
Lieu : beloeil
Distrib. : debian 10.3 buster
Noyau : Linux 5.4.0-0.bpo.3-amd64
(G)UI : kde plasma 5.14.5
Inscription : 19-11-2017
Site Web

Re : Installer le paquet fahcontrol du site foldingathome.org sur Buster

salut
hmm ta oublié sudo dpkg -i fichier.deb ? tu as installé ?

Etant dyslexique, j'ai des problèmes quant à la rédaction de messages en français courant. Je vous prie dès lors d'accepter toutes mes excuses si mes interventions peuvent vous paraître étranges et je vous remercie d'avance pour votre compréhension.

Hors ligne

#10 22-03-2020 14:34:45

hussaile
Membre
Inscription : 16-12-2018

Re : Installer le paquet fahcontrol du site foldingathome.org sur Buster

Rodrigue :

sudo n'est pas nécessaire si tu es déjà logué comme administrateur.

Hors ligne

#11 24-03-2020 11:36:42

èfpé
Membre
Inscription : 10-07-2016

Re : Installer le paquet fahcontrol du site foldingathome.org sur Buster

Bonjour,

hussaile a écrit :

J'ai avisé le webmaster de foldingathome.org et il ne reste qu'à attendre une modification de leur software, je suppose, [...]


Le paquet fahcontrol est recommandé, mais pas indispensable... fahclient fournit une interface web :

1585260611.png1585260671.png1585316852.png

Accessible depuis l'entrée de menu "Folding@home Web Control"... Il faut juste démarrer le service :

systemctl start FAHClient


Et hop. Le lien pointant sur la doc FAHClient n'est plus vraiment d'actualité (voir la version archivée).

hussaile a écrit :

[...] à moins qu'il ne soit disponible en source et modifiable par l'un des membres de ce forum.


FAHControl est sous licence GPL-3.0, donc, pourquoi pas. Le souci a été signalé sur le Git du projet.

Dernière modification par èfpé (27-03-2020 14:06:42)

Hors ligne

#12 24-03-2020 11:48:39

rodrigue7973
Membre
Lieu : beloeil
Distrib. : debian 10.3 buster
Noyau : Linux 5.4.0-0.bpo.3-amd64
(G)UI : kde plasma 5.14.5
Inscription : 19-11-2017
Site Web

Re : Installer le paquet fahcontrol du site foldingathome.org sur Buster

j'ai une problème fahcontrol voici mon message du tmux


rodirgue7973@rodrigue7973-pc:~/Téléchargements$ sudo dpkg -i fahcontrol_7.5.1-1_all.deb
[sudo] Mot de passe de rodirgue7973 :           
Sélection du paquet fahcontrol précédemment désélectionné.
(Lecture de la base de données... 284855 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de fahcontrol_7.5.1-1_all.deb ...
Dépaquetage de fahcontrol (7.5.1-1) ...
dpkg: des problèmes de dépendances empêchent la configuration de fahcontrol :
 fahcontrol dépend de python-gnome2 ; cependant :
  Le paquet python-gnome2 n'est pas installé.
 fahcontrol dépend de python-support | dh-python ; cependant :
  Le paquet python-support n'est pas installé.
  Le paquet dh-python n'est pas installé.

dpkg: erreur de traitement du paquet fahcontrol (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-4) ...
Traitement des actions différées (« triggers ») pour mime-support (3.62) ...
Des erreurs ont été rencontrées pendant l'exécution :
 fahcontrol
 


Etant dyslexique, j'ai des problèmes quant à la rédaction de messages en français courant. Je vous prie dès lors d'accepter toutes mes excuses si mes interventions peuvent vous paraître étranges et je vous remercie d'avance pour votre compréhension.

Hors ligne

#13 24-03-2020 12:16:36

rodrigue7973
Membre
Lieu : beloeil
Distrib. : debian 10.3 buster
Noyau : Linux 5.4.0-0.bpo.3-amd64
(G)UI : kde plasma 5.14.5
Inscription : 19-11-2017
Site Web

Re : Installer le paquet fahcontrol du site foldingathome.org sur Buster

j'ai trouvé !!

1) fahclient
2) installer fahcontrol
puis lancé fahclient
voila smile

Etant dyslexique, j'ai des problèmes quant à la rédaction de messages en français courant. Je vous prie dès lors d'accepter toutes mes excuses si mes interventions peuvent vous paraître étranges et je vous remercie d'avance pour votre compréhension.

Hors ligne

#14 31-03-2020 17:34:42

èfpé
Membre
Inscription : 10-07-2016

Re : Installer le paquet fahcontrol du site foldingathome.org sur Buster

Bonjour,

hussaile a écrit :

[...] à moins qu'il ne soit disponible en source et modifiable par l'un des membres de ce forum.


Fil de discussion obsolète, depuis la publication de la version 7.6.9 — qui règle le problème.

Oups... en fait la solution a été postée le 15 mars sur le Git du projet ; et est applicable localement :

dpkg-deb --raw-extract fahcontrol_7.5.1-1_all.deb fahcontrol

sed -i s,-gnome2,-gtk2, fahcontrol/DEBIAN/control

dpkg-deb --build fahcontrol fahcontrol_7.5.1-1~fixed_all.deb


Le plus simple est peut-être d'installer le paquet corrigé via la commande qui gère les dépendances :

apt install /chemin/complet/fahcontrol_7.5.1-1~fixed_all.deb


Et hop ! l'entrée de menu "FAHControl" créée vous permet de lancer l'interface graphique principale :

1585671824.png1585671891.png

L'installation du paquet fahviewer ne pose pas de problème. Testé sous Debian 10.3 Buster GNOME.

Dernière modification par èfpé (18-04-2020 16:24:42)

Hors ligne

Pied de page des forums