Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 24-03-2020 12:16:53

hussaile
Membre
Inscription : 16-12-2018

pulseaudio pas installable sur Buster backported

Bjr,

Comment forcer l'installation d'une version non-backported de pulseaudio sur une système backported ?

Le problème est, en effet, qu'avec ma version backported, pulseaudio n'est pas installable comme backported parce qu'une partie des fichiers nécessaires en termes de dépendances n'ont pas encore été backportés et cela crée des problèmes de dépendance ?

Et, sans pulsaudio mais seulement avec alsa, pas de son dans le programme "solfège" ni en navigant avec le brower "Tor", ....

Si je veux installer pulsaudio et es dépendances à partir de "sid", il me faut des heures d'installations en cascade pour les paquets nécessaires, ...;

Plus simple si je pouvais forcer l'installation non-backportée de pulseaudio, ....

Hors ligne

#2 24-03-2020 12:33:40

ubub
Membre
Distrib. : debian 10 buster/stable
(G)UI : xfce
Inscription : 14-05-2019

Re : pulseaudio pas installable sur Buster backported

Bonkour, qu'entends-tu par "système backported" ?
Si je conclus bien, t'es avec la version de buster (c'est dommage que tu ai pas notifié ton profil),  donc si t'installe pulseaudio ce ne sera pas la version backport sauf si tu le précise lors de apt install. Donc pas besoin de "forcer" pour une version non-backport.
Si tu rencontre un probleme, tu peux toujours charger le paquet aptitude et taper

aptitude install pulseaudio


Qui t'expliquera les problemes de dépendances et les solutions envisageables. De plus pulseaudio existe aussi dans les backports.
Perso j'ai pas de problemes de son (avec pulseaudio version buster) avec torbrowser (version buster-backports)..

Hors ligne

#3 24-03-2020 14:10:07

hussaile
Membre
Inscription : 16-12-2018

Re : pulseaudio pas installable sur Buster backported

Pardon, oubli : buster backporté.

aptitude install ramène vers le même problème : libpusle0 n'est pas de la bonne version ( celle du backport de pulseaudio) et donc pulseaudio n'est pas installé.

Ce que je veux pouvoir faire est installer la version buster simple de pulseaudio, mais le backportage de tout mon système m'en empêche.

Comment le forcer ?

Hors ligne

#4 24-03-2020 14:35:37

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.2
Noyau : Linux 5.3.18
(G)UI : KDE 5.18.5
Inscription : 11-03-2016

Re : pulseaudio pas installable sur Buster backported

Bonjour,
Peux-tu faire un copier coller du retour du terminal pour que ce soit le plus précis possible ? Merci smile

Hors ligne

#5 24-03-2020 16:04:49

hussaile
Membre
Inscription : 16-12-2018

Re : pulseaudio pas installable sur Buster backported

root@PC:/home/xyz#

apt-get install pulseaudio



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 pulseaudio : Dépend: libpulse0 (= 12.2-4+deb10u1) mais 13.0-3~bpo10+1 devra être installé
              Recommande: rtkit mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
 


Avec "aptitude install pulseaudio", c'est un plus long avec des choix, mais on retombe sur le même problème.

C'est que libpulse0 et ses dépendances ne sont pas encore backportés et donc entrent en conflit avec pulseauido qui a déjà été backporté.

D'où l'intérêt de pouvoir installer la version non-backportée de pulseaudio.

Edit : ajout des balises codes, voir le tuto : https://debian-facile.org/atelier:bbcode?s

Hors ligne

#6 24-03-2020 16:24:39

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.2
Noyau : Linux 5.3.18
(G)UI : KDE 5.18.5
Inscription : 11-03-2016

Re : pulseaudio pas installable sur Buster backported

En fait libpulse0 est bien dans les backports, c'est plutôt pulseaudio qui n'y est pas
le retour de

apt policy libpulse0 pulseaudio


devrait indiquer les dépôts qui proposent chacun des paquets.
Merci de nous donner le retour de cette commande, par défaut les backports ont une priorité à 100, on verra si c'est bien le cas pour toi.

Hors ligne

#7 24-03-2020 17:07:03

ubub
Membre
Distrib. : debian 10 buster/stable
(G)UI : xfce
Inscription : 14-05-2019

Re : pulseaudio pas installable sur Buster backported

En fait libpulse0 est bien dans les backports, c'est plutôt pulseaudio qui n'y est pas


l ? https://packages.debian.org/buster-backports/pulseaudio
https://packages.debian.org/buster-backports/libpulse0
au fait hussaile, t'utilises stretch ou buster comme debian ? la 9 ou la 10 ?

Hors ligne

#8 24-03-2020 17:12:44

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.2
Noyau : Linux 5.3.18
(G)UI : KDE 5.18.5
Inscription : 11-03-2016

Re : pulseaudio pas installable sur Buster backported

dans ce cas pour installer depuis les backports avec une bonne gestion des dépendances

apt install -t buster-backports pulseaudio


ubub a écrit :

au fait hussaile, t'utilises stretch ou buster comme debian ? la 9 ou la 10 ?


Voir le tuto : Trop cool d'indiquer son installation dans son profil !
ce serait bien effectivement que tu complètes ton profil pour indiquer ta distribution wink

Hors ligne

Pied de page des forums