Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-04-2020 10:34:33

DarKou
Membre
Lieu : Bordeaux
Distrib. : Debian Buster
Noyau : stable de chez kernel.org
(G)UI : GNOME 3.30.2 / i3
Inscription : 06-04-2020
Site Web

[Résolu] Pulseaudio : régler toutes les applications au même niveau

Salut tout le monde,

Je ne sais pas si c'est pareil pour vous mais il y a quelque chose qui me rend fou sous Pulseaudio c'est le réglage du volume !

Chaque application à son propre niveau de son + le niveau de son général, ce qui fait que suivant l'application lancée au moment de régler le volume général je fini par me retrouver avec le son de firefox à 100% alors que celui de Spotify est à 20%, juste insupportable quand on passe d'une application à l'autre.

Avez-vous une solution pour que toute les applications soient par exemple à 100% peu importe la situation et que le réglage du volume se fasse uniquement sur le volume général ?

Merci d'avance !

Dernière modification par DarKou (07-04-2020 11:34:35)

Hors ligne

#2 07-04-2020 11:30:30

Cauryl
Membre
Distrib. : Debian Buster
(G)UI : Xfce
Inscription : 12-02-2020

Re : [Résolu] Pulseaudio : régler toutes les applications au même niveau

Salut !

De même, je déteste ce comportement.

Je n'ai pas pris de note lorsque j'ai résolu le problème, alors à vérifier si ça fonctionne.

Dans /etc/pulse/daemon.conf, décommenter la ligne :

; flat-volumes = no

Hors ligne

#3 07-04-2020 11:34:10

DarKou
Membre
Lieu : Bordeaux
Distrib. : Debian Buster
Noyau : stable de chez kernel.org
(G)UI : GNOME 3.30.2 / i3
Inscription : 06-04-2020
Site Web

Re : [Résolu] Pulseaudio : régler toutes les applications au même niveau

Ha !

Génial, merci big_smile

Hors ligne

#4 07-04-2020 13:18:01

Trefix
Membre
Lieu : 48
Distrib. : buster 10.4 + bpo
Noyau : linux 4.19.0-9-amd64
(G)UI : Xfce4 4.12.5
Inscription : 15-02-2015

Re : [Résolu] Pulseaudio : régler toutes les applications au même niveau

Bonjour.

C'est un problème que j'avais aussi juste après installation (Buster 10.3.0-amd64) et qui s'est réglé "tout seul" quand j'ai installé Xfce4-pulsaudio-plugin 0.4.1.
Un coup d'œil

nano /etc/pulse/daemon.conf

m'a montré la ligne non pas commenté (pas de #) mais tout simplement

; flat-volumes = yes

Il faut descendre un peu, c'est une ligne seule en milieu de page...

Merci pour l'info big_smile

Hors ligne

#5 07-04-2020 14:02:40

DarKou
Membre
Lieu : Bordeaux
Distrib. : Debian Buster
Noyau : stable de chez kernel.org
(G)UI : GNOME 3.30.2 / i3
Inscription : 06-04-2020
Site Web

Re : [Résolu] Pulseaudio : régler toutes les applications au même niveau

J'avais

; flat-volumes = yes



dans mon fichier justement mais ça ne semblait pas régler mon soucis, avec

flat-volumes = no



par contre ça semble régler mon soucis

Hors ligne

#6 07-04-2020 14:15:01

Cauryl
Membre
Distrib. : Debian Buster
(G)UI : Xfce
Inscription : 12-02-2020

Re : [Résolu] Pulseaudio : régler toutes les applications au même niveau

Le point-virgule permet de commenter les lignes dans pas mal de fichiers de configuration (php.ini, gitconfig) et langages de programmation (lips, assembleur). J'entendais donc qu'il fallait retirer le point-virgule. wink

Hors ligne

#7 07-04-2020 14:16:55

DarKou
Membre
Lieu : Bordeaux
Distrib. : Debian Buster
Noyau : stable de chez kernel.org
(G)UI : GNOME 3.30.2 / i3
Inscription : 06-04-2020
Site Web

Re : [Résolu] Pulseaudio : régler toutes les applications au même niveau

Oui j'avais bien compris wink .

Maintenant la question est lorsque c'est commenté qu'elle est la valeur par défaut pour flat-volumes, yes visiblement ? (vu le comportement que j'avais)

Hors ligne

#8 07-04-2020 14:29:45

Cauryl
Membre
Distrib. : Debian Buster
(G)UI : Xfce
Inscription : 12-02-2020

Re : [Résolu] Pulseaudio : régler toutes les applications au même niveau

Je ne comprends pas ta question. scratchhead.gif

Si tu as décommenté

; flat-volumes = yes

, la valeur par défaut lorsque que c'est commenté est yes.

Par défaut, c'est donc sur yes. Visiblement, j'aurai dû prendre des notes de la manip. wink

edit :
Après investigations, les règles de constructions du paquet pulseaudio possèdent un patch (daemon-conf-disable-flat-volumes-by-default.patch) qui change

; flat-volumes = yes

pour

; flat-volumes = no

. C'est décidément bien mystérieux.

Dernière modification par Cauryl (07-04-2020 14:44:41)

Hors ligne

Pied de page des forums