Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 14-04-2020 14:13:38

johnsmoke77
Membre
Inscription : 14-04-2020

Wifi Down quand cable ethernet branché

Bonjour tout le monde,

J'ai un ordinateur portable A sous Debian connecté au Wifi. Je souhaite connecter cet ordinateur à un autre ordinateur ( pour faire un partage de souris via synergy ).
Lorsque je branche un cable ethernet croisé entre mon ordi A et un autre ordi B sous Debian également, le wifi de mon ordi A se coupe immédiatement.
En faisant un 'rfkill list', je vois que mon Wifi est en Hard Block : yes. Lorsque je débranche le calbe de mon ordi A, le wifi reveint dans les 3 secondes, et il n'est plus en hardware block  : yes.
Il semble donc que brancher le cable ethenet bloque le wifi en hardware, et que le debrancher le débloque. Problème : je voudrais pouvoir avoir le wifi ET la connexion ethernet à l'ordi B sur mon ordi A.
Comment faire pour avoir les deux ? J'ai essayé rfkill unblock all, sans succès.

Je vous remercie d'avance pour toute aide .
John

Hors ligne

#2 14-04-2020 14:42:31

raleur
Membre
Inscription : 03-10-2014

Re : Wifi Down quand cable ethernet branché

Vérifie dans les paramètres du BIOS/UEFI.

Il vaut mieux montrer que raconter.

Hors ligne

#3 14-04-2020 14:45:34

Cauryl
Membre
Distrib. : Debian Buster
(G)UI : Xfce
Inscription : 12-02-2020

Re : Wifi Down quand cable ethernet branché

Salut !

En effet, si rfkill list retourne Hard Block : yes, c'est bien côté matériel que ça se passe.
Quid de l'interrupteur physique ?

Édit: toujours très rapide ce raleur wink

Dernière modification par Cauryl (14-04-2020 14:47:13)

Hors ligne

#4 14-04-2020 17:05:29

johnsmoke77
Membre
Inscription : 14-04-2020

Re : Wifi Down quand cable ethernet branché

Merci pour vos réponses mais là mystère.

Dans mon bios, j'ai un onglet wireless et tout est sur enabled. De plus le voyant du wifi sur l'ordi est toujours activé, pas de souci aussi. C'est vraiment dès que je branche mon cable ethernet, boum la connexion Wifi disparait ( dans le network manager toutes le connexions wifis disparaissent, seul reste le bouton wifi On /off qui n'a aucun effet ) et je peux me connecter en LAN, et dès que je débranche le cable, boum la connexion wifi revient. Je fais ca 10 fois de suite et ca passe de l'un à l'autre sans souci, mais jamais les 2 en même temps. Impossible d'avoir les deux . Pour info c'est un Dell Latitude E5440. C'est dingue, c'est vraiment le branchement du cable qui fait switcher de l'un à l'autre. Voici mon fichier /etc/network/interfaces et le resultat de quelques commandes :

 This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback
 




Avant de connecter le cable, quand mon wifi marche :

john@morpheus:~$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eno1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether ec:f4:bb:28:9d:46 brd ff:ff:ff:ff:ff:ff
3: wlp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 80:86:f2:0a:7a:d5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.128/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp2s0
       valid_lft 42718sec preferred_lft 42718sec
    inet6 fe80::8286:f2ff:fe0a:7ad5/64 scope link noprefixroute
       valid_lft forever preferred_lft forever
 



Et dès que je conecte le cable :

john@morpheus:~$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether ec:f4:bb:28:9d:46 brd ff:ff:ff:ff:ff:ff
3: wlp2s0: <BROADCAST,MULTICAST> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether d2:8d:ac:70:f4:87 brd ff:ff:ff:ff:ff:ff
 

Hors ligne

#5 14-04-2020 17:21:00

raleur
Membre
Inscription : 03-10-2014

Re : Wifi Down quand cable ethernet branché

johnsmoke77 a écrit :

Dans mon bios, j'ai un onglet wireless et tout est sur enabled


"Tout", c'est-à-dire ?
Tu as vérifié aussi dans les paramètres de sécurité ?


Il vaut mieux montrer que raconter.

Hors ligne

#6 14-04-2020 17:38:36

johnsmoke77
Membre
Inscription : 14-04-2020

Re : Wifi Down quand cable ethernet branché

Tout ce qui a un rapport au Wifi.:

- Onglet Wireless :
        Wireless switch : les 4 cases proposées sont cochés : WWAN, WLAN, WiGig, Bluetooth
        Wireless device enble : les 3 cases proposées sont cochés : WWAN, WLAN/WIGig, Bluetooth

- Onglet Securite: le seul truc en rapport avec le wifi est dans l'onglet "Non-admin setup changes", la case "Allow Wireless Switch Changes" est cochée

- Onglet Systeme configuration/ Integrated NIC, , il y a 3 + 1 choix :  Enabled, Enabled w/PXE et Disabled + Enable UEFI Network Stack. La case Enabled w/PXE est cochée.

Je fouille et refouille mais j'a irien d'autre en rapport avec Wifi ...

Hors ligne

#7 14-04-2020 17:46:42

èfpé
Membre
Inscription : 10-07-2016

Re : Wifi Down quand cable ethernet branché

Bonsoir,

raleur a écrit :

Tu as vérifié aussi dans les paramètres de sécurité ?


Selon la doc page 49 cela se passe sous l'onglet "Power Management" (cf. "Wireless Radio Control").

Hors ligne

#8 14-04-2020 18:02:43

johnsmoke77
Membre
Inscription : 14-04-2020

Re : Wifi Down quand cable ethernet branché

Yes Merci beaucoup t'es un vrai tueur. Il fallait effectivement décocher les deux cases dans l'onglet PowerManagement/ WirlessRadioControl. Je sui désolé du dérangment ça m'apprendra à mieux chercher dans le bios.   Merci a tout le monde ça m'aide beaucoup

Hors ligne

Pied de page des forums