Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 24-04-2020 18:27:43

gervaisien_47
Membre
Distrib. : Debian Stretch 9.6.0 GNU/Linux
Inscription : 28-11-2018

[RESOLU] Impossibilité d'utiliser Synaptic

J'ai récemment passé de la version Stretch à la version Buster et lors de l'installation des fichiers j'ai validé (trop rapidement certainement...) une option qui me pose problème maintenant :

Alors que j'avais l'habitude d'utiliser Synaptic pour contrôler ma mise à jour ou alors charger des modules complémentaires (comme Arduino par exemple) il m'est maintenant impossible d'utiliser Synaptic : je reçois le message comme quoi j'utilise l'environnement Wayland et que donc synaptic n'a plus les facultés liées à l'administrateur...et qu'il faut relancer la session sans Wayland si je veux utiliser synaptic

D'abord pouvez vous m'expliquer ce qu'est wayland et quel intérêt cela présente, et ensuite me dire comment faire pour que Wayland ne se lance pas au démarrage.

J'entends rester maître de l'administration de mon installation.

Merci pour votre aide

Dernière modification par gervaisien_47 (24-04-2020 21:42:58)

Hors ligne

#2 24-04-2020 18:53:14

bendia
Chadministrateur
Distrib. : openSUSE Tumbleweed, Stretch
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console et un peu Openbox
Inscription : 20-03-2012
Site Web

Re : [RESOLU] Impossibilité d'utiliser Synaptic

Bonjour smile

Wayland, c'est le serveur d'affichage (un petit schéma du wiki pour comprendre comment fonctionne tout ça wink ). Il est amené à remplacer X11 le serveur d'affichage dont la première version date de 1984 et est a priori devenu très difficile à maintenir et faire évoluer. L'intérêt est donc là.

Debian a décidé au moment de la sortie de Buster de proposer Wayland comme serveur d'affichage par défaut pour l'environnement de bureau Gnome. Cependant, à ce moment, Synaptic n'était pas encore adapté à Wayland. Il avait été question de le supprimer de Buster, mais comme il fonctionne avec d'autre DE (genre XFCE), ça ne s'était pas fait.

Cependant, le problème est temporaire, puisque Synaptic a évolué, et fonctionne désormais sans soucis avec Bullseye.

Pour qu'il ne se lance pas, il suffit de choisir de démarrer Gnome sur Xorg dans GDM3 au lancement de ta session comme sur l'image ci-dessous smile

file-Reeede8dbcbc3df234c6f2daade16c8fb

Normalement, ça reste sélectionné pour le prochain démarrage smile

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

Hors ligne

#3 24-04-2020 21:41:38

gervaisien_47
Membre
Distrib. : Debian Stretch 9.6.0 GNU/Linux
Inscription : 28-11-2018

Re : [RESOLU] Impossibilité d'utiliser Synaptic

Merci pour ces précisions.

J'ai eu une notification comme cela est déjà souvent arrivé "d'importantes mises à jour....." d'habitude je n'attendais pas trop longtemps pour mettre à jour ma version avec Synaptic; mais cette fois ci ne pouvant pas utiliser Synaptic je ne sais même pas si les mises à jour ont été effectuées.

J'ai compris que Debian Buster utilise Weyland et que Synaptic va bientôt être compatible.

Je patiente pour voir comme cela se met en place.

Encore merci pour votre réponse rapide à mon message

Hors ligne

#4 25-04-2020 12:58:35

jarek
Membre
Lieu : Haute Loire
Distrib. : bullseye
Noyau : linux 5.8.0 amd64
(G)UI : Xfce4 - LightDM
Inscription : 24-06-2014

Re : [RESOLU] Impossibilité d'utiliser Synaptic

Wayland n'intervient pas avec xfce.
Mais j'ai remarqué des interférences si gnome et xfce sont installés ensemble.

Le Diable a inventé l'Administration afin que les Hommes perdent tout espoir à jamais.
Ryzen3 3200G - Asrock B450

En ligne

#5 25-04-2020 13:38:22

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.2
Noyau : Linux 5.3.18
(G)UI : KDE 5.18.5
Inscription : 11-03-2016

Re : [RESOLU] Impossibilité d'utiliser Synaptic

Bonjour,

gervaisien_47 a écrit :

J'ai compris que Debian Buster utilise Weyland et que Synaptic va bientôt être compatible.
Je patiente pour voir comme cela se met en place.


Je ne crois pas que Synaptic permettra la mise à jour du système en étant avec Wayland sur Buster.
Tu as le choix soit de sélectionner Gnome sur Xorg pour pouvoir l’utiliser et mettre à jour, soit de faire les mises à jour en lignes de commande lorsque tu es avec une session Gnome (=avec Wayland)
Ce n’est à mon avis pas une bonne idée d’attendre un correctif de Synaptic pour mettre à jour le système.

En ligne

#6 25-04-2020 14:25:21

bendia
Chadministrateur
Distrib. : openSUSE Tumbleweed, Stretch
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console et un peu Openbox
Inscription : 20-03-2012
Site Web

Re : [RESOLU] Impossibilité d'utiliser Synaptic

chalu a écrit :

Ce n’est à mon avis pas une bonne idée d’attendre un correctif de Synaptic pour mettre à jour le système.

Tout à fait. Synaptic ne fonctionnera avec Wayland qu'à la publication de Bullseye en Stable, donc Quand c'est prêt (à la grosse louche, 1 an ou 1 an 1/2 big_smile )


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

Hors ligne

Pied de page des forums