Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-04-2020 11:07:26

Spirale21
Membre
Distrib. : Debian GNU/Linux 9.12 (stretch)
Noyau : Linux 4.9.0-12-amd64
(G)UI : i3
Inscription : 26-02-2013

[RESOLU] j'ai une adresse IPv4 mais pas de connection à internet

Bonjour,
Alors voici mon problème de réseaux, ça concerne mon wifi mais c'est un problème exotique (je crois). J'ai bien une adresse IPv4 mais je n'ai pas accès à internet lol car je n'arrive même pas à atteindre ma box. (là je suis en filaire)

ip a



1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp1s0f1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 80:fa:5b:66:a5:da brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.18/24 brd 192.168.1.255 scope global enp1s0f1
       valid_lft forever preferred_lft forever
    inet6 fe80::82fa:5bff:fe66:a5da/64 scope link
       valid_lft forever preferred_lft forever
3: wlp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether b0:35:9f:c8:2e:77 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.17/24 brd 192.168.1.255 scope global dynamic wlp2s0
       valid_lft 81759sec preferred_lft 81759sec
    inet6 fe80::9dac:db2d:9ca:94d4/64 scope link
       valid_lft forever preferred_lft forever
 


(wlp2s0 est ma connexion wifi)

systemctl status NetworkManager.service



● NetworkManager.service - Network Manager
   Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled; vendor preset: enabled)
   Active: active (running) since Sat 2020-04-25 10:23:33 CEST; 1h 10min ago
     Docs: man:NetworkManager(8)
 Main PID: 504 (NetworkManager)
    Tasks: 4 (limit: 4915)
   CGroup: /system.slice/NetworkManager.service
           ├─ 504 /usr/sbin/NetworkManager --no-daemon
           └─2034 /sbin/dhclient -d -q -sf /usr/lib/NetworkManager/nm-dhcp-helper -pf /var/run/dhclient-w
 


ping 127.0.0.1



PING 127.0.0.1 (127.0.0.1) 56(84) bytes of data.
64 bytes from 127.0.0.1: icmp_seq=1 ttl=64 time=0.037 ms
64 bytes from 127.0.0.1: icmp_seq=2 ttl=64 time=0.075 ms
64 bytes from 127.0.0.1: icmp_seq=3 ttl=64 time=0.034 ms
 


ping 192.168.1.1 #192.168.1.1 c'est l'adresse de ma livebox



PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.18 icmp_seq=1 Destination Host Unreachable
From 192.168.1.18 icmp_seq=2 Destination Host Unreachable
From 192.168.1.18 icmp_seq=3 Destination Host Unreachable
 


ip -a route



default via 192.168.1.1 dev enp1s0f1
default via 192.168.1.1 dev wlp2s0 proto static metric 600
169.254.0.0/16 dev enp1s0f1 scope link metric 1000
192.168.1.0/24 dev enp1s0f1 proto kernel scope link src 192.168.1.18
192.168.1.0/24 dev wlp2s0 proto kernel scope link src 192.168.1.17 metric 600
 


rfkill list wifi



1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
 



Si une personne à une idée je suis preneur.
(PS: je suis avec le WM i3 je n'ai pas de DE)

Dernière modification par Spirale21 (25-04-2020 20:21:25)


La difficulté est source d'apprentissage

Hors ligne

#2 25-04-2020 12:25:15

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian
Noyau : Dur
(G)UI : gui gui, je zuis un doiseau
Inscription : 07-07-2008
Site Web

Re : [RESOLU] j'ai une adresse IPv4 mais pas de connection à internet

Coucou,

D'après les infos que tu nous as donné, tu es connecté deux fois à ton réseau, une fois via un câble réseau, et une fois via une carte wifi.
Est-ce que tu peux essayer de couper une des deux interface afin de voir si ça marche mieux ? Par exemple, pour couper la carte réseau :

ip link set down enp1s0f1


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.
Je suis parrain linux !

Hors ligne

#3 25-04-2020 13:49:36

Spirale21
Membre
Distrib. : Debian GNU/Linux 9.12 (stretch)
Noyau : Linux 4.9.0-12-amd64
(G)UI : i3
Inscription : 26-02-2013

Re : [RESOLU] j'ai une adresse IPv4 mais pas de connection à internet

Super !!!! merci.gif
mais pourquoi ça pose des soucis le fait que je sois connecté deux fois à mon réseaux sur le même périphérique ? scratchhead.gif

La difficulté est source d'apprentissage

Hors ligne

#4 25-04-2020 15:08:59

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU] j'ai une adresse IPv4 mais pas de connection à internet

Le système ne sait pas par laquelle des deux interfaces il doit envoyer les paquets.

Il vaut mieux montrer que raconter.

Hors ligne

Pied de page des forums