Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-04-2020 10:23:48

Daff
Membre
Distrib. : Debian 10 [Main]
Noyau : Linux 4.19 (Amd64)
(G)UI : Xfce 4.12
Inscription : 12-07-2019

Notifications dans XFCE [Résolu]

Bonjour à tous, j'ai cliquer sur "ne plus afficher ce message" lors d'une notification mais sans le vouloir vraiment.
Depuis, évidemment la notification ne s'affiche plus. Donc j'aimerais remettre cette notification.
Pour info dans

xfce4-notifyd-config


Onglet 'Applications' aucune notification n'est bloqué.

Dernière modification par Daff (26-04-2020 12:03:44)

Hors ligne

#2 26-04-2020 10:46:41

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : Notifications dans XFCE [Résolu]

Xfce peut bloquer les notifications d'une application - oui - mais une application peut aussi bloquer d'elle-même ses notifications.
C'est au cas par cas. Du coup sans plus de précision je ne peux que faire un exemple :

Si je clique sur "ne pplus afficher" sur la notification de réseau de network-manager, le changement sera opéré dans dconf.

dconf dump /


[...]
[org/gnome/nm-applet]
disable-connected-notifications=true
[...]



Je ne sais même pas si network-manager propose un moyen "graphique" pour changer ça, mais à défaut on pourrait le faire avec un "dconf write".

Voilà pour l'exemple.

Dernière modification par otyugh (26-04-2020 10:47:08)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#3 26-04-2020 10:55:36

Daff
Membre
Distrib. : Debian 10 [Main]
Noyau : Linux 4.19 (Amd64)
(G)UI : Xfce 4.12
Inscription : 12-07-2019

Re : Notifications dans XFCE [Résolu]

OK, faut-il installer un paquet supplémentaire pour "dconf" car j'ai 'commande introuvable' ?

Hors ligne

#4 26-04-2020 11:01:05

MicP
Membre
Inscription : 29-02-2016

Re : Notifications dans XFCE [Résolu]

Bonjour

J'ai désactivé les notifications de connexion réseau
en cliquant sur le bouton contenu dans le message de notification.

Donc :

gsettings get org.gnome.nm-applet disable-connected-notifications

true



Alors, je change la valeur de cette clef par false

gsettings set org.gnome.nm-applet disable-connected-notifications false


Et maintenant, les notifications de connexion réseau s'affichent à nouveau.

Dernière modification par MicP (26-04-2020 12:21:13)

Hors ligne

#5 26-04-2020 11:08:34

Daff
Membre
Distrib. : Debian 10 [Main]
Noyau : Linux 4.19 (Amd64)
(G)UI : Xfce 4.12
Inscription : 12-07-2019

Re : Notifications dans XFCE [Résolu]

OK super mais c'est déjà sur 'false' pour le réseau (org.gnome.nm-applet) car c'est plus précisemment pour la connexion réseau openvpn (VPN) que je n'ai plus la notification.

Je n'ai pas trouver ce qui se rapporte à openvpn dans

gsettings list-schemas

Dernière modification par Daff (26-04-2020 11:58:25)

Hors ligne

#6 26-04-2020 11:57:29

MicP
Membre
Inscription : 29-02-2016

Re : Notifications dans XFCE [Résolu]

pour la connexion réseau openvpn ?

Pour que les notifications concernant le vpn s'affichent :

gsettings set org.gnome.nm-applet disable-vpn-notifications false


=======

…Peut-on afficher toutes les applets disponibles pour faire du cas par cas en ligne de commande …

Je ne sais pas, mais voilà une ligne de commandes qui te permettra de visualiser avec le pager less
la liste triée des clefs accessibles par la commande gsettings et leur valeur :

gsettings list-recursively | sort | less -S

Le pager less te permettra de naviguer dans la liste affichée
en utilisant les flèches (haut bas droite gauche)
PgUp, PgDown
h pour l'aide en ligne de la commande less
et q pour quitter.

L'option S de la commande less permet d'afficher les lignes sans les tronquer,
d'où l'utilité des flèches droite gauche qui permettront de visualiser la fin des lignes trop longues.

Dernière modification par MicP (26-04-2020 12:17:33)

Hors ligne

#7 26-04-2020 12:03:07

Daff
Membre
Distrib. : Debian 10 [Main]
Noyau : Linux 4.19 (Amd64)
(G)UI : Xfce 4.12
Inscription : 12-07-2019

Re : Notifications dans XFCE [Résolu]

gsettings get org.gnome.nm-applet disable-vpn-notifications


true




Parfait c'est bien ici, je vais changer pour 'false'. Super : gsettings list-recursively | sort | less -S

Merci.

Dernière modification par Daff (26-04-2020 12:12:59)

Hors ligne

Pied de page des forums