Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-04-2020 10:40:37

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

La liste des paquets privateur de blob matériel

Salut,
pour un script je chercherai la liste de firmware/driver privateur (des blobs matériel quoi) dispo dans debian (l'idée c'est de proposer l'option "installer les blobs proprio pour tout pour tous les matériels" / "les désinstaller tous"). J'ai réussi à générer une liste en faisant "apt search firmware/driver" dans les repos privateur/contrib

alsa-firmware-loaders amd64-microcode atmel-firmware b43-fwcutter bladerf-firmware-fx3 bluez-firmware broadcom-sta-dkms bumblebee-nvidia dahdi-firmware-nonfree firmware-adi firmware-amd-graphics firmware-atheros firmware-b43-installer firmware-b43legacy-installer firmware-bnx2 firmware-bnx2x firmware-brcm80211 firmware-cavium firmware-crystalhd firmware-intel-sound firmware-intelwimax firmware-ipw2x00 firmware-ivtv firmware-iwlwifi firmware-libertas firmware-misc-nonfree firmware-myricom firmware-netxen firmware-qlogic firmware-ralink firmware-realtek firmware-samsung firmware-siano firmware-ti-connectivity firmware-zd1211 gobi-loader hdmi2usb-fx2-firmware intel-microcode ixo-usb-jtag madfuload midisport-firmware nvidia-alternative nvidia-cuda-toolkit nvidia-detect nvidia-driver nvidia-driver-bin nvidia-driver-libs nvidia-driver-libs-nonglvnd nvidia-egl-icd nvidia-installer-cleanup nvidia-kernel-dkms nvidia-kernel-source nvidia-kernel-support nvidia-legacy-304xx-alternative nvidia-legacy-304xx-driver nvidia-legacy-304xx-driver-bin nvidia-legacy-304xx-driver-libs nvidia-legacy-304xx-kernel-dkms nvidia-legacy-304xx-kernel-source nvidia-legacy-304xx-kernel-support nvidia-legacy-304xx-opencl-icd nvidia-legacy-304xx-vdpau-driver nvidia-legacy-340xx-alternative nvidia-legacy-340xx-driver nvidia-legacy-340xx-driver-bin nvidia-legacy-340xx-driver-libs nvidia-legacy-340xx-kernel-dkms nvidia-legacy-340xx-kernel-source nvidia-legacy-340xx-kernel-support nvidia-legacy-340xx-opencl-icd nvidia-legacy-340xx-vdpau-driver nvidia-legacy-check nvidia-libopencl1 nvidia-modprobe nvidia-nonglvnd-vulkan-icd nvidia-opencl-icd nvidia-persistenced nvidia-settings nvidia-settings-legacy-304xx nvidia-settings-legacy-340xx nvidia-support nvidia-vdpau-driver nvidia-vulkan-icd nvidia-xconfig r8168-dkms sl-modem-dkms sl-modem-source xserver-xorg-video-ivtv xserver-xorg-video-ivtv-dbg xserver-xorg-video-nvidia xserver-xorg-video-nvidia-legacy-304xx xserver-xorg-video-nvidia-legacy-340xx



Mais c'est "trop complet" en ce sens que je voudrai juste "le (meta)paquet de poupe".
Je pense que ça doit faire une dizaine de paquet à tout casser. Mais j'ai peur de faire une bêtise en excluant des choses valides >.<
Second problème : je voudrai que les driver de CG/CPU/carte eth/wifi du grand publique, je m'en fous un peu du firmware pour connecter des imprimantes professionnelles spéciales, je voudrais juste "le mainstream".

Je compte sur ceux d'entre vous qui y entendent quelque chose >.<

Personnellement de mon expérience je prendrai juste :

#cpu
amd64-microcode intel-microcode
#firmware par modèle (et son paquet "vrac")
firmware-amd-graphics firmware-ralink firmware-realtek firmware-atheros  firmware-iwlwifi firmware-b43-installer firmware-b43legacy-installer  firmware-brcm80211
firmware-misc-nonfree
#nvidia qui veut pas faire comme les autres
nvidia-legacy-340xx-driver nvidia-driver nvidia-legacy-304xx-driver nvidia-vulkan-icd bumblebee-nvidia
#bluetooth
bluez-firmware
#firmwares que j'ai jamais eu à utiliser (matos exotique ?)
#firmware-adi firmware-bnx2 firmware-bnx2x firmware-cavium firmware-crystalhd firmware-intel-sound firmware-intelwimax firmware-ipw2x00 firmware-ivtv firmware-libertas firmware-myricom firmware-netxen firmware-qlogic firmware-samsung firmware-siano firmware-ti-connectivity firmware-zd1211


C'est un peu... Empirique mon affaire ? >.<

Dernière modification par otyugh (29-04-2020 11:13:44)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#2 29-04-2020 18:10:25

David5647
Membre
Distrib. : Debian Bullseye/Sid
Noyau : 5.7.0-2-amd64
(G)UI : KDE/i3wm
Inscription : 27-08-2017

Re : La liste des paquets privateur de blob matériel

Mmmhhh...

Si j'me suis pas planté, ça devrait chercher les paquets dans contrib et non-free dont la description contient "metapackage", avec un grep, ça donne ça

aptitude search '(~s contrib | ~s non-free) ~dmetapackage' | egrep 'firmware|driver'


i  bumblebee-nvidia - NVIDIA Optimus support using the proprietary NVIDIA driver
p  bumblebee-nvidia:i386 - NVIDIA Optimus support using the proprietary NVIDIA driver
p  firmware-linux - Binary firmware for various drivers in the Linux kernel (metapackage)
p  nvidia-driver - NVIDIA metapackage
p  nvidia-driver:i386 - NVIDIA metapackage
p  nvidia-driver-libs - NVIDIA metapackage (OpenGL/GLX/EGL/GLES libraries)
p  nvidia-driver-libs:i386 - NVIDIA metapackage (OpenGL/GLX/EGL/GLES libraries)
p  nvidia-driver-libs-i386:i386 - NVIDIA metapackage (OpenGL/GLX/EGL/GLES 32-bit libraries)
p  nvidia-egl-icd - NVIDIA EGL installable client driver (ICD)
p  nvidia-egl-icd:i386 - NVIDIA EGL installable client driver (ICD)
p  nvidia-legacy-304xx-driver - NVIDIA metapackage (304xx legacy version)
p  nvidia-legacy-304xx-driver:i386 - NVIDIA metapackage (304xx legacy version)
p  nvidia-legacy-304xx-driver-libs - NVIDIA metapackage (OpenGL/GLX libraries) (304xx legacy version)
p  nvidia-legacy-304xx-driver-libs:i386 - NVIDIA metapackage (OpenGL/GLX libraries) (304xx legacy version)
p  nvidia-legacy-304xx-driver-libs-i386:i386 - NVIDIA metapackage (OpenGL/GLX 32-bit libraries) (304xx legacy version)
p  nvidia-legacy-340xx-driver - NVIDIA metapackage (340xx legacy version)
p  nvidia-legacy-340xx-driver:i386 - NVIDIA metapackage (340xx legacy version)
p  nvidia-legacy-340xx-driver-libs - NVIDIA metapackage (OpenGL/GLX/EGL/GLES libraries) (340xx legacy version)
p  nvidia-legacy-340xx-driver-libs:i386 - NVIDIA metapackage (OpenGL/GLX/EGL/GLES libraries) (340xx legacy version)
p  nvidia-legacy-340xx-driver-libs-i386:i386 - NVIDIA metapackage (OpenGL/GLX/EGL/GLES 32-bit libraries) (340xx legacy)
p  nvidia-legacy-390xx-driver - NVIDIA metapackage (390xx legacy version)
p  nvidia-legacy-390xx-driver:i386 - NVIDIA metapackage (390xx legacy version)
p  nvidia-legacy-390xx-driver-libs - NVIDIA metapackage (OpenGL/GLX/EGL/GLES libraries) (390xx legacy version)
p  nvidia-legacy-390xx-driver-libs:i386 - NVIDIA metapackage (OpenGL/GLX/EGL/GLES libraries) (390xx legacy version)
p  nvidia-legacy-390xx-driver-libs-i386:i386 - NVIDIA metapackage (OpenGL/GLX/EGL/GLES 32-bit libraries) (390xx legacy)
p  nvidia-legacy-390xx-driver-libs-nonglvnd - NVIDIA metapackage (non-GLVND OpenGL/GLX/EGL/GLES libraries) (390xx legacy)
p  nvidia-legacy-390xx-driver-libs-nonglvnd:i386 - NVIDIA metapackage (non-GLVND OpenGL/GLX/EGL/GLES libraries) (390xx legacy)
p  nvidia-legacy-390xx-driver-libs-nonglvnd-i386:i386 - NVIDIA metapackage (non-GLVND OpenGL/EGL etc. 32-bit libraries) (390xx legacy)
p  nvidia-legacy-390xx-egl-icd - NVIDIA EGL installable client driver (ICD)
p  nvidia-legacy-390xx-egl-icd:i386 - NVIDIA EGL installable client driver (ICD)
p  nvidia-legacy-390xx-vulkan-icd - NVIDIA Vulkan installable client driver (ICD) (390xx legacy version)
p  nvidia-legacy-390xx-vulkan-icd:i386 - NVIDIA Vulkan installable client driver (ICD) (390xx legacy version)
p  nvidia-tesla-418-driver - NVIDIA metapackage (Tesla 418 version)
p  nvidia-tesla-418-driver-libs - NVIDIA metapackage (OpenGL/GLX/EGL/GLES libraries) (Tesla 418 version)
p  nvidia-tesla-418-driver-libs:i386 - NVIDIA metapackage (OpenGL/GLX/EGL/GLES libraries) (Tesla 418 version)
p  nvidia-tesla-418-driver-libs-i386:i386 - NVIDIA metapackage (OpenGL/GLX/EGL/GLES 32-bit libraries) (Tesla 418)
p  nvidia-tesla-418-driver-libs-nonglvnd - NVIDIA metapackage (non-GLVND OpenGL/GLX/EGL/GLES libraries) (Tesla 418)
p  nvidia-tesla-418-driver-libs-nonglvnd:i386 - NVIDIA metapackage (non-GLVND OpenGL/GLX/EGL/GLES libraries) (Tesla 418)
p  nvidia-tesla-418-driver-libs-nonglvnd-i386:i386 - NVIDIA metapackage (non-GLVND OpenGL/EGL etc. 32-bit libraries) (Tesla 418)
p  nvidia-tesla-418-egl-icd - NVIDIA EGL installable client driver (ICD)
p  nvidia-tesla-418-egl-icd:i386 - NVIDIA EGL installable client driver (ICD)
p  nvidia-tesla-418-vulkan-icd - NVIDIA Vulkan installable client driver (ICD) (Tesla 418 version)
p  nvidia-tesla-418-vulkan-icd:i386 - NVIDIA Vulkan installable client driver (ICD) (Tesla 418 version)
p  nvidia-tesla-440-driver - NVIDIA metapackage (Tesla 440 version)
p  nvidia-tesla-440-driver-libs - NVIDIA metapackage (OpenGL/GLX/EGL/GLES libraries) (Tesla 440 version)
p  nvidia-tesla-440-driver-libs:i386 - NVIDIA metapackage (OpenGL/GLX/EGL/GLES libraries) (Tesla 440 version)
p  nvidia-tesla-440-driver-libs-i386:i386 - NVIDIA metapackage (OpenGL/GLX/EGL/GLES 32-bit libraries) (Tesla 440)
p  nvidia-tesla-440-egl-icd - NVIDIA EGL installable client driver (ICD)
p  nvidia-tesla-440-egl-icd:i386 - NVIDIA EGL installable client driver (ICD)
p  nvidia-tesla-440-vulkan-icd - NVIDIA Vulkan installable client driver (ICD) (Tesla 440 version)
p  nvidia-tesla-440-vulkan-icd:i386 - NVIDIA Vulkan installable client driver (ICD) (Tesla 440 version)
i A nvidia-vulkan-icd - NVIDIA Vulkan installable client driver (ICD)
i A nvidia-vulkan-icd:i386 - NVIDIA Vulkan installable client driver (ICD)
p  primus-nvidia - NVIDIA Primus support using the proprietary NVIDIA driver
p  primus-nvidia:i386 - NVIDIA Primus support using the proprietary NVIDIA driver


Je sais pas si ça t'avances, ça liste pas grand chose (à part nvidia) et je vois pas bien où tu vas... tongue

Je ne pense pas que ma commande liste tout les métapaquets, apparemment, il n'y a pas moyen de les lister comme ça, faut regarder son contenu, voir si il est vide ou non... La méthode empirique à fait ses preuves

Dernière modification par David5647 (29-04-2020 18:21:30)

Hors ligne

#3 29-04-2020 21:00:11

naguam
Membre
Lieu : Quelque part
Distrib. : Plusieurs
Noyau : Ça dépend
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : La liste des paquets privateur de blob matériel

Je te déconseilles de faire un script qui installes tout pour plusieurs raisons.
Des conflits.
Exemples :
- Drivers nvidia de deux versions différentes (et certains gpus demandent le legacy et d'autres très récente ne peuvent fonctionner qu'avec le non legacy)
- Le driver broadcom dkms pour le wifi qui est en conflis avec les b43 et les brcm80211.
- Probablement d'autres.

Et aussi une histoire de choix pour les débutants.
Tout le monde ne veux pas bumblebee, sur un desktop non optimus (et sans les deux gpus intégrés (si dispo) et dédié)) je ne sais pas si ça peut poser problème, je ne pense pas, mais au cas ou.....
Aussi quelqu'un qui n'a pas de gpu amd peut ne pas vouloir encombrer son pc de tous les firmwares, vu que dans debian on a le choix de pas installer tous les firmwares d'un coup..... pourquoi le forcer. Avec les repo non free, le meta-paquet firmware-linux permet de quasiment tous les installer (pour les microcode et gpu, pas le wifi).

Le mieux serais de faire une full détection du hardware et d'installer les choses en conséquences malheureusement si c'était si simple, cela se saurait. (Personne ne s'est jamais demandé pourquoi on configure un kernel linux à la main et dans les distros on active un maximum de hardware au lieu qu'à la compilation on détecte le matériel dont le support est à activer. Après le kernel au runtime malgré le support de tout activé, si on utilise les modules, les modules inutiles ne sont pas forcement chargés).

Faute de ça je te conseillerais plutôt de faire un truc simplifié pour les personnes qui ne savent pas, un peu à l'interface "Firmwares et drivers disponibles" sous ubuntu (qui fais déjà une sorte de détection pour tout ce qui est support supplémentaire). Mais sans même une détection, un script qui juste dit, "voulez vous activer le support de telle carte, telle carte, voulez vous utiliser le microcode intel, amd, le driver nvidia, les firmware pour les gpus amd/ati.".

Après, chercher deux minutes le nom du firmware pour sa carte graphique...
Si au lieu de rusher sur un forum (même si notre serviabilité nous permet quand même de répondre) on cherchait deux minutes, "Comment faire fonctionner ma carte amd sous debian sur un moteur de recherche................ ?"
Ça marche aussi mais ce n'est qu'un avis, je peux comprendre que cela soit être utile d'améliorer l'UX.

Disons que les personnes qui prennent le temps de chercher un minimum n'ont pas besoin de ça je penses. (car entre la proposition d'un script ou une recherche sur un moteur de recherche pour avoir la réponse en 2min, ça se vaut à peut-prêt, surtout que en théorie on réinstalle pas tous les deux jours et si c'est le cas, ont fini par connaître par cœur ce dont on a besoin).

Mais bon un script (voire même un petit programme avec une UI pour être vraiment en full adéquation avec les débutants car sinon autant installer directement avec de la ligne de commande la commande d'installation du driver) qui au moins propose les drivers à installer... pourquoi pas.

PS : Oui ubuntu préinstalle nvidia depuis pas si longtemps, mais il y a beaucoup de détection et je suis pas sur que le legacy soit d'actualité chez eux big_smile.

Dernière modification par naguam (29-04-2020 21:16:36)

Hors ligne

#4 29-04-2020 21:14:18

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : La liste des paquets privateur de blob matériel

Faute de ça je te conseillerais plutôt de faire un truc simplifié pour les personnes qui ne savent pas, un peu à l'interface "Firmwares et drivers disponibles" sous ubuntu



Mhaip c'était l'idée. Mais je veux aussi proposer un "fallback".

Pour handylinux l'inclusions de certains firmware privateur par défaut a donné le sentiment à beaucoup que d'un coup "debian marchait pour eux", alors qu'il manquait juste un paquets. Donc je me disais que ça serait intéressant de proposer d'installer un "gros set de blobs privateur" pour ceux qui n'y arriveraient pas "tout court".


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#5 29-04-2020 21:56:12

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.2
Noyau : Linux 5.3.18
(G)UI : KDE 5.18.5
Inscription : 11-03-2016

Re : La liste des paquets privateur de blob matériel

Salut smile
Handylinux (puis DFlinux ?) intégrait les firmwares non-free mais pas les drivers Nvidia.
C’est aussi le cas d’autres distributions, par exemple openSUSE que je commence à bien appréhender, propose les firmwares nonfree pour la WiFi et autres mais par les pilotes Nvidia
Il y a nouveau.
S’il y a besoin, on peut installer les drivers Nvidia.
Sans compter qu’avec les portables ayant deux cartes graphiques Intel+Nvidia je me demande si les pilotes Nvidia ne seraient pas plus un problème qu’un gain ?

Hors ligne

#6 29-04-2020 22:01:29

naguam
Membre
Lieu : Quelque part
Distrib. : Plusieurs
Noyau : Ça dépend
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : La liste des paquets privateur de blob matériel

fedora aussi installes les firmwares par default.
En fait à part debian les firmwares sont installés par default dans la majorité des distros.
Et sur les distros main comme arch gentoo voires autres, c'est souvent le premier réflexe de les installer.
On aime le libre mais malheureusement dans la plupart des cas les firmwares et microcodes pour cpu, gpus et wifi sont nécessaires.
(oui un proco peut fonctionner sans le microcode mais alors - de mitigation des failles spectre meltdown principalement côté intel et il me semble que pour la gestion d'énergie, c'est pas terrible sans surtout en post-skylake).

@Chalu de mon point de vue c'est réellement plus un problème qu'un gain.
Mais si amd en dédié est supporté c'est aussi pas super.
Bref les gpus dédiés dédiés en laptop, c'est pas incroyable.
(je parle pas des apu amd dans la phrase ci-dessus)
La batterie se vide très vite souvent et le gain est souvent, en perf pas aussi important que un gpu sur une tour.

Dernière modification par naguam (29-04-2020 22:18:01)

Hors ligne

#7 29-04-2020 22:27:53

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.2
Noyau : Linux 5.3.18
(G)UI : KDE 5.18.5
Inscription : 11-03-2016

Re : La liste des paquets privateur de blob matériel

Oui je crois que à part pour des cartes Nvidia récentes, il y a un affichage et pas trop mal.
Ce qui est « pénible » pour le débutant, c’est la galère pour la WiFi ou faire fonctionner l’imprimante ou le scanner voire le Bluetooth
Et je ne parle pas de la reconnaissance du téléphone portable  et ce n’est pas toujours gagné tongue

Hors ligne

#8 30-04-2020 10:20:02

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.7.0-3-amd64
(G)UI : mutter 3.36.5-1
Inscription : 15-02-2016

Re : La liste des paquets privateur de blob matériel

naguam a écrit :

Je te déconseilles de faire un script qui installes tout pour plusieurs raisons.
Des conflits.
Exemples :
- Drivers nvidia de deux versions différentes (et certains gpus demandent le legacy et d'autres très récente ne peuvent fonctionner qu'avec le non legacy)
- Le driver broadcom dkms pour le wifi qui est en conflis avec les b43 et les brcm80211.
- Probablement d'autres.


naguam a écrit :

fedora aussi installes les firmwares par défaut.
En fait à part debian les firmwares sont installés par défaut dans la majorité des distros.



Donc, il est vraisemblable qu'un script dans les distros détecte le matériel et installe les pilotes qui vont bien, sans les conflits de pilotes. Il suffirait de le trouver, voir comment il est appelé, qui l'appelle, ce qu'il fait, où est-il placé dans l'arborescence pour ensuite reproduire son fonctionnement. Mais chut, je n'ai rien dit ...


La liberté est liée à la qualité du langage, et les bureaucrates qui veulent détruire la liberté ont tous tendance à mal écrire et à mal parler, à se servir d’expressions pompeuses ou confuses, à user de clichés qui occultent ou oblitèrent le sens. Georges Orwell

Hors ligne

#9 30-04-2020 10:28:37

naguam
Membre
Lieu : Quelque part
Distrib. : Plusieurs
Noyau : Ça dépend
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : La liste des paquets privateur de blob matériel

@--gilles--, et non pas vraiment de détection.
En effet juste les firmwares "blobs" la plupart du temps ne sont pas en conflits avec d'autres, et c'est firmware-linux qui est inclu par default dans les distributions (et ce qui est inclus dedans ne rentre pas en conflit entre eux)

Mais pour l'exemple de broadcom.... le pilote proprio wl est jamais préinstallé, même si on a la carte et même les distro qui utilisent un max de proprio ne l'installent pas. Pourtant pour une bonne partie des modèles de broadcom il est nécessaire car b43 ou autres ne les supportent pas forcement. (mais b43 et wl = conflit)
Etc etc.
En fait les trucs externes sont toujours des sources de conflits potentielles.
En fait à part les firmwares du lien que j'ai donné et qui regroupe globalement la plupart des firmwares.... quasiment aucune distro n'installe des trucs proprios en plus.

Mais si tout installer en vrac n'est pas une solution, proposer les choix pour les trucs qui risquent de potentiels conflits résoudrait le problème.
Ou faire une détection mais c'est un travail titanesque car faut plus ou moins répertorier un maximum de modèles (même si il y a des moyens de faire correspondre des drivers avec des addresses/tables/id (je sais plus comment ça s'appelle) pci et usb

Dernière modification par naguam (30-04-2020 10:41:59)

Hors ligne

#10 30-04-2020 11:08:34

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.7.0-3-amd64
(G)UI : mutter 3.36.5-1
Inscription : 15-02-2016

Re : La liste des paquets privateur de blob matériel

J'ai écrit une erreur, je n'aurais pas du en parler vu que tout mon matos fonctionne juste avec le dépôt main. Les failles des processeurs des anciens processeurs Intel sont déjà bien atténuées par le microcode libre maintenant par rapport au jour où elles ont été découvertes.

lscpu | grep Intel

Nom de modèle :                         Intel(R) Core(TM)2 Duo CPU     E8500  @ 3.16GHz





lscpu | grep Vulnera

Vulnerability Itlb multihit:            KVM: Mitigation: Split huge pages
Vulnerability L1tf:                     Mitigation; PTE Inversion; VMX EPT disabled
Vulnerability Mds:                      Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled
Vulnerability Meltdown:                 Mitigation; PTI
Vulnerability Spec store bypass:        Vulnerable
Vulnerability Spectre v1:               Mitigation; usercopy/swapgs barriers and __user pointer sanitization
Vulnerability Spectre v2:               Mitigation; Full generic retpoline, STIBP disabled, RSB filling
Vulnerability Tsx async abort:          Not affected
 



Faire une détection par un individu, même très travailleur et intelligent, alors que même des organisations comme les distributions n'utilisent pas de détection qui leur servirait à tout installer même les pilotes proprios, c'est un travail qui me paraît infaisable avec la diversité des matériels et l'actualisation toujours à renouveler avec les nouveaux matériels.

À moins que comme tu dis,

naguam a écrit :

quasiment aucune distro n'installe des trucs proprios en plus.

, les distributions qui installent des pilotes proprios fassent de la détection pour éviter les conflits, auquel cas Otyugh pourrait s'inspirer de leur méthode.


La liberté est liée à la qualité du langage, et les bureaucrates qui veulent détruire la liberté ont tous tendance à mal écrire et à mal parler, à se servir d’expressions pompeuses ou confuses, à user de clichés qui occultent ou oblitèrent le sens. Georges Orwell

Hors ligne

#11 30-04-2020 11:39:40

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : La liste des paquets privateur de blob matériel

Après c'est pas si dur que ça en a l'air, je trouve. Bien entendu associer chaque matos à un blob, c'est titanesque (quoique c'est très dommage, certains paquets debian contiennent la liste des firmware par identifiant pci standard, s'ils faisaient tous ça, ce serait trivial de faire un outil "parfait" de reconnaissance matériel).

Mais.

Rien qu'en oubliant le matériel et en ne regardant que leur modèle, on restreint la plupart des choix de driver très strictement à 3-4 options dans le pire des cas (cartes graphiques nvidia).

Les drivers réseau/wifi/bluetooth sont vraiment très simple à attribuer via la marque. Même pas besoin de verifier le modèle ; suffit de tester si le hardware est correctement initialisé, et si non, proposer le blob de la marque.

Ça me semble pas "insurmontable" via des hacks simples, quoi, en d'autre terme. Pas que ce soit absolu non plus, mais je trouve que ça vaut le coup d'essayer >.< (perso sur les 3-4 PC que j'ai sous la main mon "hack" d'une vingtaine de lignes a trouvé les bons firmwares, sans besoin de base de donnée ni rien, c'est... Pas trop mal.)

Dernière modification par otyugh (30-04-2020 11:49:20)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#12 30-04-2020 22:43:35

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : La liste des paquets privateur de blob matériel

Un peu anecdotique, mais truc rigolo.
Si tu listes les blobs de firmware, et que tu tries, tu as le nombre de blob par paquet.

Buster :

apt-file search /lib/firmware | cut -f1 -d':' | sort | uniq -c | sort -rn


525 firmware-amd-graphics
    377 firmware-misc-nonfree
     97 firmware-atheros
     81 intel-microcode
     69 firmware-realtek
     56 firmware-iwlwifi
     55 firmware-libertas
     33 firmware-netronome
     33 firmware-brcm80211
     22 atmel-firmware
     21 firmware-qcom-media
     20 firmware-qlogic
     18 firmware-ti-connectivity
     15 firmware-intel-sound
     15 firmware-bnx2x
     13 firmware-siano
     10 firmware-zd1211
      9 ixo-usb-jtag
      8 firmware-myricom
      7 firmware-ipw2x00
      7 firmware-bnx2
      6 bluez-firmware
      5 firmware-samsung
      5 firmware-ivtv
      5 firmware-cavium
      4 wireless-regdb
      4 amd64-microcode
      3 firmware-intelwimax
      2 hdmi2usb-fx2-firmware
      2 firmware-ath9k-htc-dbgsym
      2 firmware-ath9k-htc
      2 dahdi-firmware-nonfree
      1 firmware-netxen

Dernière modification par otyugh (30-04-2020 22:51:20)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#13 01-05-2020 09:09:52

Trefix
Membre
Lieu : 48
Distrib. : buster 10.4 + bpo
Noyau : linux 4.19.0-9-amd64
(G)UI : Xfce4 4.12.5
Inscription : 15-02-2015

Re : La liste des paquets privateur de blob matériel

Bonjour.

Je vais y regarder de plus près, tiens... Merci.

Hors ligne

Pied de page des forums