Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-05-2020 08:51:12

hussaile
Membre
Inscription : 16-12-2018

HP SmartTank Plus 559

Bjr,

KWiFiManager (sous Trinity Desktop TDE) repère le bidule.

Malheureusement hplib présent sur la distro Buster 10.3 ne m'aide pas à le connecter.

Après download sur la page https://developers.hp.com/hp-linux-imaging-and-printing ,
donc la dernière version, j'essaie d'installer le run.

En cours d'installation, il me dit qu'il ne vaut que pour debian 10.2 et finit pas se bloquer sur des dépendances manquantes.

Or, pratiquant la mise à jour régulière, je suis sous 10.3.

Quelqu'un a-t-il réussi à installer ce modèle sous 10.3 ?

Hors ligne

#2 02-05-2020 14:09:42

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : HP SmartTank Plus 559

salut d’après cette page
https://developers.hp.com/hp-linux-imag … ices/index
Toute les imprimantes avec Tank dans le nom requière au maximum la version 3.19.6

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#3 02-05-2020 15:07:44

hussaile
Membre
Inscription : 16-12-2018

Re : HP SmartTank Plus 559

C'est exact : la distro Buster en est à la version 3.18.

C'est pour cela que j'ai déchargé la version 3.20 sur https://developers.hp.com/hp-linux-imag … -printing/ .

C'est  lors de cette installation qu'apparaît qu'elle ne vaut encore que pour Buster 10.2 alors que je suis déjà en 10.3 .

D'ailleurs si on regarde sur la page developpers.hp.com, ils écrivent que c'est bien jusque 10.2 que la version est adaptée.

D'où : problème ! Ce, alors que j'ai acquis cette imprimante convaincu par la réputation de compatibilté de HP avec linux.

Là, je suis le bec dans l'eau.

Le second problème est que dans les références aux nouvelles inclusions dans la version 3.19, ils indiquent HP Smart Tank Plus 550 comme nouvellement incluse.

Je présuppose que cela vaut pour la 559 aussi, encore que .....

Hors ligne

#4 02-05-2020 18:50:42

èfpé
Membre
Inscription : 10-07-2016

Re : HP SmartTank Plus 559

message à supprimer

Dernière modification par èfpé (01-07-2020 12:40:42)

Hors ligne

#5 09-05-2020 03:48:00

kirkbarnes
Membre
Inscription : 09-05-2020

Re : HP SmartTank Plus 559

Bon ok, merci pour ta réponse.
happy wheels

Dernière modification par kirkbarnes (31-07-2020 09:59:44)

Hors ligne

#6 16-05-2020 12:24:02

hussaile
Membre
Inscription : 16-12-2018

Re : HP SmartTank Plus 559

La pûûûûgne !!!!!
Maintenant Buster 10.3 est supporté (théoriquement) mais avec mes apt-get update et apt-upgrade régulers, je me retrouve avec Buster 10.4 sans le savoir !
Et, .... le 10.4 n'est pas supporté !!!! La Joie !!!!
Je pourrais essayer de passer en Bullseye qui supporte hplip 3.20 mais alors, il faut renoncer à d'autres logiciels, ...

Hors ligne

#7 16-05-2020 12:58:27

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : HP SmartTank Plus 559

Et concrètement il se passe quoi, quel message d'erreur quand tu veux installer hplip3.20?
Edit :installer la dernière version ne va rien t'apporter de +,au dessus de 3.19.6 rien de nouveau en ce qui te concerne , seulement des ajouts d'imprimante
https://sourceforge.net/p/hplip/news/

Dernière modification par Croutons (16-05-2020 13:03:19)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#8 17-05-2020 15:59:07

hussaile
Membre
Inscription : 16-12-2018

Re : HP SmartTank Plus 559

J'ai effectivement, suite au message de Croutons, essayé avec la version 3.19.6 et y suis parvenu mais seulement au travers du parcours du combattant :
le faire en user et ne passer à root qu'à la demande de l'installer, refuser les options d'installation par défaut (aucun "enter", du moins sur les options générales de départ) et ne pas accepter l'installation en PyQt4 ni PyQt4-dbus : seulement en Qt5.
À noter que l'installer, pour y parvenir, reprend des dépendances de Debian 9.8 !!!!

Enfin, nous y voilà +-, merci pour la contrib.

Reste : à chaque changement de user, il faut unplug/replug le câble USB pour imprimer ou scanner, ....

Les versions ultérieures se bloquent car elles ne contiennent pas l'option de ne pas choisir Qt4 : l'installer ne trouve pas les PyQt4 et PyQt4-dbus correspondant et finit avec un brillant "exit", .....

Hors ligne

#9 19-05-2020 21:25:20

hussaile
Membre
Inscription : 16-12-2018

Re : HP SmartTank Plus 559

Plus de problème !!!

Plus besoin de unplug/replug : il suffisait de redémarrer le PC.

Affaire résolue, donc !

Merci Croutons !!!

Hors ligne

#10 20-05-2020 08:59:54

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : HP SmartTank Plus 559

Edite ton premier message pour mettre dans le titre que c'est résolu

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

Pied de page des forums