Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-05-2020 22:31:37

remy.labene
Membre
Inscription : 05-02-2017

Debian BUSTER (10) sur MSI GP72 et autres

J'essaye depuis quelques temps d'installer correctement une Debian sur un portable MSI GP72-6QE. Cette machine à la particularité, comme d'autres, d'avoir deux cartes graphiques, Intel 530 et Nvidia GT950. Comme beaucoup de portable, l'ACPI n'est pas très bien géré par Linux et est assez difficile à comprendre et à paramétrer. Je vais donc essayer d'expliquer rapidement les paramétrages que j'ai fini par trouver en tâtonnant. Ceci doit s'appliquer à d'autres machines du même style.

La première chose est de vérifier que le BIOS boute en mode "UEFI avec CSM". J'ai longtemps hésité à utiliser cela car ça me paraissait compliqué et inutile. J'ai toujours configuré mes machines en mode héritage (Legacy). J'observais alors un certain nombre d'avertissement au moment du boot concernant le bus PCI. En mode UEFI ces avertissements ont disparu, les adressages sont mieux reconnus. Pour ceux qui veulent aller plus loin vous avez tout sur UEFI ici https://uefi.org/ c'est du lourd !

On boute ensuite sur le CD Debian 10 en mode UEFI. Je passe sur les différents paramétrages largement détaillés ailleurs. Simplement, il faut penser à créer une table de partition sur le disque en GPT (et pas en MSDOS) avec une première partition de 1Go pour l'EFI au début du disque. Après, vous partitionnez comme ça vous va, personnellement, je crée une partition de 2 Go en ext2 pour le /boot, 60 Go pour la racine / en ext4, 8 Go pour le swap, et le reste pour le /home en ext4. Pensez aussi à bien choisir les dépôts rétroportés (backport) dans votre installation.

Une fois votre installation terminée, vous n’êtes pas arrivé au bout de vos peines. En effet il y a deux problèmes à résoudre: l'un concernant la gestion d’énergie (ACPI) et l'autre la gestion de la carte Nvidia GT950 pour l'utilisation de la 3D.

Le premier problème se résout assez simplement en installant le noyau Linux 5.5 ou supérieur. Ce noyau à fait l'objet d'une correction de bug sur la gestion d’énergie sur pas mal de machines (voir ici https://bugzilla.kernel.org/show_bug.cgi?id=156341 ). Si le noyau Linux 5.5 n’apparaît pas, c'est que vous avez oublié le "backport" dans vos dépots. On peut le rajouter dans /etc/apt/sources.list, par exemple :

# buster-backports
deb http://deb.debian.org/debian buster-backports main contrib non-free


puis faire en ligne de commande :

apt-get update
apt-get install -t buster-backports linux-image-5.5 linux-headers-5.5



Une fois le noyau 5.5 ou supérieur installé, il faut rebouter la machine et vérifier s'il n'y a pas d'erreurs dans les logs du noyau (/var/log/kern.log). Si tout va bien on passe à l'installation du driver nvidia propriétaire.

On commence par désinstaller le driver "nouveau" avec la commande :

apt-get remove xserver-xorg-video-nouveau



et on reboute pour plus de sécurité.

On installe ensuite le driver propriétaire nvidia, mais pas n'importe lequel, celui du backport adapté et compilé avec votre noyau Linux 5.5.

apt-get install -t buster-backports nvidia-driver



Si tout c'est bien passé (regardez bien les messages d'erreur éventuel), on reboute encore (on se croirait sous Windows !).
On va alors installer le programme qui gère les deux cartes graphiques : Intel 530 en mode normal et Nvidia GT950 pour le 3D.

apt-get install -t buster-backports bumblebee-nvidia primus



après avoir rajouté à l'utilisateur lambda les droits pour utiliser bumblebee :

adduser $USER bumblebee



vous devriez pouvoir lancer un programme 3D en utilisant votre carte 3D Nvidia avec la commande "optirun", par exemple :

optirun glxgears



Bon courage, pour d'autres infos plus détaillés voir ici : https://wiki.debian.org/fr/NvidiaGraphi … ckports.29

Hors ligne

#2 18-05-2020 04:14:09

vigen
Adhérent(e)
Lieu : Normandie
Distrib. : Debian Buster
Noyau : Linux 4.19
(G)UI : Mate
Inscription : 10-10-2015

Re : Debian BUSTER (10) sur MSI GP72 et autres

Merci pour cette méthodologie détaillée. wink

Hors ligne

#3 18-05-2020 07:34:10

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-9-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Debian BUSTER (10) sur MSI GP72 et autres

Hello

après avoir rajouté à l'utilisateur lambda les droits pour utiliser bumblebee :

adduser $USER bumblebee


la variable $USER c'est root si le terminal est passé en root donc plus l'user lambda


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#4 18-05-2020 08:01:14

raleur
Membre
Inscription : 03-10-2014

Re : Debian BUSTER (10) sur MSI GP72 et autres

remy.labene a écrit :

première partition de 1Go pour l'EFI


C'est du gaspillage. Le contenu de la partition EFI de Debian occupe moins de 50 Mo.

remy.labene a écrit :

je crée une partition de 2 Go en ext2 pour le /boot


À moins de prévoir d'installer 30 noyaux en même temps, c'est aussi du gaspillage. D'autre part une partition /boot séparée ne se justifie pas dans la plupart des cas.


Il vaut mieux montrer que raconter.

Hors ligne

#5 18-05-2020 08:26:29

remy.labene
Membre
Inscription : 05-02-2017

Re : Debian BUSTER (10) sur MSI GP72 et autres

Bien d'accord avec vos remarques, j'ai utilisé $USER, mais j'aurai du mettre "lambda" pour être plus clair. En se qui concerne les partitions, je laisse volontairement assez de place pour des bricolages futurs. Les disques actuels sont rarement en manque de place. La partition EFI fait en général 100 Mo, mais sur un disque de 1To, 900 Mo c'est pas grand chose.

Hors ligne

#6 18-05-2020 08:57:26

raleur
Membre
Inscription : 03-10-2014

Re : Debian BUSTER (10) sur MSI GP72 et autres

Effectivement. Sur un SSD de 120 Go, ce serait différent.

Il vaut mieux montrer que raconter.

Hors ligne

Pied de page des forums