Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 27-05-2020 17:06:06

Séverine
Membre
Distrib. : Debian Buster stable
Noyau : Linux 4.19.0-9-amd64
(G)UI : Gnome
Inscription : 27-05-2020

Problème lancement Gnome depuis modification du clavier (Bépo)

Bonjour,

Je viens d'installer debian buster avec Gnome sur mon nouveau portable. Tout fonctionnait bien jusqu'à ce que je modifie les fichiers /usr/share/X11/xkb/symbols/fr et /usr/share/X11/xkb/rules/evdev.xml (ainsi base.xml dans le même répertoire). Depuis, je ne peux plus me loguer via l'interface graphique et je ne peux plus y accéder. Ça c'est passé en 2 temps. D'abord, au moment de me loguer l'interface me propose de choisir de me loguer sur X11, Gnome, Gnome classique ou Gnome sur X.org. Sur X11, Gnome classique ou Gnome sur X.org, ça marchait, mais pas sur Gnome. Suite à ça, j'ai remodifié les fichiers de config du clavier mentionnés ci-dessus. Mais depuis, impossible de me loguer ou d'avoir à l'interface graphique, enfin, je vois la flèche de la souris mais tout est noir et je ne peux rien faire à part basculer en console. Une fois dans la console, impossible de rebasculer sur l'interface graphique (Alt+F7 ne fait rien du tout). Dans la console la commande systemctl status gdm3 me renvoie entre autre que gdm3 est actif (running). Et la commande cat /etc/X11/default-display-manager renvoie : /usr/sbin/gdm3.
Je suis perdue !!

Séverine.

Hors ligne

#2 27-05-2020 17:39:12

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.8.0-2-amd64
(G)UI : mutter 3.36.6-1
Inscription : 15-02-2016

Re : Problème lancement Gnome depuis modification du clavier (Bépo)

Bonjour Séverine. D'après la méthode de Raphaël Hertzog ici : https://raphaelhertzog.fr/2011/09/30/ga … s-alteres/


En console, tu devras réinstaller le paquet xkb-data :

apt reinstall xkb-data


La liberté est liée à la qualité du langage, et les bureaucrates qui veulent détruire la liberté ont tous tendance à mal écrire et à mal parler, à se servir d’expressions pompeuses ou confuses, à user de clichés qui occultent ou oblitèrent le sens. Georges Orwell

Hors ligne

#3 27-05-2020 21:20:04

Séverine
Membre
Distrib. : Debian Buster stable
Noyau : Linux 4.19.0-9-amd64
(G)UI : Gnome
Inscription : 27-05-2020

Re : Problème lancement Gnome depuis modification du clavier (Bépo)

Bonsoir,

J'ai essayé, mais apparement je n'ai plus de connexion...
Je retenterai dès que j'en aurai une

Merci pour votre aide

Hors ligne

#4 27-05-2020 21:38:49

Séverine
Membre
Distrib. : Debian Buster stable
Noyau : Linux 4.19.0-9-amd64
(G)UI : Gnome
Inscription : 27-05-2020

Re : Problème lancement Gnome depuis modification du clavier (Bépo)

La commande "sudo /etc/init.d/networking restart" a arrêté l'ethernet (retour "ip a" = ethernet DOWN et retour ping = connect: Le réseau n'est pas accessible), alors qu'avant "ip a" = UP et ping = Destination Host Unreachable 4 paquets transmis, 0 reçu

je crois que je devrais arrêter de toucher à ma machine, c'est de pire en pire :-D

Hors ligne

#5 27-05-2020 22:02:32

Séverine
Membre
Distrib. : Debian Buster stable
Noyau : Linux 4.19.0-9-amd64
(G)UI : Gnome
Inscription : 27-05-2020

Re : Problème lancement Gnome depuis modification du clavier (Bépo)

Hallelujah !!
Merci merci merci !
J'ai pu reinstaller xkb-data et ça marche, j'ai accès à l'interface graphique !!
Je ne comprends pas le rapport entre la disposition du clavier et l'interface graphique, mais bon... Enfin, ça doit rejoindre un autre problème que j'ai avec mon layout bépo : la commande setxkbmap et l'interface graphique de changement de layout se télescopent...

Merci encore !
séverine

Hors ligne

Pied de page des forums