Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-06-2020 19:36:59

vi2
Membre
Inscription : 05-06-2020

Probleme de mise à jour pont python-uno

Bonjour je suis tout nouveau sur Debian !
Je viens d'installer sur un vieux portable VAIO.
Des mises à jour me sont proposées, lorsque je lance le processus en graphique ou en ligne de commande
j'obtiens une erreur.
Voici celle de la ligne de commande :

Atteint :1 http://security.debian.org/debian-security buster/updates InRelease
Atteint :2 https://deb.debian.org/debian buster InRelease
Atteint :3 https://deb.debian.org/debian buster-updates InRelease
Traceback (most recent call last):  
  File "/usr/lib/cnf-update-db", line 9, in <module>
    from CommandNotFound import CommandNotFound
  File "/usr/share/command-not-found/CommandNotFound/CommandNotFound.py", line 25, in <module>
    _ = getattr(gettext.translation("command-not-found", fallback=True), _gettext_method)
  File "/usr/lib/python3.7/gettext.py", line 548, in translation
  File "/usr/lib/python3.7/gettext.py", line 260, in __init__
   
  File "/usr/lib/python3.7/gettext.py", line 344, in _parse
    <doc xml:space="preserve">the size of the buffer.</doc>
  File "/usr/lib/python3.7/struct.py", line 1
    coding</doc>
           ^
SyntaxError: invalid syntax
Lecture des listes de paquets... Fait
E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/lib/command-not-found/ -a -e /usr/lib/cnf-update-db; then /usr/lib/cnf-update-db > /dev/null; fi'
E: Sub-process returned an error code



Merci pour votre aide.

Hors ligne

#2 12-06-2020 07:09:56

vi2
Membre
Inscription : 05-06-2020

Re : Probleme de mise à jour pont python-uno

Bonjour, quelqu'un pourrait-il m'aider ? SVP

Hors ligne

#3 12-06-2020 09:11:30

David5647
Membre
Distrib. : Debian Bullseye/Sid
Noyau : 5.7.0-2-amd64
(G)UI : KDE/i3wm
Inscription : 27-08-2017

Re : Probleme de mise à jour pont python-uno

J'avais vu ton sujet, mais ça me parlais pas spécialement,
après une brève recherche, il se peut que qu'il y ai un problème de lien symbolique entre la commande python et la version attendue par le système.

As tu modifié ton installation python récemment?

On peut commencer par là, que renvoie :

python3 --version

Hors ligne

#4 13-06-2020 12:48:22

vi2
Membre
Inscription : 05-06-2020

Re : Probleme de mise à jour pont python-uno

Bonjour et merci pour ton aide !
Non je n'ai rien modifié, le problème existe depuis l'installation fin mai.
Voici le résultat de ma commande :

b@b-pc:~$ python3 --version
Python 3.7.3

Hors ligne

#5 17-06-2020 07:59:49

David5647
Membre
Distrib. : Debian Bullseye/Sid
Noyau : 5.7.0-2-amd64
(G)UI : KDE/i3wm
Inscription : 27-08-2017

Re : Probleme de mise à jour pont python-uno

Bon, je ne trouve pas, il y a déjà pas mal de rapport de bogue

que renvoie ?

head -n1 /usr/share/command-not-found/CommandNotFound/CommandNotFound.py


Pour voir quelle version de python est exécutée par le module

Je me demande si le plus simple ne serait pas de virer command-not-found qui n'est pas un paquet nécessaire aux màj, mais qui peut potentiellement retirer l'interface graphique de màj.

apt remove command-not-found


(bien regarder les paquets à enlever)

Dernière modification par David5647 (17-06-2020 08:00:09)

Hors ligne

#6 19-06-2020 23:25:58

vi2
Membre
Inscription : 05-06-2020

Re : Probleme de mise à jour pont python-uno

Bonsoir David5647

Voici le résultat de la première commande :

b@b-pc:~$ head -n1 /usr/share/command-not-found/CommandNotFound/CommandNotFound.py
# (c) Zygmunt Krynicki 2005, 2006, 2007, 2008



Et donc le résultat de la seconde, mais ça coince...

apt remove command-not-found
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  apt-file libregexp-assemble-perl
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  python3-uno
Les paquets suivants seront ENLEVÉS :
  command-not-found
Les paquets suivants seront mis à jour :
  python3-uno
1 mis à jour, 0 nouvellement installés, 1 à enlever et 15 non mis à jour.
3 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/201 ko dans les archives.
Après cette opération, 105 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] O
(Lecture de la base de données... 234065 fichiers et répertoires déjà installés.)
Suppression de command-not-found (18.04.5-1) ...
Traceback (most recent call last):
  File "/usr/bin/py3clean", line 25, in <module>
    import optparse
  File "/usr/lib/python3.7/optparse.py", line 1
    meout sources, the prepare and check functions both return %TRUE
                ^
SyntaxError: invalid syntax
dpkg: erreur de traitement du paquet command-not-found (--remove) :
 installed command-not-found package pre-removal script subprocess returned error exit status 1
Traceback (most recent call last):
  File "/usr/bin/py3compile", line 26, in <module>
    import optparse
  File "/usr/lib/python3.7/optparse.py", line 1
    meout sources, the prepare and check functions both return %TRUE
                ^
SyntaxError: invalid syntax
dpkg: error while cleaning up:
 installed command-not-found package post-installation script subprocess returned error exit status 1
Des erreurs ont été rencontrées pendant l'exécution :
 command-not-found
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hors ligne

#7 20-06-2020 06:43:41

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.2
Noyau : Linux 5.3.18
(G)UI : KDE 5.18.5
Inscription : 11-03-2016

Re : Probleme de mise à jour pont python-uno

Bonjour,
On peut commencer par vérifier les dépôts. Donne nous les retours complets des commandes :

cat /etc/apt/sources.list


cat /etc/apt/sources.list.d/*


Puis les retours de

apt update


apt list --upgradable

Hors ligne

#8 21-06-2020 11:43:29

vi2
Membre
Inscription : 05-06-2020

Re : Probleme de mise à jour pont python-uno

Bonjour chalu et merci pour l'aide !

1ère commande :

b@b-pc:~$ cat /etc/apt/sources.list
## debian 10 buster main
deb https://deb.debian.org/debian/ buster main contrib non-free

## buster security
deb http://security.debian.org/debian-security buster/updates main contrib non-free
#deb https://deb.debian.org/debian-security buster/updates main contrib non-free


## buster updates
deb https://deb.debian.org/debian/ buster-updates main contrib non-free



2ème :

b@b-pc:~$ cat /etc/apt/sources.list.d/*
cat: '/etc/apt/sources.list.d/*': Aucun fichier ou dossier de ce type



3ème :

b@b-pc:~$ sudo apt update
[sudo] Mot de passe de b : 
Atteint :1 http://security.debian.org/debian-security buster/updates InRelease
Atteint :2 https://deb.debian.org/debian buster InRelease
Atteint :3 https://deb.debian.org/debian buster-updates InRelease
Traceback (most recent call last):  
  File "/usr/lib/cnf-update-db", line 9, in <module>
    from CommandNotFound import CommandNotFound
  File "/usr/share/command-not-found/CommandNotFound/CommandNotFound.py", line 25, in <module>
    _ = getattr(gettext.translation("command-not-found", fallback=True), _gettext_method)
  File "/usr/lib/python3.7/gettext.py", line 548, in translation
  File "/usr/lib/python3.7/gettext.py", line 260, in __init__
   
  File "/usr/lib/python3.7/gettext.py", line 344, in _parse
    <doc xml:space="preserve">the size of the buffer.</doc>
  File "/usr/lib/python3.7/struct.py", line 1
    coding</doc>
           ^
SyntaxError: invalid syntax
Lecture des listes de paquets... Fait
E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/lib/command-not-found/ -a -e /usr/lib/cnf-update-db; then /usr/lib/cnf-update-db > /dev/null; fi'
E: Sub-process returned an error code



4ème :

b@b-pc:~$ sudo apt list --upgradable
En train de lister... Fait
libvlc-bin/stable 3.0.11-0+deb10u1 i386 [pouvant être mis à jour depuis : 3.0.10-0+deb10u1]
libvlc5/stable 3.0.11-0+deb10u1 i386 [pouvant être mis à jour depuis : 3.0.10-0+deb10u1]
libvlccore9/stable 3.0.11-0+deb10u1 i386 [pouvant être mis à jour depuis : 3.0.10-0+deb10u1]
python3-uno/stable 1:6.1.5-3+deb10u6 i386 [pouvant être mis à jour depuis : 1:6.1.5-3+deb10u5]
vlc-bin/stable 3.0.11-0+deb10u1 i386 [pouvant être mis à jour depuis : 3.0.10-0+deb10u1]
vlc-data/stable 3.0.11-0+deb10u1 all [pouvant être mis à jour depuis : 3.0.10-0+deb10u1]
vlc-l10n/stable 3.0.11-0+deb10u1 all [pouvant être mis à jour depuis : 3.0.10-0+deb10u1]
vlc-plugin-base/stable 3.0.11-0+deb10u1 i386 [pouvant être mis à jour depuis : 3.0.10-0+deb10u1]
vlc-plugin-notify/stable 3.0.11-0+deb10u1 i386 [pouvant être mis à jour depuis : 3.0.10-0+deb10u1]
vlc-plugin-qt/stable 3.0.11-0+deb10u1 i386 [pouvant être mis à jour depuis : 3.0.10-0+deb10u1]
vlc-plugin-samba/stable 3.0.11-0+deb10u1 i386 [pouvant être mis à jour depuis : 3.0.10-0+deb10u1]
vlc-plugin-skins2/stable 3.0.11-0+deb10u1 i386 [pouvant être mis à jour depuis : 3.0.10-0+deb10u1]
vlc-plugin-video-output/stable 3.0.11-0+deb10u1 i386 [pouvant être mis à jour depuis : 3.0.10-0+deb10u1]
vlc-plugin-video-splitter/stable 3.0.11-0+deb10u1 i386 [pouvant être mis à jour depuis : 3.0.10-0+deb10u1]
vlc-plugin-visualization/stable 3.0.11-0+deb10u1 i386 [pouvant être mis à jour depuis : 3.0.10-0+deb10u1]
vlc/stable 3.0.11-0+deb10u1 i386 [pouvant être mis à jour depuis : 3.0.10-0+deb10u1]

Hors ligne

#9 21-06-2020 13:03:22

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.2
Noyau : Linux 5.3.18
(G)UI : KDE 5.18.5
Inscription : 11-03-2016

Re : Probleme de mise à jour pont python-uno

On peut essayer de remettre en ordre avec

sudo dpkg --configure -a

puis

sudo apt --fix-broken instal

Hors ligne

#10 21-06-2020 17:12:39

vi2
Membre
Inscription : 05-06-2020

Re : Probleme de mise à jour pont python-uno

Voici les résultats crash.gif
1 :

b@b-pc:~$ sudo dpkg --configure -a
[sudo] Mot de passe de b : 
Paramétrage de vlc-l10n (3.0.11-0+deb10u1) ...
Paramétrage de command-not-found (18.04.5-1) ...
Traceback (most recent call last):
  File "/usr/bin/py3compile", line 26, in <module>
    import optparse
  File "/usr/lib/python3.7/optparse.py", line 1
    meout sources, the prepare and check functions both return %TRUE
                ^
SyntaxError: invalid syntax
dpkg: erreur de traitement du paquet command-not-found (--configure) :
 installed command-not-found package post-installation script subprocess returned error exit status 1
Paramétrage de libvlccore9:i386 (3.0.11-0+deb10u1) ...
Paramétrage de vlc-plugin-qt:i386 (3.0.11-0+deb10u1) ...
Paramétrage de python3-minimal (3.7.3-1) ...
Traceback (most recent call last):
  File "/usr/bin/py3compile", line 26, in <module>
    import optparse
  File "/usr/lib/python3.7/optparse.py", line 1
    meout sources, the prepare and check functions both return %TRUE
                ^
SyntaxError: invalid syntax
dpkg: erreur de traitement du paquet python3-minimal (--configure) :
 installed python3-minimal package post-installation script subprocess returned error exit status 1
dpkg: des problèmes de dépendances empêchent la configuration de python3-uno :
 python3-uno dépend de libreoffice-core (= 1:6.1.5-3+deb10u5) ; cependant :
  La version de libreoffice-core sur le système est 1:6.1.5-3+deb10u6.

dpkg: erreur de traitement du paquet python3-uno (--configure) :
 problèmes de dépendances - laissé non configuré
Paramétrage de vlc-data (3.0.11-0+deb10u1) ...
Paramétrage de vlc-plugin-notify:i386 (3.0.11-0+deb10u1) ...
Paramétrage de vlc-plugin-video-output:i386 (3.0.11-0+deb10u1) ...
Paramétrage de vlc-plugin-samba:i386 (3.0.11-0+deb10u1) ...
Paramétrage de vlc-plugin-skins2:i386 (3.0.11-0+deb10u1) ...
Paramétrage de vlc-plugin-video-splitter:i386 (3.0.11-0+deb10u1) ...
Paramétrage de libvlc5:i386 (3.0.11-0+deb10u1) ...
Paramétrage de vlc-plugin-visualization:i386 (3.0.11-0+deb10u1) ...
Paramétrage de libvlc-bin:i386 (3.0.11-0+deb10u1) ...
Paramétrage de vlc-plugin-base:i386 (3.0.11-0+deb10u1) ...
Paramétrage de vlc-bin (3.0.11-0+deb10u1) ...
Paramétrage de vlc (3.0.11-0+deb10u1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.62) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.17-2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.28-10) ...
Traitement des actions différées (« triggers ») pour man-db (2.8.5-2) ...
Traitement des actions différées (« triggers ») pour libreoffice-common (1:6.1.5-3+deb10u6) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-4) ...
Traitement des actions différées (« triggers ») pour libvlc-bin:i386 (3.0.11-0+deb10u1) ...
Des erreurs ont été rencontrées pendant l'exécution :
 command-not-found
 python3-minimal
 python3-uno


2 :

b@b-pc:~$ sudo apt --fix-broken install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
  python3-uno
Les paquets suivants seront mis à jour :
  python3-uno
1 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
3 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/201 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
(Lecture de la base de données... 234066 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python3-uno_1%3a6.1.5-3+deb10u6_i386.deb ...
Traceback (most recent call last):
  File "/usr/bin/py3clean", line 25, in <module>
    import optparse
  File "/usr/lib/python3.7/optparse.py", line 1
    meout sources, the prepare and check functions both return %TRUE
                ^
SyntaxError: invalid syntax
dpkg: avertissement: old python3-uno package pre-removal script subprocess returned error exit status 1
dpkg: tentative d'exécution du script du nouveau paquet à la place...
Traceback (most recent call last):
  File "/usr/bin/py3clean", line 25, in <module>
    import optparse
  File "/usr/lib/python3.7/optparse.py", line 1
    meout sources, the prepare and check functions both return %TRUE
                ^
SyntaxError: invalid syntax
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/python3-uno_1%3a6.1.5-3+deb10u6_i386.deb (--unpack) :
 new python3-uno package pre-removal script subprocess returned error exit status 1
Traceback (most recent call last):
  File "/usr/bin/py3compile", line 26, in <module>
    import optparse
  File "/usr/lib/python3.7/optparse.py", line 1
    meout sources, the prepare and check functions both return %TRUE
                ^
SyntaxError: invalid syntax
dpkg: error while cleaning up:
 installed python3-uno package post-installation script subprocess returned error exit status 1
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/python3-uno_1%3a6.1.5-3+deb10u6_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hors ligne

#11 21-06-2020 19:36:42

vi2
Membre
Inscription : 05-06-2020

Re : Probleme de mise à jour pont python-uno

Bonsoir et Merci David5647 et chalu pour le temps que vous m'avez consacré !
J'ai décidé de changer de distribution par manque de temps.
Donc Problème non résolu.
Par contre je ne sais pas si je dois indiquer quelque part la fin de ce forum....

Hors ligne

#12 21-06-2020 20:29:42

David5647
Membre
Distrib. : Debian Bullseye/Sid
Noyau : 5.7.0-2-amd64
(G)UI : KDE/i3wm
Inscription : 27-08-2017

Re : Probleme de mise à jour pont python-uno

Bon, bah, on en reste là, non tu n'as pas à spécifier que le sujet n'est pas résolu, l’absence de la mention "résolu" me semble suffisante.

Ok, dommage pour le changement de distrib, je ne pense pas que ton problème soit survenu suite à l'install de base, visiblement, il y a un problème avec python, je reste sur mon idée de base d'un problème de lien/version python. Il s'est passé un truc... Et je me sentais pas de te proposer des manip fastidieuses, sans vraiment comprendre le problème, ni être sûr que cela apporte une résolution.

Si tu optes pour une distrib fille de debian (ou retente ta chance avec debian), tu peux continuer à traîner par ici, le forum sera adapté. A ta convenance!

Hors ligne

Pied de page des forums