Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-06-2020 19:57:05

Minvinea
Membre
Inscription : 10-06-2020

Problème d’installation de Java 7

Bonjour,

Je vous explique mon problème. J’ai actuellement une machine sous Debian 9 (Strech), sur laquelle j’aimerais y installé Java 7.

Le problème est que ce que je vois a chaque vois c’est un « sudo apt-get install openjdk-7-jdk ». Mais le problème est que ça me dit « E: Le paquet « openjdk-7-jdk » n’a pas de version susceptible d’être installée ».
J’ai un peu chercher, j’ai trouver des java 7 a télécharger, mais rien ne fonctionne.

Si quelqu’un pouvais m’aider, merci d’avance.

Dernière modification par Minvinea (11-06-2020 00:06:52)

Hors ligne

#2 10-06-2020 21:44:58

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : Problème d’installation de Java 7

Regarde d'abord les paquets openjdk que tu peux installer :

apt list openjdk\*

Dernière modification par Beta-Pictoris (10-06-2020 21:45:34)

Hors ligne

#3 10-06-2020 21:45:57

naguam
Membre
Lieu : Quelque part
Distrib. : Plusieurs
Noyau : Ça dépend
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : Problème d’installation de Java 7

Bonjour,
Debian Buster est la version 10 et non la version 9 de debian.
Java 7 est une version de java très ancienne.
En effet sous buster openjdk est présent mais pas en version 7, en 8 ou en 11 (11 par default sous buster).
La dernière version de debian ayant java-7 dans les dépôts est debian jessie mais elle commence vraiment à dater.
Pourquoi as-tu besoin de cette version en particulier ?

Hors ligne

#4 11-06-2020 00:06:26

Minvinea
Membre
Inscription : 10-06-2020

Re : Problème d’installation de Java 7

Beta-Pictoris a écrit :

Regarde d'abord les paquets openjdk que tu peux installer :

apt list openjdk\*



Salut, je viens de regarder. Il y a du jdk 8 seulement: http://prntscr.com/sxj33v

Hors ligne

#5 11-06-2020 00:09:55

Minvinea
Membre
Inscription : 10-06-2020

Re : Problème d’installation de Java 7

naguam a écrit :

Bonjour,
Debian Buster est la version 10 et non la version 9 de debian.
Java 7 est une version de java très ancienne.
En effet sous buster openjdk est présent mais pas en version 7, en 8 ou en 11 (11 par default sous buster).
La dernière version de debian ayant java-7 dans les dépôts est debian jessie mais elle commence vraiment à dater.
Pourquoi as-tu besoin de cette version en particulier ?



Bonjour,
Autant pour moi pour l'erreur du debian, c'est modif.
Je sais que java 7 commence a daté. J'ai besoin de cette version en particulier pour
lancer une vielle version d'un serveur minecraft, et ça ne fonctionne que sous Java 7.

Donc si t'a moyen de m'aider je suis là.

Hors ligne

#6 11-06-2020 23:14:20

naguam
Membre
Lieu : Quelque part
Distrib. : Plusieurs
Noyau : Ça dépend
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : Problème d’installation de Java 7

Tu peux peut-être faire du pinning avec debian sid car openjdk-7-jre est toujours dans les dépôts sid.
Normalement tu n'a besoin que du runtime (jre) mais au cas ou tu peux aussi installer le jdk.

Dernière modification par naguam (11-06-2020 23:15:05)

Hors ligne

#7 12-06-2020 08:23:52

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Problème d’installation de Java 7

Hello
quel est le message d'erreur?
car de manière générale qui peu le + peu le moins smile
Si besoin on peu spécifier la version a utiliser

man java a écrit :

-version:release
           Specifies the release version to be used for running the application. If the version of the java command called does not meet this specification and an appropriate
           implementation is found on the system, then the appropriate implementation will be used.

           The release argument specifies either the exact version string, or a list of version strings and ranges separated by spaces. A version string is the developer designation of
           the version number in the following form: 1.x.0_u (where x is the major version number, and u is the update version number). A version range is made up of a version string
           followed by a plus sign (+) to designate this version or later, or a part of a version string followed by an asterisk (*) to designate any version string with a matching
           prefix. Version strings and ranges can be combined using a space for a logical OR combination, or an ampersand (&) for a logical AND combination of two version
           strings/ranges. For example, if running the class or JAR file requires either JRE 6u13 (1.6.0_13), or any JRE 6 starting from 6u10 (1.6.0_10), specify the following:

               -version:"1.6.0_13 1.6* & 1.6.0_10+"


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#8 12-06-2020 12:19:26

naguam
Membre
Lieu : Quelque part
Distrib. : Plusieurs
Noyau : Ça dépend
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : Problème d’installation de Java 7

Java 8 n'est pas 100% rétrocompatible avec java 7 @Croutons et pour une vieille version de minecraft pas update pour les nouvelles versions de java....
La commande java permet de spécifier la version mais il faut que la version soit installée.

Dernière modification par naguam (12-06-2020 12:22:39)

Hors ligne

#9 12-06-2020 15:45:26

Minvinea
Membre
Inscription : 10-06-2020

Re : Problème d’installation de Java 7

Bonjour,
Merci a vous j'ai continuer a chercher et du coup j'ai réussi.

J'ai télécharger une archive sur le site de oracle et je l'ai décompresser et je l'ai mit en route.

Hors ligne

Pied de page des forums