Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-06-2020 18:44:47

chrispierret
Membre
Distrib. : Debian 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : MATE Desktop Environment 1.20.4
Inscription : 04-02-2017

[résolu] paquet rake non installable ?

Bonjour,
Je souhaite utiliser LyX, pour la création de documents LaTeX. Je lance Synaptic, et au terme du travail, plusieurs paquets n'ont pu être configurés (libruby2.5:amd64, ruby2.5, ruby) parce qu'ils dépendent d'un autre qui n'a pu l'être non plus : rake.
Et si je demande spécifiquement l'installation de ce paquet rake, Synaptic répond : "

W: Échec de la récupération de http://deb.debian.org/debian/pool/main/ … -3_all.deb    404  Not Found [IP : 2a04:4e42:1d::204 80]

".
Ce paquet est pourtant bien trouvable, dans les packages Debian, mais donc, apparemment, pas utilisable ?
Je précise que je ne suis pas un utilisateur expert, je ne sais qu'appliquer les consignes, et lorsque ça ne fonctionne pas...
Que pourrais-je faire ?

Edit à  toto : Pour que la lecture du code sur le forum soit lisible par tous, il faut disposer le code en utilisant le bouton Autre code du forum
Oh, quel beau BB …code où comment mettre en forme vos messages dans le fofo . Modif fête. smile

Dernière modification par chrispierret (19-06-2020 07:57:52)

Hors ligne

#2 18-06-2020 08:02:52

chrispierret
Membre
Distrib. : Debian 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : MATE Desktop Environment 1.20.4
Inscription : 04-02-2017

Re : [résolu] paquet rake non installable ?

Pour préciser le problème à résoudre, voici donc ce que j'obtiens lorsque je veux installer le paquet rake :

root@debian:/home/chris/Téléchargements# gdebi rake_12.3.1-3+deb10u1_all.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading state information... Done
Ce paquet ne peut pas être installé
Failed to satisfy all dependencies (broken cache)


Comment faire ?

Hors ligne

#3 18-06-2020 08:36:47

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [résolu] paquet rake non installable ?

salut
pourrait on voir le contenu de ton fichier sources liste

cat /etc/apt/sources.list


ls /etc/apt/sources.list.d


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#4 19-06-2020 05:56:52

chrispierret
Membre
Distrib. : Debian 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : MATE Desktop Environment 1.20.4
Inscription : 04-02-2017

Re : [résolu] paquet rake non installable ?

Oui, les voici :

chris@debian:~$ cat /etc/apt/sources.list
# Debian Buster, dépôt principal + paquets non libres
deb http://deb.debian.org/debian/ buster  main contrib non-free

# Debian Buster, mises-à-jour de sécurité + paquets non libres
deb http://security.debian.org/ buster/updates main contrib non-free

# buster-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ buster-updates main contrib non-free

# Debian Buster, dépôt de rétroportage ("backports")
deb http://httpredir.debian.org/debian/ buster-backports main

# ajout dépôt pour Wine
deb https://dl.winehq.org/wine-builds/ubuntu/ buster main



chris@debian:~$ ls /etc/apt/sources.list.d
home:colomboem.list  iridium-browser.list  isv:ownCloud:desktop.list

Hors ligne

#5 19-06-2020 07:13:34

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.2
Noyau : Linux 5.3.18
(G)UI : KDE 5.18.5
Inscription : 11-03-2016

Re : [résolu] paquet rake non installable ?

Bonjour,

Failed to satisfy all dependencies (broken cache)


Effectue les commandes suivantes et donnes nous les retours
Tu passes en root avec soit

su -


soit

sudo -i


suivant ton choix à l’installation de créer un mot de passe root ou de donner les droits d’administration au premier utilisateur créé
voir le wiki su et sudo : https://debian-facile.org/doc:systeme:su et https://debian-facile.org/doc:systeme:sudo
Ensuite

apt clean


apt update


apt --fix-broken install


apt upgrade


On voit déjà ce que ça retourne.

Hors ligne

#6 19-06-2020 07:56:46

chrispierret
Membre
Distrib. : Debian 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : MATE Desktop Environment 1.20.4
Inscription : 04-02-2017

Re : [résolu] paquet rake non installable ?

Bonjour,
Je n'ai pas compris comment (ce --fix-broken ?), mais en tout cas ça a marché. Par cette mise à jour s'est installé le paquet rake, et je peux reprendre mon installation de LyX.
Merci beaucoup !

Hors ligne

#7 19-06-2020 13:08:24

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.2
Noyau : Linux 5.3.18
(G)UI : KDE 5.18.5
Inscription : 11-03-2016

Re : [résolu] paquet rake non installable ?

apt clean a supprimé le cache
apt update a mis à jour la liste des paquets disponible
apt --fix-broken install corrige les problèmes d'installation, dépendances

Hors ligne

Pied de page des forums