Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-07-2020 13:41:53

dd40
Membre
Inscription : 10-07-2020

Problème d'installationde packet "n'est pas disponible : NO_PUBKEY"

Bonjour,
Je n'arrive pas à installer de nouveaux paquets destinés aux développement.
Voici mon source.list :


#


# deb cdrom:[Debian GNU/Linux bullseye-DI-alpha2 _Bullseye_ - Official Snapshot amd64 NETINST 20200315-11:07]/ bullseye main

#deb cdrom:[Debian GNU/Linux bullseye-DI-alpha2 _Bullseye_ - Official Snapshot amd64 NETINST 20200315-11:07]/ bullseye main

deb http://ftp.fr.debian.org/debian/ bullseye main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ bullseye main contrib non-free


deb http://security.debian.org/debian-security bullseye-security main contrib non-free
deb-src http://security.debian.org/debian-security bullseye-security main contrib non-free


# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.
deb [trusted=yes] http://debian.moxa.com/debian stretch main
#deb [trusted=yes] mirror://debian.moxa.com/debian/mirrors stretch main contrib non-free


Le message d'erreur sur un apt update et la tentative de solution par gpg :


****@pcdebian:~$ sudo apt update
Réception de :1 http://ftp.fr.debian.org/debian bullseye InRelease [116 kB]
Atteint :2 http://security.debian.org/debian-security bullseye-security InRelease                                     
Réception de :3 http://debian.moxa.com/debian stretch InRelease [8540 B]                                             
Ign :3 http://debian.moxa.com/debian stretch InRelease
125 ko réceptionnés en 1s (182 ko/s)
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
83 paquets peuvent être mis à jour. Exécutez « apt list --upgradable » pour les voir.
W: Erreur de GPG : http://debian.moxa.com/debian stretch InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 24A4A1C69F63FFA0
ddulau@pcdebian:~$ sudo apt install gnupg
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
gnupg est déjà la version la plus récente (2.2.20-1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 83 non mis à jour.
****@pcdebian:~$ gpg --keyserver keys.gnupg.net --recv-key 24A4A1C69F63FFA0
gpg: échec de réception depuis le serveur de clefs : No data


Quelqu'un a t'il une idée du problème ?

Hors ligne

#2 17-07-2020 14:54:42

èfpé
Membre
Inscription : 10-07-2016

Re : Problème d'installationde packet "n'est pas disponible : NO_PUBKEY"

Bonjour,

dd40 a écrit :

gpg --keyserver keys.gnupg.net --recv-key 24A4A1C69F63FFA0

gpg: échec de réception depuis le serveur de clefs : No data


Cette clé OpenPGP n'est pas sur les serveurs publics mais il existe un paquet moxa-archive-keyring.

apt-cache policy moxa-archive-keyring

moxa-archive-keyring:
  Installé : (aucun)
  Candidat : 2019.4.26+deb9
 Table de version :
     2019.4.26+deb9 500
        500 http://debian.moxa.com/debian stretch/main amd64 Packages
     2018.4.11 500
        500 http://debian.moxa.com/debian stretch/main amd64 Packages


Ne m'en veux pas de préciser @ll que l'option [trusted=yes] pourra être supprimée du sources.list !

Dernière modification par èfpé (17-07-2020 22:24:42)

Hors ligne

Pied de page des forums