Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-08-2020 14:15:59

zechocobo
Membre
Inscription : 06-08-2020

Impossible de corriger les dépendances

Bonjour,

Après avoir cherché sur le net la solution à mon problème, je me résout à poster ici car je suis dans l'impasse...
J'ai voulu passer de Debian 8 à 9, apt est cassé avec des problèmes de dépendances.

Voici mon sources.list

 
     1  deb http://deb.debian.org/debian/ stretch main contrib non-free
     2  deb-src http://deb.debian.org/debian/ stretch main contrib non-free
     3 
     4  deb http://security.debian.org/ stretch/updates main contrib non-free
     5  deb-src http://security.debian.org/ stretch/updates main contrib non-free
 



et le pb rencontré :


root@lagardelle:~# apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 libebackend-1.2-10 : Dépend: libedataserver-1.2-22 (>= 3.21.90) mais il n'est pas installé
 libicu57 : Dépend: libstdc++6 (>= 5.2) mais 4.9.2-10+deb8u2 est installé
 python3-apt : Dépend: libapt-inst2.0 (>= 1.4~beta3) mais il n'est pas installé
               Dépend: libapt-pkg5.0 (>= 1.4~beta3) mais il n'est pas installé
               Dépend: libstdc++6 (>= 5.2) mais 4.9.2-10+deb8u2 est installé
 rhythmbox-plugins : Dépend: rhythmbox (= 3.4.1-2+b1) mais 3.1-1 est installé
                     Dépend: gir1.2-rb-3.0 (= 3.4.1-2+b1) mais 3.1-1 est installé
                     Dépend: gir1.2-webkit2-4.0 mais il n'est pas installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.



la commande apt-get -f install me renvoie la même erreur :

root@lagardelle:~# apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Correction des dépendances... a échoué.
Les paquets suivants contiennent des dépendances non satisfaites :
 libebackend-1.2-10 : Dépend: libedataserver-1.2-22 (>= 3.21.90) mais il n'est pas installé
 libicu57 : Dépend: libstdc++6 (>= 5.2) mais 4.9.2-10+deb8u2 est installé
 python3-apt : Dépend: libapt-inst2.0 (>= 1.4~beta3) mais il n'est pas installé
               Dépend: libapt-pkg5.0 (>= 1.4~beta3) mais il n'est pas installé
               Dépend: libstdc++6 (>= 5.2) mais 4.9.2-10+deb8u2 est installé
 rhythmbox-plugins : Dépend: rhythmbox (= 3.4.1-2+b1) mais 3.1-1 est installé
                     Dépend: gir1.2-rb-3.0 (= 3.4.1-2+b1) mais 3.1-1 est installé
                     Dépend: gir1.2-webkit2-4.0 mais il n'est pas installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Impossible de corriger les dépendances
 

Hors ligne

#2 07-08-2020 01:59:10

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.7 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : Impossible de corriger les dépendances

Salut zechocobo wink

Est-ce que tu te rappelles quelle action a déclenché ces erreurs ?

Ce que je propose pour cette mise-à-jour, c’est :
1. Revenir à une Debian 8 (Jessie) à jour, sans aucune erreur APT
2. Recommencer la mise-à-jour vers Debian 9 (Stretch), en suivant attentivement le guide de mise à niveau

Je peux te dépanner pour la première étape, et je pense que tu devrais pouvoir t’en sortir ensuite avec la documentation pour la seconde étape.

Jouer sous Debian ? Facile !

Hors ligne

Pied de page des forums