Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-08-2020 11:44:25

Innocent1
Membre
Inscription : 13-08-2020

[Résolu] Problème d'installation de GCC

Bonjour,

Je suis sous Kali Linux et j'essaie d'installer GCC ( je ne suis pas sous Kali Linux Live ),

J'ai donc suivi un tutoriel, normal mais le problème c'est que rien ne fonctionne....

Voici ce que j'ai fait ( je précise que bien entendu je le fait en tant que root ):


apt-get install build-essential
 



Mais voici mon code d'erreur:


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 build-essential : Dépend: gcc (>= 4:9.2) mais ne sera pas installé
                   Dépend: g++ (>= 4:9.2) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
 



J'ai essayer plusieurs choses, comme --purge, --reinstall etc... Malheureusement avec toujours le même résultat...

( Même si c'est une précision relativement bête, bien entendu GCC n'est déjà pas installé, sinon je ne chercherais pas à le faire )

S'il vous plaît, aidez-moi car c'est très embêtant....

Merci,

Innocent1

Dernière modification par Innocent1 (13-08-2020 12:52:03)

Hors ligne

#2 13-08-2020 12:01:42

robert2a
Membre
Inscription : 15-11-2014

Re : [Résolu] Problème d'installation de GCC

Bonjour
voila ce que j'ai sous testing (Bullseye)


apt-cache policy gcc gcc-10-base build-essential g++
gcc:
  Installé : 4:9.2.1-3.1
  Candidat : 4:9.2.1-3.1
 Table de version :
 *** 4:9.2.1-3.1 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status
gcc-10-base:
  Installé : 10.1.0-6
  Candidat : 10.1.0-6
 Table de version :
 *** 10.1.0-6 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status
build-essential:
  Installé : 12.8
  Candidat : 12.8
 Table de version :
 *** 12.8 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status
g++:
  Installé : 4:9.2.1-3.1
  Candidat : 4:9.2.1-3.1
 Table de version :
 *** 4:9.2.1-3.1 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status
 



tu peu essayer aptitude pour comprendre le souci


aptitude -s install build-essential
 



ps: idem pour g++ et gcc
l'option "-s" permet de simuler (pas obligatoire)
aptitude risque de te donner des solutions

nota: je ne connais pas Kali comme OS

gcc a besoin de ccp


cpp:
  Installé : 4:9.2.1-3.1
  Candidat : 4:9.2.1-3.1
 Table de version :
 *** 4:9.2.1-3.1 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status
 

Dernière modification par robert2a (13-08-2020 12:07:07)

Hors ligne

#3 13-08-2020 12:06:12

Innocent1
Membre
Inscription : 13-08-2020

Re : [Résolu] Problème d'installation de GCC

Merci de cette réponse,

Bon pour être très honnête c'est la première fois que j'utilise aptitude...

Donc je ne sais pas vraiment à quoi sers exactement cette commande ( je vais aller me renseigner ) mais voici le résultat obtenu en lançant:


aptitude -s install build-essential
 




Les NOUVEAUX paquets suivants vont être installés :    
  binutils{a} binutils-x86-64-linux-gnu{a} build-essential dpkg-dev{a} fakeroot{a} g++{a} g++-9{a} gcc{a} gcc-9{a} libalgorithm-diff-perl{a}
  libalgorithm-diff-xs-perl{a} libalgorithm-merge-perl{a} libasan5{a} libbinutils{a} libcc1-0{a} libctf-nobfd0{a} libctf0{a} libfakeroot{a}
  libgcc-9-dev{a} libitm1{a} liblsan0{a} libstdc++-9-dev{a} libtsan0{a} libubsan1{a}
Les paquets suivants seront mis à jour :
  binutils-common cpp-9 gcc-10-base gcc-9-base libatomic1 libgomp1 libquadmath0 libstdc++6
8 paquets mis à jour, 24 nouvellement installés, 0 à enlever et 1221 non mis à jour.
Il est nécessaire de télécharger 43,2 Mo d'archives. Après dépaquetage, 112 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 libgcc1 : Dépend: gcc-9-base (= 9.2.1-22) but 9.3.0-15 is to be installed
 libgfortran5 : Dépend: gcc-9-base (= 9.2.1-22) but 9.3.0-15 is to be installed
 libgcc-s1 : Dépend: gcc-10-base (= 10-20200222-1) but 10.1.0-6 is to be installed
Les actions suivantes permettront de résoudre ces dépendances :

     Supprimer les paquets suivants :                            
1)     libgcc1 [1:9.2.1-22 (now)]                                

     Mettre à jour les paquets suivants :                        
2)     libgcc-s1 [10-20200222-1 (now) -> 10.1.0-6 (kali-rolling)]
3)     libgfortran5 [9.2.1-22 (now) -> 10.1.0-6 (kali-rolling)]  



Accepter cette solution ? [Y/n/q/?] y
Les NOUVEAUX paquets suivants vont être installés :
  binutils{a} binutils-x86-64-linux-gnu{a} build-essential dpkg-dev{a} fakeroot{a} g++{a} g++-9{a} gcc{a} gcc-9{a} libalgorithm-diff-perl{a}
  libalgorithm-diff-xs-perl{a} libalgorithm-merge-perl{a} libasan5{a} libbinutils{a} libcc1-0{a} libctf-nobfd0{a} libctf0{a} libfakeroot{a}
  libgcc-9-dev{a} libitm1{a} liblsan0{a} libstdc++-9-dev{a} libtsan0{a} libubsan1{a}
Les paquets suivants seront ENLEVÉS :
  libgcc1{a}
Les paquets suivants seront mis à jour :
  binutils-common cpp-9 gcc-10-base gcc-9-base libatomic1 libgcc-s1 libgfortran5 libgomp1 libquadmath0 libstdc++6
10 paquets mis à jour, 24 nouvellement installés, 1 à enlever et 1219 non mis à jour.
Il est nécessaire de télécharger 43,9 Mo d'archives. Après dépaquetage, 112 Mo seront utilisés.

Note: Using 'Simulate' mode.
Voulez-vous continuer ? [Y/n/?] y
Charger/installer/enlever des paquets.
 



Innocent1

Hors ligne

#4 13-08-2020 12:10:50

robert2a
Membre
Inscription : 15-11-2014

Re : [Résolu] Problème d'installation de GCC

voila tu des problèmes de version

il me semble correct


Les actions suivantes permettront de résoudre ces dépendances :

     Supprimer les paquets suivants :                            
1)     libgcc1 [1:9.2.1-22 (now)]                                

     Mettre à jour les paquets suivants :                        
2)     libgcc-s1 [10-20200222-1 (now) -> 10.1.0-6 (kali-rolling)]
3)     libgfortran5 [9.2.1-22 (now) -> 10.1.0-6 (kali-rolling)]  
 



sans le "-s"

Hors ligne

#5 13-08-2020 12:15:16

Innocent1
Membre
Inscription : 13-08-2020

Re : [Résolu] Problème d'installation de GCC

Wow, en effet c'est radical ça à totalement réglé le problème smile

Je ne comprend pas pourquoi cette différence entre aptitude et apt-get en revanche...

Pourquoi apt-get n'était pas capable de le faire à ton avis ? Y aurais-t-il une raison quelconque ?

En tout cas merci ça a vraiment réglé le problème, vraiment merci ^^

Innocent1

Hors ligne

#6 13-08-2020 12:28:08

Innocent1
Membre
Inscription : 13-08-2020

Re : [Résolu] Problème d'installation de GCC

Ah, bon j'ai un autre soucis maintenant, je ne sais pas si je peut le posté au même endroit ou non mais bon,

Je voudrais maintenant installer SDL,

Donc encore une fois j'ai suivi un tuto (lol) https://doc.ubuntu-fr.org/sdl

Bon alors, cette fois-ci aucune erreur à l'installation, mais le problème maintenant vient quand je compile....


cc test.c `sdl-config --cflags --libs`
 



Erreur de compilation:


bash: sdl-config : commande introuvable
cc: error: test.c: Aucun fichier ou dossier de ce type
cc: fatal error: no input files
compilation terminated.
 



Code de test.c:


#include <stdio.h>
#include <SDL/SDL.h>
int main(){
  return 0;
}
 



Vous auriez une idée ??

Merci,

Innocent1

Hors ligne

#7 13-08-2020 12:29:56

robert2a
Membre
Inscription : 15-11-2014

Re : [Résolu] Problème d'installation de GCC

c'est l'utilisateur qui limite , avec "apt-get" ou "apt" je le fais mais faut pas se tromper smile
il existe un outil autant l'utiliser  wink
ps: parfois il n'y a pas de solution
j'ai un souci similaire cette semaine sur deux migrations (Buster => Bullseye)  , si on lit bien le retour de "apt-get (lacommande)" on peu trouver la solution

en cas de souci tu le sais maintenant  smile

Hors ligne

#8 13-08-2020 12:31:32

robert2a
Membre
Inscription : 15-11-2014

Re : [Résolu] Problème d'installation de GCC

ouvre un autre fil , la dessus je suis moins performant tongue

Hors ligne

#9 13-08-2020 12:51:01

Innocent1
Membre
Inscription : 13-08-2020

Re : [Résolu] Problème d'installation de GCC

D'accord, je comprend mieux maintenant,

Merci de ton aide précieuse, je vais mettre le sujet en résolu,

Merci,

Innocent1

Hors ligne

Pied de page des forums