Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-09-2020 13:38:15

jiherbay
Membre
Lieu : sudouest33 sur le A de Atlanti
Distrib. : HL 2.5.x - Bullseye/Sid- tumbleweed
Noyau : évolutif
(G)UI : KDE
Inscription : 12-07-2016

Pilote NVidia

Bonjour à toutes et tous
Je suis toujours réticent pour installer les pilotes propriétaires , mais je viens de changer ma carte graphique pour une  NVidia  Geforce GT 710  ,et j'ai quelques soucis d'affichage ,d'instabilité de l'image ou le pire ,le gel complet de l'écran ,plus rien ne bouge , à part la souris que je peux promener un peu partout , mais elle ne sert à rien , je suis obligé de sortir avec Alt+syst+o
J'ai téléchargé le pilote NVidia , c'est un " .run "  , j'ai essayer de l'installer en terminal ouvert dans le dossier , mais .run il ne reconnaît pas ( je le comprend un peu ) , j'ai essayé avec  "Discover " ( que l'on trouve maintenant dans toutes les distrib  ,que je connais ) mais ça ne marche pas non plus , ça ne m'étonne pas non plus , je me doute qu'il faut transformer ce . run en .deb , mais là je ne sais pas faire
Si vous pouvez m'aider un peu , ça m'aiderait bien ( c'est le cas de le dire )
Bonne journée

Hors ligne

#2 23-09-2020 15:49:27

Yanatoum
Membre
Lieu : Dyle
Distrib. : Debian Buster
Noyau : Linux 4.19.0-8-amd64
(G)UI : xfce
Inscription : 10-07-2016

Re : Pilote NVidia

Bonsoir à Toi,
J'ai eu une 'Nvidia GeForce GT 710' et ' nvidia-legacy-390xx-driver NVIDIA metapackage (390xx legacy version)' avec Synaptic donnait de bons résultats.

Hors ligne

#3 23-09-2020 16:57:11

jiherbay
Membre
Lieu : sudouest33 sur le A de Atlanti
Distrib. : HL 2.5.x - Bullseye/Sid- tumbleweed
Noyau : évolutif
(G)UI : KDE
Inscription : 12-07-2016

Re : Pilote NVidia

Bonsoir Yanatoum
Je viens de regarder sur apper ( KDE ) , Metapackage , c'est ce qui "permet " l'installation du pilote proprio ,ou tu mets les deux , Metapackage + Legacy
Merci

edit : j'ai avancé un petit peu , je suis allé faire un tor dans le wiki DEBIAN  et voila ce que j'ai fait

jiherbay@jiher:~$ nvidia-detect
Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK208B [GeForce GT 710] [10de:128b] (rev a1)

Checking card:  NVIDIA Corporation GK208B [GeForce GT 710] (rev a1)
Your card is supported by all driver versions.
Your card is also supported by the Tesla 450 drivers series.
Your card is also supported by the Tesla 440 drivers series.
Your card is also supported by the Tesla 418 drivers series.
It is recommended to install the
    nvidia-driver
package.
 


il me conseil d'installer le pilote nvidia ( bien sûr )
Il y a une tripotée de pilote ,aussi bien en " legacy " qu'en " tesla "  avec le même N° , comment faire pour savoir qquel est le  " bon " " meilleur "
Voici la liste
http://pix.toile-libre.org/upload/origi … 898011.png
je n'ai mis que comme exemple le 450 , les autres sont pareils

Bonne soirée

Dernière modification par jiherbay (23-09-2020 21:31:00)

Hors ligne

#4 24-09-2020 06:46:16

Yanatoum
Membre
Lieu : Dyle
Distrib. : Debian Buster
Noyau : Linux 4.19.0-8-amd64
(G)UI : xfce
Inscription : 10-07-2016

Re : Pilote NVidia

Je n'ai plus la carte sous la main et ne peux te donner le résultat de 'nvidia-detect'. De mémoire , c'est là que j'ai identifié le paquet 'nvidia-legacy-390xx-driver NVIDIA metapackage (390xx legacy version)'.
Je suis sous 'Buster- Xfce' avec juste les dépôts 'contrib' et 'non-free', aucune expérience des autres pilotes.

Hors ligne

#5 24-09-2020 09:30:40

jiherbay
Membre
Lieu : sudouest33 sur le A de Atlanti
Distrib. : HL 2.5.x - Bullseye/Sid- tumbleweed
Noyau : évolutif
(G)UI : KDE
Inscription : 12-07-2016

Re : Pilote NVidia

Bonjour et merci Yanatoum
Ce peut il qu'en quelques (mois / années ) ils aient changé le pilote pour l'adapter aux nouvelles versions de DEBIAN  , ou DEBIAN adapté le pilote par rapport à ses nouvelles versions
J'ai suivi le tuto de smolsky et Chalu , installer un pilote Nvidia proprio ,  " ça fout les jetons " , blague à part , cela paraît quand même un peu lourd pour un citoyen lambda comme moi , même en imprimant toute la procédure de " sauvetage " je n'ai pas trop envie de m'y coller , à la limite je crois que je referais une install complète
J'ai regardé dans Apper , je n'ai que NVidia-detect  d'installé ( coché ), rien d'autre
J'attends  un peu si il y a d'autres retour pour confirmer soit la soluce que tu m'as donné soit celle de NVidia -detect , ou le pilote proprio si je suis sûr qu'il n'y ai rien d'installé qui m'amènerait un conflit
A toutes fins uties , je mets le résultat de la recherche

jiherbay@jiher:~$ grep -B2 'Module class: X.Org Video Driver' /var/log/Xorg.0.log
[    38.067] (II) Module modesetting: vendor="X.Org Foundation"
[    38.068]    compiled for 1.20.9, module version = 1.20.9
[    38.068]    Module class: X.Org Video Driver
--
[    38.147] (II) Module fbdev: vendor="X.Org Foundation"
[    38.147]    compiled for 1.20.0, module version = 0.5.0
[    38.147]    Module class: X.Org Video Driver
--
[    38.241] (II) Module vesa: vendor="X.Org Foundation"
[    38.241]    compiled for 1.20.4, module version = 2.4.0
[    38.241]    Module class: X.Org Video Driver
 


  Bonne journée

Hors ligne

Pied de page des forums