Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-10-2020 09:53:56

Kirdam
Membre
Lieu : Lyon (69) / Annecy (74)
Distrib. : Debian Stretch - Debian 4.9.88-1+deb9u1
Noyau : Linux 4.9.0-6-amd64
(G)UI : Gnome 3.22.2
Inscription : 15-04-2018

Debian ne démarre plus (Message erreur : Nvidia & Kernel Module)

Bonjour à tous,

J'ai fait une mise à jour récemment du système.
Notamment des drivers Nvidia.

En bootant sur ma partition Linux (je suis en dual boot), j'ai un message d'erreur "fail to load kernel module", et un autre message d'erreur concernant nvidia.
Je ne sais pas trop quoi faire...

J'ai essayé de lancer la becane en recovery mode, de faire un apt-get update apt-get upgrade, mais il dit qu'il ne trouve pas les serveurs pour faire les mises à jours... (pas internet ? problème du source.list ?)

Merci de votre aide smile

Dernière modification par Kirdam (10-10-2020 11:57:06)

Hors ligne

#2 10-10-2020 10:06:53

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : Debian ne démarre plus (Message erreur : Nvidia & Kernel Module)

Pour choper internet sans avoir des gestionnaire de connexion qui le fait pour toi, il suffit généralement de lancer

dhclient



À ta place je commencerai par faire ça :

#Vérifier si y a des paquets cassés
dpkg --configure -a
apt install -f
 


Normalement si y a pas de ce problème à ce niveau, j'essayerai de démarrer sur le kernel précédent s'il y en a deux d'installé.
Sinon je désinstallerai (temporairement au moins) le driver nvidia, voir si ça vient bien de là déjà.


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#3 10-10-2020 10:15:56

raleur
Membre
Inscription : 03-10-2014

Re : Debian ne démarre plus (Message erreur : Nvidia & Kernel Module)

Kirdam a écrit :

J'ai essayé de lancer la becane en recovery mode, de faire un apt-get update apt-get upgrade, mais il dit qu'il ne trouve pas les serveurs pour faire les mises à jours


Certains gestionnaires de réseau comme NetworkManager ne sont pas démarrés en recovery mode. Si on a une configuration réseau particulière (wifi, statique...) il faut le démarrer manuellement avec la commande "service <nom_du_service>" ou "systemctl start <nom_du_service>". Pour une interface ethernet configurée en DHCP, on peut simplement exécuter dhclient comme suggéré plus haut.
Pour démarrer sans interface graphique mais avec le réseau, il suffit de démarrer en runlevel 2 en ajoutant "2" à la ligne de commande du noyau via l'éditeur du menu de GRUB (touche "e").

Concernant le pilote nvidia, je laisse les connaisseurs répondre. Et je te suggère de modifier le titre pour les attirer.


Il vaut mieux montrer que raconter.

Hors ligne

#4 10-10-2020 10:52:11

Kirdam
Membre
Lieu : Lyon (69) / Annecy (74)
Distrib. : Debian Stretch - Debian 4.9.88-1+deb9u1
Noyau : Linux 4.9.0-6-amd64
(G)UI : Gnome 3.22.2
Inscription : 15-04-2018

Re : Debian ne démarre plus (Message erreur : Nvidia & Kernel Module)

Merci déjà pour vos premiers retour.

J'ai pu me connecter en DHCP.

J'ai fait un apt-get update puis upgrade --> une des sources ne marchait pas (ftp.fr.debian/debian/dist/buster/InRelease je crois).
J'ai mis à jour le système --> des paquets Nvidia installés.

J'ai fait la commande dpkg --configure -a
--> pas de problème elle se lance.
J'ai fait la commande de apt install -f
--> commande pas trouvée. En faisant apt-get install -f ca a marché.

Je redémarre le système
--> plus de problème Nvidia. Mais j'ai toujours "fail to load kernel module" et "fail to start kernel module".
Sur les deux versions du noyau installé dès que je lance --> écran noir et un tiret qui clignote.

Voilà...

Hors ligne

#5 10-10-2020 11:57:41

Kirdam
Membre
Lieu : Lyon (69) / Annecy (74)
Distrib. : Debian Stretch - Debian 4.9.88-1+deb9u1
Noyau : Linux 4.9.0-6-amd64
(G)UI : Gnome 3.22.2
Inscription : 15-04-2018

Re : Debian ne démarre plus (Message erreur : Nvidia & Kernel Module)

Bon, j'ai supprimé les pacquets nvidia.
Tout refonctionne smile

Vous avez une idée du pourquoi ca à planté ?

Hors ligne

#6 11-10-2020 07:32:55

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Debian ne démarre plus (Message erreur : Nvidia & Kernel Module)

Bonjour
pour avoir le réseau en mode dépannage (tu remplace "status" par "start" pour le lancer)


systemctl status networking.service
 


ou


service networking status
 


si ta carte est active tu a un retour du genre


● networking.service - Raise network interfaces
     Loaded: loaded (/lib/systemd/system/networking.service; enabled; vendor preset: enabled)
     Active: active (exited) since Sat 2020-10-10 16:05:19 CEST; 15h ago
       Docs: man:interfaces(5)
    Process: 627 ExecStart=/sbin/ifup -a --read-environment (code=exited, status=0/SUCCESS)
   Main PID: 627 (code=exited, status=0/SUCCESS)
 



remarque: ça ne fonctionne que avec un fichier "interfaces" du genre


# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# interface enp6s0
#allow-hotplug enp6s0
auto enp6s0
iface enp6s0 inet dhcp
 


ps: quand tu a finit tu le remet a l'origine pour utiliser "network-manager" de nouveau (enp6s0 est a remplacer par le nom de ta carte réseau )

pour le driver nvidia il faut une debian propre (driver bien purgé et cuda si besoin )
avoir les bonnes versions noyau + headers ( soit de stretch ou stretch-backports)
le mieux utiliser les méta-paquet


apt-get --reinstall install linux-image-amd64 linux-headers-amd64
 


si tu utilise le driver par défaut de stretch par exemple


apt-get install nvidia-driver
 


ps: pour les backports utiliser "-t stretch-backports nvidia-driver" mais il faut aussi utiliser les méta-paquet ci dessus des backports aussi
si ta carte le supporte le plus simple est d'utiliser le driver de stretch (sans backports)
la raison peut être une différence de version entre noyau , headers et outils de compilation (ou il manque quelque chose )
la console te dira si tout est correct et si oui tu peu reboot , sinon recommencer .

Dernière modification par robert2a (11-10-2020 07:39:45)

Hors ligne

#7 11-10-2020 09:39:12

raleur
Membre
Inscription : 03-10-2014

Re : Debian ne démarre plus (Message erreur : Nvidia & Kernel Module)

robert2a a écrit :

ça ne fonctionne que avec un fichier "interfaces" du genre

auto enp6s0


Et c'est superflu avec un fichier interfaces qui contient

allow-hotplug enp6s0


car l'interface réseau sera configurée dès sa découverte, indépendamment du lancement du service networking.

robert2a a écrit :

quand tu a finit tu le remet a l'origine pour utiliser "network-manager" de nouveau


Si l'interface réseau est normalement gérée par NetworkManager, pourquoi ne pas démarrer directement le service NetworkManager au lieu de s'embêter à modifier le fichier interfaces deux fois ?


Il vaut mieux montrer que raconter.

Hors ligne

#8 11-10-2020 11:24:02

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Debian ne démarre plus (Message erreur : Nvidia & Kernel Module)

oui exact , mais aucune idée du nom du service avec NM sur le système
pour "allow-hotplug enp6s0" il me semble que mes commandes ne fonctionne pas

donc jamais fait sur NM en mode dépannage .

Hors ligne

#9 11-10-2020 14:12:08

raleur
Membre
Inscription : 03-10-2014

Re : Debian ne démarre plus (Message erreur : Nvidia & Kernel Module)

robert2a a écrit :

aucune idée du nom du service avec NM sur le système


"NetworkManager", tout simplement.

robert2a a écrit :

pour "allow-hotplug enp6s0" il me semble que mes commandes ne fonctionne pas


En effet puisque le démarrage du service networking ne configure que les interfaces marquées "auto" ou "allow-auto". Mais ce n'est pas gênant, comme je l'ai écrit les interfaces marquées "allow-hotplug" sont automatiquement configurées par udev lors de leur découverte, indépendamment du service networking.


Il vaut mieux montrer que raconter.

Hors ligne

Pied de page des forums