Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-10-2020 21:13:59

Guy19550
Membre
Inscription : 10-08-2016

wifi perdu [RESOLU du mieux possible]

Bonjour,

J'ai relashé ma partition primaire et pareil, pas de wifi. J'ai une installation avec un home sur partition séparée et si des données de la configuration wifi sont sur cette partition, il est normal que cela ne revienne plus. La cause peut être autre évidemment. Je voudrais savoir essentiellement si des données de la configuration de la wifi se trouvent sur la partition home ou pas. Si c'est le cas, je ne dois plus faire ce genre d'installation avec partition séparée, cela revient à cela car je ne sais pas réparer les choses avec clonezilla.

C'est moins important de résoudre le problème que de se retrouver dans le même cas après. C'est arrivé en essayant dosbox et sans résultat. J'ai aussi remarqué que dans le Bios, la configuration de la carte wifi a été modifiée en la plaçant sur disable alors que pour l'installation de départ, elle était sur last one ou quelque chose ainsi. C'est clair pour moi qu'on ne ne saurait pas avoir la wifi quand c'est sur disable. J'ai remis le Bios par défaut mais cela ne change rien pour retrouver la wifi.

Réinstaller le firmware a également été essayé et ne change rien.

Les autres fonctionalités semblent correctes.

C'est peut-être simplement à réactiver, je n'en sais rien.

Dernière modification par Guy19550 (17-10-2020 07:05:53)

Hors ligne

#2 13-10-2020 23:57:22

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : wifi perdu [RESOLU du mieux possible]

mochi-tehehe.png
Plus de détaaaaails !

#Vérifier l'état des periphériques wifi
rfkill
#Afficher le modèle de la carte wifi et firmware utilisé
lspci -kd ::0280
#Afficher les éventuelles erreur du noyau (gérant le matériel - donc aussi la carte wifi)
dmesg --level=err,warn
 

Dernière modification par otyugh (14-10-2020 00:23:10)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#3 14-10-2020 01:27:18

Guy19550
Membre
Inscription : 10-08-2016

Re : wifi perdu [RESOLU du mieux possible]

J'ai cherché un peu sur internet et j'avais vu un lien avec rfkill pour ubtuntu, rien essayé de cela car cela concernait ubuntu. J'ai vu aussi que pour Stretch les commandes ne sont plus les mêmes or j'ai déjà vu que les commandes lspci et probablement aussi dmesg que je n'ai jamais utilisé réapparaissent ici. Je vais changé de PC pour introduire les commandes et donner plus d'information.

Ce que je peux déjà dire est que la wifi provient d'une carte wlan de Intel du type IPW 2200.

guy@debian:~$ lspci -kd ::0280

06:05.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)
 
Subsystem: Intel Corporation WM3B2200BG Mini-PCI Card
 
Kernel driver in use: ipw2200
 
Kernel modules: ipw2200

 


bloc à supprimer si la commande n’affiche rien



root@debian:/home/guy# dmesg --level=err,warn

[   10.139750] ACPI Warning: SystemIO range 0x00000000000011B0-0x00000000000011BF
conflicts with OpRegion 0x0000000000001180-0x00000000000011BB (\GPIO) (20160831/utaddress-247)

[   10.139766] ACPI Warning: SystemIO range 0x0000000000001180-0x00000000000011AF
conflicts with OpRegion 0x0000000000001180-0x00000000000011BB (\GPIO) (20160831/utaddress-247)

[   10.139775] lpc_ich: Resource conflict(s) found affecting gpio_ich

[   11.515204] ipw2200: Radio Frequency Kill Switch is On:
               
Kill switch must be turned off for wireless networking to work.

[  621.841871] sd 2:0:0:0: [sdb] No Caching mode page found

[  621.841885] sd 2:0:0:0: [sdb] Assuming drive cache: write through
 


bloc à supprimer si la commande n’affiche rien



J'ai vu tout à l'heure quelques nouvelles commandes, le problème est de retrouver la même chose 2x, si je trouve, je vais essayer de désactiver. Si je ne trouve pas, je vais faire une nouvelles réinstallation en changeant le clavier car je suis sur une installation avec un clavier allemand en Néerlandais. J'ai des lettres autocollantes pour un clavier français et la langue passera alors en Français avec un clavier français.

Kill switch ne marche pas à la console de commande ni en root ni en normal. La commande est inconnue (écrit en Néerlandais évidemment).

Dernière modification par Guy19550 (14-10-2020 02:35:25)

Hors ligne

#4 14-10-2020 08:13:51

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : wifi perdu [RESOLU du mieux possible]

En tous cas le message dmesg est très explicite. Reste à trouver comment couper ce "kill switch".

...

mochi-neh.png
Où est ma sortie rfkill ?

Si tu ne l'a pas, rfkill fait partie du paquet rfkill qu'on peut installer avec

apt install rfkill
#et sauf switch hardware, cette commande est censé débloquer la wifi
rfkill unblock wifi



---

Si ça échouait, tu as ce premier résultat sur un moteur de recherche à adapter à ta situation :
https://www.debian-fr.org/t/pseudo-reso … boot/11094

Dernière modification par otyugh (14-10-2020 08:19:57)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#5 14-10-2020 18:49:44

Guy19550
Membre
Inscription : 10-08-2016

Re : wifi perdu [RESOLU du mieux possible]

Je vais essayer cela et en donner le résultat par la suite. La nuit dernière, j'ai tout réinstallé en Français après avoir collé des étiquettes sur le clavier allemand (infernal avec Dosbox que c'était). J'ai pu changer la langue en Français et maintenant j'ai un PC normal installé en Français avec un clavier français, j'aurais préféré un clavier belge mais soit, le clavier français ne me dérange pas trop et est bien meilleur que celui des allemands. C'est la troisième installation, les deux premières fois j'ai eu la wifi sans problème et la troisième fois j'ai plus eu la wifi. Cela me semble fonctionner avec une espèce de bascule car j'ai vu des instructions du genre "ifup" et "ifdown". En cas de beisoin, je peux aussi changer la carte wifi, des fois qu'elle serait tombée en panne. Je dois attendre la nuit pour poursuivre pour ne pas être dérangé car je perds mes moyens en cas de dérangement le jour. Merci pour l'aide, j'ignorais qu'il y avait lieu d'installer un paquet pour rfkill.

Hors ligne

#6 16-10-2020 00:22:54

Guy19550
Membre
Inscription : 10-08-2016

Re : wifi perdu [RESOLU du mieux possible]

Je n'ai eu aucun essai concluant pour refaire fonctionner la carte wifi. J'ai même changé la carte par une autre avec le même résulat.
J'ai fini par retirer la seconde carte wifi du même type et utilisé un port USB avec un stick wifi Realtek, la généralement j'y arrive. Mais j'ai eu le même constat d'échec. Suite à cela, j'ai déconnecté l'alimentation et et patienté pendant une heure ou deux en faisant autre chose. Quand je l'ai repris pour pousuivre, j'ai eu de suite après allumage que des réseaux étaient détectés et j'ai pu me connecter à la wifi via le stick USB wifi. J'ai alors vu que le switch hardware wifi est opérationnel, la led peut s'allumer ou s'éteindre par impusion sur le switch. La wifi est présente dans les deux cas et c'est normal car la wifi ne passe plus par la carte Wlan. Cette signalisation wifi est non fonctionnelle avec les deux cartes Wlan, mais on se rend compte que le switch est désactivé car en allant avec la souris sur l'icône internet on a l'information avec un clic gauche de la souris. Il est possible que si je remette la carte wlan maintenant que j'ai la wifi mais sans la signalisation comme cela a été le cas pour les deux premières installations, mais cela ne sera plus essayé. L'essentiel est d'avoir la wifi de la manière la plus stable possible et c'est avec le stick wifi, pas la carte wlan. Ce qui serait encore possible est de reperdre à nouveau la wifi en l'ayant coupée avec le switch au démarrage suivant. Cela je dois encore le vérifier, mais cela métonnerait beaucoup car une fois la carte wlan retirée, le Bios le voit plus la carte et ne reprend plus rien de la wifi précâblée. Je pense donc que le problème est réglé ainsi. Je dois encore le vérifier avant de mettre clôturé dans le titre. Généralement, la wifi est meilleure avec une carte wlan qu'avec un stick USB, cela ne semble pas le cas avec ce PC. J'ai 2/5 à l'icone dans une pièce éloignée du routeur que ce soit avec la carte Wlan ou un stick wifi.

http://pix.toile-libre.org/?img=1602914057.jpg
Avec la carte Wlan, c'est ce que j'ai dans le Bios, c'est cela qui me fait penser à une bascule pour la Wifi, l'autre option est disable et c'est ce que j'avais après les problèmes.
Il y a plusieurs modèles pour le Vim 2090 et pour un autre modèle plus ancien, j'ai vu que Fn F1 est pour activer la carte Wifi et Fn F2 pour connecter ou déconnecter. Sur le mien, plus récent, cela ne fonctionne pas non plus, faut passer par le switch hardware et sans la signalisation avec le type de carte wlan essayé. Quand on installe la première fois, tout se passe correctement, le problème vient par la suite après que la wifi est perdue, on est aveugle. rfKill fonctionne, cela se passe je pense normalement, mais quand on fait l'instruction avec list, on voit que rien n'a changé. C'est pour l'essentiel ce que j'ai constaté. J'ai d'autres PC avec cette même carte lan mais seul celui-ci a cet espèce de bascule et je n'ai jamais eu ce type de problème avec les autres.

Dernière modification par Guy19550 (17-10-2020 07:03:50)

Hors ligne

Pied de page des forums