Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 24-10-2020 15:03:21

Herve5
Membre
Lieu : région de Cannes, France
Distrib. : Debian 10
Noyau : Linux 5.7.0-3-amd64
(G)UI : Mate 1.20.4
Inscription : 02-03-2019

[Résolu] Incompatibilité du pilote non-libre nvidia avec Linux 5.9

Bonjour,
j'ai une question très bête.

Dans ma distribution Debian Testing vient d'apparaître spontanément la mise à niveau du noyau en version 5.9 (au lieu de ma 5.8 qui marchait très bien) et naïvement j'ai installé.
Résultat : au réveil d'une mise en hibernation, plus d'écran, et à y regarder de plus près, durant le boot au début avant la série des [OK] ordinaires je vois fugacement passer des messages en ROUGE qui indiquent que le kernel n'a pas pu charger... je ne sais quoi, parce que çadéfilevraimenttrèsviteettantpispourtoilehautdel'écranl'amangé.

Bon, malgré ma rusticité linuxienne j'ai réussi à demander poliment à la machine de repartir en 5.8, mais j'aimerais bien comprendre ce que je vois en 5.9.

D'où ma question : y a-t-il moyen de mettre en pause ce défilement frénétique du début de boot, juste pour lire tranquillement ce que je vois?
(vous voyez que c'était bien une question très bête!)

Merci!! :-)

Dernière modification par Herve5 (26-10-2020 18:51:39)


--
Hervé S.
deux machines de type Clevo (donc pas très solides) de 2017, l'une sous Debian 10, l'autre Ubuntu 16LTS, plus depuis peu un beau Lenovo Thinkpad P53 sous Debian Testing Xfce

Hors ligne

#2 24-10-2020 15:13:04

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu] Incompatibilité du pilote non-libre nvidia avec Linux 5.9

Je pense que ce que tu cherches en vrai, c'est pas de ralentir le démarrage, mais de voir le journal système.
Genre :

dmesg


et pour filtrer pour ne voir que les erreurs/avertissement :

dmesg --level=err,warn


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#3 24-10-2020 16:04:02

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Incompatibilité du pilote non-libre nvidia avec Linux 5.9

otyugh a écrit :

Je pense que ce que tu cherches en vrai, c'est pas de ralentir le démarrage, mais de voir le journal système.


Ouais. C'est quand même curieux cette tendance des gens à demander comment faire le truc qu'il croient être la meilleure solution à leur problème plutôt que d'exprimer leur vrai besoin.

Ctrl+S fige l'affichage de la console jusqu'à Ctrl+Q, mais je n'ai pas testé si c'est actif au démarrage.

otyugh a écrit :

dmesg


dmesg affiche les messages du noyau, pas le journal système. Pour ça, voir plutôt journalctl. Les messages [OK] et [FAILED] proviennent du gestionnaire d'init, pas du noyau.

Dernière modification par raleur (24-10-2020 16:04:53)


Il vaut mieux montrer que raconter.

Hors ligne

#4 24-10-2020 19:01:23

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Incompatibilité du pilote non-libre nvidia avec Linux 5.9

Bonsoir
pour le journal


journalctl -r -p err
 


pour le système (avec un mot clé ici "drm")


dmesg | grep drm
 


du moment que tu arrive a ouvrir une console sans bureau ( ctrl+alt+f2 par exemple ).

mais a l'installation (ou l' upgrade) tu a eu des messages d'erreur , bien avant la mise en veille ou le reboot de la machine
a moins que tu fasse les mises a jours en auto

sinon pas compris pourquoi maintenant le noyau 5.9 ,  (par rapport au 5.8)
peut être qu'il apporte plus de prise en charge du matériel
les gens qui fonctionnent en driver libre pourront le confirmer
pas testé
ps: le non free n'est pas une priorité mais un plus .
la série 3000 de nvidia est en rupture de stock jusqu'en 2021  tongue
et amd j'ai pas de date mais en driver libre (série 6000)

Hors ligne

#5 24-10-2020 20:01:38

Herve5
Membre
Lieu : région de Cannes, France
Distrib. : Debian 10
Noyau : Linux 5.7.0-3-amd64
(G)UI : Mate 1.20.4
Inscription : 02-03-2019

Re : [Résolu] Incompatibilité du pilote non-libre nvidia avec Linux 5.9

raleur a écrit :

C'est quand même curieux cette tendance des gens à demander comment faire le truc qu'il croient être la meilleure solution à leur problème plutôt que d'exprimer leur vrai besoin.

Ctrl+S fige l'affichage de la console jusqu'à Ctrl+Q, mais je n'ai pas testé si c'est actif au démarrage.


Ben, mon vrai besoin était de voir ce qui défile lors du boot...
Cela dit, la destruction de mon système a fortement progressé depuis ma demande.
Désormais même en 5.8 mon compte user ne gère plus les fenêtres correctement (plus de barre supérieure, impossible de lancer le gestionnaire de fenêtres...), peut-être que 5.9 a cassé le support Nvidia...
Actuellement j'en suis à
- booter en root, qui lui gère encore proprement ses fenêtres,
- puis recopier mon dernier backup du dossier home/moi,
- puis basculer de root sur moi,
- mais lorsque je reboote je perds à nouveau la gestion des fenêtres sur mon compte...
Le tout en imposant à la main le noyau 5.8.3 au boot au lieu du 5.9.
Bref, ce qui précède vous montre que lire les états d'âme du 5.9 n'est plus vraiment mon problème actuellement :-/
P. S. je suis effectivement en non-free, et avec une carte Nvivia...
Merci!!

Dernière modification par Herve5 (24-10-2020 20:18:24)


--
Hervé S.
deux machines de type Clevo (donc pas très solides) de 2017, l'une sous Debian 10, l'autre Ubuntu 16LTS, plus depuis peu un beau Lenovo Thinkpad P53 sous Debian Testing Xfce

Hors ligne

#6 24-10-2020 21:46:17

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Incompatibilité du pilote non-libre nvidia avec Linux 5.9

Bonsoir
tu purge le 5.9 et démarrer normalement
pour le reste je sais pas ce que tu a fait
j'ai installé le 5.9 sans casser mon système , juste ne pas redémarrer et le purger
j'ai posté sur le sujet , j'ai bullseye + nvidia + cuda + noyau 4.8

Hors ligne

#7 24-10-2020 22:15:49

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.9 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : [Résolu] Incompatibilité du pilote non-libre nvidia avec Linux 5.9

Je confirme que les pilotes propriétaires nVIDIA semblent incompatibles avec la version 5.9 du noyau Linux : NVIDIA Driver not yet supported for Linux Kernel 5.9+

En gros tu as pour l'instant le choix entre utiliser le pilote libre nouveau, ou rester sur le noyau 5.8.

Jouer sous Debian ? Facile !

Hors ligne

#8 25-10-2020 08:47:56

Herve5
Membre
Lieu : région de Cannes, France
Distrib. : Debian 10
Noyau : Linux 5.7.0-3-amd64
(G)UI : Mate 1.20.4
Inscription : 02-03-2019

Re : [Résolu] Incompatibilité du pilote non-libre nvidia avec Linux 5.9

Merci Robert21, vv222!

Pour purger mon noyau est-ce qu'il suffit de supprimer le paquet linux-image à partir de Synaptic, ci-dessous? (en tournant sous 5.8 smile )
cGgmPyQ.png
Sinon, au début lorsque j'ai installé Debian j'avais effectivement et uniquement le pilote libre "nouveau", et bien que j'aie ajouté ceux de Nvidia pour accélérer mes  logiciels de traitement photo, je l'ai peut-être encore.
Je ne sais pas si je peux faire facilement la bascule à l'envers.

Côté encadrement des fenêtres qui disparaît je me demande si ça ne vient pas du fait que j'ai installé un thème qui n'était pas standard et que la mise à jour ne suporterait pas; je suis revenu au défaut et je vais voir...

Merci encore!
H.

--
Hervé S.
deux machines de type Clevo (donc pas très solides) de 2017, l'une sous Debian 10, l'autre Ubuntu 16LTS, plus depuis peu un beau Lenovo Thinkpad P53 sous Debian Testing Xfce

Hors ligne

#9 25-10-2020 12:21:05

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.9 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : [Résolu] Incompatibilité du pilote non-libre nvidia avec Linux 5.9

Gaffe par contre si tu choisis de rester sur le noyau 5.8 : celui-ci n'est plus maintenu chez Debian, donc tu n'en recevras aucune mise-à-jour en cas de faille de sécurité.

Jouer sous Debian ? Facile !

Hors ligne

#10 25-10-2020 12:51:10

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Incompatibilité du pilote non-libre nvidia avec Linux 5.9

Bonjour
une commande de ce genre en simulation , puis en vrais si tout va bien (sans le -s )
pour faire cela il faut que tu démarre avec le 5.8


apt-get -s remove --purge linux-image-5.9.*
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Note : sélection de linux-image-5.9.0-1-rt-amd64-dbg pour l'expression rationnelle « linux-image-5.9.* »
Note : sélection de linux-image-5.9.0-1-amd64-dbg pour l'
expression rationnelle « linux-image-5.9.* »
Note : sélection de linux-image-5.9.0-1-amd64 pour l'expression rationnelle « linux-image-5.9.* »
Note : sélection de linux-image-5.9.0-1-rt-amd64-unsigned pour l'
expression rationnelle « linux-image-5.9.* »
Note : sélection de linux-image-5.9.0-1-cloud-amd64-unsigned pour l'expression rationnelle « linux-image-5.9.* »
Note : sélection de linux-image-5.9.0-1-cloud-amd64 pour l'
expression rationnelle « linux-image-5.9.* »
Note : sélection de linux-image-5.9.0-1-cloud-amd64-dbg pour l'expression rationnelle « linux-image-5.9.* »
Note : sélection de linux-image-5.9.0-1-amd64-unsigned pour l'
expression rationnelle « linux-image-5.9.* »
Note : sélection de linux-image-5.9.0-1-rt-amd64 pour l'expression rationnelle « linux-image-5.9.* »
Le paquet « linux-image-5.9.0-1-amd64-dbg » n'
est pas installé, et ne peut donc être supprimé
Le paquet « linux-image-5.9.0-1-amd64-unsigned » n'est pas installé, et ne peut donc être supprimé
Le paquet « linux-image-5.9.0-1-cloud-amd64-dbg » n'
est pas installé, et ne peut donc être supprimé
Le paquet « linux-image-5.9.0-1-cloud-amd64-unsigned » n'est pas installé, et ne peut donc être supprimé
Le paquet « linux-image-5.9.0-1-rt-amd64-dbg » n'
est pas installé, et ne peut donc être supprimé
Le paquet « linux-image-5.9.0-1-rt-amd64-unsigned » n'est pas installé, et ne peut donc être supprimé
Le paquet « linux-image-5.9.0-1-cloud-amd64 » n'
est pas installé, et ne peut donc être supprimé
Le paquet « linux-image-5.9.0-1-rt-amd64 » n'est pas installé, et ne peut donc être supprimé
Les paquets suivants seront ENLEVÉS :
  linux-image-5.9.0-1-amd64* linux-image-amd64*
0 mis à jour, 0 nouvellement installés, 2 à enlever et 0 non mis à jour.
Purg linux-image-amd64 [5.9.1-1]
Purg linux-image-5.9.0-1-amd64 [5.9.1-1]



idem pour les headers


apt-get -s remove --purge linux-headers-5.9.*
 



je te conseille aussi de virer les meta paquet (provisoire jusqu'a la résolution du problème )


apt-get -s remove --purge linux-image-amd64 linux-headers-amd64
 



il te restera les outils de compilation pour le 5.9 qui ne sont plus utile
si tu n'a pas cassé les modules nvidia du 5.8 le bureau doit être correct .

Dernière modification par robert2a (25-10-2020 12:53:28)

Hors ligne

#11 25-10-2020 13:02:18

Herve5
Membre
Lieu : région de Cannes, France
Distrib. : Debian 10
Noyau : Linux 5.7.0-3-amd64
(G)UI : Mate 1.20.4
Inscription : 02-03-2019

Re : [Résolu] Incompatibilité du pilote non-libre nvidia avec Linux 5.9

Merci Robert2a! j'essaie et je reviens. Je suis loggué en root vue que je n'arrive à manipuler fenêtres et menus que là sad
(2mn après ) je vais rebooter, mais pour info sur la dernière commande (métapaquet) apt n'a rien trouvé à enlever. Je ne sais pas si c'est significatif :

root@LinuxHerve:~# apt-get -s remove --purge linux-image-amd64 linux-headers-amd64
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Le paquet « linux-headers-amd64 » n'est pas installé, et ne peut donc être supprimé
Le paquet « linux-image-amd64 » n'
est pas installé, et ne peut donc être supprimé
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-5.8.0-2-amd64 linux-headers-5.8.0-2-common linux-image-5.8.0-2-amd64 linux-kbuild-5.7 linux-kbuild-5.9
Veuillez utiliser « apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
 


(encore 2mn plus tard) : je boote bien en 5.8 sans problème mais en user mes fenêtres ne sont toujours pas revenues.
Je repars en root pour recopier (avec un cp -p -r) tout mon ancien dossier dans /home... comme j'avais déjà fait plus haut, mais manifestement cette astuce ne survit pas à un reboot sad
P. S. je note aussi que Synaptic maintenant ne me propose plus d'upgrader le noyau en 5.9. Aurais-je fait une bêtise?

Dernière modification par Herve5 (25-10-2020 13:17:08)


--
Hervé S.
deux machines de type Clevo (donc pas très solides) de 2017, l'une sous Debian 10, l'autre Ubuntu 16LTS, plus depuis peu un beau Lenovo Thinkpad P53 sous Debian Testing Xfce

Hors ligne

#12 25-10-2020 13:19:02

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Incompatibilité du pilote non-libre nvidia avec Linux 5.9

ne fait pas l' autoremove pour l'instant , garde tous les noyaux en 5.8

tu peu donner le retour de ceci


apt policy linux-kbuild-5.*
 



sur le bureau il faut entrer en user (pas en root )  si possible

non si tu n'a pas les méta paquet il ne te le proposera plus
le 5.9 n'est pas une mise a jour du 5.8 mais un nouveau noyau
justement  linux-image-amd64 et et linux-headers-amd64 te propose toujours d'installer le plus récent .

Dernière modification par robert2a (25-10-2020 13:21:53)

Hors ligne

#13 25-10-2020 13:21:27

Herve5
Membre
Lieu : région de Cannes, France
Distrib. : Debian 10
Noyau : Linux 5.7.0-3-amd64
(G)UI : Mate 1.20.4
Inscription : 02-03-2019

Re : [Résolu] Incompatibilité du pilote non-libre nvidia avec Linux 5.9

je l'ai fait en root parce que j'ai pas encore tenté de revenir en user, mais ça donne :

root@LinuxHerve:~# apt policy linux-kbuild-5.*
linux-kbuild-5.7:
  Installé : 5.7.17-1
  Candidat : 5.7.17-1
 Table de version :
 *** 5.7.17-1 100
        100 /var/lib/dpkg/status
linux-kbuild-5.8:
  Installé : 5.8.14-1
  Candidat : 5.8.14-1
 Table de version :
 *** 5.8.14-1 100
        100 /var/lib/dpkg/status
linux-kbuild-5.9:
  Installé : 5.9.1-1
  Candidat : 5.9.1-1
 Table de version :
 *** 5.9.1-1 500
        500 http://ftp.fr.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status
root@LinuxHerve:~#


je tente de revenir en user...

Dernière modification par Herve5 (25-10-2020 13:22:39)


--
Hervé S.
deux machines de type Clevo (donc pas très solides) de 2017, l'une sous Debian 10, l'autre Ubuntu 16LTS, plus depuis peu un beau Lenovo Thinkpad P53 sous Debian Testing Xfce

Hors ligne

#14 25-10-2020 13:24:42

Herve5
Membre
Lieu : région de Cannes, France
Distrib. : Debian 10
Noyau : Linux 5.7.0-3-amd64
(G)UI : Mate 1.20.4
Inscription : 02-03-2019

Re : [Résolu] Incompatibilité du pilote non-libre nvidia avec Linux 5.9

Bon, je suis revenu en user, mais toujours sans barre de fenêtres ni fond d'écran ni bureau ni possibilité de lancer le gestionnaire de fenêtre dans les préférences...

Dernière modification par Herve5 (25-10-2020 13:25:22)


--
Hervé S.
deux machines de type Clevo (donc pas très solides) de 2017, l'une sous Debian 10, l'autre Ubuntu 16LTS, plus depuis peu un beau Lenovo Thinkpad P53 sous Debian Testing Xfce

Hors ligne

#15 25-10-2020 13:28:08

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Incompatibilité du pilote non-libre nvidia avec Linux 5.9

tu peu faire ceci


apt-get -s remove --purge linux-kbuild-5.9 linux-headers-5.9.0-1-common
 



en user teste une des noyaux en 5.8 pour démarrer

Hors ligne

#16 25-10-2020 13:30:17

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Incompatibilité du pilote non-libre nvidia avec Linux 5.9

puis ceci


apt policy linux-compiler-gcc*
 

Hors ligne

#17 25-10-2020 13:32:12

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Incompatibilité du pilote non-libre nvidia avec Linux 5.9

sur tous les noyaux en 5.7 ou 5.8 tu n'a pas un bureau correct ?

le retour de update-grub


update-grub
 



je vais passer ma machine en buster (a la place de bullseye) , je risque d'être absent
pour nividia (sans cuda ) vérifier les modules dans /lib/modules/lesnoyaux/updates/dkms/les-4-modules et ceci pour les noyaux encore installés

au pire réinstaller le driver nvidia après une purge (si c'est bien un souci de driver graphique )

Dernière modification par robert2a (25-10-2020 13:43:09)

Hors ligne

#18 25-10-2020 13:34:58

Herve5
Membre
Lieu : région de Cannes, France
Distrib. : Debian 10
Noyau : Linux 5.7.0-3-amd64
(G)UI : Mate 1.20.4
Inscription : 02-03-2019

Re : [Résolu] Incompatibilité du pilote non-libre nvidia avec Linux 5.9

- je suis en 5.8.3 (je n'ai plus le 5.9)
- le bureau n'est pas correct
- le résultat de la simu me donne ceci :

herve@LinuxHerve:~$ apt-get -s remove --purge linux-kbuild-5.9 linux-headers-5.9.0-1-common
NOTE: Ceci n'est qu'une simulation !
      apt-get a besoin des privilèges du superutilisateur
      pour pouvoir vraiment fonctionner.
      Veuillez aussi noter que le verrouillage est désactivé,
      et la situation n'est donc pas forcément représentative
      de la réalité !
Lecture des listes de paquets... Fait
Construction de l'
arbre des dépendances      
Lecture des informations d'état... Fait
Le paquet « linux-headers-5.9.0-1-common » n'
est pas installé, et ne peut donc être supprimé
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-5.8.0-2-amd64 linux-headers-5.8.0-2-common
  linux-image-5.8.0-2-amd64 linux-kbuild-5.7
Veuillez utiliser « apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  linux-kbuild-5.9*
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
Purg linux-kbuild-5.9 [5.9.1-1]
 


--
Hervé S.
deux machines de type Clevo (donc pas très solides) de 2017, l'une sous Debian 10, l'autre Ubuntu 16LTS, plus depuis peu un beau Lenovo Thinkpad P53 sous Debian Testing Xfce

Hors ligne

#19 25-10-2020 13:45:50

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Incompatibilité du pilote non-libre nvidia avec Linux 5.9

tu passe en root avec "su -" pour faire cette commande en vrais .
tu a testé aussi le 5.7 comme noyau ?

re , mon install est en cour

Dernière modification par robert2a (25-10-2020 14:14:16)

Hors ligne

#20 25-10-2020 14:16:35

Herve5
Membre
Lieu : région de Cannes, France
Distrib. : Debian 10
Noyau : Linux 5.7.0-3-amd64
(G)UI : Mate 1.20.4
Inscription : 02-03-2019

Re : [Résolu] Incompatibilité du pilote non-libre nvidia avec Linux 5.9

robert2a a écrit :

tu passe en root avec "su -" pour faire cette commande en vrais .
tu a testé aussi le 5.7 comme noyau ?


C'est fait et rebooté, mais sans changement.
De façon surprenante je ne vois pas de noyau 5.7 possible lorsque je choisis au boot, seulement les trois 5.8 -alors que je croyais bien me souvenir, suite à une précédente discussion ici, avoir gardé aussi le 5.7.
Cela dit, avec le 5.8 et si je me loggue en root, j'ai un bureau tout-à-fait bien, donc j'ai tendance à en déduire que c'est mon user qui est mal foutu côté bureau...

Dernière modification par Herve5 (25-10-2020 14:17:12)


--
Hervé S.
deux machines de type Clevo (donc pas très solides) de 2017, l'une sous Debian 10, l'autre Ubuntu 16LTS, plus depuis peu un beau Lenovo Thinkpad P53 sous Debian Testing Xfce

Hors ligne

#21 25-10-2020 14:22:13

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Incompatibilité du pilote non-libre nvidia avec Linux 5.9

si tu a le paquet "mesa-utils" installé , mais ne fonctionne que en user


glxinfo -B
 



tu a fait le "update-grub" et donner le retour ?
mate est assez solide je sais pas ce qui s'est passé

Hors ligne

#22 25-10-2020 14:29:38

Herve5
Membre
Lieu : région de Cannes, France
Distrib. : Debian 10
Noyau : Linux 5.7.0-3-amd64
(G)UI : Mate 1.20.4
Inscription : 02-03-2019

Re : [Résolu] Incompatibilité du pilote non-libre nvidia avec Linux 5.9

je n'arrive plus à accéder au terminal en user (l'intérieur de sa fenêtre apparaît mais cliquer dessus ne l'active pas apparemment)
Je vais fermer et rouvrir ma session, puis me logguer en root si ça ne marche pas
... ça ne marche pas. En me loguant en root j'obtiens :

root@LinuxHerve:~# glxinfo -B
name of display: :1.0
display: :1  screen: 0
direct rendering: Yes
Memory info (GL_NVX_gpu_memory_info):
    Dedicated video memory: 4096 MB
    Total available memory: 4096 MB
    Currently available dedicated video memory: 3699 MB
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: Quadro T2000/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 450.66
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.6.0 NVIDIA 450.66
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)

OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 450.66
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20

 



update-grub donne :

root@LinuxHerve:~# update-grub
Generating grub configuration file ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Found linux image: /boot/vmlinuz-5.8.0-3-amd64
Found initrd image: /boot/initrd.img-5.8.0-3-amd64
Found linux image: /boot/vmlinuz-5.8.0-2-amd64
Found initrd image: /boot/initrd.img-5.8.0-2-amd64
Found linux image: /boot/vmlinuz-5.8.0-1-amd64
Found initrd image: /boot/initrd.img-5.8.0-1-amd64
Found Windows Boot Manager on /dev/nvme0n1p1@/EFI/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for EFI firmware configuration
done
 

Dernière modification par Herve5 (25-10-2020 14:34:07)


--
Hervé S.
deux machines de type Clevo (donc pas très solides) de 2017, l'une sous Debian 10, l'autre Ubuntu 16LTS, plus depuis peu un beau Lenovo Thinkpad P53 sous Debian Testing Xfce

Hors ligne

#23 25-10-2020 14:40:56

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Incompatibilité du pilote non-libre nvidia avec Linux 5.9

tu a 3 noyaux 5.8.0-1   , 2  et 3
les 3 donne le même résultat et vue que en root le retour de glinfo -B est correct le souci provient certainement du bureau (ou de lightdm)
que donne


service lightdm status
 

Hors ligne

#24 25-10-2020 14:49:55

Herve5
Membre
Lieu : région de Cannes, France
Distrib. : Debian 10
Noyau : Linux 5.7.0-3-amd64
(G)UI : Mate 1.20.4
Inscription : 02-03-2019

Re : [Résolu] Incompatibilité du pilote non-libre nvidia avec Linux 5.9

robert2a a écrit :

que donne
service lightdm status


Alors : en user je n'ai plus accès au terminal, donc je ne sais pas si c'est pertinent mais en me logguant en root j'obtiens ceci :

● lightdm.service - Light Display Manager
     Loaded: loaded (/lib/systemd/system/lightdm.service; enabled; vendor preset: enabled)
     Active: active (running) since Sun 2020-10-25 15:35:27 CET; 48min left
       Docs: man:lightdm(1)
   Main PID: 879 (lightdm)
      Tasks: 7 (limit: 18781)
     Memory: 102.4M
     CGroup: /system.slice/lightdm.service
             ├─ 879 /usr/sbin/lightdm
             ├─ 888 /usr/lib/xorg/Xorg :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
             └─4961 /usr/lib/xorg/Xorg :1 -seat seat0 -auth /var/run/lightdm/root/:1 -nolisten tcp vt8 -novtswitch

oct. 25 15:35:37 LinuxHerve lightdm[1324]: gkr-pam: gnome-keyring-daemon started properly and unlocked keyring
oct. 25 14:45:54 LinuxHerve lightdm[5008]: Error getting user list from org.freedesktop.Accounts: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: TThe name org.freedesktop.Accounts was not provided by any .service files
oct. 25 14:45:54 LinuxHerve lightdm[5008]: pam_unix(lightdm-greeter:session): session opened for user lightdm by (uid=0)
oct. 25 14:45:56 LinuxHerve lightdm[5076]: pam_unix(lightdm:auth): Couldn't open /etc/securetty: No such file or directory
oct. 25 14:45:59 LinuxHerve lightdm[5076]: pam_unix(lightdm:auth): Couldn'
t open /etc/securetty: No such file or directory
oct. 25 14:45:59 LinuxHerve lightdm[5076]: gkr-pam: unable to locate daemon control file
oct. 25 14:45:59 LinuxHerve lightdm[5076]: gkr-pam: stashed password to try later in open session
oct. 25 14:45:59 LinuxHerve lightdm[5076]: Error getting user list from org.freedesktop.Accounts: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Accounts was not provided by any .service files
oct. 25 14:46:00 LinuxHerve lightdm[5076]: pam_unix(lightdm:session): session opened for user root by (uid=0)
oct. 25 14:46:00 LinuxHerve lightdm[5076]: gkr-pam: gnome-keyring-daemon started properly and unlocked keyring
~
~
~
~
~
~
 


Il y a deux lignes en jaune, celles qui commencent par "error", et une en rouge, celle qui contient "unable to locate..."
et hélas je ne vois pas comment lancer une commande terminal dans la session user fautive :-(

Dernière modification par Herve5 (25-10-2020 14:53:33)


--
Hervé S.
deux machines de type Clevo (donc pas très solides) de 2017, l'une sous Debian 10, l'autre Ubuntu 16LTS, plus depuis peu un beau Lenovo Thinkpad P53 sous Debian Testing Xfce

Hors ligne

#25 25-10-2020 15:05:15

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Incompatibilité du pilote non-libre nvidia avec Linux 5.9

simplement en passant en console pure
avec "Ctrl+Alt+F2" et tu te log en user puis "su -" et mdp root
tu pourra lancer les commandes en user ou en root
pour ci dessus rien de spécial a part que ouvrir le bureau en root pas bien

voila pour moi sur la machine que j'ai passé de bullseye en buster


service lightdm status
● lightdm.service - Light Display Manager
   Loaded: loaded (/lib/systemd/system/lightdm.service; indirect; vendor preset: enabled)
   Active: active (running) since Sun 2020-10-25 14:43:38 CET; 20min ago
     Docs: man:lightdm(1)
 Main PID: 580 (lightdm)
    Tasks: 5 (limit: 4915)
   Memory: 61.4M
   CGroup: /system.slice/lightdm.service
           ├─580 /usr/sbin/lightdm
           └─611 /usr/lib/xorg/Xorg :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

oct. 25 14:43:37 debian4 systemd[1]: Starting Light Display Manager...
oct. 25 14:43:38 debian4 systemd[1]: Started Light Display Manager.
oct. 25 14:43:39 debian4 lightdm[624]: pam_unix(lightdm-greeter:session): session opened for user lightdm by (uid=0)
oct. 25 14:43:52 debian4 lightdm[670]: pam_unix(lightdm:session): session opened for user robert by (uid=0)
 

Hors ligne

Pied de page des forums