Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 11-11-2020 18:19:11

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU] Exécution de grub-install dummy" a échoué

Debian Alain a écrit :

pour la petite note , le bios de la C.M.(Carte Mère)  était à l'origine en legacy :
- il ne supportait que des disques maxi 2 To
- et au maxi 3 partitions principales + 1 étendue (et donc autant de partions logiques que l'on veut(formatage (DOS / MBR))


C'est faux.
- Il n'y a jamais eu de limite formelle d'adressage à 2 To dans le BIOS. Il y a eu une limite à 8 Go à cause de l'adressage CHS, dépassée par les extensions EDD qui introduisent l'adressage LBA sur 64 bits. Il y a eu une limite à 137 Go pour les disques IDE/PATA  à cause de l'adressage LBA32, dépassée par l'adressage LBA48. Tout ça date de 20 ans. Il y a peut-être quelques BIOS buggés qui ne sont pas capables d'adresser plus de 2 Tio, mais c'est un bug, pas une limite intrinsèque du BIOS.
- En principe, le BIOS n'est pas concerné par la table de partition de son format et son rôle devrait se limiter à vérifier la signature du MBR et lancer le programme d'amorce qu'il contient (c'est ce dernier qui se débrouille avec la table de partition le cas échéant). Néanmoins certains BIOS exigent une entrée de partition DOS avec l'indicateur d'amorçage activé, mais ça n'a jamais été une spécification intrinsèque du BIOS et ça n'empêche pas d'utiliser une table de partition GPT.

Dernière modification par raleur (11-11-2020 18:20:47)


Il vaut mieux montrer que raconter.

Hors ligne

#27 11-11-2020 18:24:28

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU] Exécution de grub-install dummy" a échoué

redelap a écrit :

en haut à droite: -->Debian GNU/LInux UEFI Installer menu..


Donc c'est bien un amorçage en mode EFI. Il n'est pas normal que cela partitionne et installe GRUB pour BIOS. A-t-il proposé au moment du partitionnement d'abandonner l'installation EFI et de poursuivre en mode BIOS ?


Il vaut mieux montrer que raconter.

Hors ligne

#28 11-11-2020 18:30:42

redelap
Membre
Lieu : SAINTES 17
Distrib. : LMDE4 & Raspbian
Noyau : Linux 4.19.0.9 - amd64
Inscription : 14-05-2012
Site Web

Re : [RESOLU] Exécution de grub-install dummy" a échoué

Non.. avec le CD d'install, justement j'ai forcé l'Uefi...
Installation en cours... avec le CD d'install (pas de Live...) sur le disque SSD reconnu par l'installateur.
On va voir... Installation.... je croise les doigts... y compris les doigts de pieds...:o

Dernière modification par redelap (11-11-2020 18:31:38)


LMDE4 sur Lenovo LEGION Y520 - 16 Go - SSD128 + HHD1000
Raspberry-Pi-OS sur Rasberry Pi 400 sur clé USB 64 Go

Hors ligne

#29 11-11-2020 18:54:21

redelap
Membre
Lieu : SAINTES 17
Distrib. : LMDE4 & Raspbian
Noyau : Linux 4.19.0.9 - amd64
Inscription : 14-05-2012
Site Web

Re : [RESOLU] Exécution de grub-install dummy" a échoué

L'installation est arrivé à la fin... Installation et update du grub... Ejection du CD
je redémarre.... en croisant les doigts

ça se lance... Ecran d'accueil debian....
OK
mais.... " 8.390423 r8169 0000:01:00.1 firmware: falled to load rtl_nic/rt18411-2.fw (-2)"
et curseur clignotant dessous.... bloqué....

Toujours ce blocage....


Il est connnecté en câble au net...

LMDE4 sur Lenovo LEGION Y520 - 16 Go - SSD128 + HHD1000
Raspberry-Pi-OS sur Rasberry Pi 400 sur clé USB 64 Go

Hors ligne

#30 11-11-2020 18:57:00

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU] Exécution de grub-install dummy" a échoué

Un firmware pour carte réseau manquant n'empêche pas le démarrage. C'est autre chose.
Que donne le démarrage en mode recovery ?

Il vaut mieux montrer que raconter.

Hors ligne

#31 11-11-2020 19:09:58

redelap
Membre
Lieu : SAINTES 17
Distrib. : LMDE4 & Raspbian
Noyau : Linux 4.19.0.9 - amd64
Inscription : 14-05-2012
Site Web

Re : [RESOLU] Exécution de grub-install dummy" a échoué

je vais essayer... pas de suite... je souffle un peu...
-------
je ne peux m'empêcher d'y revenir...
Mais avant de lancer le mode recovery, j'ai lancé le Bios, et là, le SSD où j'ai installé la Buster est visible. Je peux choisir entre le CD d'install et ce SSD

Demarrage en recovery..heu..... en mise en route ordinaire ? sans le CD ?
Je vais voir

Dernière modification par redelap (11-11-2020 21:30:11)


LMDE4 sur Lenovo LEGION Y520 - 16 Go - SSD128 + HHD1000
Raspberry-Pi-OS sur Rasberry Pi 400 sur clé USB 64 Go

Hors ligne

#32 28-01-2021 23:10:54

debGuillaume
Membre
Distrib. : Debian Buster
Noyau : 4.19.0-13-amd64
(G)UI : MATE
Inscription : 28-01-2021

Re : [RESOLU] Exécution de grub-install dummy" a échoué

Bonjour redelap,

Je vois que le fil est résolu.

Je suis en train d'installer une Debian sur un portable avec la même carte mère que toi (NJ50_70CU).
J'ai résolu, grâce à l'aide de forumeurs de LinuxMAO, le problème de firmware Realtek que tu mentionnes en dernier.

As-tu eu d'autres soucis ? Si oui, comment les as-tu résolus ?

(Il me manque un léger détail pour pour profiter pleinement de la bête : un serveur graphique. big_smile
Cf ce fil : http://linuxmao.org/tiki-view_forum_thr … tId=103502.)

Merci !

EDIT: en lisant le règlement, j'espère ne pas avoir "bernaclé le post d'autrui", étant donné que je demande au créateur du fil des détails sur la résolution de son problème. Si je pinaille, merci de me l'indiquer, je créerai un nouveau fil. smile

Dernière modification par debGuillaume (28-01-2021 23:29:01)

Hors ligne

Pied de page des forums