Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-11-2020 18:11:33

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

[Résolu] problème avec apt policy


$ apt policy <unPaquet>
 


sur une station debian 8 quelque soit le paquet j'ai le tretour:
E: L'opération policy n'est pas valable

Même chose en root. Jusqu'à présent je n'ai constaté qu'il faut quelque chose de spécial pour passer cette commande ?
Merci pour votre aide.

Dernière modification par gargamel79 (15-11-2020 12:14:57)

Hors ligne

#2 13-11-2020 18:24:14

phlinux
Membre
Distrib. : Jessie
Noyau : 4.9
(G)UI : Openbox (+Rox+Feh)
Inscription : 09-05-2009

Re : [Résolu] problème avec apt policy

Bjr,

Et comme ça ?

apt-cache policy <unPaquet>


Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#3 13-11-2020 18:29:45

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu] problème avec apt policy

J'ai le même message en utilisant apt-cache.

Hors ligne

#4 13-11-2020 20:00:51

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [Résolu] problème avec apt policy

hello
Tu aurais pas un alias mal défini?
https://debian-facile.org/doc:programmation:bash:alias
me souviens d'un poste ou il y avait se soucis avec la commande tar

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#5 14-11-2020 17:59:06

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu] problème avec apt policy

Non aucun alias, excepté l'habituel "ll", ni en user, ni en root.
Par contre et c'est un autre sujet, je vois qu tu as un kernel  4.19.09 avec Buster (au lieu de  4.19.0-12) c'est possible ?

Pour mon problème, je me demande si je n'ai pas cassé l'arbre des dépendances après des manips. "scabreuses" sur cette station. tongue
Est-ce que c'est possible de vérifier cela avec apt ?

Hors ligne

#6 14-11-2020 18:42:11

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [Résolu] problème avec apt policy

je vois qu tu as un kernel  4.19.09 avec Buster (au lieu de  4.19.0-12) c'est possible ?


ouais possible car pas mis le profil a jour

sinon reinstall apt et vois si cela change quelque chose

Dernière modification par Croutons (14-11-2020 18:45:24)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#7 15-11-2020 10:33:05

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu] problème avec apt policy

J'ai ré-installé apt et apt-utils. C'est encore pareille... mad
Merci pour tes suggestions.

Hors ligne

#8 15-11-2020 11:17:34

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [Résolu] problème avec apt policy

regarde état du cache

apt-cache stats


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#9 15-11-2020 11:50:27

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] problème avec apt policy

gargamel79 a écrit :

sur une station debian 8 quelque soit le paquet j'ai le retour:
E: L'opération policy n'est pas valable


Normal, la version d'apt de Jessie ne supporte pas la commande policy. Par contre ça doit marcher avec apt-cache. Tu dois faire une erreur de frappe quelque part.


Il vaut mieux montrer que raconter.

Hors ligne

#10 15-11-2020 12:13:14

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu] problème avec apt policy

Effectivement, avec apt-cache ça marche.
J'avais dû faire une erreur de frappe. Mille excuses à Croutons. roll
À moins que ce ne soit le fait d'avoir réinstallé apt...
Je passe en résolu.

Dernière modification par gargamel79 (15-11-2020 14:42:09)

Hors ligne

Pied de page des forums