Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 15-11-2020 00:10:26

Gab'
Membre
Distrib. : Debian/GNU 10 (Buster) (dualboot W10)
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mutter (je crois ...)
Inscription : 07-11-2020

[Résolu] LED Wifi clignotante

Bonsoir smile

J'ai récemment installé Debian 10 (dualboot W10) sur mon ordinateur portable Latitude E5510 et tout fonctionne... sauf une toute petite chose : la LED du wifi clignote ! Je trouvais ça marrant au début, mais petit à petit ça devient obsédant kernal_panic.gif

La petite lumière est bien éteinte lorsque je coupe le wifi (j'ai un bouton sur le côté de mon ordinateur). D'après mes observations, je pense que la LED éclaire en continue lorsque la carte wifi est alimentée mais qu'elle ne communique pas, et se met à clignoter dès que la carte wifi communique avec internet (quand j'ouvre mon navigateur, quand j'utilise thunderbird, quand je mets à jour les logiciels...).

J'ai trouvé plusieurs posts liés à ce sujet, mais aucun n'a vraiment reçu de réponse :
https://debian-facile.org/viewtopic.php?id=216
https://debian-facile.org/viewtopic.php?id=16250
https://www.generation-nt.com/reponses/ … 60105.html

Merci d'avance pour vos idées smile Si vous n'en avez pas, je scotcherai un bout de papier tongue

Pour info :

lspci


00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 05)
00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 05)
00:1c.3 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 4 (rev 05)
00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 (rev 05)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation HM55 Chipset LPC Interface Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 05)
02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6200 (rev 35)
03:00.0 SD Host controller: Ricoh Co Ltd MMC/SD Host Controller (rev 03)
03:00.4 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 PCIe IEEE 1394 Controller (rev 03)
0b:00.0 Ethernet controller: Broadcom Limited NetXtreme BCM5761e Gigabit Ethernet PCIe (rev 10)
3f:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
3f:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
3f:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
3f:02.1 Host bridge: Intel Corporation 1st Generation Core i3/5/7 Processor QPI Physical 0 (rev 02)
3f:02.2 Host bridge: Intel Corporation 1st Generation Core i3/5/7 Processor Reserved (rev 02)
3f:02.3 Host bridge: Intel Corporation 1st Generation Core i3/5/7 Processor Reserved (rev 02)

Dernière modification par Gab' (15-11-2020 17:45:19)


Quand on veut, on peut ! Mais des fois, il faut vraiment le vouloir... big_smile

Hors ligne

#2 15-11-2020 06:00:42

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] LED Wifi clignotante

<blink> Bonjour, </blink>

Gab' a écrit :

lspci -d ::0280

02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6200 (rev 35)


Ce contrôleur est pris en charge par le module iwlwifi pour lequel il existe un paramètre led_mode :

/sbin/modinfo -p iwlwifi | grep led

led_mode:0=system default, 1=On(RF On)/Off(RF Off), 2=blinking, 3=Off (default: 0) (int)


La commande suivante tente de recharger le module/pilote iwlwifi, avec le paramètre 'led_mode=1'.

modprobe -rv iwlwifi && modprobe -v iwlwifi led_mode=1


Si le résultat te convient tu pourras le rendre permanent en créant le petit fichier de configuration :

echo "options iwlwifi led_mode=1" > /etc/modprobe.d/iwlwifi.conf


Ne disposant pas de ce matériel je ne peux pas vérifier que le rechargement du module est opérant.

Hors ligne

#3 15-11-2020 11:52:31

Gab'
Membre
Distrib. : Debian/GNU 10 (Buster) (dualboot W10)
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mutter (je crois ...)
Inscription : 07-11-2020

Re : [Résolu] LED Wifi clignotante

èfpé a écrit :

<blink> Bonjour, </blink>

lol

J'ai bien les options que tu as indiquées :

/sbin/modinfo -p iwlwifi | grep led


led_mode:0=system default, 1=On(RF On)/Off(RF Off), 2=blinking, 3=Off (default: 0) (int)


Par contre, je viens d'essayer mais j'ai cette erreur :

modprobe -rv iwlwifi && modprobe -v iwlwifi led_mode=1


modprobe: FATAL: Module iwlwifi is in use.


J'ai essayé d'éteindre la carte wifi (avec le bouton sur le côté de mon ordi) et de me connecter en Ethernet en attendant, mais rien. Et j'ai essayé de redémarrer mais toujours pas possible.
J'ai vu qu'on pouvait utiliser ifdown pour éteindre une interface réseau, est-ce que c'est adéquat dans cette situation ?

En attendant <blink> ça continue de clignoter <blink> wink

Dernière modification par Gab' (15-11-2020 17:47:10)


Quand on veut, on peut ! Mais des fois, il faut vraiment le vouloir... big_smile

Hors ligne

#4 15-11-2020 12:11:11

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] LED Wifi clignotante

Il faut désactiver administrativement (down) l'interface wifi wl* pour pouvoir décharger le module pilote. Soit via le gestionnaire de réseau qui gère l'interface, soit avec ip link ou ifconfig.

Note : certains paramètres de modules sont modifiables à chaud via /sys/module/<module>/parameters/<paramètre> mais ça dépend des modules et des paramètres. Apparemment ce n'est hélas pas le cas de celui-ci :

ls /sys/module/iwlwifi/parameters/led_mode


-r--r--r-- 1 root root 4096 nov.  15 12:07 /sys/module/iwlwifi/parameters/led_mode

Dernière modification par raleur (15-11-2020 12:12:33)


Il vaut mieux montrer que raconter.

Hors ligne

#5 15-11-2020 12:40:09

Gab'
Membre
Distrib. : Debian/GNU 10 (Buster) (dualboot W10)
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mutter (je crois ...)
Inscription : 07-11-2020

Re : [Résolu] LED Wifi clignotante

Bonjour raleur smile

Je crois que je n'ai pas compris ce que tu as dit ou alors je ne l'ai pas bien exécuté :

ip a


1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp11s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether f0:4d:a2:79:99:78 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.13/24 brd 192.168.1.255 scope global dynamic noprefixroute enp11s0
       valid_lft 86235sec preferred_lft 86235sec
    inet6 2a01:cb1c:4e3:100:7024:2cc6:8c14:d730/64 scope global dynamic noprefixroute
       valid_lft 1788sec preferred_lft 588sec
    inet6 fe80::af7a:ef4f:4fc9:5cea/64 scope link noprefixroute
       valid_lft forever preferred_lft forever
3: wlp2s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether f6:4e:37:e2:f3:8e brd ff:ff:ff:ff:ff:ff


su -


Mot de passe :


ip link set dev wlp2s0 down
modprobe -rv iwlwifi && modprobe -v iwlwifi led_mode=1


modprobe: FATAL: Module iwlwifi is in use.

Dernière modification par Gab' (15-11-2020 17:48:01)


Quand on veut, on peut ! Mais des fois, il faut vraiment le vouloir... big_smile

Hors ligne

#6 15-11-2020 13:37:24

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] LED Wifi clignotante

L'interface wifi est bien désactivée. Le module iwlwifi est peut-être utilisé par un autre module. À vérifier avec

/sbin/lsmod | grep iwlwifi



Si tu n'as pas envie de t'embêter à chercher, tu peux aussi redémarrer en ajoutant iwlwifi.led_mode=1 à la ligne de commande du noyau.

Dernière modification par raleur (15-11-2020 13:40:26)


Il vaut mieux montrer que raconter.

Hors ligne

#7 15-11-2020 17:01:01

Gab'
Membre
Distrib. : Debian/GNU 10 (Buster) (dualboot W10)
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mutter (je crois ...)
Inscription : 07-11-2020

Re : [Résolu] LED Wifi clignotante

Voilà ce que j'obtiens :

/sbin/lsmod | grep iwlwifi


iwlwifi               249856  1 iwldvm
cfg80211              774144  3 iwldvm,iwlwifi,mac80211


Par contre, je ne sais pas comment arrêter cfg80211. J'ai pas l'impression de pouvoir faire ça avec modprobe. Il y a une commande qui permet d'éteindre les modules qui sont en cours de fonctionnement ? (un peu comme le gestionnaire des tâches qui permet d'arrêter un processus sous W)

raleur a écrit :

Si tu n'as pas envie de t'embêter à chercher, tu peux aussi redémarrer en ajoutant iwlwifi.led_mode=1 à la ligne de commande du noyau.


J'ai installé Debian très récemment et je débute avec le monde linux : je n'ai encore jamais touché au noyau et ne sais pas du tout comment m'y prendre... Donc si la première solution fonctionne rapidement, c'est mieux pour moi. Sinon, il va me falloir un peu de temps et d'accompagnement.

Pour info, l'interface wifi que j'ai éteinte, elle se rallumera automatiquement au prochain démarrage ?

Dernière modification par Gab' (15-11-2020 17:49:06)


Quand on veut, on peut ! Mais des fois, il faut vraiment le vouloir... big_smile

Hors ligne

#8 15-11-2020 17:08:37

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] LED Wifi clignotante

Tu lis la sortie de lsmod à l'envers : c'est iwlwifi qui utilise cfg80211 et non l'inverse. Et c'est le module iwldvm (pilote AGM, ne me demandez pas ce que c'est) qui utilise iwlwifi, et qu'il faut donc décharger pour pouvoir décharger iwlwifi.

Il vaut mieux montrer que raconter.

Hors ligne

#9 15-11-2020 17:28:20

Gab'
Membre
Distrib. : Debian/GNU 10 (Buster) (dualboot W10)
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mutter (je crois ...)
Inscription : 07-11-2020

Re : [Résolu] LED Wifi clignotante

raleur a écrit :

Tu lis la sortie de lsmod à l'envers : c'est iwlwifi qui utilise cfg80211 et non l'inverse. Et c'est le module iwldvm (pilote AGM, ne me demandez pas ce que c'est) qui utilise iwlwifi, et qu'il faut donc décharger pour pouvoir décharger iwlwifi.


Okay, merci. Je crois que je comprends.
J'ai fait ça :

/sbin/lsmod | grep iwldvm


iwldvm                159744  0
mac80211              835584  1 iwldvm
iwlwifi               249856  1 iwldvm
cfg80211              774144  3 iwldvm,iwlwifi,mac80211


modprobe -rv iwldvm && modprobe -rv iwlwifi && modprobe -v iwlwifi led_mode=1 && modprobe -v iwldvm


rmmod iwldvm
rmmod mac80211
rmmod iwlwifi
rmmod cfg80211
insmod /lib/modules/4.19.0-12-amd64/kernel/net/wireless/cfg80211.ko
insmod /lib/modules/4.19.0-12-amd64/kernel/drivers/net/wireless/intel/iwlwifi/iwlwifi.ko led_mode=1
insmod /lib/modules/4.19.0-12-amd64/kernel/net/mac80211/mac80211.ko
insmod /lib/modules/4.19.0-12-amd64/kernel/drivers/net/wireless/intel/iwlwifi/dvm/iwldvm.ko


Et ça marche : la lumière est maintenant allumée (sans clignoter) quand la carte wifi est alimentée et éteinte quand elle ne l'est pas.
Je termine donc avec :

echo "options iwlwifi led_mode=1" > /etc/modprobe.d/iwlwifi.conf



Merci ! smile

Dernière modification par Gab' (15-11-2020 17:50:29)


Quand on veut, on peut ! Mais des fois, il faut vraiment le vouloir... big_smile

Hors ligne

#10 15-11-2020 17:46:38

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] LED Wifi clignotante

Note : si le module iwlwifi.ko est inclus dans l'initramfs, il faut aussi recontruire ce dernier pour inclure le fichier iwlwifi.conf, sinon il ne sera pas pris en compte (trop tard car le module aura déja été chargé par l'initramfs).

lsinitramfs /boot/initrd.img-$(uname -r) | grep iwlwifi


Si iwlwifi.ko est présent,

update-initramfs -u -k $(uname -r)


Note : cela ne reconstruit que l'initramfs du noyau actif (uname -r). Ajuster la version s'il y a d'autres noyaux installés dans /boot et utilisés.

Dernière modification par raleur (15-11-2020 17:50:18)


Il vaut mieux montrer que raconter.

Hors ligne

#11 15-11-2020 17:59:04

Gab'
Membre
Distrib. : Debian/GNU 10 (Buster) (dualboot W10)
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mutter (je crois ...)
Inscription : 07-11-2020

Re : [Résolu] LED Wifi clignotante

Dans mon cas, le module iwlwifi.ko ne semble pas être inclus dans l'initramfs puisque je n'obtiens aucun retour à :

lsinitramfs /boot/initrd.img-$(uname -r) | grep iwlwifi


Donc le problème est résolu !


Quand on veut, on peut ! Mais des fois, il faut vraiment le vouloir... big_smile

Hors ligne

#12 16-11-2020 20:42:42

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] LED Wifi clignotante

(Épilogue,)

raleur a écrit :

Et c'est le module iwldvm (pilote AGM, ne me demandez pas ce que c'est) qui utilise iwlwifi, et qu'il faut donc décharger pour pouvoir décharger iwlwifi.


C'est AGN, pour IEEE 802.11a/g/n (description historique, un module iwlagn a été renommé iwlwifi).
Le module iwldvm gère le matériel mis sur le marché en 2008-2012 (à partir de 2013, c'est iwlmvm).


Gab' a écrit :

modprobe -rv iwldvm && modprobe -rv iwlwifi && modprobe -v iwlwifi led_mode=1 ...


<pinaillage> Sauf erreur de ma part la commande "modprobe -rv iwlwifi" est superflue </pinaillage>.

Hors ligne

Pied de page des forums